Creating 3D bodies

From Apache OpenOffice Wiki
Jump to: navigation, search



You can produce 3D bodies in several different ways: extrusion, body rotation, and using ready made objects.

Variation 1: Extrusion

Firstly you draw one of the common Draw objects, for example a square/rectangle, circle/ellipse or a text box using the RectCircle.png or TextIcon.png icons on the Draw toolbar. Next choose Modify > Convert > To 3D (alternatively right-click with the mouse on the object and choose Convert > To 3D) or the To 3D icon To3DIcon.png, to produce a 3D object from the 2D surface.

The To3DIcon.png icon is not usually visible on the Draw toolbar. To make it visible, select Visible Buttons from the toolbar menu at the right hand end of the toolbar and click on the icon to make it visible.

Extruding 3D objects from 2D surfaces
Figure 2: Extruding 3D objects from 2D surfaces

The procedure by which parallel surfaces are moved to create a 3D object is known as extrusion. In this case the 2D surface is moved forwards “out of” the drawing level. At the same time the object is slightly tilted and central projection turned on so that one can better recognize the object. Draw uses a default value for the extrusion (the body depth) based on the size of the 2D object. The value can be changed after the extrusion; see Editing 3D objects.

Variation 2: Body rotation

Choose a common drawing object, for example a (non black) line. Then change this into a rotation body. There are two methods available in Draw to do this:

  1. Click the icon To3DRotation.png in the Draw toolbar (this icon is also usually not visible) or choose Modify > Convert > To 3D Rotation object. With this rotation method, the axis of rotation lies always on the left edge of the enclosing rectangle, through the green rectangle handles.
  2. [[Image:|Image:]]
    Figure 3: Rotation body created using variation 2.1

  3. Click the icon In3DRotation.png on the pulldown menu Effects on the Draw toolbar. Watch out – this icon has no large red arrow. The same icon can be accessed from the tearoff menu Mode, opened with View >Toolbars> Mode.
  4. This method allows you to change the location of the rotation axis.

    Rotation body created using variation 2.2
    Figure 4: Rotation body created using variation 2.2

    Click one of the white endpoints with the mouse and drag it so that the axis moves to the desired position. You may need to move both ends to achieve this. The outline shows how the figure will be rotated. When you click on the figure again the rotation will be carried out and the new 3D body produced.

Variation 3: Using ready made objects

Use the 3D Objects toolbar/pulldown menu – to activate this toolbar click View > Toolbars > 3D Objects; see Figure 5.

3Dobjects.png
Figure 5: The 3D Objects toolbar

If you add the icon File:3DIcon.png to the Draw toolbar, the 3D Object bar will be available as a pulldown menu or as a floating toolbar.

After choosing the type of object, left-click on the starting point and drag the mouse diagonally until the outline of the object is the size you want.

After releasing the mouse button the 3D object will appear. If you keep the Shift key pressed while dragging the mouse, you can change the height:width ratio of the object. These objects are constructed as rotation objects. Cubes and spheres are special types of 3D objects which are directly defined in the OOo program code.

3D Scenes

The above variations all produce a result known as a 3D scene. If you click on a 3D scene, the status bar text shows “3D scene selected”. Such a scene is actually a group of objects.

As mentioned in Chapter 6, you can access individual elements of the group from Modify > Enter group or the context menu. The status bar text will then change and show the type of each individual element selected, for example “Sphere selected”, “Extrusion object selected”.

If you constructed the object using one of the above methods, the 3D scene consists of the 3D body as a single element. 3D scenes can, however, be extended to include other 3D objects, as is described later in this chapter.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools