Difference between revisions of "OpenOffice NetBeans Integration"

From Apache OpenOffice Wiki
Jump to: navigation, search
(Overview)
(added information about installation from within NetBeans)
 
(85 intermediate revisions by 14 users not shown)
Line 1: Line 1:
 +
[[image:OOo-Netbeans-Plugin.png|right]]
 
= Overview =
 
= Overview =
 
The OpenOffice.org API plugin for NetBeans simplifies the development of OpenOffice.org extensions. You can use the OpenOffice.org API to program OpenOffice.org, and automate remote or in process tasks extend OpenOffice.org with completely new functionality. The OpenOffice.org API plugin for NetBeans simplifies accessing and using of the API in new projects and simplifies the task of creating complete OpenOffice.org extension packages (comparable to the NetBeans plugin modules).
 
The OpenOffice.org API plugin for NetBeans simplifies the development of OpenOffice.org extensions. You can use the OpenOffice.org API to program OpenOffice.org, and automate remote or in process tasks extend OpenOffice.org with completely new functionality. The OpenOffice.org API plugin for NetBeans simplifies accessing and using of the API in new projects and simplifies the task of creating complete OpenOffice.org extension packages (comparable to the NetBeans plugin modules).
  
= Features =
+
= Download and Installation =
All features listed here are available in the current Preview. Download it here
+
''[http://api.openoffice.org/Projects/NetBeansIntegration/org-openoffice-extensions.nbm org-openoffice-extensions.nbm]'' and try it out!
+
  
 +
== NetBeans 6.x and OpenOffice 3.x (Obsolete) ==
 +
The plugin appears automatically in Netbeans 6.5.x, 6.7.x, 6.8 (version 2.0.6) but is not listed for later versions.
 +
 +
== NetBeans 7.x and Apache OpenOffice 4.0.x ==
 +
The plugin for versions of NetBeans through 7.x is available for download from [http://people.apache.org/~cmarcum/devtools/ http://people.apache.org/~cmarcum/devtools/] provided by Carl Marcum. Use 3.x versions for extension development for OpenOffice.org versions 3.0 thru 3.4. Use the latest 4.0.5 alpha version for extension development for Apache OpenOffice 4.x. This version is under active development and will be made available in the NetBeans plugin manager list when finished. Until then, remember that it is an '''Beta''' version.
 +
 +
The configuration is self explanatory, for detailed information see [[OpenOffice_NetBeans_Integration#Configuration|Configuration]].
 +
 +
== NetBeans 8.x and Apache OpenOffice 4.1.x ==
 +
The NetBeans plugin is now available for download from [http://plugins.netbeans.org/plugin/57917/apache-openoffice-api-plugin NetBeans.org AOO Plugin Page].
 +
 +
This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin.
 +
 +
The previous version of the plugin for NetBeans 8.x and AOO 4.1.x is available for download from [http://people.apache.org/~jsc/aoo_plugin/org-openoffice-extensions-4.0.6.nbm http://people.apache.org/~jsc/aoo_plugin/org-openoffice-extensions-4.0.6.nbm] provided by Jürgen Schmidt.
 +
 +
Also see the mail message concerning this version: [http://markmail.org/message/7kr7b3gs2baqxdsw
 +
http://markmail.org/message/7kr7b3gs2baqxdsw]
 +
 +
== From source ==
 +
The source is available in the Apache OpenOffice source SVN repository in the '''devtools''' tree.
 +
 +
The 3.0 source is available from:
 +
<blockquote>[https://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/branches/3.0 https://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/branches/3.0]</blockquote>
 +
 +
The recent source to use for 4.1 is available from:
 +
<blockquote>[https://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/trunk https://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/trunk]</blockquote>
 +
 +
= Features =
 +
Overview of the features included in the current plugin.
 
== Project Types ==
 
== Project Types ==
All project types create working code. Once the wizard is finished, a working
+
Click on &quot;File&quot; - &quot;New Project...&quot; and choose category &quot;OpenOffice.org&quot; to open a new project. All project types create working code. Once the project wizard is finished, a working
 
compilable project is created. It may not do anything, but it can be used
 
compilable project is created. It may not do anything, but it can be used
 
in OpenOffice.org from the beginning.
 
in OpenOffice.org from the beginning.
Line 33: Line 61:
  
 
== File Types ==
 
== File Types ==
 +
Click on &quot;File&quot; - &quot;New File...&quot; and select &quot;OpenOffice.org&quot; as category to create a new file for an OpenOffice.org project. Note, that the OpenOffice.org category is available in all projects, although it only makes sense to use it in one of the projects stated above.
 
*'''xcu file type'''
 
*'''xcu file type'''
 
Create an empty xcu file type. The files are recognized in NetBeans and  
 
Create an empty xcu file type. The files are recognized in NetBeans and  
Line 45: Line 74:
 
and UNO type (e.g. Service or Interface). You can add additional  
 
and UNO type (e.g. Service or Interface). You can add additional  
 
information in the second step. When an interface is created, the second step asks about
 
information in the second step. When an interface is created, the second step asks about
the functions that the interface should contain. A complete working idl file is created.
+
the functions that the interface should contain. A complete working idl file is created, and NetBeans provides syntax highlighting. When you choose
 +
to also create an implementation object (only available for service or interface), a Java skeleton file implementing
 +
your new idl file will also be created.
 +
 
 +
*'''Java UNO Object file type'''
 +
This file wizard creates a Java skeleton file that implements all functions defined in an interface or service idl file. If you choose a service, the Java implementation file will also be
 +
registered in OpenOffice.org when your extension is deployed.
  
 
== Create, deploy and debug ==
 
== Create, deploy and debug ==
 
These are actions that are available in the context menu of an extension project in the &quot;Project&quot;  
 
These are actions that are available in the context menu of an extension project in the &quot;Project&quot;  
 
view.
 
view.
 
*'''Create OXT'''
 
If necessary, your code is compiled. The resulting jar file is packed into an OXT file, together with other necessary files such as configuration files, a manifest file, and images.  The OXT file is located in the &quot;dist&quot; directory of the project.
 
 
*'''Deploy OpenOffice.org Extension'''
 
If necessary, &quot;Create OXT&quot; is executed. The resulting OXT file is registered inside the user installation of OpenOffice.org.
 
  
 
*'''Debug Extension in Target OpenOffice.org'''
 
*'''Debug Extension in Target OpenOffice.org'''
If necessary, &quot;Create OXT&quot; is executed. The resulting OXT file is registered in a temporary user installation of OpenOffice.org, which is located in the build directory of the project. (Cleaning of the project removes the user installation again.) Then OpenOffice.org is started with this user installation and the action that triggers the registered extension must be done in OpenOffice.org.
+
If necessary, &quot;Create OXT&quot; is executed. The resulting OXT file is registered in a temporary user installation of OpenOffice.org, which is located in the build directory of the project. (Cleaning of the project removes the user installation again.) Then OpenOffice.org is started with this user installation. To trigger the registered extension, an appropriate action must be done in OpenOffice.org.
 
Execution stops at any breakpoints added to the code of the extension and debugging can start from there.
 
Execution stops at any breakpoints added to the code of the extension and debugging can start from there.
 +
 +
*'''Deploy and Run OpenOffice.org Extension'''
 +
If necessary, &quot;Create OXT&quot; is executed. The resulting OXT file is registered inside the user installation of OpenOffice.org. Then OpenOffice.org is started.
 +
 +
*'''Create OXT'''
 +
If necessary, your code is compiled. The resulting jar file is packed into an OXT file, together with other necessary files such as configuration files, a manifest file, and images. The OXT file is located in the &quot;dist&quot; directory of the project.
 +
 +
*'''Publish Extension on OpenOffice.org Website'''
 +
The starting page for uploading and publishing your extension on api.services.openoffice.org is loaded in your default web browser.
  
 
== Miscellaneous ==
 
== Miscellaneous ==
Line 66: Line 104:
 
The jars can be added to the project as a single jar or as part of a NetBeans library. Note: All the jars from a library will be added to the OXT file, independent from their usage in the extension.
 
The jars can be added to the project as a single jar or as part of a NetBeans library. Note: All the jars from a library will be added to the OXT file, independent from their usage in the extension.
  
= Preview =
+
== Specifications ==
The current preview (version 0.8) supports four project types, one client application wizard, a Calc Add-In wizard, a wizard for general UNO components and an Add-On wizard. The Calc Add-In allows you to define new Calc built-in functions for the spreadsheet application which can be directly used from the built-in functions wizard. The user does not need any knowledge of the underlying UNO technology and can define new functions on a higher level. The general UNO component wizard requires some more UNO base knowledge but really simplifies the initial creation of a new component. The Add-On wizard supports the definition of new top-level menus and toolbars and generates the appropriate code skeleton and the necessary config files. The generated project can be used as a starting point to extend it to a more complex Add-On.
+
 
 +
Find here links to the specifications of the plugin on the api.openoffice.org page.
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration.odt OpenOffice.org Plugin for NetBeans]
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration-addon-wizard.odt OpenOffice.org Plugin for NetBeans: Add-On Wizard]
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration-calc-addin-wizard.odt OpenOffice.org Plugin for NetBeans: Add-In Wizard]
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration-component-wizard.odt OpenOffice.org Plugin for NetBeans: Component Wizard]
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration-debug-component.odt OpenOffice.org Plugin for NetBeans: Debug Feature]
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration-new-idl-type.odt OpenOffice.org Plugin for NetBeans: IDL type support]
 +
 
 +
[http://specs.openoffice.org/sdk/tools/spec_openoffice-netbeans-integration-description-xml.odt OpenOffice.org Plugin for NetBeans: Support description.xml]
  
Once you have installed the plugin manually you will be able to update to future releases easily by using the integrated '' '''Update Center''' '' in NetBeans. The plugin comes with its own '' '''OpenOffice.org Preview Updated Center''' '' where we will provide future previews.
+
= Working with the plugin =
 +
The following section describes how you can work with the plugin and describes the requirements because the plugin  make use of some external stuff provided by an office and the OpenOffice.org SDK.
  
 
== Requirements ==
 
== Requirements ==
The plugin ''[http://api.openoffice.org/Projects/NetBeansIntegration/org-openoffice-extensions.nbm org-openoffice-extensions.nbm]'' works only in combination with OpenOffice.org and an appropriate OpenOffice.org Software Development Kit (SDK).  
+
The plugin works only in combination with OpenOffice.org and an appropriate OpenOffice.org Software Development Kit (SDK). The minimal suggested version is OpenOffice.org 2.0.4. With earlier versions, some features of the plugin will not work.
  
*'''[http://api.openoffice.org/Projects/NetBeansIntegration/org-openoffice-extensions.nbm org-openoffice-extensions.nbm]''' - the plugin module
+
*'''[http://download.openoffice.org OpenOffice.org]''' or '''[http://www.sun.com/staroffice StarOffice 8]''' or higher versions of both programs
*'''[http://download.openoffice.org/2.0.4/index.html#download OpenOffice.org 2.0.4]''' or '''[http://www.sun.com/staroffice StarOffice 8 Product Update 4]''' or higher versions of both programs
+
*'''[http://download.openoffice.org/sdk.html OpenOffice.org Software Development Kit (SDK)]'''
*'''[http://download.openoffice.org/sdk.html OpenOffice.org Software Development Kit (SDK) 2.0.4]''' or a higher version
+
  
For the Add-on wizard you must have the latest version of the uno-skeletonmaker (comes with OpenOffice.org SDK 2.2.0) and you can download a pre-compiled binary from the file section of the [http://api.openoffice.org API] project ([http://api.openoffice.org/files/documents/22/3823/uno-skeletonmaker_linux_x86zip.zip Linux-x86], [http://api.openoffice.org/files/documents/22/3824/uno-skeletonmaker_solaris_sparc.zip Solaris-Sparc], [http://api.openoffice.org/files/documents/22/3825/uno-skeletonmaker_solaris_x86.zip Solaris-x86], [http://api.openoffice.org/files/documents/22/3826/uno-skeletonmaker_windows.zip Windows])
+
Note that the versions of OpenOffice.org and the OpenOffice.org SDK must match for everything to work.
  
== Installation ==
+
== Configuration ==
The current version of the NetBeans plugin is a first preview and must be installed manually as a normal NetBeans plugin in the “Update Center” in NetBeans. The manual installation is only necessary the first time and then you can use the integrated ''OpenOffice.org Preview Update Center''. Simply choose
+
Before you can use the new project types you must configure the plugin because it needs an installed OpenOffice.org and OpenOffice.org SDK.
*'' '''NetBeans -> Tools -> Update Center -> Install Manually Downloaded Modules (.nbm Files)''' ''
+
select the downloaded module and follow the wizard to install it.
+
  
=== Configuration ===
+
Note:
Before you can use the new project types you must configure the plugin because it needs an installed OpenOffice.org and OpenOffice.org SDK.  
+
* As default settings, a standard installation will be found by the plugin - but only if OpenOffice.org together with the SDK are present.
 +
* When you choose the OpenOffice.org installation and an appropriate SDK is found, that SDK is chosen, the &quot;OpenOffice.org SDK Installation&quot; field is then disabled.
 +
* If you change the OpenOffice.org or OpenOffice.org SDK installation, these changes are effective for projects created from now on only.
  
The current version of the plugin asks during the installation for an OpenOffice.org and OpenOffice.org SDK installation. You also configure or change both programs later. Note: If you change the OpenOffice.org or OpenOffice.org SDK installation, these changes are effective for newly created projects only. This will be changed in the future, and you will be asked if you want accept these changes for existing projects.
 
  
 
For changing the office and SDK installation please choose
 
For changing the office and SDK installation please choose
*'' '''Tools -> Options -> Miscellaneous -> StarOffice/OpenOffice.org Extensions''' ''
+
*'' '''Tools -> Options -> Miscellaneous -> OOo API plugin''' ''
 
and select a valid OpenOffice.org and OpenOffice.org SDK installation.  
 
and select a valid OpenOffice.org and OpenOffice.org SDK installation.  
 
<br>[[Image:OpenOffice_Extensions_Plugin_Options.png|center]]<br>
 
<br>[[Image:OpenOffice_Extensions_Plugin_Options.png|center]]<br>
 
The configuration step automatically installs a new OpenOffice.org library which can be used in other projects to support the OpenOffice.org API. Including this library in your own projects enables context sensitive help and code completion.
 
The configuration step automatically installs a new OpenOffice.org library which can be used in other projects to support the OpenOffice.org API. Including this library in your own projects enables context sensitive help and code completion.
 +
 +
Note: on Debian/Ubuntu, the OpenOffice.org installation directory is <code>/usr/lib/openoffice/</code>. For other *nix platforms the location may vary, but you can find the location by inspecting the shell script <code>/usr/bin/ooffice</code> to see where the <code>ooqstart</code> executable is in your installation.
  
 
== Working with new Project Types ==
 
== Working with new Project Types ==
 
The plugin integrates four new project types under the category '''StarOffice/OpenOffice.org''':
 
The plugin integrates four new project types under the category '''StarOffice/OpenOffice.org''':
*'''StarOffice/OpenOffice.org Calc Add-On'''
+
*'''StarOffice/OpenOffice.org Add-On'''
 
*'''StarOffice/OpenOffice.org Calc Add-Ins'''
 
*'''StarOffice/OpenOffice.org Calc Add-Ins'''
 
*'''StarOffice/OpenOffice.org Client Application'''
 
*'''StarOffice/OpenOffice.org Client Application'''
Line 104: Line 158:
  
 
The wizards will collect the necessary information to create the new projects and should follow the NetBeans philosophy. You can simply choose
 
The wizards will collect the necessary information to create the new projects and should follow the NetBeans philosophy. You can simply choose
*'' '''File -> New Project -> StarOffice/OpenOffice.org -> <project_type>''' ''
+
*'' '''File -> New Project -> OpenOffice.org -> <project_type>''' ''
 
For more details about the project types please take a look at
 
For more details about the project types please take a look at
 
*[[OpenOffice_Simple_UNO_Client_Application_Project_Type|OpenOffice.org UNO Client Application Project Type]]
 
*[[OpenOffice_Simple_UNO_Client_Application_Project_Type|OpenOffice.org UNO Client Application Project Type]]
Line 110: Line 164:
 
*[[General_UNO_Component_Project_Type|OpenOffice.org Component Project Type]]
 
*[[General_UNO_Component_Project_Type|OpenOffice.org Component Project Type]]
 
*[[OpenOffice_Add-On_Project_Type|OpenOffice.org Add-On Project Type]]
 
*[[OpenOffice_Add-On_Project_Type|OpenOffice.org Add-On Project Type]]
 +
 +
== Migrate Projects ==
 +
To migrate projects from an older version of the plugin to a new one is not necessary - the plugin itself will take care of that: build-uno-impl.xml and the project-uno.properties are updated, when updated versions of these files are needed for new features of the updated plugin. Note that build-uno-impl.xml will be overwritten, but project-uno.properties not. In the properties file, only new entries are added, existing ones are kept as they are. The update of the files happens when an old project is opened with a new version of the plugin and for all opened projects when the new plugin is downloaded and installed.
 +
 +
When migrating from one Office version to another (or porting a project across platforms), only a library has to be changed, called &quot;OpenOffice.org <version_number>&quot; (or &quot;StarOffice <version_number>&quot;). Choose '''Tools -> Libraries''' to get an overview of the existing libraries. A library is created when a valid OpenOffice.org and OpenOffice.org SDK is selected in '''Tools -> Options -> Miscellaneous -> OOo API Plugin''' (See [[OpenOffice_NetBeans_Integration#Configuration|Configuration]] for more details).
 +
* To change the library, click right on the project in the '''Project''' window and open the properties. Select '''Libraries''' as category and remove the one that points to the old installation and add the new one.
 +
* When porting the project across platforms, NetBeans notifies that a reference problem exists. The steps for changing the libraries also help in this case.
  
 
== Known Problems and Missing Features ==
 
== Known Problems and Missing Features ==
  
 
* Context sensitive help does not work on Linux (Solaris not yet tested), even the javadoc generated Java UNO runtime reference documentation does not work on Linux. Under Windows both work as expected.
 
* Context sensitive help does not work on Linux (Solaris not yet tested), even the javadoc generated Java UNO runtime reference documentation does not work on Linux. Under Windows both work as expected.
* The integrated update center module does not work on Unix systems (known bug [http://www.netbeans.org/issues/show_bug.cgi?id=72960&x=23&y=7 72960] in NetBeans which is fixed in NetBeans 6.0). Workaround is to install NetBeans locally where you have write access.
+
* &quot;Red Dot Problem&quot;: When you have created a project that supports own idl files (e.g. a Clac AddIn), a &quot;clean&quot; on the project will produce &quot;red dots&quot; that show that imported functionality is missing. The cause for this is the deleted jar file with the idl types that are used in your project. Although this does not seem to be the case, a compile will work and solve the problem. Sometimes the signs appear when &quot;clean and build&quot; is chosen - here the compiled idl files exist, but NetBeans does not recognize that. Open the offending Java file to solve that. Solution: compile idl files in the background and produce a &quot;shadow&quot; jar file in a temp directory that can be used even if the &quot;official&quot; file in the <project_name>/dist folder is deleted.
* The backward compatibility mode for Calc Add-Ins creates still an '''.oxt''' extension package. This of course makes no sense for older OpenOffice.org versions because this file extension was first introduced in OO.org 2.0.4. Please simply rename it to '''.uno.pkg'''
+
* With NetBeans versions at least 6.1 there is an update problem regarding NetBeans property sheets and node views: property sheet changes are not reflected in the node view. Seems like the notify mechanism for these updates has changed.
* Projects are currently not platform independent. If you want to build a project on a different platform you must adapt the '''&lt;projectname&gt;/nbproject/project-uno.properties''' file by hand.
+
 
 +
= Releases =
 +
 
 +
{|cellpadding=5 cellspacing=0 border=1 style="border-collapse:collapse; margin-left: 3em; border-color: #333;"
 +
|- style="background-color: #DEDEDE;"
 +
| Release Version || Planned Release Date || Release Date || Planned Features
 +
|- align=center
 +
| 1.0 || 05/08/07 || 05/08/07 || -
 +
|- align=center
 +
| 1.1 || 09/01/07 || 09/18/07 || [[OpenOffice_NetBeans_Integration/Releases/Release_1.1| see 1.1]]
 +
|- align=center
 +
| 1.1.1 || 03/08 || 03/20/08 || [[OpenOffice_NetBeans_Integration/Releases/Release_1.1.x| see 1.1.1]]
 +
|- align=center
 +
| 1.1.2 || 04/08 || 04/30/08 || [[OpenOffice_NetBeans_Integration/Releases/Release_1.1.x| see 1.1.2]]
 +
|- align=center
 +
| 1.1.3 || 06/30/08 || - || [[OpenOffice_NetBeans_Integration/Releases/Release_1.1.x| see 1.1.3]]
 +
|- align=center
 +
| 2.0 || 09/08 || - || [[OpenOffice_NetBeans_Integration/Releases/Release_2.0| see 2.0]]
 +
|- align=center
 +
| 2.0.3 || - || - || bugfixes only
 +
|- align=center
 +
| 2.0.4 || - || - || bugfixes only
 +
|- align=center
 +
| 2.0.5 || - || - || bugfixes only
 +
|- align=center
 +
| 2.0.6 || - || - || bugfixes only
 +
|- align=center
 +
| 2.0.7.alpha || - || - || changes to support NetBeans 6.9, opnly available in the file section of the API project, [http://api.openoffice.org/files/documents/22/4772/org-openoffice-extensions-2.0.7.alpha.nbm org-openoffice-extensions-2.0.7.alpha.nbm]
 +
|}
 +
 
 +
: &nbsp;&nbsp;Detailed download statistics can be found [[OpenOffice_NetBeans_Integration/Releases/Download_Statistic| here]] (not up-to-date)
 +
 
 +
* [[OpenOffice_NetBeans_Integration/Releases/Release_1.2#Current_issues_concerning_NetBeans_6|Issues]] for using the plugin with NetBeans 6.
  
 
= Planned Features =
 
= Planned Features =
Line 123: Line 216:
 
== New Project Types ==
 
== New Project Types ==
 
*'''[[OpenOffice_Scripting_Project_Type|OpenOffice.org Scripting Project Type]]'''<br>This new project type will create an adapted J2SE class library project with special support for OpenOffice.org scripting. It should provide you the possibility to import scripts from OpenOffice.org and open documents, edit, change and build these scripts, debug them and export them back (currently the support is planned for Java scripts only).
 
*'''[[OpenOffice_Scripting_Project_Type|OpenOffice.org Scripting Project Type]]'''<br>This new project type will create an adapted J2SE class library project with special support for OpenOffice.org scripting. It should provide you the possibility to import scripts from OpenOffice.org and open documents, edit, change and build these scripts, debug them and export them back (currently the support is planned for Java scripts only).
 +
*'''[[OpenOffice_SmartTag_Project_Type|OpenOffice.org SmartTag Project Type]]'''<br>This new project type will simplify the development of SmartTags for the OpenOffice.org Writer application.
 
*'''[[OpenOffice_API_Library_Wrapper_Project_Type|OpenOffice.org API Library API Wrapper Project Type]]'''<br>This new project type should create a ''Library Wrapper Module'' to support simple usage of the OpenOffice.org API in your own projects. It bundles the necessary API jar files from OpenOffice.org in the library and in client applications. This of course is necessary to make use of the OpenOffice.org API in clients running on machines where no OpenOffice.org is installed and where the communication with OpenOffice.org is made over a remote socket connection.
 
*'''[[OpenOffice_API_Library_Wrapper_Project_Type|OpenOffice.org API Library API Wrapper Project Type]]'''<br>This new project type should create a ''Library Wrapper Module'' to support simple usage of the OpenOffice.org API in your own projects. It bundles the necessary API jar files from OpenOffice.org in the library and in client applications. This of course is necessary to make use of the OpenOffice.org API in clients running on machines where no OpenOffice.org is installed and where the communication with OpenOffice.org is made over a remote socket connection.
  
 
== Common Features ==
 
== Common Features ==
*'''UNOIDL Support'''<br>Means support of a new file type for UNOIDL files, including compiling, UNOIDL editor with syntax highlighting. A wizard for defining new UNOIDL types should be supported as well.
+
*'''Editor for xcu files'''<br>This must be defined in detail but we can think of a special editor for OpenOffice .org configuration files.
*'''Debug Support'''<br>Means debug support directly from NetBeans for new built and deployed extensions in the OpenOffice.org process as well as the debugging of scripts in OpenOffice.org.
+
*'''Support of OpenOffice.org extension package'''<br>This must be defined in detail but it should at least support the browsing of an '' '''.oxt''' '' file in the NetBeans file system similar to jar|zip files.
+
*'''File type for xcu files'''<br>This must be defined in detail but we can think of a special editor for OpenOffice .org configuration files.
+
  
 
= Quality Assurance =
 
= Quality Assurance =
Line 136: Line 227:
  
 
* [[OpenOffice_NetBeans_Integration_QA|Schedule for OpenOffice.org NetBeans Integration QA ]]
 
* [[OpenOffice_NetBeans_Integration_QA|Schedule for OpenOffice.org NetBeans Integration QA ]]
 +
 +
= Localization =
 +
* [[OpenOffice_NetBeans_Integration/Localization|Localization Tutorial]]
 +
  
 
= Things to be done =
 
= Things to be done =
Line 141: Line 236:
  
 
= Feedback =
 
= Feedback =
This is a preview only. Everything is under development and needs to be improved. Feedback is welcome and highly appreciated and we would like to invite you to discuss it on [mailto:dev@api.openoffice.org dev@api.openoffice.org] (Note: you have to be subscribed on the mailing list).
+
We will continuously extend and improve the plugin in the future and your feedback is welcome and highly appreciated. We would like to invite you to discuss it on [mailto:dev@api.openoffice.org dev@api.openoffice.org] (Note: you have to be subscribed on the mailing list).
  
 
You can also submit new [http://api.openoffice.org/issues/enter_bug.cgi?component=sdk&issue_type=FEATURE feature] or [http://api.openoffice.org/issues/enter_bug.cgi?component=sdk&issue_type=ENHANCEMENT enhancement] requests in the issue tracker in the category '''sdk''' and the subcomponent '''netbeans-integration'''
 
You can also submit new [http://api.openoffice.org/issues/enter_bug.cgi?component=sdk&issue_type=FEATURE feature] or [http://api.openoffice.org/issues/enter_bug.cgi?component=sdk&issue_type=ENHANCEMENT enhancement] requests in the issue tracker in the category '''sdk''' and the subcomponent '''netbeans-integration'''

Latest revision as of 10:37, 15 April 2015

OOo-Netbeans-Plugin.png

Overview

The OpenOffice.org API plugin for NetBeans simplifies the development of OpenOffice.org extensions. You can use the OpenOffice.org API to program OpenOffice.org, and automate remote or in process tasks extend OpenOffice.org with completely new functionality. The OpenOffice.org API plugin for NetBeans simplifies accessing and using of the API in new projects and simplifies the task of creating complete OpenOffice.org extension packages (comparable to the NetBeans plugin modules).

Download and Installation

NetBeans 6.x and OpenOffice 3.x (Obsolete)

The plugin appears automatically in Netbeans 6.5.x, 6.7.x, 6.8 (version 2.0.6) but is not listed for later versions.

NetBeans 7.x and Apache OpenOffice 4.0.x

The plugin for versions of NetBeans through 7.x is available for download from http://people.apache.org/~cmarcum/devtools/ provided by Carl Marcum. Use 3.x versions for extension development for OpenOffice.org versions 3.0 thru 3.4. Use the latest 4.0.5 alpha version for extension development for Apache OpenOffice 4.x. This version is under active development and will be made available in the NetBeans plugin manager list when finished. Until then, remember that it is an Beta version.

The configuration is self explanatory, for detailed information see Configuration.

NetBeans 8.x and Apache OpenOffice 4.1.x

The NetBeans plugin is now available for download from NetBeans.org AOO Plugin Page.

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin.

The previous version of the plugin for NetBeans 8.x and AOO 4.1.x is available for download from http://people.apache.org/~jsc/aoo_plugin/org-openoffice-extensions-4.0.6.nbm provided by Jürgen Schmidt.

Also see the mail message concerning this version: [http://markmail.org/message/7kr7b3gs2baqxdsw http://markmail.org/message/7kr7b3gs2baqxdsw]

From source

The source is available in the Apache OpenOffice source SVN repository in the devtools tree.

The 3.0 source is available from:

https://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/branches/3.0

The recent source to use for 4.1 is available from:

https://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/trunk

Features

Overview of the features included in the current plugin.

Project Types

Click on "File" - "New Project..." and choose category "OpenOffice.org" to open a new project. All project types create working code. Once the project wizard is finished, a working compilable project is created. It may not do anything, but it can be used in OpenOffice.org from the beginning.

This project type creates an adapted J2SE client application project with additional support of the simple UNO bootstrap feature. To enable this, some pre-compiled glue code is bundled with the client application. The result is a portable jar file that bootstraps OpenOffice.org on any supported OS.

This project type creates an adapted J2SE class library project with special support for a UNO component library and an office extension package. The wizard collects the necessary information for new Calc built-in functions and abstracts from the underlying UNO technology.

This project type creates an adapted J2SE class library project with special support for a UNO component library and an OpenOffice.org extension package. The wizard collects information about services and additional optional interfaces which should be implemented. Additional IDL types can also be defined. A complete code skeleton is generated, with the component helper functions and the default interface methods already implemented.

This project type creates an adapted J2SE class library project with special support for a UNO component library and an OpenOffice.org extension package. The wizard collects the necessary information for an OpenOffice.org Add-On component and generates an Add-On specific code skeleton.

File Types

Click on "File" - "New File..." and select "OpenOffice.org" as category to create a new file for an OpenOffice.org project. Note, that the OpenOffice.org category is available in all projects, although it only makes sense to use it in one of the projects stated above.

  • xcu file type

Create an empty xcu file type. The files are recognized in NetBeans and syntax highlighting is supported.

  • xcs file type

Create an empty xcs file type. The files are recognized in NetBeans and syntax highlighting is supported.

  • UNO idl file type

You can use a file type wizard to create idl files. In the first step, you must select the name location and UNO type (e.g. Service or Interface). You can add additional information in the second step. When an interface is created, the second step asks about the functions that the interface should contain. A complete working idl file is created, and NetBeans provides syntax highlighting. When you choose to also create an implementation object (only available for service or interface), a Java skeleton file implementing your new idl file will also be created.

  • Java UNO Object file type

This file wizard creates a Java skeleton file that implements all functions defined in an interface or service idl file. If you choose a service, the Java implementation file will also be registered in OpenOffice.org when your extension is deployed.

Create, deploy and debug

These are actions that are available in the context menu of an extension project in the "Project" view.

  • Debug Extension in Target OpenOffice.org

If necessary, "Create OXT" is executed. The resulting OXT file is registered in a temporary user installation of OpenOffice.org, which is located in the build directory of the project. (Cleaning of the project removes the user installation again.) Then OpenOffice.org is started with this user installation. To trigger the registered extension, an appropriate action must be done in OpenOffice.org. Execution stops at any breakpoints added to the code of the extension and debugging can start from there.

  • Deploy and Run OpenOffice.org Extension

If necessary, "Create OXT" is executed. The resulting OXT file is registered inside the user installation of OpenOffice.org. Then OpenOffice.org is started.

  • Create OXT

If necessary, your code is compiled. The resulting jar file is packed into an OXT file, together with other necessary files such as configuration files, a manifest file, and images. The OXT file is located in the "dist" directory of the project.

  • Publish Extension on OpenOffice.org Website

The starting page for uploading and publishing your extension on api.services.openoffice.org is loaded in your default web browser.

Miscellaneous

  • External Jars

Additional external jars that are used in an extension are automatically copied into the OXT file and added to the extension's classpath. A registered extension in OpenOffice.org can still use the functionality provided there. The jars can be added to the project as a single jar or as part of a NetBeans library. Note: All the jars from a library will be added to the OXT file, independent from their usage in the extension.

Specifications

Find here links to the specifications of the plugin on the api.openoffice.org page.

OpenOffice.org Plugin for NetBeans

OpenOffice.org Plugin for NetBeans: Add-On Wizard

OpenOffice.org Plugin for NetBeans: Add-In Wizard

OpenOffice.org Plugin for NetBeans: Component Wizard

OpenOffice.org Plugin for NetBeans: Debug Feature

OpenOffice.org Plugin for NetBeans: IDL type support

OpenOffice.org Plugin for NetBeans: Support description.xml

Working with the plugin

The following section describes how you can work with the plugin and describes the requirements because the plugin make use of some external stuff provided by an office and the OpenOffice.org SDK.

Requirements

The plugin works only in combination with OpenOffice.org and an appropriate OpenOffice.org Software Development Kit (SDK). The minimal suggested version is OpenOffice.org 2.0.4. With earlier versions, some features of the plugin will not work.

Note that the versions of OpenOffice.org and the OpenOffice.org SDK must match for everything to work.

Configuration

Before you can use the new project types you must configure the plugin because it needs an installed OpenOffice.org and OpenOffice.org SDK.

Note:

  • As default settings, a standard installation will be found by the plugin - but only if OpenOffice.org together with the SDK are present.
  • When you choose the OpenOffice.org installation and an appropriate SDK is found, that SDK is chosen, the "OpenOffice.org SDK Installation" field is then disabled.
  • If you change the OpenOffice.org or OpenOffice.org SDK installation, these changes are effective for projects created from now on only.


For changing the office and SDK installation please choose

  • Tools -> Options -> Miscellaneous -> OOo API plugin

and select a valid OpenOffice.org and OpenOffice.org SDK installation.


OpenOffice Extensions Plugin Options.png

The configuration step automatically installs a new OpenOffice.org library which can be used in other projects to support the OpenOffice.org API. Including this library in your own projects enables context sensitive help and code completion.

Note: on Debian/Ubuntu, the OpenOffice.org installation directory is /usr/lib/openoffice/. For other *nix platforms the location may vary, but you can find the location by inspecting the shell script /usr/bin/ooffice to see where the ooqstart executable is in your installation.

Working with new Project Types

The plugin integrates four new project types under the category StarOffice/OpenOffice.org:

  • StarOffice/OpenOffice.org Add-On
  • StarOffice/OpenOffice.org Calc Add-Ins
  • StarOffice/OpenOffice.org Client Application
  • StarOffice/OpenOffice.org Component

The wizards will collect the necessary information to create the new projects and should follow the NetBeans philosophy. You can simply choose

  • File -> New Project -> OpenOffice.org -> <project_type>

For more details about the project types please take a look at

Migrate Projects

To migrate projects from an older version of the plugin to a new one is not necessary - the plugin itself will take care of that: build-uno-impl.xml and the project-uno.properties are updated, when updated versions of these files are needed for new features of the updated plugin. Note that build-uno-impl.xml will be overwritten, but project-uno.properties not. In the properties file, only new entries are added, existing ones are kept as they are. The update of the files happens when an old project is opened with a new version of the plugin and for all opened projects when the new plugin is downloaded and installed.

When migrating from one Office version to another (or porting a project across platforms), only a library has to be changed, called "OpenOffice.org <version_number>" (or "StarOffice <version_number>"). Choose Tools -> Libraries to get an overview of the existing libraries. A library is created when a valid OpenOffice.org and OpenOffice.org SDK is selected in Tools -> Options -> Miscellaneous -> OOo API Plugin (See Configuration for more details).

  • To change the library, click right on the project in the Project window and open the properties. Select Libraries as category and remove the one that points to the old installation and add the new one.
  • When porting the project across platforms, NetBeans notifies that a reference problem exists. The steps for changing the libraries also help in this case.

Known Problems and Missing Features

  • Context sensitive help does not work on Linux (Solaris not yet tested), even the javadoc generated Java UNO runtime reference documentation does not work on Linux. Under Windows both work as expected.
  • "Red Dot Problem": When you have created a project that supports own idl files (e.g. a Clac AddIn), a "clean" on the project will produce "red dots" that show that imported functionality is missing. The cause for this is the deleted jar file with the idl types that are used in your project. Although this does not seem to be the case, a compile will work and solve the problem. Sometimes the signs appear when "clean and build" is chosen - here the compiled idl files exist, but NetBeans does not recognize that. Open the offending Java file to solve that. Solution: compile idl files in the background and produce a "shadow" jar file in a temp directory that can be used even if the "official" file in the <project_name>/dist folder is deleted.
  • With NetBeans versions at least 6.1 there is an update problem regarding NetBeans property sheets and node views: property sheet changes are not reflected in the node view. Seems like the notify mechanism for these updates has changed.

Releases

Release Version Planned Release Date Release Date Planned Features
1.0 05/08/07 05/08/07 -
1.1 09/01/07 09/18/07 see 1.1
1.1.1 03/08 03/20/08 see 1.1.1
1.1.2 04/08 04/30/08 see 1.1.2
1.1.3 06/30/08 - see 1.1.3
2.0 09/08 - see 2.0
2.0.3 - - bugfixes only
2.0.4 - - bugfixes only
2.0.5 - - bugfixes only
2.0.6 - - bugfixes only
2.0.7.alpha - - changes to support NetBeans 6.9, opnly available in the file section of the API project, org-openoffice-extensions-2.0.7.alpha.nbm
  Detailed download statistics can be found here (not up-to-date)
  • Issues for using the plugin with NetBeans 6.

Planned Features

The focus is on creating new wizards for various tasks plus common basic functionality. The main programming language is Java. Support for C++ is also planned and depends on the C++ support in NetBeans which will be available at least for NetBeans 6.0. The planned feature list is not final and more specialized wizards for other service provider interfaces (SPI) are coming in the future.

New Project Types

  • OpenOffice.org Scripting Project Type
    This new project type will create an adapted J2SE class library project with special support for OpenOffice.org scripting. It should provide you the possibility to import scripts from OpenOffice.org and open documents, edit, change and build these scripts, debug them and export them back (currently the support is planned for Java scripts only).
  • OpenOffice.org SmartTag Project Type
    This new project type will simplify the development of SmartTags for the OpenOffice.org Writer application.
  • OpenOffice.org API Library API Wrapper Project Type
    This new project type should create a Library Wrapper Module to support simple usage of the OpenOffice.org API in your own projects. It bundles the necessary API jar files from OpenOffice.org in the library and in client applications. This of course is necessary to make use of the OpenOffice.org API in clients running on machines where no OpenOffice.org is installed and where the communication with OpenOffice.org is made over a remote socket connection.

Common Features

  • Editor for xcu files
    This must be defined in detail but we can think of a special editor for OpenOffice .org configuration files.

Quality Assurance

If you find bugs please submit a new issue in the category sdk and the subcomponent netbeans-integration

Localization


Things to be done

Feedback

We will continuously extend and improve the plugin in the future and your feedback is welcome and highly appreciated. We would like to invite you to discuss it on dev@api.openoffice.org (Note: you have to be subscribed on the mailing list).

You can also submit new feature or enhancement requests in the issue tracker in the category sdk and the subcomponent netbeans-integration

Personal tools