Difference between revisions of "Documentation/OOoAuthors User Manual/Impress Guide/Adding and Formatting Text"

From Apache OpenOffice Wiki
Jump to: navigation, search
(Pasting unformatted text)
m
 
(21 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{NeedsWork}}
+
{{DISPLAYTITLE:Adding and Formatting Text}}
This page was created by converting ODT to Mediawiki using Writer2MediaWiki.
+
{{ImpressTextTOC|PrevNext=block
 +
|ShowPrevNext=block
 +
|PrevPage=Documentation/OOoAuthors User Manual/Impress Guide/Slide Masters, Styles, and Templates
 +
|NextPage=Documentation/OOoAuthors_User_Manual/Impress Guide/Working with text boxes}}__notoc__
  
 
This is Chapter '''3''' of '''OpenOffice.org 2.x Impress Guide''' (first edition), produced by the [http://oooauthors.org/ OOoAuthors group]. A PDF of this chapter is available from the [http://documentation.openoffice.org/manuals/oooauthors2/ OOoAuthors Guides page] at OpenOffice.org.
 
This is Chapter '''3''' of '''OpenOffice.org 2.x Impress Guide''' (first edition), produced by the [http://oooauthors.org/ OOoAuthors group]. A PDF of this chapter is available from the [http://documentation.openoffice.org/manuals/oooauthors2/ OOoAuthors Guides page] at OpenOffice.org.
 
[[User_Manuals| &lt;&lt; User Manuals page]]<br>
 
[[Impress Guide| &lt;&lt; Impress Guide Table of Contents]]<br>
 
[[Impress Guide/Slide Masters, Styles, Templates| &lt;&lt; Chapter 2 Using Slide Masters, Styles, and Templates]] &nbsp;&nbsp;|
 
&nbsp;&nbsp;[[Impress Guide/Adding and Formatting Pictures|Chapter 4 Adding and Formatting Pictures &gt;&gt;]]
 
 
  
 
= Introduction =
 
= Introduction =
Line 17: Line 14:
 
There are two ways to add text boxes to a slide:
 
There are two ways to add text boxes to a slide:
  
* Choose a predefined layout from the ''Layouts'' section of the Tasks pane, as described in [[Impress Guide/Introducing Impress|Chapter 1]]. These text boxes are called '''AutoLayout''' text boxes.
+
* Choose a predefined layout from the ''Layouts'' section of the Tasks pane, as described in [[Documentation/OOoAuthors User Manual/Impress Guide/Introducing Impress|Chapter 1]]. These text boxes are called '''AutoLayout''' text boxes.
 
* Create a text box using the text tool.
 
* Create a text box using the text tool.
  
 
This chapter describes how to create, modify, use, and delete text boxes; discusses the various types of text that can be inserted; and explains how to format the text, how to insert a numbered or bulleted list. and finally how and when to use fields.
 
This chapter describes how to create, modify, use, and delete text boxes; discusses the various types of text that can be inserted; and explains how to format the text, how to insert a numbered or bulleted list. and finally how and when to use fields.
 
=Working with text boxes=
 
 
==Using text boxes created from the Layout pane==
 
 
In Normal view:
 
 
# Click in the text box that reads '''Click to add text''', '''Click to add an outline''', or a similar notation.
 
# Type or paste your text in the text box.
 
 
These text boxes are known as AutoLayout text boxes. See also [[#Creating bulleted and numbered lists|Creating bulleted and numbered lists]].
 
 
==Using text boxes created from the text box tool==
 
In Normal View:
 
 
# Click on the '''Text''' icon [[Image:TextIcon.png]] on the Drawing toolbar. If the toolbar with the text icon is not visible, choose '''View > Toolbars > Drawing'''.
 
# Click and drag to draw a box for the text on the slide. Do not worry about the vertical size and position—the text box will expand if needed as you type. To reposition the text box to a different part of the slide, see [[#Moving a text box|Moving a text box]]; to change the horizontal size, see [[#Resizing a text box|Resizing a text box]].
 
# Release the mouse button when finished. The cursor appears in the text box, which is now in edit mode (gray hashed border with green resizing handles).
 
# Type or paste your text in the text box.
 
# Click outside the text box to deselect it.
 
[[Image:IG3-1.png|Selected text box]]<br>Selected text box showing the green resizing handles and text toolbar.
 
 
'''Note:'''  In addition to the normal text boxes where text is horizontally aligned, it is possible to insert text boxes where the text is aligned vertically. This choice is available only when Asian languages are enabled in '''Tools > Options > Language Settings > Languages'''. Click on the  inline:graphics29.png  button in the drawing toolbar to create a vertical text box. Note that when editing the contents, the text is displayed horizontally.
 
 
==Moving a text box==
 
In Normal view, notice how the pointer changes from an arrow to an I-beam as you move it over the text in a text box.
 
 
# Click when the pointer becomes an I-beam. The text box is now in edit mode, with a gray border and green resizing handles.
 
# Move the I-beam (or pointer) over the gray border. Notice how it changes shape, becoming a four-headed arrow (or a similar shape depending on the operating system and user's settings).
 
# When the four-headed arrow appears, click and drag to move the text box. An empty dashed-line box shows where your text box will be placed.
 
# Release the mouse button when the text box is in the desired position.
 
 
==Resizing a text box==
 
In Normal view, when the green resizing handles are displayed, move the I-beam (or pointer) over any handle. Notice how the pointer changes shape, indicating in what direction the text box will be resized. The corner handles change the two dimensions of the text area simultaneously while the four handles in the middle of the sides modify only one of the dimensions.
 
 
When the two-headed arrow is displayed, click and drag to resize the text box.
 
 
'''Tip:'''  To maintain the proportions of a text box while resizing, press and hold the ''Shift'' key, then click and drag. Make sure to release the mouse button '''before''' releasing the ''Shift'' key.
 
 
OOo also provides a different type of text box which resizes horizontally to automatically fit the text as it is inserted. To insert an auto-resizing text box, click on the  inline:graphics30.png  Icon in the text toolbar (see Figure 1) and then click on the place in the slide where you want the first letter of the text to appear. If the text toolbar is not visible, choose '''View > Toolbars > Text'''.
 
 
For more accurate control over the shape, size and position of the text box, instead of using the mouse, use the Position and Size dialog. Select the text box, then press ''F4'' or select '''Format > Position and Size''' from the menu bar. The use of this dialog is explained in [[Impress Guide/Slide Masters, Styles, Templates|Chapter 2]].
 
 
==Deleting a text box==
 
# Click the text once to display the gray border and green resizing handles of the text box.
 
# Position the pointer anywhere on the gray border so that it becomes either a four-headed or two-headed arrow.
 
# Click once. The gray border disappears, leaving only the green resizing handles.
 
# Press ''Delete''.
 
 
'''Tip:'''  Sometimes it is faster to to delete a text box by dragging a selection rectangle around the text box and then hitting the ''Delete'' key. Take care to avoid selecting and accidentally deleting other text boxes or shapes.
 
 
=Inserting text=
 
 
==Pasting text==
 
Text may be inserted into the text box by copying it from another document and pasting it into Impress. However, the pasted text will probably not match the formatting of the surrounding text or that of the other slides in the presentation. This may be what you want on some occasions, however in most cases you want to make sure that the presentation does not become a patchwork of different paragraph styles, font types, bullet points and so on. There are several ways to ensure consistency; these methods are explained below.
 
 
===Pasting unformatted text===
 
It is normally good practice to paste text without formatting and apply the formatting later. To paste without formatting, either press ''Control+Shift+V'' and then select '''Unformatted text''' from the dialog that appears, or click on the small black triangle next to the paste symbol in the standard toolbar [[Image:PasteIcon.png]] and select '''Unformatted text'''. The unformatted text will be formatted with the outline style at the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.
 
 
===Formatting pasted text===
 
If pasting the text into an '''AutoLayout''' area, then to give the pasted text the same look and feel of the rest of the presentation apply the appropriate ''outline style'' to the text. To do so:
 
 
# Paste the text in the desired position. Do not worry if it does not look right: it will in a minute.
 
# Select the text you have just pasted (see [[#Selecting text|Selecting text]] for details on how to do that).
 
# Select '''Format > Default formatting''' from the menu bar.
 
# Use the four arrow buttons in the Text Formatting toolbar  inline:graphics7.png  to move the text to the appropriate position and give it the appropriate outline level. The button with the arrow pointing left promotes the list entry by one level (for example from Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the up and down arrow buttons move the list entry.
 
# Apply manual formatting as required to sections of the text (to change font attributes, tabs, and so on).
 
 
If you are pasting text in a '''text box''', you can still use styles to quickly format the text. Note that one and only one graphic style can be applied to the copied text. To do that:
 
 
# Paste the text in the desired position.
 
# Select the text you have just pasted (see [[#Selecting text|Selecting text]] for details).
 
# Select the desired graphic style.
 
# Apply manual formatting as required to sections of the text.
 
 
'''Tip:'''  Presentation styles are very different from Writer styles and are applied in quite a different way. Refer to [[#Using styles to format text|Using styles to format text]] for details.
 
 
==Inserting special characters==
 
To insert special characters, such as copyright, math, geometric, or monetary symbols, or characters from another language:
 
<ol>
 
<li>Click in the place in the text where you want to insert the character.</li>
 
<li>Choose '''Insert > Special Character'''. The Special Characters dialog appears. Alternatively if the  inline:graphics34.png  icon is visible, you can click this to bring up the Special Characters dialog.</li>
 
 
'''Tip:'''  To show toolbar buttons that are not visible, click on the small down-arrow on the right end of the tool bar, move the cursor over '''Visible Buttons''' and then click on the icon you wish to make visible.
 
 
<li>Choose the font and character subset from the ''Font'' and ''Subset'' drop-down menus.</li>
 
<li>Click the character you want to insert. You may have to scroll to find the one you want.
 
<li>Click '''OK'''.</li>
 
</ol>
 
 
Selecting more than one character will insert all those characters. Characters to be inserted are displayed below the character section in the order they were selected. They will also be inserted in this order. If you accidentally click the wrong character, clicking another character will only add it to the ones being inserted. Click '''Delete''' (all the characters selected will be deleted), then click the correct characters.
 
 
[[Image:IG3-2.png|Special Characters dialog]]<br>Special Characters dialog.
 
 
===Inserting non-breaking spaces and hyphens===
 
Where it is not desirable for words separated by a space or by a hyphen to span over two lines, or where an optional hyphen is desired, you can insert a special formatting mark.
 
 
To access the Formatting marks options, select from the menu bar '''Insert > Formatting marks'''. Impress supports three formatting marks:
 
 
* '''Non-breaking space''': A non-breaking space between two words prevents these two words being separated over two lines. Press ''Control+Space bar'' on the keyboard to insert a non-breaking space.
 
* '''Non-breaking hyphen''': A non-breaking hyphen keeps the two words separated by the hyphen on the same line.
 
* '''Optional hyphen''': An invisible hyphen that is activated (thus breaking the word) only when the word is too long to fit on one line.
 
 
'''Caution:'''  In OOo Writer a non-breaking hyphen can be inserted by pressing ''Control+Minus sign''. This shortcut does not work in Impress.
 
 
=Formatting text=
 
Formatting text can give a presentation a consistent look and a dynamic feel. The appropriate use of formatting can even enhance the audience's understanding of your message by holding their interest.
 
 
Whenever you enter text, either in an AutoLayout text box or in a normal text box, it already comes with an underlying style. Generally this style is the outline level of the point where the text was entered for AutoLayout text boxes or the Default Graphic style for text boxes. Sometimes, as seen also in the “Pasting text" section on page 3, it is very useful to re-apply the baseline style to a selection of text, thus eliminating any manual formatting applied to it (particularly if you made a mistake and you do not know how to undo it). On these occasions, select the manually formatted text, and then select '''Format > Default formatting''' from the menu bar.
 
 
==Using styles to format text==
 
This chapter describes ways to apply manual formatting, but you are encouraged to use styles to really get the best out of Impress. The good news is that all the information given here can be immediately reused for applying styles. Chapter 2 describes how to use styles efficiently and the difference between the presentation and graphic styles available in Impress.
 
 
===Modifying a style===
 
In Impress there are two categories of styles: presentation styles and graphics styles. When inserting text in an AutoLayout area, the presentation styles become available, while when inserting text in a text box or a graphic object it is possible to apply the graphic styles.
 
 
It is possible to create new graphics styles, but not the presentation styles which are fixed and can only be modified.
 
 
To modify a style, follow these steps:
 
 
# Open the Styles and Formatting window by pressing ''F11'' or selecting '''Format > Styles and Formatting''' from the menu bar.
 
# Select the style category by clicking on either the Presentation Styles icon or the Graphic Styles icon at the top of the Style and Formatting window (see ).
 
# Right-click on the style to be modified and select '''Modify''' from the pop-up menu.
 
 
If you have selected a presentation style, this dialog is shown:
 
 
[[Image:IG3-3.png|Presentation Style dialog]]<br>Presentation Style dialog.
 
 
The dialog for making modifications to a graphics style is shown below.
 
 
[[Image:IG3-4.png|Graphics Style dialog]]<br>The Graphics Style modification dialog.
 
 
The Presentation Style dialog shares five pages with the Graphics Style dialog; these are the ones that determine the formatting of the text.
 
 
There is no difference between the parameters that characterize a style and the attributes given manually to portions of text: in fact the same dialogs are used in both cases. Therefore once you master the formatting of text, you will know how to create and modify a style. In particular:
 
 
* For the ''Font'' page of a style refer to [[#Formatting characters|Formatting characters]].
 
* For the ''Font Effects'' page of a style refer to [[#Formatting characters|Formatting characters]].
 
* For the ''Indents and Spacing'' page of a style refer to [[#Formatting paragraphs|Formatting paragraphs]].
 
* For the ''Alignment'' page of a style refer to [[#Formatting paragraphs|Formatting paragraphs]].
 
* For the ''Tabs'' page of a style refer to [[#Formatting paragraphs|Formatting paragraphs]].
 
 
The other tabs of the Presentation Style dialog are all related to bullets and numbering and are described in [[#Creating bulleted and numbered lists|Creating bulleted and numbered lists]].
 
 
For additional details on the other tabs in the Graphics Style dialog, please refer to [[Impress Guide/Formatting Graphic Objects|Chapter 6]] (Formatting Graphic Objects).
 
 
'''Note:'''  When Asian typography is activated ('''Tools > Options > Language Settings > Languages'''), the dialogs above contain an additional page to set some high-level options for Asian typography, the ''Fonts'' page contains additional information and the ''Alignment'' page is slightly different.
 
 
==Selecting text==
 
Text must be selected before it can be formatted manually.
 
 
* To format ''all'' the text in a text box, click once on the text, then click once on the border of the text box. Only the green resizing handles are displayed. Now any formatting changes will apply to all the text in the text box.
 
* To format only ''part'' of the text, click once on the text, then select the text to be formatted by clicking and dragging (highlighting) over it. You can also use keyboard combinations to select text: move the cursor where you want to begin your selection, press ''Shift'' and then use the arrow buttons to extend your selection. Formatting changes will apply only to the selected text.
 
 
'''Tip:'''  Pressing the ''Control'' key along with the ''Shift'' key while creating a selection is useful to speed up the process. This combination highlights the text word by word instead of character by character. To speed up the selection even further, you can combine the ''Shift'' key with the ''Home'' key or the ''End'' key to extend the selection up to the start or end of the line in which the cursor is positioned, respectively.
 
 
==Formatting characters==
 
To view the character formatting options, select '''Format > Character''' or click the '''Character''' button  inline:graphics3.png  on the Text Formatting toolbar. (If a toolbar with the text icon is not visible, choose '''View > Toolbars > Text Formatting'''.) The Character dialog appears.
 
 
===Font page===
 
Use the ''Font'' page to select the desired font type, its base attributes (Italic, Bold, etc.) as well as the size. A sample of the font is displayed in the lower part of the dialog. You can also specify the language of this style.
 
 
[[Image:IG3-5.png|Font page]]<br>The Font page, to set the basic font attributes.
 
 
'''Tip:'''  When writing a presentation in multiple languages, you can make the best of the language setting by creating two styles that only differ in the language but are otherwise the same. This allows you to check the spelling of all of the contents without affecting the appearance.
 
 
This page is available when creating or modifying a presentation style or a graphics style.
 
 
If Asian Typography has been enabled, the ''Font'' page looks like this:
 
 
[[Image:IG3-6.png|Asian Font page]]<br>The Font page when Asian typography is enabled.
 
 
The page is divided into three parts. The top and bottom parts have the same functionality as described above, while in the middle part you can specify the Asian text font and its attributes.
 
 
===Font Effects page===
 
Use the ''Font Effects'' page to apply special effects to the text, such as underlining, color, shadow and so on. As for the ''Font'' page, a sample of the text is displayed in the lower part of the dialog allowing a quick visual check of the effects applied.
 
 
This page is available when creating or modifying a presentation style or a graphics style.
 
 
[[Image:IG3-7.png|Font Effects page]]<br>Advanced options for the character can be set in the Font Effects page.
 
 
===Position page===
 
The ''Position'' page has advanced options to customize text. This page is not available when creating or modifying a presentation style or a graphics style.
 
 
Use this page to set the text position relative to the baseline when you need to insert subscripts or superscripts.
 
 
To create a superscript or a subscript do the following:
 
 
# Select Superscript or subscript as applicable.
 
# Specify the amount by which the text should be raised (superscripts) or lowered (subscripts).
 
# Specify the dimension of the character relative to the baseline character size (in percentage).
 
 
The amount by which the text is raised or lowered can be set to automatic by selecting the '''Automatic''' checkbox.
 
 
[[Image:IG3-8.png|Position page]]<br>Dialog to set the character position attributes.
 
 
Two more position attributes can be set on this page:
 
 
* The (width) scaling of the text, which specifies the percentage of the font width by which to compress or expand the ''individual'' characters of the selected text.
 
* The spacing between the characters of the font, which can be defined in number of points. Selecting the Pair kerning checkbox causes OOo to automatically adjust the spacing between certain pairs of characters to visually improve the appearance. For example, when writing a V followed by an A (VA) the spacing between the two letters is reduced (strong kerning) as can be easily seen when compared with, say, VS which is not a kerning pair.
 
 
==Formatting paragraphs==
 
To view the paragraph formatting options, select '''Format > Paragraph''' or click the '''Paragraph''' button  inline:graphics6.png  on the Text Formatting toolbar. If a toolbar with the text icon is not visible, choose '''View > Toolbars > Text Formatting'''. The Paragraph dialog is shown.
 
 
This dialog contains three pages that are described in detail below. If Asian Typography has been activated, a page called Asian Typography is also displayed.
 
 
[[Image:IG3-9.png|Paragraph formatting dialog]]<br>The paragraph formatting dialog.
 
 
===Indents and Spacing page===
 
The ''Indents and Spacing'' page has four sections:
 
 
* '''Indent''': modifies the indentation of the text (before and after) as well as the indentation of the first line.
 
* '''Spacing''': defines the space before and after each paragraph formatted with the style.
 
* '''Line spacing''': determines the spacing between two lines formatted with the style. Note that selecting ''Proportional'' spacing requires specifying the percentage of a line to be used as spacing; 100% corresponds to a single line, 200% to a double line, 50% to half a line. If ''Leading'' is selected, specify the amount of line spacing in your default unit of measurement.
 
* '''Preview area''': provides a visual representation of the settings before you apply them.
 
 
'''Tip:'''  Setting the line spacing to less than 100% is a good method to cram a lot of text into a text box, however care must be taken as too small a value will make the text hard to read.
 
 
'''Tip:''' You can change the default unit of measurement, for example from inches to centimetres, from '''Tools > Options > OpenOffice.org Impress > General'''.
 
 
[[Image:IG3-10.png|Indent and spacing settings]]<br>Indent and spacing settings for the selected paragraph or style.
 
 
The Indents and Spacing page is also available when creating or modifying a graphics style, or modifying a presentation style.
 
 
===Alignment page===
 
Use the ''Alignment'' page to determine the text alignment: Left, Right, Center, or Justified. A preview shows the effects of the changes. The same choices can be accessed from the Text Formatting toolbar.  inline:graphics24.png
 
 
This page is also available when creating or modifying a graphics style, or modifying a presentation style.
 
 
===Tabs page===
 
Use the ''Tabs'' page, shown in the style modification dialog in Figure 11, to set tab stops. To delete one existing tab stop, select it in the list and click the '''Delete''' button. To delete all the tab stops, click the '''Delete All''' button. To create a new tab stop:
 
 
# Set the size of the tab stop in the edit box on the left.
 
# Select the type. If you set the type to ''Decimal''. specify in the box below the character to be considered the decimal point.
 
# Select a fill character which will be drawn from the tab insertion point up to the tab stop. You can choose any character to act as fill character.
 
# Click the '''New''' button to apply the new tab stop.
 
 
This page is also available in the '''Format > Paragraph''' dialog, as seen in Figure 9.
 
 
[[Image:IG3-11.png|Setting tab stops]]<br>Dialog to set tab stops in a paragraph or style.
 
 
===Asian Typography page===
 
Use the ''Asian Typography'' page to set the following properties relative to line changes:
 
 
* Apply list of forbidden characters to the beginning and end of lines
 
* Allow hanging punctuation
 
* Apply spacing between Asian, Latin and Complex text
 
 
Their use is self-explanatory.
 
 
[[Image:IG3-12.png|Asian Typography page]]<br>Asian Typography page options.
 
 
=Creating bulleted and numbered lists=
 
The procedure to create a bulleted or numbered list is quite different depending on the type of text box used, although the tools to manage the list and customize the appearance are the same.
 
 
In text boxes created automatically by Impress (called AutoLayout), the outline styles available are by default bulleted lists, while for normal text boxes an additional step is required to create a bulleted list.
 
 
==Creating lists in AutoLayout text boxes==
 
Every text box included in the available layouts is already formatted as a bulleted list, therefore to create a bulleted list the only necessary steps are:
 
 
# From the Layout pane, choose a slide design that contains a text box. Those are easily recognizable from the thumbnail.
 
# Click in the text box that reads '''Click to add an outline'''.
 
# Type the text, then press ''Enter'' to start a new bulleted line.
 
# The default list type is a bulleted list. The mechanisms to change the list from bulleted to numbered and vice versa are explained in [[#Changing the appearance of the list|Changing the appearance of the list]].
 
 
'''Tip:'''  Press ''Shift + Enter'' to start a new line without creating a new bullet or number. The new line will have the same indentation of the previous line. Press instead the button bullets on/off on the text formatting toolbar for a line without bullet. If the text formatting toolbar is not showing, enable it selecting '''View > Toolbar > Formatting''' in the menu bar.
 
 
==Creating lists in other text boxes==
 
To create a list in a text box, follow these steps:
 
 
# Place the cursor in the text box.
 
# Click the '''Bullets On/Off''' button  inline:graphics15.png  on the text formatting toolbar. If the text formatting toolbar is not showing, enable it by selecting '''View > Toolbar > Formatting''' from the menu bar.
 
# Type the text and press ''Enter'' to start a new bulleted line.
 
# The default list type is a bulleted list. The mechanisms to change the appearance of the list are explained on page 16.
 
 
==Creating a new outline level==
 
 
# If necessary, press ''Enter'' to begin a new line.
 
# Press ''Tab''. Each time you press ''Tab'' the line indents to the next outline level. Pressing ''Enter'' creates a new line at the same level as the previous one. To return to the previous level, press ''Shift+Tab''.
 
 
In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 3 style and so on.
 
 
'''Caution:'''  Unlike styles in Writer, do not try to change the outline level by selecting the text and then clicking the desired outline style. Due to the way the presentation styles work, it is not possible to apply them in this way.
 
 
==Changing the appearance of the list==
 
You can fully customize the appearance of a list, changing the bullet type or numbering for the entire list or for single entry. All the changes can be made using the Bullets and Numbering dialog, which is accessed by selecting '''Format > Bullets and Numbering''' or by clicking on the '''Bullets and Numbering''' icon  inline:graphics12.png on the text formatting toolbar.
 
 
===Selecting the entries===
 
For the entire list:
 
 
# Select the entire list or click on the gray border of the text box so that just the green resizing handles are displayed.
 
# Select '''Format > Bullets and Numbering''' or click on the '''Bullets and Numbering''' icon. inline:graphics9.png
 
# The Bullets and Numbering dialog contains five tabs: Bullets, Numbering type, Graphics, Position, and Customize.
 
#* If a bulleted list is needed, select the desired bullet style from the six default styles available on the ''Bullets'' page.
 
#* If a graphics style is needed, select one from those available on the ''Graphics'' page.
 
#* If a numbered list is needed, select one of the 6 default numbering styles on the ''Numbering type'' page.
 
 
Later in this section is an explanation on how to add further bullets and numbering styles to the existing ones.
 
 
[[Image:IG3-13.png|Bullets and Numbering dialog]]<br>The Bullets and Numbering dialog.
 
 
For a single line in the list:
 
 
# Click anywhere in the line to place the cursor in it.
 
# Follow steps 2-4 of the previous instruction set.
 
 
If the list was created in an AutoLayout text box, then an alternative way to change the entire list is to modify the Outline styles. Changes made to the outline style will apply to all the slides using them. Sometimes this is what you want; sometimes it is not, so some care must be taken. Follow the procedure to change the Presentation style described in [[#Modifying a style|Modifying a style]]. The tabs related to list management in Figure 3 are the same ones described below.
 
 
===Bullets, Numbering type and Graphics pages===
 
These three tabs contain predefined formatting for either the bullet type (Bullets and Graphics tabs) or for the numbering. To apply a specific one, it is sufficient to click on the image. A thick border will indicate the selection.
 
 
===Position page===
 
Use the ''Position'' page to fine tune the indentation and spacing of the bullet point and its text. This page is particularly effective when used in combination with the ''Customize'' page.
 
 
[[Image:IG3-14.png|Position page]]<br>The Position page used to set list indentation.
 
 
To set up an outline level, first select it from the list on the left hand side of the page. Then set the Indent, which is the spacing between the bullet or number and the text. If you select the checkbox '''Relative''' next to the indent, the indent value will be measured relative to the previous level and not from the margin.
 
 
The numbering alignment is only useful when creating a numbered list; use it to specify the alignment of the numbers. For example, you may want to align them to the right to line up one- and two-digit numbers in a pleasing way.
 
 
'''Tip:'''  To fully appreciate how the Numbering alignment works, try to create a numbered list with more than 10 elements and make sure that enough room has been made for a two (or more) digit number.
 
 
The ''Position'' page is not available if you are modifying a presentation style or graphics style, however the same effects can be obtained by using the ''Indents and Spacing'' page of the dialog for creating or modifying a slide (see Figure 10).
 
 
===Customize page===
 
Use the ''Customize'' page to alter the style of all the outline levels. The options available on this page depend on the type of marker selected for the list. Select first the level you want to modify on the left hand side of the box. To modify all 9 levels at once, select ''1 - 9'' as the level. Because the levels are arranged in a hierarchical structure, changing for example the font attribute of one of the levels ripples through all the lower levels.
 
 
[[Image:IG3-15.png|Customize page]]<br>The Customize page for the list outline.
 
 
Depending on the numbering style selected in the Numbering box (bullet, graphic, numbering), some of the following options become available on the page:
 
 
* '''Before''': Enter any text to appear before the number (for example, ''Step'').
 
* '''After''': Enter any text to appear after the number (for example, a punctuation mark).
 
* '''Color''': Pick the color for the list marker (number or bullet character).
 
* '''Relative size''': Specify the size of the number relative to the size of the characters in the paragraph of the list.
 
* '''Start at''': Enter the first value of the list (for example, you might want the list to start at 4 instead of 1).
 
* '''Character button''': Click this button to select the character for the bullet.
 
* '''Graphics selection button''': Opens a list of available graphics (Gallery) or allows the selection of a file on the hard disk to be used as marker.
 
* '''Width and Height''': Specify the dimensions of the graphic marker.
 
* '''Keep ratio checkbox''': If selected, the ratio between the width and the height of the graphic marker is fixed.
 
 
The right hand side of the screen shows a preview of the modifications made.
 
 
To revert to the default values, click the '''Reset''' button in the bottom right corner.
 
 
Using the Customize page, you can create complex structured layouts, for example a nested list with numbering followed by bullets, as shown below.
 
 
[[Image:IG3-16.png|Nested list]]<br>Nested list with mixture of numbers and bullets.
 
 
==Changing the order or the outline level of bulleted or numbered lines==
 
Click once in a line of text to place the cursor in it, then click on the Outline tab (to the right of the Normal tab) in the Workspace and use the '''Promote/Demote''' buttons in the Text Formatting toolbar to move the text to the appropriate position and give it the appropriate outline level.
 
 
inline:graphics32.png  The button with the arrow pointing left promotes the list entry by one level (for example from Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the up and down arrow buttons move the list entry. Numbering adjusts automatically.
 
 
'''Tip:'''  You can also use the ''Tab'' key and ''Shift + Tab'' keys to promote and demote the outline level of a line in a list.
 
 
=Using fields=
 
Fields allow the insertion of text automatically in the slide. Rather than text, think of a field as a kind of formula which is calculated when the document is loaded or printed, where the result of the formula is written to the document.
 
 
==Inserting a field==
 
To insert a field in a slide, move the cursor where the field will be and then select from the menu bar '''Insert > Fields''' followed by one of these choices:
 
 
* '''Date (fixed)''': inserts the date at time of inserting the field.
 
* '''Date (variable)''': upon loading the file, the field is updated and contains the date at the time of opening the file.
 
* '''Time (fixed)''': a field displaying the time of insertion.
 
* '''Time (Variable)''': a field which is updated at time of opening the file.
 
* '''Author''': The author of the presentation. This information is derived from the value recorded in the general options. To modify this information go to '''Tools > Options > OpenOffice.org''' section then select '''User Data'''.
 
* '''Page number''': inserts the page number of the slide.
 
* '''File name''': a field with the name of the file.
 
 
By default, the fields are displayed with a gray background. To remove the shading, go to '''View''' in the menu bar and deselect '''Field Shading'''; alternatively, press ''Control+F8''.
 
 
==Customizing fields==
 
The appearance of all the fields, excluding the page number field, can be customized from the corresponding field editor. To access the field editor (Figure 17):
 
 
# Move the cursor to the field and select it.
 
# Select '''Edit > Fields '''from the menu bar.
 
# Select the desired format in the dialog that appears.
 
# Click '''OK''' when satisfied.
 
 
[[Image:IG3-17.png|Customizing a field]]<br>Dialog to set up the Time format for a time field.
 
 
'''Tip:'''  A similar list of format choices can be accessed by selecting the field and right-clicking.
 
 
Modifications to the page number fields can be done in two different ways:
 
 
* Select the field and apply the formatting manually.
 
* Switch to the slide master editing mode ('''View > Master > Slide Master'''), then modify the Background object style as desired. Once back in Normal view, insert the page numbers from the '''Insert > Page Number''' box. See [[Impress Guide/Slide Masters, Styles, Templates|Chapter 2]] for more information about editing a slide master.
 
 
==Tips on use of fields==
 
When you want to have the same field appearing on all the slides of the presentation (for example the page number), it is faster and more convenient to add the field to the slide master, as explained in [[Impress Guide/Slide Masters, Styles, Templates|Chapter 2]].
 
 
Some fields, such as the file name or the author, are often more suitable to be inserted in a single slide such as the first or the last.
 
 
=Using hyperlinks=
 
When inserting text (such as a website addresses or URL) that can be used as a hyperlink, Impress formats it automatically, creating the hyperlink and applying to the text a color and underlining. If you do not want OOo to do that, select '''Edit > Undo Insert '''from the menu bar or press ''Control+Z'' immediately after the formatting has been applied.
 
 
'''Tips:'''  To prevent OOo from automatically turning website addresses (URLs) into hyperlinks, go to '''Tools > AutoCorrect > Options''' and deselect the '''URL Recognition''' checkbox. To change the color of hyperlinks, go to '''Tools > Options > OpenOffice.org > Appearance''', scroll to ''Unvisited links'' and/or ''Visited links'', select the checkboxes, pick the new colors and click '''OK'''. Caution: this will change the color for all hyperlinks in all components of OpenOffice.org—this may not be what you want.
 
 
You can also insert hyperlinks manually.
 
 
To insert a hyperlink, or to customize the appearance of a hyperlink, select '''Insert > Hyperlinks''' from the menu bar. The dialog shown below opens.
 
 
[[Image:IG3-18.png|Hyperlink dialog]]<br>Dialog to edit hyperlinks.
 
 
On the left hand side, select one of the four types of hyperlinks:
 
 
* '''Internet''': a web address, normally starting with http://
 
* '''Mail & News''': for example an email address.
 
* '''Document''': the hyperlink points to another document or to another place in the presentation.
 
* '''New document''': the hyperlink creates a new document.
 
 
The top right part of the dialog changes according to the choice made for the hyperlink type. A full description of all the choices, and their interactions, is beyond the scope of this chapter. Here is a summary of the most common choices used in presentations.
 
 
For an ''Internet'' type hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet), and enter the required web address (URL).
 
 
For a ''Mail and News'' type hyperlink, specify whether it is a mail or news link, the receiver address and for email, also the subject.
 
 
For a ''Document'' type hyperlink, specify the document path (the '''Open File''' button opens a file browser); leave this blank if you want to link to a target in the same presentation. Optionally specify the target in the document (for example a specific slide). Click on the '''Target''' icon to open the Navigator where you can select the target, or if you know the name of the target, you can type it into the box.
 
 
For a ''New Document'' type hyperlink, specify whether to edit the newly created document immediately or just create it ('''Edit later''') and the type of document to create (text, spreadsheet, etc.). For a presentation, '''Edit now''' is the more likely choice. The '''Select path''' button opens a directory picker.
 
 
The ''Further settings'' section in the bottom right part of the dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.
 
 
* Set the value of '''Frame''' to determine how the hyperlink will open. This applies to documents that open in a Web browser.
 
* '''Form''' specifies if the link is to be presented as text or as a button. See “Working with hyperlink buttons" for more information.
 
* '''Text''' specifies the text that will be visible to the user.
 
* '''Name''' is applicable to HTML documents. It specifies text that will be added as a <tt>NAME</tt> attribute in the HTML code behind the hyperlink.
 
* '''Event''' button: this button will be activated to allow OOo to react to events for which the user has written some code (macro). This function is not covered in this book.
 
 
==Editing text hyperlinks==
 
To edit a text hyperlink, select it (by dragging across the text, not clicking on it), then choose '''Edit > Hyperlink''' from the main menu bar. Make changes as needed and click '''Apply''' when done. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click '''Apply''' after each one. When you are finished, click '''Close'''.
 
 
==Working with hyperlink buttons==
 
A hyperlink button is inserted in the center of the current slide. In most cases, that is not where you want it to appear. To edit the text or size of a hyperlink button, or to move it to another place on the slide, first display the Form Controls toolbar ('''View > Toolbars > Form Controls'''). Select the '''Design Mode On/Off''' icon (upper right corner of the toolbar).
 
 
[[Image:FormControlToolbar.png|Form Controls toolbar]]<br>Form Controls toolbar.
 
 
Now you can click on the button and drag it to another position, or right-click to open a dialog where you can change the text on the button, the size of the button, and other properties.
 
 
When you have finished editing the button, click the '''Design Mode On/Off''' icon again to make the button active again.
 
  
  
 
{{CCBY}}
 
{{CCBY}}
[[Category: Documentation]]
+
[[Category: Impress Guide (Documentation)]]

Latest revision as of 07:16, 11 January 2009



This is Chapter 3 of OpenOffice.org 2.x Impress Guide (first edition), produced by the OOoAuthors group. A PDF of this chapter is available from the OOoAuthors Guides page at OpenOffice.org.

Introduction

This chapter describes the different ways to add text to slides and format the text.

Text in slides is contained in text boxes.

There are two ways to add text boxes to a slide:

  • Choose a predefined layout from the Layouts section of the Tasks pane, as described in Chapter 1. These text boxes are called AutoLayout text boxes.
  • Create a text box using the text tool.

This chapter describes how to create, modify, use, and delete text boxes; discusses the various types of text that can be inserted; and explains how to format the text, how to insert a numbered or bulleted list. and finally how and when to use fields.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools