Difference between revisions of "Documentation/OOo3 User Guides/Writer Guide/Entering a formula"

From Apache OpenOffice Wiki
Jump to: navigation, search
(New page: {{DISPLAYTITLE:Entering a formula}} {{Documentation/WG3MathTOC |ShowPrevNext=block |PrevPage=Documentation/OOo3_User_Guides/Writer Guide/Math Objects |NextPage=Documentation/OOo3_User_Guid...)
(No difference)

Revision as of 09:56, 1 December 2008


The equation editor uses a markup language to represent formulas. For example, %beta creates the Greek character beta (). This markup is designed to read similar to English whenever possible. For example, a over b produces a fraction: .

You can enter a formula in three ways:

  • Select a symbol from the Elements window.
  • Right-click on the equation editor and select the symbol from the context menu.
  • Type markup in the equation editor.

The context menu and the Elements window insert the markup corresponding to a symbol. Incidentally, this provides a convenient way to learn the OOoMath markup.

Documentation note.png Click on the document body to exit the formula editor.
Double-click on a formula to enter the formula editor again.

The Elements window

The simplest method for entering a formula is the Elements window, shown below.

Symbols are divided into categories.

The Elements window is divided into two main portions.

  • The top shows the symbol categories. Click on these to change the list of symbols.
  • The bottom shows the symbols available in the current category.
Tip.png You can hide (or unhide) the Elements window with View > Elements.


Example 1: 5 × 4

For this example we will enter a simple formula: 5 × 4

On the Elements window:

  1. Select the top-left button of the categories (top) section.
  2. Click on the multiplication symbol.
Unary/binary operators.

When you select the multiplication symbol on the Elements window, two things happen:

  • The equation editor shows the markup: <?> times <?>
  • The body of the document shows a gray box with the figure:
The multiplication symbol.

The <?> symbols are placeholders that you can replace by other text. The equation will update automatically, and the result should resemble the figure below.

Result of multiplication
Result of entering "5" and "4" next to the "times" operator.

Tip.png To keep the equation from updating automatically, select View > AutoUpdate display. To update a formula manually, press F9 or select View > Update.


Right-click menu

Another way to access mathematical symbols is to right-click on the equation editor. This produces a menu as shown in the figure below.

Right-click menu.
Documentation note.png The entries in this menu correspond exactly to those in the Elements window.

Markup

You can type the markup directly in the equation editor. For example, you can type “5 times 4" to obtain . If you know the markup, this can be the fastest way to enter a formula.

Tip.png The formula markup resembles the way the formula reads in English.


Below is a short list of common equations and their corresponding markup.

Display Command Display Command
a=b a = b a sqrt {a}
a2 a^2 an a_n
f(x)dx int f(x) dx an sum a_n
a≤b a <= b infinity
a×b a times b x·y x cdot y

Greek characters

Greek characters (α, β, γ, θ, etc.) are common in mathematical formulas. These characters are not available in the Elements window or the right-click menu. Fortunately, the markup for Greek characters is simple: Type a % sign followed the name of the character, in English.

  • To type a lowercase character, write the name of the character in lowercase.
  • To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples.

Lowercase Uppercase
%alpha α %ALPHA Α
%beta β %BETA Β
%gamma γ %GAMMA Γ
%psi ψ %PSI Ψ
%phi φ %PHI Φ
%theta θ %THETA Θ
Documentation note.png A complete table of Greek characters is included at the end of the Reference section.

Another way to enter Greek characters is by using the catalog window. Go to Tools > Catalog. The catalog window is shown below. Under “Symbol Set" select “Greek" and double-click on a Greek letter from the list. The markup name of the character is shown below the list window.

Catalog, used for entering Greek characters and some special symbols.

Example 2: π 3.14159

For this example we will suppose that:

  • We want to enter the above formula (the value of pi rounded to 5 decimal places).
  • We know the name of the Greek character ("pi").
  • But we do not know the markup associated with the symbol.

Step 1: Type % followed by the text pi. This displays the Greek character π.

Step 2: Open the Elements window (View > Elements).

Step 3: The symbol is a relation, so we click on the relations button MathRelBtn.png. If you hover the mouse over this button you see the tooltip "Relations".

Tooltip indicates the "Relations" button.
After selecting "Relations".

Step 4: Click on the symbol. The equation editor now shows the markup %pi<?> simeq <?>.

Step 5: Delete the <?> text and add 3.14159 at the end of the equation. Hence we end up with the markup %pi simeq 3.14159. The result is shown below.

Final result.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).

Personal tools