Difference between revisions of "Documentation/OOo3 User Guides/Getting Started/Printing, Exporting, Emailing"

From Apache OpenOffice Wiki
Jump to: navigation, search
(E-mailing a document to several recipients)
 
(32 intermediate revisions by 4 users not shown)
Line 1: Line 1:
{{DISPLAYTITLE:Printing, Exporting, and E-mailing - DRAFT}}
+
{{DISPLAYTITLE:Printing, Exporting, and E-mailing}}
 
{{Documentation/Print3TOC
 
{{Documentation/Print3TOC
 
|ShowPrevNext=block
 
|ShowPrevNext=block
|PrevPage=Documentation/OOo3_User_Guides/Getting Started/
+
|PrevPage=Documentation/OOo3_User_Guides/Getting Started/Numbering equations
|NextPage=Documentation/OOo3_User_Guides/Getting Started/
+
|NextPage=Documentation/OOo3_User_Guides/Getting Started/Exporting to PDF
}}
+
}}__notoc__
This is Chapter '''10''' of '''Getting Started with OpenOffice.org 3.x''', produced by the [http://oooauthors.org/ OOoAuthors group].  
+
This is Chapter '''10''' of '''Getting Started with OpenOffice.org 3.x''', produced by the [http://oooauthors.org/ OOoAuthors group]. A PDF of this chapter is available from [[Documentation/OOo3_User_Guides/Chapters | this wiki page]]. The PDFs are up to date for the second edition of the book, but not all of the wiki pages for this chapter have been updated yet.
<!-- A PDF of this chapter is available from the [http://documentation.openoffice.org/manuals/oooauthors2/ OOoAuthors Guides page] at OpenOffice.org. -->
+
 
This chapter provides general information about printing, faxing etc documents from OOo.
+
=Introduction=
 +
This chapter provides general information about printing, exporting and e-mailing documents from {{OOo}}.
  
 
= Quick printing =
 
= Quick printing =
 
Click the '''Print File Directly''' icon [[Image:PrintFileDir.png]] to send the entire document to the default printer defined for your computer.
 
Click the '''Print File Directly''' icon [[Image:PrintFileDir.png]] to send the entire document to the default printer defined for your computer.
  
{{Documentation/Note| You can change the action of the '''Print File Directly''' icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to '''Tools > Options > Load/Save > General''' and select the '''Load printer settings with the document''' option.}}
+
{{Note| You can change the action of the '''Print File Directly''' icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to '''Tools > Options > Load/Save > General''' and select the '''Load printer settings with the document''' option.}}
  
 
= Controlling printing =
 
= Controlling printing =
For more control over printing, use '''File > Print''' to display the Print dialog.
+
For more control over printing, use the Print dialog ('''File > Print''' or ''Ctrl+P'').
 
+
On the Print dialog, you can choose:
+
 
+
* Which printer to use (if more than one are installed on your system) and the properties of the printer—for example, orientation (portrait or landscape), which paper tray to use, and what paper size to print on. The properties available depend on the selected printer; consult the printer’s documentation for details.
+
* What pages to print, how many copies to print, and in what order to print them. Use dashes to specify page ranges and commas or semicolons to separate ranges; for example: 1, 5, 11–14, 34–40. ''Selection'' is the highlighted part of a page or pages.
+
* What items to print. Click the '''Options''' button to display the Printer Options dialog.
+
 
+
 
[[Image:PrintDialog.png|thumb|none|500px|''The Print dialog.'']]
 
[[Image:PrintDialog.png|thumb|none|500px|''The Print dialog.'']]
 +
The Print dialog has four tabs from which you can choose a range of options as described in the following sections:
  
Selections on the Printer Options dialog are different in Writer, Calc, Impress, and Draw, but in all cases they apply to this printing of this document only. For details, see the chapters on the various OOo components.
+
{{Note| Selections on the Printer Options dialog are different in Writer, Calc, Impress, and Draw, but in all cases they apply to this printing of this document only.
 
+
For details, see the chapters on the various components. To specify default print settings for OOo, go to '''Tools > Options > OpenOffice.org - Print''' and '''Tools > Options > Open Office.org Writer - Print'''.}}
To specify default printing options, see Chapter 2 (Setting up OpenOffice.org) and the chapters on the various OOo components.
+
 
+
= Exporting to PDF =
+
OpenOffice.org can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.
+
 
+
The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.
+
 
+
== Quick export to PDF ==
+
Click the '''Export Directly as PDF''' icon [[Image:PDF-direct-icon.png]] to export the entire document using your default PDF settings. You are asked to enter the file name and location for the PDF file, but you do not get a chance to choose a page range, the image compression, or other options.
+
 
+
== Controlling PDF content and quality ==
+
For more control over the content and quality of the resulting PDF, use '''File > Export as PDF'''. The PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links, and Security). Make your selections, and then click '''Export'''. Then you are asked to enter the location and file name of the PDF to be created, and click '''Save''' to export the file.
+
 
+
=== General page of PDF Options dialog ===
+
On the ''General'' page, you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.
+
 
+
[[Image:PDFGeneral3.png|thumb|none|500px|''General page of PDF Options dialog.'']]
+
 
+
'''Range section'''
+
 
+
* '''All''': Exports the entire document.
+
* '''Pages''': To export a range of pages, use the format '''3-6''' (pages 3 to 6). To export single pages, use the format '''7;9;11''' (pages 7, 9, and 11). You can also export a combination of page ranges and single pages, by using a format like '''3-6;8;10;12'''.
+
* '''Selection''': Exports whatever material is selected.
+
 
+
'''Images section'''
+
 
+
* '''Lossless compression''': Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other images.
+
* '''JPEG compression''': Allows for varying degrees of quality. A setting of 90% tends to work well with photographs (small file size, little perceptible loss).
+
* '''Reduce image resolution''': Lower-DPI (dots per inch) images have lower quality.
+
 
+
{{Documentation/Note| EPS images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.}}
+
 
+
'''General section'''
+
 
+
* '''PDF/A-1''': PDF/A is an ISO standard established in 2005 for long-term preservation of documents, by embedding all the pieces necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, encryption, and tagged PDF). If you select PDF/A-1, the forbiden elements are greyed-out (not available).
+
* '''Tagged PDF''': Exports special tags into the corresponding PDF tags. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.
+
* '''Export bookmarks: '''Exports headings in Writer documents, and page names in Impress and Draw documents, as “bookmarks” (a table of contents list displayed by some PDF readers, including Adobe Reader).
+
* '''Export notes''': Exports notes in Writer and Calc documents as PDF notes. You may not want this!
+
* '''Create PDF form - Submit format:''' Choose the format of submitting forms from within the PDF file. This setting overrides the control’s URL property that you set in the document. There is only one common setting valid for the whole PDF document: PDF (sends the whole document), FDF (sends the control contents), HTML, and XML. Most often you will choose the PDF format.
+
* '''Export automatically inserted blank pages''': If selected, automatically inserted blank pages are exported to the PDF. This is best if you are printing the PDF double-sided. For example, books usually have chapters set to always start on an odd-numbered (right-hand) page. When the previous chapter ends on an odd page, OOo inserts a blank page between the two odd pages. This option controls whether to export that blank page.
+
 
+
=== Initial View page of PDF Options dialog ===
+
On the ''Initial View'' page, you can choose how the PDF opens by default in a PDF viewer. The selections should be self-explanatory.
+
 
+
[[Image:PDFInitialView.png|thumb|none|500px|''Initial View page of PDF Options dialog.'']]
+
 
+
=== User Interface page of PDF Options dialog ===
+
On the ''User Interface'' page, you can choose more settings to control how a PDF viewer displays the file. Some of these choices are particularly useful when you are creating a PDF to be used as a presentation or a kiosk-type display.
+
 
+
[[Image:PDFUI.png|thumb|none|500px|''User Interface page of PDF Options dialog.'']]
+
 
+
'''Window options section'''
+
 
+
* '''Resize window to initial page.''' Causes the PDF viewer window to resize to fit the first page of the PDF.
+
* '''Center window on screen.''' Causes the PDF viewer window to be centered on the computer screen.
+
* '''Open in full screen mode.''' Causes the PDF viewer to open full-screen instead of in a smaller window.
+
* '''Display document title.''' Causes the PDF viewer to display the document’s title in the title bar.
+
 
+
'''User interface options section'''
+
 
+
* '''Hide menubar.''' Causes the PDF viewer to hide the menu bar.
+
* '''Hide toolbar.''' Causes the PDF viewer to hide the toolbar.
+
* '''Hide window controls.''' Causes the PDF viewer to hide other window controls.
+
 
+
'''Transitions'''
+
 
+
In Impress, displays slide transition effects as their respective PDF effects.
+
 
+
'''Bookmarks'''
+
 
+
Select how many heading levels are displayed as bookmarks, if ''Export bookmarks'' is selected on the General page.
+
 
+
=== Links page of PDF Options dialog ===
+
PDF export includes options to choose how links in documents are exported to PDF.
+
 
+
[[Image:PDFLinks.png|thumb|none|500px|''Links page of PDF Options dialog.'']]
+
 
+
'''Export bookmarks as named destinations'''
+
 
+
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.
+
 
+
'''Convert document references to PDF targets'''
+
 
+
If you have defined links to other documents with OpenDocument extensions (such as .ODT, .ODS, and .ODP), this option converts the files names to .PDF in the exported PDF document.
+
 
+
'''Export URLs relative to file system'''
+
 
+
If you have defined relative links in a document, this option exports those links to the PDF.
+
 
+
'''Cross-document links'''
+
 
+
Defines the behavior of links clicked in PDF files.
+
 
+
=== Security page of PDF Options dialog ===
+
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and apply some digital rights management (DRM) features.
+
 
+
* With an ''open password'' set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
+
* With a'' permissions password set'', the PDF can be opened by anyone, but its permissions can be restricted. See Figure 6.
+
* With ''both'' the ''open password'' and ''permission password'' set, the PDF can only be opened with the correct password, and its permissions can be restricted.
+
 
+
[[Image:PDFSecurity.png|thumb|none|500px|''Security page of PDF Options dialog.'']]
+
 
+
{{Documentation/Note| Permissions settings are effective only if the user’s PDF viewer respects the settings.}}
+
 
+
The figure below shows the pop-up dialog displayed when you click the '''Set open password''' button on the Security page of the PDF Options dialog.
+
 
+
After you set a password for permissions, the other choices on the Security page become available. These selections should be self-explanatory.
+
 
+
[[Image:SetPassword.png|thumb|none|500px|''Setting a password to encrypt a PDF.'']]
+
 
+
= Exporting to other formats =
+
OOo uses the term “export” for some file operations involving a change of file type. If you cannot find what you want under '''Save As''', look under '''Export''' as well.
+
 
+
OpenOffice.org can export files to XHTML.
+
 
+
In addition, OOo Writer can export to BibTeX (.bib), LaTeX 2e (.tex) and (new in OOo 2.3) MediaWiki (.txt). OOo Draw and OOo Impress can export to Macromedia Flash (.swf).
+
 
+
To export to one of these formats, choose '''File > Export'''. On the Export dialog, specify a file name for the exported document, then select the required format in the ''File format'' list and click the '''Export''' button.
+
 
+
= E-mailing documents =
+
OOo provides several ways to quickly and easily send documents as an e-mail attachment in one of three formats: OpenDocument (OOo’s default format), Microsoft Office formats, or PDF.
+
 
+
To send the current document in OpenDocument format:
+
 
+
# Choose '''File > Send > Document as E-mail'''. OpenOffice.org opens the e-mail program specified in '''Tools > Options > Internet > E-mail'''. The document is attached.
+
# In your e-mail program, enter the recipient, subject and any text you want to add, then send the e-mail.
+
 
+
'''File > Send > E-mail as OpenDocument Text''' (or Spreadsheet or Presentation) has the same effect.
+
 
+
If you choose '''<nowiki>E-mail as Microsoft [Word</nowiki>''',''' Excel''', or''' Powerpoint]''', OOo first creates a file in one of those formats and then opens your e-mail program with the file attached.
+
 
+
Similarly, if you choose '''E-mail as PDF''', OOo first creates a PDF using your default PDF settings (as when using the '''Export Directly as PDF''' toolbar button) and then opens your email program with the .PDF file attached.
+
 
+
== E-mailing a document to several recipients ==
+
To e-mail a document to several recipients, you can use the features in your e-mail program or you can use OOo’s mail merge facilities to extract email addresses from an address book.
+
 
+
You can use OOo’s mail merge to send e-mail in two ways:
+
 
+
* Use the Mail Merge Wizard to create the document and send it. See Chapter 11 (Using Mail Merge) of the ''Writer Guide'' for details.
+
* Create the document in Writer without using the Wizard, then use the Wizard to send it. This method is described here.
+
 
+
To use the Mail Merge Wizard to send a Writer document:
+
 
+
<ol>
+
<li>Click '''Tools > Mail Merge Wizard'''. On the first page of the wizard, select '''Use the current document''' and click '''Next'''.</li>
+
 
+
[[Image:MMWiz1.png|thumb|none|500px|''Select starting document.'']]
+
 
+
<li>On the second page, select '''E-mail message''' and click '''Next'''.</li>
+
 
+
[[Image:MMWiz2.png|thumb|none|500px|''Select document type.'']]
+
 
+
<li>On the third page, click the '''Select Address List''' button. Select the required address list (even if only one is shown) and then click '''OK'''. (If the address list you need is not shown here, you can click '''Add''' to find it and add it to the list.)</li>
+
 
+
[[Image:MMWiz3.png|thumb|none|500px|''Selecting an address list.'']]
+
 
+
<li>Back on the Select address list page, click '''Next'''. On the Create salutation page, deselect the checkbox by '''This document should contain a salutation'''.</li>
+
 
+
[[Image:MMWiz4.png|thumb|none|500px|''Deselecting a salutation.'']]
+
 
+
<li>In the left-hand list, click '''8 Save, print or send'''. OOo displays a “Creating documents” message and then displays the ''Save, print or send'' page of the Wizard.</li>
+
<li>Select '''Send merged document as E-Mail'''. The lower part of the page changes to show e-mail settings choices.</li>
+
<li>Type a subject for your email and click '''Send documents'''. OOo sends the e-mails.</li>
+
 
+
[[Image:MMWiz8.png|thumb|none|500px|''Sending a document as an email message.'']]
+
</ol>
+
  
== See also ==
+
= Selecting general printing options =
[[OpenOffice.org Writer and Outlook 2003]]
+
  
= Digital signing of documents =
+
On the ''General'' tab of the Print dialog, you can choose:
To sign a document digitally, you need a personal key, the certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.
+
  
When you apply a digital signature to a document, a kind of checksum is computed from the document’s content plus your personal key. The checksum and your public key are stored together with the document.
+
* The '''printer''' (from the printers available)
  
When someone later opens the document on any computer with a recent version of OpenOffice.org, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document. In addition, the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority.
+
* Which '''pages''' to print, the number of copies to print, and whether to collate multiple copies (Range and copies section)
  
Whenever someone changes something in the document, this change breaks the digital signature.
+
* Whether to print any '''comments''' that are in the document, and where to print the comments.
  
On Windows operating systems, the Windows features of validating a signature are used. On Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For a more detailed description of how to get and manage a certificate, and signature validation, see “Using Digital Signatures” in the OOo Help.
 
  
To sign a document:
+
Select the '''Properties''' button to display a dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.
  
# Choose '''File > Digital Signatures'''.
+
On the Options tab of the Print dialog (Figure 3), the last item, ''Use only paper tray from printer preference'', is not available in Calc.
# If you have not saved the document since the last change, a message box appears. Click '''Yes''' to save the file.
+
# After saving, you see the Digital Signatures dialog. Click '''Add''' to add a public key to the document.
+
# In the Select Certificate dialog, select your certificate and click '''OK'''.
+
# You see again the Digital Signatures dialog, where you can add more certificates if you want. Click '''OK''' to add the public key to the saved file.
+
  
A signed document shows an icon [[Image:SecurePDFicon.png]] in the status bar. You can double-click the icon to view the certificate.
 
  
 +
{{AddThis}}
  
 
{{CCBY}}
 
{{CCBY}}
 
[[Category:Getting Started (Documentation)]]
 
[[Category:Getting Started (Documentation)]]

Latest revision as of 17:23, 4 July 2018


This is Chapter 10 of Getting Started with OpenOffice.org 3.x, produced by the OOoAuthors group. A PDF of this chapter is available from this wiki page. The PDFs are up to date for the second edition of the book, but not all of the wiki pages for this chapter have been updated yet.

Introduction

This chapter provides general information about printing, exporting and e-mailing documents from Apache OpenOffice.

Quick printing

Click the Print File Directly icon PrintFileDir.png to send the entire document to the default printer defined for your computer.

Documentation note.png You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

The Print dialog.

The Print dialog has four tabs from which you can choose a range of options as described in the following sections:

Documentation note.png Selections on the Printer Options dialog are different in Writer, Calc, Impress, and Draw, but in all cases they apply to this printing of this document only.

For details, see the chapters on the various components. To specify default print settings for OOo, go to Tools > Options > OpenOffice.org - Print and Tools > Options > Open Office.org Writer - Print.

Selecting general printing options

On the General tab of the Print dialog, you can choose:

  • The printer (from the printers available)
  • Which pages to print, the number of copies to print, and whether to collate multiple copies (Range and copies section)
  • Whether to print any comments that are in the document, and where to print the comments.


Select the Properties button to display a dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog (Figure 3), the last item, Use only paper tray from printer preference, is not available in Calc.



Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools