Difference between revisions of "Documentation/How Tos/Handling the OpenOffice.org User Profile"

From Apache OpenOffice Wiki
Jump to: navigation, search
m
Line 1: Line 1:
 
==Introduction==
 
==Introduction==
{{AOo}} (AOO) stores all the data user-related in a dedicated folder, often called the profile. You can check its location on your hard disk in the OOo menu '''Tools > Options > OpenOffice > Paths'''. Most of the folders mentioned in that dialog are in the AOO user profile.
+
{{AOo}} (AOO) stores all the data user-related in a dedicated folder, often called the profile. You can check its location on your hard disk in the OOo menu {{menu|Tools|Options|OpenOffice|Paths}}. Most of the folders mentioned in that dialog are in the AOO user profile.
  
 
The folders are hidden by default, make sure your file explorer is configured to display the hidden files and folders.
 
The folders are hidden by default, make sure your file explorer is configured to display the hidden files and folders.
  
 
{{Win| Before Vista:<br> <tt> \Documents and Settings\<user name>\Application Data\OpenOffice\4\user\ </tt> <br>
 
{{Win| Before Vista:<br> <tt> \Documents and Settings\<user name>\Application Data\OpenOffice\4\user\ </tt> <br>
From Vista: <br> <tt>  \Users\<user name>\AppData\Roaming\OpenOffice\4\user </tt> }}
+
From Vista: <br> <tt>  \Users\<username>\AppData\Roaming\OpenOffice\4\user </tt> }}
  
 
{{Lin| For GNU/Linux users:<br> <tt> /home/<user name>/.openoffice/4/user </tt> }}
 
{{Lin| For GNU/Linux users:<br> <tt> /home/<user name>/.openoffice/4/user </tt> }}
Line 18: Line 18:
 
The user profile has several sub-folders related to dedicated items:
 
The user profile has several sub-folders related to dedicated items:
  
* autocorr: table of replacement from '''Tools > AutoCorrect'''
+
* autocorr: table of replacement from {{menu|Tools|AutoCorrect}}
 
* autotext: your AutoText entries
 
* autotext: your AutoText entries
* backup: backup files if you have activated the feature in '''Tools > Options > Load/Save > General'''. Always create a backup copy. Each time you save manually a file, the previous version is saved here (overwriting the former one). So you have the version n-1, n being the current version saved.
+
* backup: backup files if you have activated the feature in {{menu|Tools|Options|Load/Save|General}}. Always create a backup copy. Each time you save manually a file, the previous version is saved here (overwriting the former one). So you have the version n-1, n being the current version saved.
 
* basic: contains all the macros you have installed
 
* basic: contains all the macros you have installed
 
* config: some configuration files
 
* config: some configuration files
 
* database: registered databases
 
* database: registered databases
* gallery: customized gallery ('''Tools > Gallery''')
+
* gallery: customized gallery ({{menu|Tools|Gallery}})
 
* psprint: used for PDF export ?
 
* psprint: used for PDF export ?
 
* registry: contains most of the configuration files that could be damaged, especially in <tt> /data/org/openoffice/Office subfolder </tt>
 
* registry: contains most of the configuration files that could be damaged, especially in <tt> /data/org/openoffice/Office subfolder </tt>
Line 30: Line 30:
 
* store:  
 
* store:  
 
* temp:  
 
* temp:  
* template: your custom templates ('''File > Templates > Organize > My Templates''')
+
* template: your custom templates ({{menu|File|Templates|Organize|My Templates}})
 
* uno_packages: contains the extensions installed for the user only (including the spell checking dictionaries)
 
* uno_packages: contains the extensions installed for the user only (including the spell checking dictionaries)
 
* wordbook: contains the custom dictionaries  
 
* wordbook: contains the custom dictionaries  
Line 42: Line 42:
 
That's rather easy, just copy the whole profile (<tt>\user\ ...</tt>) to the new machine. You can even do that between a Windows install and a GNU/Linux one.
 
That's rather easy, just copy the whole profile (<tt>\user\ ...</tt>) to the new machine. You can even do that between a Windows install and a GNU/Linux one.
  
{{Warn|Note that version 3 asks during the install if you want to transfer your personal data, that is import your former 2.x version user configuration. Don't check that option! It can lead to issues afterwards, so better start from scratch and do that step by step.}}
+
{{Warn|Note that version 3 asks during the install if you want to transfer your personal data, that is, import your former 2.x version user configuration. Don't check that option! It can lead to issues afterwards, so better start from scratch and do that step by step.}}
  
  
 
== Resetting the User Profile ==
 
== Resetting the User Profile ==
  
A corruption of your profile can sometimes occur (an OS crash when using OOo for example). If you notice some strange behavior of OOo or if it just crashes or does not start, the first thing to try is to reset the user profile.
+
A corruption of your profile can sometimes occur (an OS crash when using {{AOo}} for example). If you notice some strange behavior of {{AOo}} or if it just crashes or does not start, the first thing to try is to reset the user profile.
 
# Rename it: change the <tt> \user </tt> folder (see above for its location) to <tt> \user.old </tt> for example. This way, you still keep a backup of your configuration.
 
# Rename it: change the <tt> \user </tt> folder (see above for its location) to <tt> \user.old </tt> for example. This way, you still keep a backup of your configuration.
# Restart OOo, it will create a new profile. You will have to go through the welcome process again. Note that if you had a version 2.x installed before, version 3 asks if you want to transfer your personal data, that is import your former 2.x profile. Don't check that option! It can wreck the new profile because of deprecated configuration files.
+
# Restart {{AOo}}, it will create a new profile. You will have to go through the welcome process again.  
 +
 
 +
{{Note |Note that if you had a version 2.x installed before, version 3 asks if you want to transfer your personal data, that is import your former 2.x profile. Don't check that option! It can wreck the new profile because of deprecated configuration files.}}
 +
 
 
# See if the issue has been fixed or not.
 
# See if the issue has been fixed or not.
#* If it has not been fixed the user profile may not be involved and you can replace the new profile by the old one (delete the new and rename back the old one to <tt>\user</tt>).
+
#* If it has not been fixed the user profile may not be involved, and you can replace the new profile by the old one (delete the new and rename back the old one to <tt>\user</tt>).
#* If it has been fixed one or few configuration files have been damaged. But that does not mean that the whole profile is dead. If you have heavily customized OOo, you can still try to retrieve some parts of your configuration: as you have kept a backup, copy the sub-folders (one at a time), and restart OOo to see if the issue is back or not. You can therefore spot from where the issue comes.
+
#* If it has been fixed one or few configuration files have been damaged. But that does not mean that the whole profile is dead. If you have heavily customized {{AOo}}, you can still try to retrieve some parts of your configuration: as you have kept a backup, copy the sub-folders (one at a time), and restart {{AOo}} to see if the issue is back or not. You can therefore spot from where the issue comes.
  
  

Revision as of 15:23, 31 August 2021

Introduction

Apache OpenOffice (AOO) stores all the data user-related in a dedicated folder, often called the profile. You can check its location on your hard disk in the OOo menu Tools → Options → OpenOffice → Paths. Most of the folders mentioned in that dialog are in the AOO user profile.

The folders are hidden by default, make sure your file explorer is configured to display the hidden files and folders.

Documentation windows.png Before Vista:
\Documents and Settings\<user name>\Application Data\OpenOffice\4\user\

From Vista:
\Users\<username>\AppData\Roaming\OpenOffice\4\user

Documentation linux.png For GNU/Linux users:
/home/<user name>/.openoffice/4/user
Documentation Mac Logo 40.png For Mac users:
/Users/<user name>/Library/Application Support/OpenOffice/4/user

Note that version 3 & 4 profiles have slightly changed from the 2.x branch, a directory level has been added, former profile was ...\OpenOffice.org2\user\ .


Profile Content

The user profile has several sub-folders related to dedicated items:

  • autocorr: table of replacement from Tools → AutoCorrect
  • autotext: your AutoText entries
  • backup: backup files if you have activated the feature in Tools → Options → Load/Save → General. Always create a backup copy. Each time you save manually a file, the previous version is saved here (overwriting the former one). So you have the version n-1, n being the current version saved.
  • basic: contains all the macros you have installed
  • config: some configuration files
  • database: registered databases
  • gallery: customized gallery (Tools → Gallery)
  • psprint: used for PDF export ?
  • registry: contains most of the configuration files that could be damaged, especially in /data/org/openoffice/Office subfolder
  • Scripts:
  • store:
  • temp:
  • template: your custom templates (File → Templates → Organize → My Templates)
  • uno_packages: contains the extensions installed for the user only (including the spell checking dictionaries)
  • wordbook: contains the custom dictionaries

Note that in parallel with this user profile, AOO also takes into account the configuration set for all users, that is the subfolders located in the main installation directory:

Documentation linux.png /opt/openoffice4/share under GNU/Linux
Documentation windows.png \Program Files(X86)\OpenOffice4\share under Windows
Documentation note.png Because there is no 64 bit Version of AOO for Windows, all program file are in the Program Files(X86) area on 64 bit Versions of the Windows OS

Moving User Settings

That's rather easy, just copy the whole profile (\user\ ...) to the new machine. You can even do that between a Windows install and a GNU/Linux one.

Documentation caution.png Note that version 3 asks during the install if you want to transfer your personal data, that is, import your former 2.x version user configuration. Don't check that option! It can lead to issues afterwards, so better start from scratch and do that step by step.


Resetting the User Profile

A corruption of your profile can sometimes occur (an OS crash when using Apache OpenOffice for example). If you notice some strange behavior of Apache OpenOffice or if it just crashes or does not start, the first thing to try is to reset the user profile.

  1. Rename it: change the \user folder (see above for its location) to \user.old for example. This way, you still keep a backup of your configuration.
  2. Restart Apache OpenOffice, it will create a new profile. You will have to go through the welcome process again.
Documentation note.png Note that if you had a version 2.x installed before, version 3 asks if you want to transfer your personal data, that is import your former 2.x profile. Don't check that option! It can wreck the new profile because of deprecated configuration files.
  1. See if the issue has been fixed or not.
    • If it has not been fixed the user profile may not be involved, and you can replace the new profile by the old one (delete the new and rename back the old one to \user).
    • If it has been fixed one or few configuration files have been damaged. But that does not mean that the whole profile is dead. If you have heavily customized Apache OpenOffice, you can still try to retrieve some parts of your configuration: as you have kept a backup, copy the sub-folders (one at a time), and restart Apache OpenOffice to see if the issue is back or not. You can therefore spot from where the issue comes.


Contents of this article derived from the OpenOffice User Forum

Content on this page is licensed under the Public Documentation License (PDL).
Personal tools
In other languages