How to create presentations easily in OpenOffice.org 2

From Apache OpenOffice Wiki
Jump to: navigation, search

Template:Documentation/NeedsRework



These instructions will give you an overview over the possibilities of "Impress“ explained with a small and easy example. It is provided that you have minor experiences with the handling of your computer and your operating system (for example windows ®, Linux with the graphical environment (X11)). It is not possible to describe all menus in detail. If you need assistance with the setup of OpenOffice.org, take a look at the "Getting Started-Guides“ or "First Steps in OpenOffice.org Writer“.

If you want to re-do the given example, you will need about one hour. After this training you will be able to create a new presentation with OpenOffice.org Impress.

It is not possible to offer guidelines about how to form a "good“ presentation. This would be too much for this document.

Starting your first presentation

Start the program with the selection presentations in the group OpenOffice.org (or OpenOffice.org Impress under Linux/KDE) in the start-menu.

The assistant of OpenOffice.org Impress appears. Under the guidance of the assistant you'll create the basis of your presentation with only a few mouse-clicks.


tip You can prevent the automatic start of the assistant with a new presentation. For this choose in the menu Tools > Options. In the new window select Presentation – General and disable "start with assistant“ under "new document“.

Note: In OpenOffice.org 2.0 the options-dialogue is context-sensitive to the used module. If you start an other module of OpenOffice.org, you can't see this dialogue.


Figure 1: presentation-assistant step 1


Since you haven't made a presentation choose "empty presentation“. Later on you can select your own presentations and patterns.

Click on "Next“. The next dialogue appears:


Figure 2: presentation-assistant step 2


You made here the decision for which medium you want to create your presentation (paper, screen...). For the beginning choose "screen“. Assume the pre-installed setting with "Next“.


tip
If you want to show your presentation with a beamer, choose also "screen“.


During the third step you can choose the change from one slide to the next.


Figure 3: presentation-assistant step 3


For example, you can lay down, if the content of your slide will be changed through overlaying from the left side... Take a look at the options. Maybe you're surprised about the possibilities of Impress.

In the second drop-down-menu you can choose how fast the change will happen.

In the last selection you can automate your presentation (change of the portrayal or the slides after a fixed time).

For the beginning, you should use the "standard presentation“. For this click – without any changes – on "Create“.

After you have clicked on create, you'll see the working space of OpenOffice.org Impress with its three parts. In the middle of the window, there is the film, which has OpenOffice.org created for you. Since OpenOffice 2.0 it's the standard.

Figure 4: The working space


On the left side of the window you can find in the standard setup of OpenOffice.org Impress the "slides“-view. In this view you'll find all slides of your presentation which you've created. They were in that order, which you've chosen. If you want to change the order, you can do it here. Click on the slide and move it with pressed left mouse button at the new place and let the mouse button go of.

On the right side you'll see the floating window of the templates (also known as the "stylist“). You can reach this window by pressing on the button <F11> or over the menu with Format > Templates.


Hint.png
For showing not too many elements at the figures, is the template-window not shown on some screen shots.


On the right side of the working space you'll find the window "Area of responsibility“ . You'll see at the moment the part Layout opened. You find there different templates with the following combinations:


  • titletextfield,
  • text fields,
  • clipart
  • tables,
  • diagrams and
  • objects.

If you have a look at all variants for the layout you'll see, that all convenient combination were there. The short-info for the layout, called "quick-info“ will be shown when you move your mouse-pointer over the different layouts.

For your first presentation start with the title-slide. For this click with the mouse on the corresponding layout-symbol. Your empty slide will change now for the new layout. You'll find there an area for the title of your presentation and a text field below.

Figure 5: Selection title-slide


Before you start working on your first presentation, you should acquaint oneself with your working space.

If you don't need this informations at the moment, then you can leave this chapter and can continue with [#0.0.Draw up your first presentation|outline Draw up your first presentation]. When needed, you can come back to this chapter.

Introduction to the Working Space

Under the title border (where you can find the name of your document and the actually used module) you'll find the

  • menu bar.

Under the menu bar you find three symbol-bars :

  • the standard bar,
  • the presentation bar and
  • the lines and filling bar.
Figure 6: menu bars/symbol-bars


The menu bar contains the main-commands for the presentation.

  • In the menu file you'll find the commands for open, draw up (new), save, export and print of files and closing OpenOffice.org.
  • The menu edit contains commands for the working with your file, like cancel, cut out, copy, select all, find and replace, the call for the navigator and duplicate.
  • With the commands under the menu look you can change the measure of the representation of your presentation. You can slot in the different symbol-bars, rulers and status bars and you can change the look.
  • With the menu insert you can insert new pages, tables, field commands, graphics and so on in your presentation.
  • The menu format gives you the possibility to change the different objects in your presentation. You can change the style of the used lines (go through , interrupted), the direction of your text (diagonal, vertical), the position (spaces) and the size of fonts. Additionally you can call the layout for slides (if faded out ) (slide layout) and the template for the slide.
  • In the menu tools you can start the spellcheck and the syllabification. Additionally you'll find here the gallery with the available graphics and under macro you find different entries for the recording, managing and carry out for the macros. Furthermore you'll find here the entry for the new Mediaplayer. The mediaplayer gives you the possibility to play sound- or video objects in your presentation. For the mediaplayer, the JMF (Java Media Framework) must be installed. In the tools-menu there is also an entry for changing your working area (shortcuts, menus, toolbars) and another entry with options for the standard adjustments (standard fonts or user-data).
  • The menu screen-presentation shows you dialogues, which have to do with your presentation. You can start the presentation (with or without stopping the time). You can select, how the presentation will run down (with which page starts the presentation, the style for the mouse pointer) (adjustment for the screen-presentation). Additionally you can open the part for the animations and you can choose how Impress will react after a mouse click.
  • In the menu window you can navigate between your open documents or open a new window or close another window.
  • The menu help provides you the access to all the different help-functions.

Open the menus and try all the commands. You can retract all your changes regularly in the Edit-menu with the command cancel.

The toolbar standard gives you access to all functions like "Edit file", "New" presentation, "Open file", "Save document", "Export directly as PDF-file" (since version 1.1), "Print", "Cut", "Copy" and "Paste". Additionally you'll find here the "Back-Arrows". As standard, you can take back 100 actions. You can increase or decrease this number in both directions.


tip
You can choose purposeful one action from this list. You needn't taking back all actions in chronological order. The menu will open, when you take a long click on the arrow-button.

In the toolbar standard you'll find the "navigator".

You find the toolbar presentation on the right side beneath the standard-toolbar. You find on that toolbar buttons for starting the slide show, access to the template, and for inserting a new slide. Like other toolbars you can move this toolbar to any other place where you want. You can place it as a floating window by pressing on the left border and place it where you want (the mouse pointer changed into a cross with 4 arrows).

The toolbar Lines and filling gives you some tools from this part. You'll find buttons the button for the "stylist" (templates). In the versions until 1.1.x you'll find at the same place the "objects bar", which shows you context-sensitive buttons. This has changed since OpenOffice.org 2.0. When needed, the context-sensitive toolbars will be shown as floating windows. You can have a look at all toolbars by choosing them in the menu View – toolbars. Have a look at them and test the different functions. (When you see a hook in front of the toolbar's name, the toolbar is selected, otherwise it's deselected.)


Figure 7: Toolbar Drawing


At the bottom of your window, you'll find the:

  • Toolbar Drawing.

In version 1.1 was these toolbar located at the left border of your window. If you prefer this, you can change the location for this toolbar.

The toolbar drawing contains useful resources for inserting very fast different arrangements in your presentation. For example, you find a button for inserting a text-field. If you had chosen the place for the field, you can insert your text.

You find two buttons for graphical elements plus some drop-down-menus with the most important standard forms, standard symbols, arrows... To learn more about this elements, press the left mouse-button on one element. A submenu will be opened with more variations of the different elements. If you leave the mouse-pointer a longer time over a button, then a short explanation (Quicktip) will appear.

Make some time for testing the functions of the toolbars with the following example. You can take all commands back with the "back-arrow", if a command has not the effect, you've expected.


Small example for testing the toolbars and the "Back-arrows":
Click in the lower text field of your presentation. Choose in the toolbar drawing a rectangle. Place the rectangle with the mouse in the text field and change the size, that the rectangle is a quarter of your text field. Choose an ellipse from the toolbar drawing and place it on the right side of your text field, change the size. Select in the toolbar line and filling an other colour for the area of the ellipse (perhaps red).

Click on the lines-and-arrows-button in the toolbar drawing. Then take a stand of the mouse-pointer in the middle of the right side from your rectangle, press the left mouse button, keep it pressed and move your mouse-pointer to the left side of the ellipse, let the mouse button go of. Now, you can choose in the toolbar lines and filling a colour for the arrow and a bigger thickness.

Please note, that the attitude in the toolbar lines and drawing is only valid for the selected object. You can select an object by clicking on it with the left mouse button. The selection is symbolised through the coloured squares around the object. By clicking on an already selected object, you can move the object to another place. By clicking and pulling with pressed mouse button on these coloured squares you can change the size of the object.

After a right-click on an object the context-menu will appear, where you have access to different object-characteristics.

Choose the rectangle and insert the text "What first". Mark the text and search a colour for the text in the toolbar lines and filling. Place the mouse-pointer in the ellipse and insert the text "And then". Select the text and choose another colour for the fonts.

Now you can do some experiments with the Back-arrows and can take back different steps or make them again.

example for the back arrows

At the end, delete all insertions from this example as a demonstration for the function of the Undo-symbols.

On the upper right border or your working area you will find the registers for the different working-views . You can activate the different views by clicking on the register. OpenOffice.org Impress gives you the following views (from left to right):

  • View Normal (For drawing),
  • View Structure,
  • View,
  • View Handout.

Select each of this views. Additionally exists the view "slide show". You can reach this command under the button in the toolbar presentation or by pressing the function key <F5>. You can do it without this view, because you have only an empty title page.

Drawing up Your First Presentation

After this short explanation of the working area of Impress you continue with your presentation. Change the view to "normal". Insert on the title page of the first part a title for the presentation. For this, click in the upper text field "Insert title by clicking" and insert the text "Introduction in OpenOffice.org". In the lower text field write "A short overview over the free office-suite", after clicking in the field.

Figure 8: Title page with inserted text


Add a new page to your presentation. For this, go to the menu Insert and choose the command page. A new, empty page, will be added. Select with the mouse pointer from the layout a layout with title, graphic and listed text (the quicktip shows "title, clipart, text"). This selection will be used immediately for your new page. Insert the text from the first page.

In the lower left half you'll insert a graphic. Make a double-click in this part. Choose in the next dialog the image, which you wish to insert, and click on "open". (Probably, the dialog can be different, depending on the used operating system.)

Figure 9: Dialog for the selection of the picture


Use the lower right half for a bulleted list:

  • free office-suite
  • file-exchange with office-suites from other producers
  • platform-independent (windows, Linux, MacOS and Solaris)

Select the inserted text from your list and change the font size with the toolbar lists and filling to 28. Afterwards make a right-click on the marked text for the context-menu.

Figure 10: dialog text


Select "text" there. On the register "you can change text" on the right of down the text anchorage of anchorage "above" on "center".

The result looks then as follows:


Figure 11: slide 2 with graphic and bulleted list


Until now, you have worked in the view normal of OpenOffice.org Impress. A little bit earlier you've learned about the registers for the other views. Choose the second register of the left hand side ("view structure"). You can see now all the slides with the texts:

Figure 12: view structure


In this view you can control the contents of your slides. You can insert new structure-levels and distribute contents on the different slides.

The view structure is very helpful for the planning and the arrangement of the content of your presentation.

The result of your changes can you see with a short delay in the structure view in the left window "slides".

Select the first row of the second slide and replace the text with "Advantages of OpenOffice.org". Go to the end of the last row and press the return-button and insert "Transformed for other operating systems". On your second slide appears a new point.

Place your Mouse pointer behind the title of your second slice and press the return-key. A new slide (number 3) appears. The structure-points will be moved to slide 3. With the backspace-key you can take back the changes. The structure points are on slide 2 again.

Repeat the creation of a new slide. But now, press the <Tab>-key instead of the return-key. The new slide disappears. On the second slide there is only one structure-point at the beginning. This point can be deleted with the <backspace>-key.


Hint.png
For your information: With the <Tab>-key have you classified the new slide in a lower category. The text, which was inserted as title is now a structure-point.

Try this by creating a new slide and inserting text. Then place the mouse pointer in front of the newly added text and press the <Tab>-key.

As a next step place your mouse-pointer in front of your bulleted list and press the combination <CAPS>+<Tab>. Your listed text will now change to a new title on the next slide. With this combination you can change the classification to a higher level.

As you see, changes can be done easily in the structure view.

Effects

Change back to the view Normal (register with "normal").

Choose on the left side of the workspace in the window "slides" side 1 of your presentation.

Select the (lower) text field.


Figure 13: User defined Animation


Open in the task-area on the right side the part "user defined animation". When you press the button "add" a dialogue appears, where you can choose different effects for the slides. In the register "start/entry" you'll find elements for the appearance of the text fields on the slide. In the register "exit" you'll find effects for the disappearance of the text fields. You can choose the different effects from a list. The effects are sorted in categories by the reaction of the audience. In another register you'll find paths of animations, which means that different effects are combined. In the lower part of the dialogue you can adjust the speed of the animations. When you've marked the "automatic preview" you can see how your presentation is working.

When you press the "OK"-button, you'll see in the task-area a list with the selected animations. You can choose from this list an entry as animation for your objects. The name of this animation is written in bold letters over the part with the adjustments for this entry. Changes can be made for the kind of starting the effect (with mouse click), for the direction (from outside to inside) or the speed.

With the arrow keys below the list field you can change the order of the effects. If you want to delete an effect from this list, you can do this with the context-menu (right-click with the mouse) or by pressing the "delete"-key, when the entry is selected.

You can add sounds for the change from one slide to the next. You find them – like the optical animations – in the part "slide transition" in the task area. You can select the optical and acoustical animation-template from a list.

Similar to the optical user defined effects you can choose the speed for the effect, the action, which starts the effect. When you choose a sound, you can adjust, that the sound should be repeated.

Furthermore, you can choose, if the selected animation is valid only for this slide or all slides.

If you have chosen a sound for the slide transition, you can reach the dialogue through the list-entry "other sound...". A new dialogue for the selection of the sound-file will appear.

Background and Background Colour

As a next step, you can add a background colour. Place your mouse-pointer on your slide and call the menu format > page.


Hint.png
If you hadn't chosen an object, you can click on a free part of your slide with the right mouse-button and can choose from the appearing context-menu slide > page adjustment.


Figure 14: Dialogue page adjustment – background


In the opening window you can select in the register "background" the background colour for your slide.

You can choose between plain colour, colour gradient, hatching or bitmap. Look at all possibilities and test them with your presentation.


Tip2.png
If you don't like the "standard-colours", you can define new colours. More informations about this are mentioned in the help-file (menu help > content and search for "colours" (subsearch "define").

You've been asked about the selection of the background, if the background adjustments are only valid for all slides. You can change (fast and simple) the adjustments for all slides of your presentation (master function).

If you want to create a special background (for example using a graphic or a logo) go to the menu bar view > master > slide master into the master view of the slides. Now you can go to the menu insert receive through the command image > from file a dialog for the selection of the image you want to insert. Confirm your selection with the "open"-button. Select the image and call for the context-menu (click with the right mouse-button). Choose position and size. In the following dialog you can change the size and the alignment of your graphic.

Figure 15: Dialog position and size


Eventually, you'll have to go to the context-menu arrangement and put your graphic in the right level (maybe in the level behind the text boxes).

In the slide master view you can change the text styles of the structure-texts and the colours. Leave the slide master view by clicking in the menu bar master view on the button "close master view".

Saving

You can save your presentation with the menu file > save or by clicking on the button "save" (disk symbol). You can also use the menu file > save as... and may define a path.

You can save your presentation as a template for using it as a base for your next presentation.


Hint.png
First, you should know, where you have to save the template. You can see the path in the menu tools > options "OpenOffice.org", "paths", "templates".

When you know the path, go to the dialog under file > save as..., select the correct directory, give it a easy-to-know-name without file-extension and select in the list-field file type "OpenDocument Presentation Template" (or the format of the older versions: OpenOffice.org 1.0 Presentation Template).


Hint.png
You can use two paths for the templates (one directory for the templates for all users and one directory for your own templates). You have to save your templates into your own directory.

If you use a multi-user-system like Linux or Windows XP Professional the operating system will check, if you have write-access to the chosen directory. Normally you only have reading-access but not writing-access. When the template should be available for all users, you have to talk with your administrator.

When you start OpenOffice.org for the next time, go to the menu file > templates > manage. You can see in the left list-field after a double-click on "My templates" your saved template. After closing this dialog-box, you can use the wizard for creating a new presentation. Now you'll find your own template under step 1 in the register "My templates".

Notes

You can make some notes for your presentation quite easy. Choose the register notes in the task-area. You'll see the notes-area to your slide, where you can write down some headwords or your lecture-text.

When you print your presentation, you can choose, if this part will be printed too or not.

Handouts

In the view Handout you can check, how the documents for the listeners look like. If you prefer another sharing out of the slides, you can change the Layout in the right side of the working area. This selection is used after a mouse click for all pages of the handout.

Printing

If you want to print your presentation directly, you can click on the printer-button (printer symbol) in the standard-toolbar. Special adjustments can be done with the menu file > print.

Here you can define if all pages should be printed or only separate pages.

When you click on the button "Additional Tools" a dialog box will appear, where you can define, that notes or handouts should be printed too.

Presenting Your Slide Show

Open your presentation with file > open. Start the slide show with the menu slide show > slide show or with the button in the toolbar. As alternative, you can start the slide show with the function-key <F5> .


Win.png
When you're a windows-user, you can use the short-cut <Strg>+<F2> (for versions of OpenOffice.org until 1.0.3). In the version 1.1.x, for starting of the slide show you can press the <F9> button.
Linux.png
The short-cut <Strg>+<F2> is used with Linux/KDE for another action. If you use Linux/KDE with a version of OpenOffice.org 1.0.3 (or lower) you should adapt the short-cut with tools > adapt , as solution for the conflict.

After a short moment, the first slide of your presentation will appear. If you hadn't chosen an automatic change to the next slide, you can reach the next slide by clicking with the left mouse-button or by pressing the space-bar.


Hint.png
Use a cordless mouse (or one with a long cord), so you have the possibility for bigger moves during your lecture.

If you want to go back to the previous slide, press the right mouse-button. You can also use the arrow-keys for browsing fast back or forward.

If you want to browse to a slide, which is near the end (while you're on the very beginning), you can use the navigator. For calling the navigator, press the <shift>-key and the function-key <F5> (until version 1.1 only the function-key <F5>). The navigator appears on your actual presentation-slide.

Additionally you can cancel your presentation with the <ESC>-button (is needed by OpenOffice.org 1.0.3). Click in the standard-toolbar on the button with the compass.

You can choose with the mouse in the open navigator-window the slide you want to go to or you can browse with the arrow-keys on the upper border of the window. If you double click on a slide, this slide will be shown immediately in the edit-area.

With the <ESC>-key you can cancel your presentation at any time.

Export of your file as HTML-file

You want to show your presentation with internet-techniques. This can be needed, when on the computer, which you use for the presentation, OpenOffice.org isn't installed.

For this, choose in the menu file the submenu export. A dialog will be opened, where you can insert the file-name and the directory for saving the file. As file-extension "HTML-document (OpenOffice.org Impress)" is preselected. The extension HTML will be added automatically (if you haven't deselected the automatic file-extension). When you click on "export", the next dialog will appear.

Figure 16: dialog box: Design


When you open this dialog for the first time, there is no "existing design", so you have to add a "new design", which you can use for other presentations as well. Leave the pre-installed settings as they are and click on "next". The following dialog will appear:


Figure 17: dialog box: HTML-adjustment


On the left hand side you can choose how your HTML-code should look like. Leave the pre-installed settings as they are.

On the right side you should ask OpenOffice.org to create a title-page (index-file). Deselect "show notes". If you do not deselect them, then on each page will a note-area be added. But this isn't needed for your presentation. Click on "next" and a new dialog will appear.

Figure 18: dialog box: graphic / screen size


Here you can choose, in which format (gif or jpeg) your graphics will be saved and how strong they will be compressed (only possible, if you choose jpeg). On the right side you can enter the screen size for your presentation. Choose "middle screen size". In the lower part of the window, you can select or deselect, if sounds should be used when the slides are changing. Press the "next" button and the next dialog box will appear:

Figure 19: dialog box: author and other informations


Here you can enter for the newly created title-page your personal data and additionally other data. By clicking on the button "next" you reach the following dialog.

Figure 20: dialog box: buttons


Here you can choose a button-set for your presentation. Deselect "Only text" and apply your choice by clicking on the button "next". Now you can choose the colour-scheme for your document.

Figure 21: dialog box: colour-scheme and background


Leave the pre-installed settings as they are and use the colour-scheme of your document. Alternatively you can use the settings of your browser or other - quite different – settings – as you like. If you want to choose your own settings, you can do this with the different buttons "text", "hyperlink" and so on by entering different colours. When you've entered everything, then click on the button "finish". The export of your presentation is finished and you can look at it with a browser.

Exporting Your Presentation as PDF-File

Since version 1.1 of OpenOffice.org, it's possible to save (export) a file directly as a pdf-file. You needn't another program for creating these files. You only have to click on the button Impress button pdf.png in the menu bar. An other way for this function is to use the menu file > export as PDF.

Tip2.png
This way has the advantage, that you can manipulate the quality-standard of the created file.

The following dialog (with several register) appears:


Figure 22: dialog PDF-options

In the first register ( you can choose, which slides should be exported (all, special pages...), the quality-level of your graphics. In the lower part of the window, you'll find options, if the notes should be added too, and if a "tagged" PDF-file will be created. A tagged PDF-file has some advantages: If you use this file on the internet, the beginning will be shown, during the rest of the file will be downloaded. Additionally, hyperlinks have the same function in the pdf-file as in the original document. In the register „Benutzeroberfläche“ you get settings for animations, to transfer the transitions of the slides to the pdf file.

If you have made your selections, click on "export" and a new dialog appears. In this dialog you have to enter a name for the file and the directory, where it should be saved. Apply your entries by clicking on the button "export" and OpenOffice.org creates the pdf file.

Tip2.png
In former versions of OpenOffice.org the dialogs were in another direction. The file dialog were the first step. If you have cancelled the creation of the file in this first step, you probably had to delete the empty pdf-file, which Impress has already created.


Feedback

Please direct any comments or suggestions about this document to:andreasma[at]openoffice.org

Acknowledgments

Initial author: Andreas Mantke

Corrections (of the German version): Klaus Endelmann, Helga Fischer, Michael Kirchner, Michael Scheurer, Thomas Hackert

Version: third (for the German version), first (for the English version)

Last changes::

First translation into English: Sigrid Kronenberger

Modifications and Updates

Version
Date
Description of Change
0.1 042103 Original-Dokument (german language) by Andreas Mantke (andreasma[at]openoffice.org)
0.2 090203 Update for OpenOffice.org 1.1 (german language) by Andreas Mantke (andreasma[at]openoffice.org)
0.3 050805 Update for OpenOffice.org 2.0 (german language) by Andreas Mantke (andreasma[at]openoffice.org)
0.4 061405 Translation into English by Sigrid Kronenberger (eskroni[at]openoffice.org)
0.5 102305 English screen shots by Andreas Mantke (andreasma[at]openoffice.org)
0.6 113005 Update to Oasis-format by Andreas Mantke (andreasma[at]openoffice.org)
0.7 101307 Move to Wiki and update section export to pdf by Andreas Mantke (andreasma[at]openoffice.org)
Personal tools