Difference between revisions of "Documentation/Dashboard/Styles"

From Apache OpenOffice Wiki
Jump to: navigation, search
 
(25 intermediate revisions by 8 users not shown)
Line 1: Line 1:
{| cellpadding="3" cellspacing="1" style="background-color: #666666; margin-left: 3em;"  
+
{{DISPLAYTITLE:Styles}}
 +
== Project-independent ruleset ==
 +
{{Note|See the general project-independent rules at [[Wiki Contribution Guidelines]] first!}}
 +
== Styles used in the Documentation Project Wiki ==
 +
{| cellpadding="3" cellspacing="1" style="background-color: #666666; margin-left: 1em;"  
 
|- bgcolor="#DDDDDD"
 
|- bgcolor="#DDDDDD"
! Style !! Wiki syntax example !! What you get   
+
! width="20%" | Style  
 +
! width="40%" | Wiki syntax example  
 +
! width="40%" | What you get   
 
|- bgcolor="#FFFFFF"
 
|- bgcolor="#FFFFFF"
| Headings,<br> levels 1, 2, 3
+
| Headings,<br> levels 2, 3, 4
 
||<nowiki> ==Working with Layers== </nowiki>
 
||<nowiki> ==Working with Layers== </nowiki>
 
<nowiki> ===Hiding Layers=== </nowiki> <br>
 
<nowiki> ===Hiding Layers=== </nowiki> <br>
Line 30: Line 36:
 
To hide a layer
 
To hide a layer
 
# Select a layer, and then choose '''Format > Layer'''.
 
# Select a layer, and then choose '''Format > Layer'''.
# In the properties area, clear the '''Visible''' check box and click '''OK'''.
+
# In the properties area, clear the '''Visible''' check box and click '''OK'''.  
 
|- bgcolor="#FFFFFF"
 
|- bgcolor="#FFFFFF"
| Emphasis||<nowiki> The '''layout''' layer is the default work space.</nowiki>|| The '''layout''' layer is the default work space.
+
| Interrupted numbered lists <br>
 +
(works also for pictures and long code examples within lists)
 +
||To print a mail merge document
 +
<nowiki> <ol> </nowiki><br>
 +
<nowiki><li> Choose '''File > Print'''. </li> </nowiki> <br>
 +
<nowiki><li> Click '''Yes''' to confirm that you want to print a form letter </li> </nowiki> <br>
 +
<nowiki>{{Warn|Do not mark the checkbox saying you do not want to see the message again.}} </nowiki> <br>
 +
<nowiki><li> In the Mail Merge window select the first record, ...  </li>.</nowiki>
 +
<nowiki> </ol> </nowiki>
 +
||
 +
To print a mail merge document
 +
<ol>
 +
<li> Choose '''File > Print'''. </li>
 +
<li> Click '''Yes''' to confirm that you want to print a form letter </li>
 +
{{Warn|Do not mark the checkbox saying you do not want to see the message again.}}
 +
<li> In the Mail Merge window select the first record, ...  </li>.
 +
</ol>
 +
|- bgcolor="#FFFFFF"
 +
| Note ||<nowiki>{{Note| You cannot change the name of or delete a predefined StarOffice Draw layer.}} </nowiki>
 +
||
 +
{{Note| You cannot change the name of or delete a predefined StarOffice Draw layer.}}
 +
|- bgcolor="#FFFFFF"
 +
| Tip || <nowiki> {{Tip| You can make a layer visible or invisible by clicking on its tab while holding down the Shift key.}} </nowiki>
 +
||
 +
{{Tip| You can make a layer visible or invisible by clicking on its tab while holding down the Shift key.}}
 +
|- bgcolor="#FFFFFF"
 +
| Caution || <nowiki> {{Warn| The validation of a signature is not a legally binding guarantee of any kind.}} </nowiki>
 +
||
 +
{{Warn| The validation of a signature is not a legally binding guarantee of any kind.}}
 +
|- bgcolor="#FFFFFF"
 +
| Emphasis (also used for menu paths and GUI elements)||<nowiki> The '''layout''' layer is the default work space.</nowiki>|| The '''layout''' layer is the default work space.
 
|- bgcolor="#FFFFFF"
 
|- bgcolor="#FFFFFF"
 
| Menu paths||<nowiki> Select a layer, and then choose '''Format > Layer'''. </nowiki>|| Select a layer, and then choose '''Format > Layer'''.
 
| Menu paths||<nowiki> Select a layer, and then choose '''Format > Layer'''. </nowiki>|| Select a layer, and then choose '''Format > Layer'''.
 
|- bgcolor="#FFFFFF"
 
|- bgcolor="#FFFFFF"
| Links ||<nowiki> See the [http://en.wikipedia.org/wiki/Layers_%28digital_image_editing%29 Layer]entry in Wikipedia. </nowiki>|| See the [http://en.wikipedia.org/wiki/Layers_%28digital_image_editing%29 Layer]entry in Wikipedia.
+
| Links ||<nowiki> See the [http://en.wikipedia.org/wiki/Layers_%28digital_image_editing%29 Layer] entry in Wikipedia. </nowiki>|| See the [http://en.wikipedia.org/wiki/Layers_%28digital_image_editing%29 Layer] entry in Wikipedia.
 +
|- bgcolor="#FFFFFF"
 +
| "See Also" jump list (at the end of a page) ||<nowiki> {{SeeAlso|EN |
 +
* [[Documentation/OOo3_User_Guides/Getting_Started|Getting Started with OpenOffice.org 3.x]]
 +
}} </nowiki>|| {{SeeAlso|EN|
 +
* [[Documentation/OOo3_User_Guides/Getting_Started|Getting Started with OpenOffice.org 3.x]]
 +
}}
 +
|- bgcolor="#FFFFFF"
 +
| Code in running text || <nowiki> The <tt>Select Case</tt> statement...</nowiki>|| The <tt>Select Case</tt> statement...
 +
|- bgcolor="#FFFFFF"
 +
| Short code examples
 +
|Open a terminal and enter:
 +
:<nowiki>tar -vxzf ''filename'' </nowiki>
 +
|Open a terminal and enter:
 +
    tar -vxzf ''filename''
 +
|- bgcolor="#FFFFFF"
 +
|Long code examples
 +
|(The <nowiki><nowiki><code>...</code></nowiki></nowiki> tags are deprecated.)
 +
<!-- The &lt;br> tags in this column are only for formatting the column; for unknown reasons, they are needed to force new lines. -->
 +
<nowiki><source lang="oobas"> </nowiki><br>
 +
Option Explicit
 +
 
 +
Sub Main<br/>
 +
Dim oDoc as Object<br/>
 +
. . . <br/>
 +
End Sub 'Main<br/>
 +
<nowiki></source></nowiki>
 +
|(The <nowiki><code>...</code></nowiki> tags are deprecated.)
 +
 
 +
<source lang="oobas">
 +
Option Explicit
 +
 
 +
Sub Main
 +
Dim oDoc as Object
 +
. . .
 +
End Sub 'Main
 +
</source>
 +
 
 
|- bgcolor="#FFFFFF"
 
|- bgcolor="#FFFFFF"
| Code ||........ || ........
+
| Displaying markup
 +
| Highlight text and select the nowiki icon at the top of the text editing box.
 +
<nowiki><nowiki>==Example Title==</nowiki></nowiki>
 +
|<nowiki>==Example Title==</nowiki>
 +
 
 
|}
 
|}
 +
 +
 +
{{PDL1}}
 +
 +
[[Category:Guidelines]]
 +
[[Category:How to]]

Latest revision as of 08:41, 17 July 2018

Project-independent ruleset

Documentation note.png See the general project-independent rules at Wiki Contribution Guidelines first!

Styles used in the Documentation Project Wiki

Style Wiki syntax example What you get
Headings,
levels 2, 3, 4
==Working with Layers==

===Hiding Layers===
====Showing Hidden Layers====

Working with Layers

Hiding Layers

Showing Hidden Layers

Bullet lists OpenOffice Draw provides three default layers:

*Layout
*Controls
*Dimension lines

OpenOffice Draw provides three default layers:

  • Layout
  • Controls
  • Dimension lines
Numbered lists To hide a layer

# Select a layer, and then choose '''Format > Layer'''.
# In the properties area, clear the '''Visible''' check box and click '''OK'''.

To hide a layer

  1. Select a layer, and then choose Format > Layer.
  2. In the properties area, clear the Visible check box and click OK.
Interrupted numbered lists

(works also for pictures and long code examples within lists)

To print a mail merge document

<ol>
<li> Choose '''File > Print'''. </li>
<li> Click '''Yes''' to confirm that you want to print a form letter </li>
{{Warn|Do not mark the checkbox saying you do not want to see the message again.}}
<li> In the Mail Merge window select the first record, ... </li>. </ol>

To print a mail merge document

  1. Choose File > Print.
  2. Click Yes to confirm that you want to print a form letter
  3. Documentation caution.png Do not mark the checkbox saying you do not want to see the message again.
  4. In the Mail Merge window select the first record, ...
  5. .
Note {{Note| You cannot change the name of or delete a predefined StarOffice Draw layer.}}
Documentation note.png You cannot change the name of or delete a predefined StarOffice Draw layer.
Tip {{Tip| You can make a layer visible or invisible by clicking on its tab while holding down the Shift key.}}
Tip.png You can make a layer visible or invisible by clicking on its tab while holding down the Shift key.
Caution {{Warn| The validation of a signature is not a legally binding guarantee of any kind.}}
Documentation caution.png The validation of a signature is not a legally binding guarantee of any kind.
Emphasis (also used for menu paths and GUI elements) The '''layout''' layer is the default work space. The layout layer is the default work space.
Menu paths Select a layer, and then choose '''Format > Layer'''. Select a layer, and then choose Format > Layer.
Links See the [http://en.wikipedia.org/wiki/Layers_%28digital_image_editing%29 Layer] entry in Wikipedia. See the Layer entry in Wikipedia.
"See Also" jump list (at the end of a page) {{SeeAlso|EN | * [[Documentation/OOo3_User_Guides/Getting_Started|Getting Started with OpenOffice.org 3.x]] }}
See Also


Code in running text The <tt>Select Case</tt> statement... The Select Case statement...
Short code examples Open a terminal and enter:
tar -vxzf ''filename''
Open a terminal and enter:
   tar -vxzf filename 
Long code examples (The <nowiki><code>...</code></nowiki> tags are deprecated.)

<source lang="oobas">
Option Explicit

Sub Main
Dim oDoc as Object
. . .
End Sub 'Main
</source>

(The <code>...</code> tags are deprecated.)
Option Explicit
 
Sub Main
Dim oDoc as Object
. . . 
End Sub 'Main
Displaying markup Highlight text and select the nowiki icon at the top of the text editing box.

<nowiki>==Example Title==</nowiki>

==Example Title==


Content on this page is licensed under the Public Documentation License (PDL).
Personal tools