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Introducing Impress

What is Impress?
Impress is OpenOffice.org’s presentation (slide show) component. You
can create slides that contain text, bulleted and numbered lists and a
wide range of OLE objects. Impress has access to the spelling checker
and thesaurus and comes with pre-packaged text styles, background
styles, and a handy online help.
This chapter introduces the Impress user interface and describes how
to create a simple slide show using the Presentation Wizard.
The rest of this guide illustrates many other features available in
Impress that can be used to create more sophisticated slide shows.
Note

Drawings are created in the same way with Impress as they are
with Draw. Refer to the Draw Guide for details on how to use the
drawing facilities.

Note for Mac users
Some keystrokes and menu items on a Mac are different from those
given in this book. Please see “Using Impress on a Mac” on page 25
for a list of differences.

The main Impress window
The main Impress window (Figure 1) has three parts: the Slides pane,
the Workspace, and the Tasks pane. Additionally, several toolbars can
be displayed or hidden during the creation of a presentation.

Tip

You can remove the Slides pane or the Tasks pane from view by
clicking the X in the upper right corner of each pane. You can
also show or hide these panes using View > Slide Pane or View
> Task Pane.

Slides pane
The Slides pane on the left hand side of the screen contains thumbnail
pictures of the slides in your presentation, in the order they will be
shown—unless you change the order, as described in Chapter 9 (Slide
Shows). Clicking a slide in this pane selects it and places it in the
Workspace. When a slide is in the Workspace, you can apply to it any
changes desired.

The main Impress window
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Figure 1: Main window of Impress
Several additional operations can be performed on one or more slides
simultaneously in the Slides pane:
• Add new slides to the presentation.
• Mark a slide as hidden so that it will not be shown as part of the
presentation.
• Delete a slide from the presentation if it is no longer needed.
• Rename a slide.
• Duplicate a slide (copy and paste) or move it to a different
position in the presentation (cut and paste).
It is also possible to perform the following operations, although there
are more efficient methods than using the Slides pane, as you will see
in this chapter:
• Change the slide transition following the selected slide or after
each slide in a group of slides.
• Change the sequence of slides in the presentation.
• Change the slide design.
• Change slide layout for a group of slides simultaneously.
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Tasks pane
The Tasks pane on the right hand side of the screen has five sections:
Master Pages, Layouts, Table Design, Custom Animation, and
Slide Transition.
Master Pages
Here you define the page style for your presentation. Impress
contains prepackaged Master Pages (slide masters). One of them—
Default—is blank, and the rest have a background and styled text.

Tip

Press F11 to open the Styles and Formatting window, where you
can modify the styles used in any slide master to suit your
purposes. This can be done at any time. See Chapter 2 for more
information.

Layouts
The prepackaged layouts are shown here. You can choose the one
you want, use it as it is, or modify it to your own requirements. At
present it is not possible to create custom layouts.
Table Design
The standard table styles are provided in this pane. You can further
modify the appearance of a table with the selections to show or hide
specific rows and columns, or to apply a banded appearance to the
rows and columns. Refer to Chapter 3 (Adding and Formatting Text)
for details on how to work with tables.
Custom Animation
A variety of animations for selected elements of a slide are listed.
See Chapter 9 (Slide Shows) for an overview of how to add and
customize animations.
Slide Transition
Many transitions are available, including No Transition, which
makes the next slide simply replace the existing one. You can select
the transition speed (slow, medium, fast). You can also choose
between an automatic or manual transition, and how long the
selected slide should be shown (automatic transition only).

Workspace
The Workspace (normally in the center) has five tabs: Normal,
Outline, Notes, Handout, and Slide Sorter. These five tabs are also
called View buttons.
The main Impress window
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Figure 2: Workspace tabs
The Workspace below the View buttons changes depending on the
chosen view. The workspace views are described in detail on page 9.

Toolbars
Many toolbars can be used during slide creation; they can be displayed
or hidden by clicking View > Toolbars and selecting from the menu.
You can also select the icons that you wish to appear on each toolbar.
For more information, refer to Chapter 11 (Setting Up and Customizing
Impress).
Many of the toolbars in Impress are similar to the toolbars in Draw.
Refer to the Draw Guide for details on the functions available and how
to use them.

Status bar
The status bar, located at the bottom of the Impress window, contains
information that you may find useful when working on a presentation.

Figure 3: Left end of the Impress status bar

Figure 4: Right end of Impress status bar
From left to right, you will find:
• A general information area, which changes depending on the
selection. For example:
–
Text area—”TextEdit: Paragraph x, Row y, Column z”
–
Charts, spreadsheets—”Embedded object (OLE) ‘ObjectName’
selected”
–
Graphics—”Bitmap with transparency selected”
8
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• The position of the cursor or of the top left corner of the selection

•
•
•
•

measured from the top left corner of the slide, followed by the
width and height of the selection or of the text box where the
cursor is located.
A modified flag, showing a star when the file needs saving.
A flag indicating whether the document is digitally signed.
The slide number currently displayed in the workspace, and the
total number of slides in the presentation.
The slide master or page style associated with the slide, handout,
or notes page currently in the Workspace.

• The zoom slider and zoom level (percent) of the Workspace.

Tip

By right-clicking on the slide master area of the Status bar, you
can quickly apply a different slide master to the current slide.

You can hide the information in the Status Bar by selecting View >
Status Bar from the main menu.

Navigator
The Navigator (Figure 5) displays all
objects contained in a document. It
provides another convenient way to
move around a document and find
items in it. To display the Navigator,
click its icon
on the Standard
toolbar, choose View > Navigator on
the menu bar, or press Ctrl+Shift+F5.
The Navigator is more useful if you
give your objects (pictures,
spreadsheets, and so on) meaningful
names, instead of leaving them as the
default “Object 1” and “Shape 1”
shown in the example.
Figure 5: Navigator

Workspace views
Each of the workspace views is designed to ease the completion of
certain tasks; it is therefore useful to familiarize yourself with them in
order to quickly accomplish those tasks.
Workspace views
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• Normal view is the main view for creating individual slides. Use

•

•
•

•

this view to format and design slides and to add text, graphics,
and animation effects.
Outline view shows topic titles, bulleted lists, and numbered lists
for each slide in outline format. Use this view to rearrange the
order of slides, edit titles and headings, rearrange the order of
items in a list, and add new slides.
Notes view lets you add notes to each slide; these notes are not
seen when the presentation is shown.
Handout view lets you print your slides for a handout. You can
choose from several layouts from Tasks pane > Layouts.
Thumbnails can be re-arranged in this view by dragging and
dropping them.
Slide Sorter view shows a thumbnail of each slide in order. Use
this view to rearrange the order of slides, produce a timed slide
show, or add transitions between selected slides.

Normal view
To place a slide in the slide design area (Workspace) of the Normal
view (Figure 1), either click the slide thumbnail in the Slides pane or
double-click it in the Navigator (page 9).

Outline view
Outline view contains all of the slides of the presentation in their
numbered sequence. Only the text in each slide is shown. Slide names
are not included.

Figure 6: Outline view
Use Outline view for the following purposes.
1) Making changes in the text of a slide:
•
Add or delete text in a slide just as in the Normal view.
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•

•
•

Move the paragraphs of text in the selected
slide up or down by using the up and down
arrow buttons (Move Up or Move Down) on
the Text Formatting toolbar.
Change the outline level for any of the paragraphs in a slide
using the left and right arrow buttons (Promote or Demote).
Both move a paragraph and change its outline level using a
combination of these four arrow buttons.

2) Comparing the slides with your outline (if you have prepared one
in advance). If you notice from your outline that another slide is
needed, you can create it directly in the Outline view, or you can
return to the Normal view to create it.

Notes view
Use the Notes view to add notes to a slide:
1) Click the Notes tab in the Workspace.
2) Select the slide to which you want to add notes.
•
Click the slide in the Slide pane, or
•
Double-click the slide’s name in the Navigator.
3) In the text box below the slide, click on the words Click to add
notes and begin typing.

Figure 7: Adding notes in Notes view
Workspace views
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You can resize the Notes text box using the green resizing handles and
move it by placing the pointer on the border, then clicking and
dragging. To make changes in the text style, press the F11 key to open
the Styles and Formatting window.

Handout view
Handout view is for setting up the
layout for a printed handout. Click the
Handout tab in the workspace, then
choose Layouts in the tasks pane. You
can then choose to print 1, 2, 3, 4, 6,
or 9 slides per page.
Figure 8: Handout layouts

Slide Sorter view
The Slide Sorter view contains all of the slide thumbnails. Use this
view to work with a group of slides or with only one slide.

Figure 9: Slide Sorter view

Customizing Slide Sorter view
To change the number of slides per row:
1) Check View > Toolbars > Slide View to show or hide the Slide
view toolbar.
12
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Figure 10: Slide Sorter and Slide View toolbars
2) Adjust the number of slides (up to a maximum of 15).

Moving a slide using Slide Sorter
To move a slide in a presentation using the Slide Sorter:
1) Click the slide. A thick border is drawn around it.
2) Drag and drop it to the location you want.
•
As you move the slide, a black vertical line appears to one side
of the slide.
•
Drag the slide until this black vertical line is located where
you want the slide to be moved.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:
• Use the Control (Ctrl) key: Click on the first slide and, while
pressing Control, select the other desired slides.
• Use the Shift key: Click on the first slide, and while pressing the
Shift key, select the final slide in the group. This selects all of the
other slides in between the first and the last.
• Use the mouse: Click slightly to the left of the first slide to be
selected. Hold down the left mouse button and drag the mouse
pointer to a spot slightly to the right of the last slide to be
included. (You can also do this right to left.) A dashed outline of a
rectangle forms as you drag the pointer through the slide
thumbnails and a thick border is drawn around the selected
slides. Make sure the rectangle includes all the slides you want to
select.
To move a group of slides:
1) Select the group.
2) Drag and drop the group to their new location. A vertical black
line appears to show you where the group of slides will go.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the
Slide pane.

Workspace views
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To make changes, right-click a slide and chose any of the following
from the pop-up menu:
• Add a new slide after the selected slide.
• Rename or delete the selected slide.
• Change the slide layout.
• Change the slide transition.
–
For one slide, click the slide to select it. Then add the desired
transition.
–
For more than one slide, select the group of slides and add the
desired transition.
• Mark a slide as hidden. Hidden slides will not be shown in the
slide show.
• Copy or cut and paste a slide.

Renaming slides
Right-click on a thumbnail in the Slides pane or the Slide Sorter and
choose Rename Slide from the pop-up menu. In the Name field,
delete the old name of the slide and type the new name. Click OK.

Creating a new presentation
This section shows you how to set up a new presentation using the
Presentation Wizard.

Planning the presentation
The first thing to do is decide on the purpose of the presentation.
Simply putting a group of digital photos together requires very little
planning. However, using a presentation to teach others about your
topic requires much more planning. Although you can make changes as
you go, having an idea of who the audience will be, the structure, the
content, and how the presentation will be delivered, will save you a lot
of time from the start.

Using the Presentation Wizard
You can start Impress in several ways:
• If no component of OOo is open, from the Start Center: click on
the Presentation icon.
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• From the system menu or the OpenOffice.org Quickstarter.

Details vary with your operating system; see Chapter 1 in the
Getting Started guide if you need more information.
• From any open component of OOo, click the triangle to the right
of the New icon on the main toolbar and select Presentation from
the drop-down menu.

Figure 11: Opening the presentation wizard
• From any open component of OOo, choose File > New >

Presentation on the menu bar.

When you start Impress, the Presentation Wizard appears.

Figure 12. Choosing the type of presentation

Creating a new presentation
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Tips

If you do not want the wizard to start every time you start
Impress, select the Do not show this wizard again option. You
can enable the wizard again later under Tools > Options >
OpenOffice.org Impress > General > Wizard, and select the
Start with wizard option.
Leave the Preview option selected, so templates, slide designs,
and slide transitions appear in the preview box as you choose
them.

1) Select Empty presentation under Type. This creates a
presentation from scratch.
•
From template uses a template design already created as the
basis for a new presentation. The wizard changes to show a
list of available templates. Choose the template you want.
More details can be found in Chapter 2.
•
Open existing presentation continues work on a previously
created presentation. The wizard changes to show a list of
existing presentations. Choose the one you want.
2) Click Next. Figure 13 shows the Presentation Wizard step 2 as it
appears if you selected Empty presentation at step 1. If you
selected From template, an example slide is shown in the Preview
box.
3) Choose a design under Select a slide design. The slide design
section gives you two main choices: Presentation Backgrounds
and Presentations. Each one has a list of choices for slide designs.
If you want to use one of these other than <Original>, click it to
select it.
The types of Presentation Backgrounds are shown in Figure 13.
When you click an item, a preview of the slide design appears in
the Preview window. <Original> is an empty background.
Impress contains three choices under Presentations:
•
<Original> is for a blank presentation slide design.
•
Both Introducing a New Product and Recommendation of a
Strategy have their own prepackaged slide designs. Each
design appears in the Preview window when its name is
clicked.

16
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Figure 13. Selecting a slide design
To start with a blank presentation, select <Original>. Click an
item to see a preview of the slide design in the Preview window.

Note

Introducing a New Product and Recommendation of a Strategy
are pre-packaged presentation templates. They can be used to
create a presentation by choosing From template in the first
step (Figure 12).

4) Select how the presentation will be used under Select an output
medium. Most often, presentations are created for computer
screen display, so you would select Screen. You can change the
page format at any time
5) Click Next. The Presentation Wizard step 3 appears.
In this step you can choose the desired slide transition from the
Effect drop-down menu. Select the desired speed for the
transition between the different slides in the presentation from
the Speed drop-down menu. Medium is a good choice for now.

Creating a new presentation
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Figure 14: Selecting a slide transition effect
6) Click Create. A new presentation is created.

Tip

Note

Caution
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You might want to accept the default values for both Effect and
Speed unless you are skilled at creating presentations. Both of
these values can be changed later while working with slide
transitions and animations. These two are explained in more
detail in Chapter 9 (Slide Shows).
If you selected From template on step 1 of the Wizard, the Next
button will be active on step 3 and other pages will be available.
Remember to save frequently while working on the presentation,
to prevent any loss of information should something unexpected
occur. You might also want to activate the AutoRecovery function
(Tools > Options > Load/Save > General). Make sure Save
AutoRecovery information every is selected and that you have
entered a recovery frequency.
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Formatting a presentation
A new presentation only contains one empty slide. In this section we
will start adding new slides and preparing them for the intended
contents.

Creating the first slide
The first slide is normally a title slide. Decide which of the layouts will
be best for this first slide. You can use the pre-packaged layouts
available in the Layout section of the Tasks pane. Suitable layouts are
Title Slide (which also contains a section for a subtitle) or Title Only;
however, all but one layout (the blank one) contain a title section, so
you are not restricted to the two layouts described here.

Tip

If you do not know the names for the pre-packaged layouts, you
can use the tooltip feature. Position the cursor on an icon in the
Layout section (or on any toolbar icon) and its name will be
displayed in a small rectangle.
If the tooltips are not enabled, you can enable them from the
main menu: choose Tools > Options > OpenOffice.org >
General > Help and select the Tips option. If the Extended
tips option is also selected, you will get more detailed tooltip
information, but the tooltip names themselves will not be
provided.

Select a layout in the Layouts section of the Tasks pane by clicking on
it; the slide in the Workspace is updated to show the chosen layout
elements. To create the title, click on Click to add title (assuming the
Blank Slide layout was not used) and then type the title text. To adjust
the formatting of the title, modify the Title presentation style; see
Chapter 2 (Using Slide Masters, Styles, and Templates) for
instructions.
If you are using the Title Slide layout, click on Click to add text to add
a subtitle. Proceed as above to make adjustments to the formatting if
required modifying the Subtitle presentation style instead.

Inserting additional slides
The steps for inserting additional slides are the same as for selecting
the title page. You need to repeat the process for each slide. Unless
you are using more than one slide master, your only concern is the
Layouts section of the Tasks pane.

Formatting a presentation
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Figure 15: Choosing a slide layout
First, insert all the slides your outline indicates you will need. After
this you can begin adding special effects such as custom animation and
slide transitions.
1) Insert a new slide. This can be done in a variety of ways—take
your pick.
•
Insert > Slide.
•
Right-click on the present slide, and select Slide > New Slide
from the pop-up menu.
•
Click the Slide icon in the Presentation toolbar.

Figure 16: Presentation toolbar
2) Select the layout slide that bests fits your needs.
3) Modify the elements of the slide. At this stage, the slide consists
of everything contained in the slide master, as well as in the
chosen layout slide; you may want to remove unneeded elements
and add objects (such as pictures), as well as insert text.
Caution
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Changes to any of the pre-packaged layouts should only be made
using View > Normal. Attempting to make changes by modifying
a slide master may result in unpredictable results and requires
extra care.
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Modifying slides
1) To remove any element on the slide that is not required, click the
element to highlight it. The green squares show it is highlighted;
press the Delete key to remove it.

Figure 17: Deleting an element of a slide

Tip

Sometimes you will accidentally select the wrong layout slide or
decide to change the layout. This may change the appearance of
the slide, but it does not cause loss of the contents already on
the slide.

2) To add any pictures or objects to the slide. follow these steps:
a) To add a picture to the clipart frame:
i. Double-click the picture within the frame. The Insert
picture dialog box opens.
ii. Browse to the location of the picture you want to include.
To see a preview of the picture, check Preview at the
bottom of the Insert picture dialog box.
iii. Select the picture and click Open.
iv. Resize the picture as necessary. Follow the directions in
the Caution note below.
b) To add pictures from graphic files to places other than the
clipart frame:
i. Insert > Picture > From File. The Insert picture dialog
box opens.
Formatting a presentation
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ii. Browse to the graphic file. To see a preview of the picture,
check Preview at the bottom of the Insert picture dialog
box. Select a picture and click Open.
iii. Move the picture to its location.
iv. Resize the picture, if necessary.
c) To add OLE Objects, refer to Chapter 7 (Inserting
Spreadsheets, Charts, and Other Objects) where this
advanced technique is described.

Caution

When resizing a graphic, right-click the picture. Select Position
and Size from the context menu and make sure that Keep ratio
is selected. Then adjust the height or width to the size you need.
(As you adjust one dimension both dimensions will change.)
Failure to do so will cause the picture to become distorted.
Remember also that resizing a bitmap image will reduce its
quality on screen, even though the original image is unchanged
(Impress stores the original file). A better approach is to create
an image of the desired size outside of Impress and then import it
into the presentation.

3) If you need to add text to a slide that contains a text frame, click
on Click to add an outline in the text frame and then type your
text. The Outline styles are automatically applied to the text as
you insert it. You can change the outline level of each paragraph
as well as its position within the text by using the arrow buttons
on the Text Formatting toolbar (see “Outline view” on page 10).
4) To create additional slides, repeat steps 1–3.

Modifying the appearance of slides
To change the background and other characteristics of all slides in the
presentation, you need to modify the slide master or choose a different
slide master.
A Slide Master is a slide with a specified set of characteristics that acts
as a template and is used as the beginning point for creating other
slides. These characteristics include the background, objects in the
background, formatting of any text used, and any background
graphics.
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Note

OOo uses three interchangeable terms for this one concept.
Master slide, slide master, and master page all refer to a slide
that is used to create other slides. This book, however, will use
only the term slide master, except when describing the user
interface.

Impress has a range of pre-packaged slide masters, found in the
Master Pages section of the Tasks pane (Figure Error: Reference
source not found). You can also create and save additional slide
masters or add more from other sources. See Chapter 2 for
information on creating and modifying slide masters.

Modifying the slide show
Now review the entire presentation and answer some questions. Run
the slide show at least once (see “Running the slide show” on page 24)
before answering them. You might want to add some questions of your
own.
1) Are the slides in the correct order? If not, some of them will need
to be moved.
2) Is the information well spaced and visible to members of an
audience at the back of a large room? They may not be able to see
information at the bottom of a slide, so you may need to design
your presentation to fit the top three-quarters of the screen.
3) Would an additional slide make a particular point clearer? If so,
another slide needs to be created.
4) Do some of the slides seem unnecessary? Hide or delete them.
5) Would custom animations help some of the slides? (Advanced
technique.)
6) Should some of the slides have a different slide transition than
others? The transition of those slides should be changed.

Caution

If one or more slides seem to be unnecessary, hide the slide or
slides, and view the slide show a few more times to make sure
they aren't needed. To hide a slide, right-click the slide in the
Slides pane and select Hide Slide in the pop-up menu. Do not
delete a slide until you have done this; otherwise you may have
to create that slide again.

Once you have answered these and your own questions, make the
necessary changes. This is done most easily in the Slide Sorter view
(see page 12). If you need one or more new slides, create them using
the steps listed in “Inserting additional slides” on page 19.
Formatting a presentation

23

Custom animations
If you wish to add a custom animation to a slide, do it now. Custom
animations are found on the Tasks pane. This is an advanced technique
and is explained in Chapter 9 (Slide shows).

Slide transitions
Your first slide show should probably have the same slide transition for
all slides. Setting Advance slide to On mouse click is the default. If
you want each slide to be shown for a specific amount of time, click
Automatically after and enter the number of seconds. Click Apply to
all slides.
Transition choices are found on the Tasks pane. For more information
about slide transitions, see Chapter 9 (Slide Shows).

Tip

The Slide transition section has a very useful option: Automatic
preview. With this option selected, when you make any changes
in a slide transition, the new slide is previewed in the Slide
Design area, including its transition effect.

Running the slide show
To run the slide show, do one of the following:
• Click Slide Show > Slide Show on the main menu bar.
• Click the Slide Show button on the Presentation toolbar (Figure
16) or the Slide Sorter toolbar (Figure 10).
• Press F5 or F9. (F5 only on a Mac.)
If the slide transition is Automatically after x seconds, let the slide
show run by itself.
If the slide transition is On mouse click, do one of the following to
move from one slide to the next.
• Use the arrow keys on the keyboard to go to the next slide or to
go back to the previous one.
• Click the mouse button to advance to the next slide.
• Press the Spacebar on the keyboard to advance to the next slide.
When you advance past the last slide, the message Click to exit
presentation... appears. Click the mouse or press any key to exit the
presentation.
To exit the slide show at any time, including at the end, press the Esc
key.
24
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Using Impress on a Mac
Some keystrokes and menu items are different on a Mac from those
used in Windows and Linux. The following table gives some common
substitutions for the instructions in this book. For a more detailed list,
see the application Help.
Windows/Linux

Mac equivalent

Effect

Tools > Options
menu selection

OpenOffice.org >
Preferences

Access setup options

Right-click

Control+click

Open context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Open the Navigator

F11

z+T

Open the Styles and
Formatting window

Using Impress on a Mac
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