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Drawing an organization chart

Draw offers no special toolbar for creating organization charts, where
individual fields appear as rectangles. However, drawing these charts
presents no special problems. The use of different fill colors clearly
represents organizational linkages and by drawing rectangles with
different heights you can see the various hierarchies (see Figure 1).
With a color progression from dark tones to bright, this effect can be
reinforced. Watch that the color choices maintain a good contrast
between text color and background so that you can easily read the
printed diagram.

Management
Development Sales
Hardware Software Serie Parts North South

Figure 1: Example of an Organization Chart

At the beginning it is useful to prepare a setup page or draft, with snap
lines, to assist in drawing the various hierarchies and responsibility
paths and typical boxes that you will use in drawing the chart. Using
styles can also be helpful; see the relevant section in Chapter 4
(Changing Object Attributes).

Fzgure 2 Draft wzth snap lmes

Individual boxes are placed and dimensioned according to ‘feel’. The
exact size (particularly width), position, and color will be fixed later. It
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is sometimes easier to draw only one box per level, copy and paste this
box and then move it to the desired position.

You can also select one or more boxes and use Edit > Duplicate to
make copies (see Figure 3). The spacing of the duplicated objects to
the original can be input in the placement fields for X and Y axes. Note
that positive values for X and Y are (relative to the original object) to
the right and downwards respectively.

: .
5 g:::% # Duplicate =
...... L : - Number of copies 1 = & oK
: ' Placement Cancel
X axis 3.00cm S
................. Help
Y axis 2.00cm =
- Default
Angle 0 degrees =

Enlargement

Width 0.00cm =
.......................... R 0.00em :
: : Colors
...... Start [IBlue 8 -
. . End [IBlue 8 -

Figure 3: Duplicating an object

Which replication technique you use is up to you. The draft for the
example in this chapter should look similar to that in Figure 4.

| S o S S N e S e B H e B

Figure 4: The finished draffi
In the next step, add text to the boxes. As described in Chapter 2
(Drawing Basic Shapes), the text is best input as an element in the box.

Activate the ” icon on the Options toolbar and then double-click the
box to enter text into it. Alternatively, select the box and press F2. You
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should then see a blinking cursor in the box and the Text Formatting
toolbar should be visible.

Set the text formatting and type the text. Depending on the length and
formatting of the text, you may need to adjust the size of the box and
the spacing to neighboring boxes. Adjustments can be made initially
with the mouse and then fine-tuned with the Position and Size dialog.

Now you can set up the fill colors and save the drawing. The
connections between the boxes are not drawn with ordinary lines but
with Draw’s connectors. How to draw these connectors and add text to
them is described in “Glue points and connectors” starting on page 8.

You can also use text frames for the boxes. These have the advantage
of automatic line breaks. Figure 5 shows the individual editing steps of
text input, adding lines, and setting the background color for a text
frame.
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Figure 5: Working with text frames
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Drawing a flow diagram

For drawing flow diagrams (also known as flowcharts), Draw offers a

=

separate toolbar, which is reached from an icon ™ ~ found on the main

Draw toolbar (see Figure 6).

Flowchart v X
N eeFN N
HVseaw
Qv EFASS
XPLVEDPD
QS0 @

Figure 6: The Flowchart toolbar

The easiest way to draw a flowchart is to follow the same setup
procedure as for organization charts. The necessary symbols are
selected from the toolbar and dragged into position as described in
Chapter 2 (Drawing Basic Shapes). See Figure 7 for an example of a
typical flowchart.

The individual symbols must be exactly positioned if the connectors
joining them are to form a vertical line. The midpoints of all the
symbols that lie in a vertical straight line should have the same X
coordinate and those on the same level should have the same Y
coordinate.

Select the shapes that are to lie in a vertical straight line and center
them with Modify > Alignment > Centered. For those on a
horizontal line, select the shapes and center them with Modify >
Alignment > Center. You can also set snap lines if you need several
vertical lines.

After adding text and setting the fill color, you can join individual
symbols together and add text to the connectors where necessary. This
technique is described in the next section.
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Figure 7: Example of a flow diagram

Glue points and connectors

These elements were briefly introduced in Chapter 2 (Drawing Basic
Shapes). This section describes how to use them.

Connectors are lines or arrows whose ends automatically “dock” to a
connection or glue point of an object. Connectors are particularly
useful when drawing organization charts, flow diagrams, and
mindmaps. The connecting lines between the symbols remain intact
even after moving and rearranging of the various drawing blocks.
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The Connector toolbar

Click the ™" button on the Draw toolbar to open the tearoff Connectors
toolbar (Figure 8).

If the type of connector you want is not shown, click on the small black
triangle in the right upper part of the Connectors toolbar. In the list
that appears, click on Visible buttons (Figure 9) to open a menu from
which you can activate additional connector types.

Connectors * x

g Byt Oy By &y
Byg By %y By By &

Figure 8: The Connectors toolbar

Connectors T X
o, by, 4, Og oy  Visible Buttons »__ [gonnector
Customize Toolbar... | 4; Connector Starts with Arrow
By Oy Ry Mg Oy .
———— Dock Toolbar Connector Ends with Arrow
Dock All Toolbars Connector with Arrows
Lock Toolbar Position “iz Connector Starts with Circle
Close Toolbar B, Connector Ends with Circle

“, Connector with Circles

Line Connector

+g Line Connector Starts with Arrow
Line Connector Ends with Arrow
Line Connector with Arrows

=g Line Connector Starts with Circle
I Line Connector Ends with Circle
=5 Line Connector with Circles

Straight Connector

"g Straight Connector starts with Arrow
Straight Connector ends with Arrow

Straight Connector with Arrows

“g Straight Connector starts with Circle
&, Straight Connector ends with Circle

*. Straight Connector with Circles

Curved Connector

%2y Curved Connector Starts with Arrow
Curved Connector Ends with Arrow
Curved Connector with Arrows

*zg Curved Connector Starts with Circle
Bz, Curved Connector Ends with Circle
%z, Curved Connector with Circles

Figure 9: Activating additional connectors
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Connector types fall into four groups:

- Standard connectors - the line segments run vertically and
horizontally. All angles are right angles. The connector does not
bend around the objects it binds.

- Line connectors - consist of a line segment and two smaller
horizontal or vertical segments at the ends.

- Straight connectors - consist of a single line.

« Curved connectors - are based on Bézier curves, as described in
Chapter 10 (Advanced Draw Techniques).

You can modify all the connector types. From the context menu, choose
Connector to change from one connector type to another (as well as
some other properties). With the Line dialog you can change the
appearance of the line (color, arrow style, and line style) but not the
connector type.

Drawing connectors—basics

When you choose a connector from the toolbar, the mouse pointer

changes to ".-. As you move the cursor over an object, the available
connection (glue) points become visible. To connect two shapes, move
the mouse cursor over a glue point, click and hold the left mouse
button to establish the first point, and then drag the mouse cursor (left
button still pressed) to the other glue point and release the mouse
button. The ends of the line are now docked and the connection is
established (see Figure 10).

Figure 10: Gluing a
connector to a shape

You can also attach the beginning or the end of a connector to the
middle of an object. This is useful when the final position of the object
is not yet fixed. When you move the object, Draw automatically selects
the optimal location for the connector ends (see Figure 11).
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Figure 11: Connector attached to the middle of an object

As with all other objects, connectors have one or more control points to
simplify the construction of the drawing. You can use these points to
change the shape, length, and proportions of the connector line (see
Figure 12).

| . |
Figure 12: Control points
of a connector

To remove a connector from an object, either move the end of the
connector from the gluepoint of the object or simply delete the
connector entirely.

Editing glue points
Glue points can be edited using a separate toolbar (see Figure 13).

This toolbar appears when you click on the Glue Points icon |#| or
select Edit > Glue Points from the main menu.

Glue points EE
B B0 b Gd

Figure 13: The Gluepoints toolbar

The following briefly describes the function of each button on this
toolbar.
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Use this button to insert a new glue point. Draw a new object.
If the object is filled, you can place a glue point anywhere
inside the object or on its frame. With unfilled objects you can
place a glue point only on the outside frame, but after inserting
it you can then drag it inside the object. Activate the Glue
Points icon on the Drawing toolbar.

The glue points that you add remain visible as
long as the Glue Points icon is active. They
appear as small blue crosses. A selected glue
point has a gray square behind the cross. You

can move a selected glue point with the mouse
or delete it with the Del key.

Use these four buttons to choose one or more directions
permitted for a connector to join to a particular glue point.

Activate Glue Points and then choose the direction. If, for
example, you activate only the & button, every connector will
be forced to come to that glue point from the left side of the
point.

In the left drawing below is a glue point in the circle with a left
entry and one in the square with a right entry. The effect of this
is shown in the right drawing after adding a connector between
the two glue points.

If you are in glue point editing mode and you add another
direction to the glue point (for example by activating the &
button), Draw tries to optimize the length of the connector. For
the example above, the connection inside the circle would
change as shown below.

12
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[%] If the Glue Point Relative button is active (it is active by
default) the glue point will move when you change the size of
the object, as shown below.

If the Glue Point Relative button is deactivated, the remaining
buttons on the toolbar, previously grayed out, become active.
With these buttons you can decide how a glue point will be
placed when the size of the object is changed.

These buttons determine how the horizontal position of a glue
point changes when you resize the object containing the glue
point. You can choose whether the distance of the glue point to
the left edge, a vertical line through the middle, or the right
edge of the object remains fixed when you change the size of
the object. If the width of the object becomes less than that
distance, the glue point is attached to the object frame.

The following example shows what happens when an object’s
width is changed and the glue point is set to be a fixed distance
to the left frame.

[G] These buttons determine in a similar manner the vertical
position of a glue point when the size of the object is changed.

(]

Adding text to connectors

To add text to a connector, double-click the connector. The end and
control points become active and the familiar flashing text cursor
appears (the cursor position is determined by the last used setting).
The Text Formatting toolbar also appears (under the menu bar). Use
this toolbar to set the desired text properties; you can directly input
the text.
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If you draw a connector and then click on it, only the end points and
control points become active. In spite of this, a connector has its own
object frame—in this case an invisible one. You can picture it easily by
imagining a rectangle enclosing the start and end points of the
connector (Figure 14).

When you add text to a connector, the location of the text is referenced
to this rectangle. The exact position of the text can be set in the Text
dialog (Figure 15). This dialog appears when you double-click on text
and then choose Text from the pop-up menu or when you single-click
on the connector and select Format > Text from the menu bar.

Invisible text
object frame

Figure 14: Object frame of a connector

Text| Text Animation

Text

Fit to frame,

Adjust to contour

Spacing to borders Text anchor
Left 0.25cm = & -
Right 0.25cm = P = A
Top 0.13cm =
.
Bottom 0.13cm =
Full width

Cancel Help Reset

Figure 15: The Text dialog
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Take particular note of the Spacing to borders and Text anchor
sections in the Text dialog. In the Text anchor section you can see the
possible locations for the text. In the above example the text is
anchored at the top left. In the Spacing to borders section at the lower
left, negative values of spacing will position the text outside the frame.

Adjusting text to suit the connecting line

If you want the text to follow the slope or curve of a line, you need to
activate and use the Fontwork tool. To add it to the Draw toolbar,
choose Tools > Customize from the menu bar. On the Toolbars tab, in
the upper pulldown list of toolbars choose Drawing. In the Toolbar
content section, click Add. On the Add Commands dialog, select the
Category Format and the Command Fontwork. Click Add, then Close.
Back on the Customize dialog, in the list of commands under Toolbar

Content, move the Fontwork icon ¥ to the location you want, and then
click OK.

To write slanting text, two steps are necessary. First, add the text to
the connector as described earlier. The anchor location of the text is
not important at this stage. Second, select the object with the text (in

this case the connector) and click on the Fontwork icon ¥ to open the
Fontwork dialog. To make the text lie along the inclined line, click the
Rotate icon and set the distance to the line you wish.

Text line

Figure 16: Adding text to an inclined line, Step 1
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Figure 17: Adding text to an inclined line, Step 2

The Fontwork dialog opens up many other possibilities to manipulate
the text. You can, for example, turn the text around 180 degrees with
the Orientation # icon (as was done in the example above) or place

the text under the line by assigning a negative value to the spacing
between text and line.

In addition, you can use the Fontwork dialog to generate curved text
that follows the shape of a curved line. It pays to experiment a little to
investigate some of the possibilities.
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