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Creating simple drawings
You can create 2D and 3D objects in Draw. In this chapter, we restrict 
ourselves to producing 2D drawing objects. The following chapters 
describe how to work with and edit such objects.

This chapter describes how to draw simple shapes. All shapes, whether 
they are simple lines, rectangles, or more complicated shapes, are 
called objects. This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar. Figures 1 and 14 
show parts of the standard form of the toolbar, as installed with Draw.

As described in Chapter 1 (Introducing Draw), the Drawing toolbar is 
normally located at the bottom of the window. If you do not see it, you 
can activate it from the View > Toolbars menu. As in all components 
of OpenOffice.org, you can place the toolbar on the Draw window 
wherever you wish, and  you can configure this and other toolbars to 
your own needs by adding, moving, hiding, or deleting toolbar icons as 
you wish.

Custom shapes
Draw version 3 offers the ability to create custom shapes. These 
correspond to autoshapes in Microsoft Office. The shape elements used 
in version 1 of Draw are still available, but  their use is now deprecated 
and support for them may be dropped in some future version of OOo.

The two types of shapes differ in their properties and are dealt with 
separately in the relevant chapter of this guide. The main differences 
relate to the behavior of 3D objects and text handling. Beginners can 
safely ignore both for the present.

Text frames in Draw version 3 have their own geometric format.

Drawing basic shapes
Basic shapes include:

• Lines
• Arrows
• Rectangles and squares
• Ellipses and circles
• Curves and polygons
• Connectors
• Lines and arrows
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Note

When you draw a basic shape or select one for editing, the Info 
field in the status bar changes to reflect the action taken or in 
progress: Line created, Text frame xxyy selected, TextEdit: 
Paragraph 1, Row 1, Column 8 and so on.

Figure 1 shows part of the Drawing toolbar with the icons needed in 
the following sections. The Text icon is also included.

Figure 1: Part of the Drawing toolbar

Drawing a straight line
We begin with the drawing of the simplest element—a straight line.

Click on the Line icon  on the Drawing toolbar and place the mouse 
pointer at the point where you want to start the line (see Figure 2). 
Drag the mouse while keeping the mouse button pressed. Release the 
mouse button at the point where you want to end the line. A blue 
selection handle appears at each end of the line, showing that this is 
the currently selected object.

Holding down the Shift key while you draw a line restricts the angle of 
the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

Caution

This action is the default action but it depends on whether you 
have changed the settings for “Snap position” under Tools > 
Options > OpenOffice.org-Draw > Grid. If When creating or 
moving objects is selected, the action of the Shift key will be the 
reverse to that described above: normal action will be to restrict 
the angle of the line to a multiple of 45 degrees and holding 
down the Shift key will lift this restriction.

Figure 2: Drawing a straight line

Keeping the Ctrl key pressed while drawing a line enables the end of 
the line to snap to the nearest grid point.
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Caution
The effect of the Ctrl key depends on the settings of the Snap to 
Grid option on the View->Grid menu:
Snap to Grid on: Ctrl deactivates the snap option for this 
activity.
Snap to Grid off: Ctrl activates the snap option for this activity.

The spacing (resolution) of the grid points can be adjusted under Tools 
> Options > OpenOffice.org-Draw > Grid. See also Chapter 8 (Tips 
and Tricks).

Holding down the Alt key while drawing a line results in the line 
extending outwards symmetrically from the start point. (The line will 
extend out equally each side of the starting point). This lets you draw 
lines by starting from the middle of the line.

The line just drawn has all the standard attributes, such as color and 
line style. To change any of these line properties, select the line by 
clicking on it, then right-click and select Line.

While you are working with a line (or other elements), you can look at 
the information field on the status bar to monitor the activity or status. 
A description of the current activity or status of the selection is shown 
when you are working with an element or elements. See Figure 3 for 
two examples.

Figure 3: The information area in the status bar
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Drawing an arrow
Arrows are drawn like lines. Draw classifies arrows as a subgroup of 
lines: Lines with arrowheads. They are shown in the information field 
on the status bar only as lines. Click on the Line Ends with Arrow 
icon  to draw an arrow.

Drawing lines and arrows

Click on the small black triangle on the Lines and Arrows  icon on 
the Drawing toolbar to open a toolbar with ten tools for drawing lines 
and arrows (Figure 4). ( View > Toolbars > Arrows opens the toolbar 
as a floating toolbar). In both cases, the last-used command will be 
stored on the toolbar to make it quicker to call it up again: click 
directly on the symbol to repeat the last used command chosen from 
this toolbar.

After drawing the line, you can change the arrow style by clicking on 
the Arrow button in the Line and Filling toolbar and choose from 13 
arrow start and end options.

Figure 4: Lines and Arrows toolbar

Drawing a rectangle or square
Drawing a rectangle is similar to drawing a straight line, except that 
you click on the Rectangle icon  on the Drawing toolbar, and the 
(imaginary) line drawn by the mouse corresponds to a diagonal of the 
rectangle. In addition, you will see the outline of the future rectangle 
change in shape as you drag the mouse around. Note - the outline may 
beshown as a dashed line until you release the mouse button, when the 
rectangle is drawn.
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Figure 5: Drawing a rectangle

Draw considers squares to be rectangles with equal length sides. Hold 
down the Shift key to draw a square. Hold down the Alt key while 
dragging with the mouse to create a rectangle with its center (rather 
than a corner) at the start point (where you first clicked the mouse).

Note

Blue or green selection handles appear around an object made 
up of more than 2 points, showing that this is the currently 
selected object. The colors depend on the standard selection 
mode—green with a normal selection or blue if you are in the 
point edit mode (this effect is easily apparent if on the Options 
toolbar both Simple Handles and Large Handles are 
switched on. See Chapter 3 for more details on points.

Drawing ellipses (ovals) and circles
To draw an ellipse (also called an oval) or a circle, click on the Ellipse 
icon  on the main Drawing toolbar. (A circle is simply an ellipse with 
both axes the same length.) The ellipse drawn is the largest ellipse that 
fits within the (imaginary) rectangle drawn by the mouse (Figure 6).

Figure 6: Drawing an ellipse

There are three ways to draw an ellipse or a circle:

• Holding down the Shift key while dragging with the mouse draws 
a circle.

• Holding down the Alt key (together with the Shift key) draws a 
symmetrical ellipse (a circle) with the center point as the starting 
point.
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• Holding down the Ctrl key while dragging with the mouse draws 
an ellipse or circle that snaps to the nearest grid points.

Note

If you first press and hold the Ctrl key down and then click on 
one of the icons for Line, Rectangle, Ellipse or Text, a 
“standard” sized object is drawn automatically in the work area
— the size, shape, and color are all standard values. These 
attributes can be changed later, if desired. This only works if 
the icon has no associated toolbar (no arrow on right side of 
icon - for example ).

Adding ellipse and arc tools to the Drawing toolbar
In previous versions of Draw, a long-click on the ellipse button opened 
a new toolbar that contained tools for drawing elliptical and circular 
arcs. This function is not directly available in Version 3.

If you really need this tool, you can add an Ellipse toolbar to the 
Drawing toolbar:

1) Click on the arrow on the right-hand end of the Drawing toolbar 
and select Customize Toolbar.

2) On the Toolbars page of the Customize dialog, select Drawing in 
the Toolbar field and click Add.

3) In the Add Commands dialog (Figure 7), select Drawing in the 
Category drop-down menu, select the first Ellipse command in 
the  Commands drop-down menu, and then click Add or drag that 
Ellipse icon from that Commands drop-down menu to the 
Commands drop-down menu in the Customize dialog. Click Close.

4) On the Customize dialog, select the checkbox to enable the new 
Ellipse command and use the arrow buttons to move it to the 
desired position on the toolbar.

5) If you wish, you can now hide the simple Ellipse icon from the 
Drawing toolbar by deselecting it or highlight it on the Customize 
dialog, click Modify, and choose Delete on the pull down menu 
to remove it from the Drawing toolbar.

6) Click OK to complete the process.
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Figure 7: Adding the extended Ellipse toolbar

You should now see another Ellipse icon  on the Drawing toolbar. 
If you use this icon instead of the standard Ellipse icon on the Drawing 
toolbar, all the extended ellipse functions  are available. Clicking on 
the black arrow by the icon opens the floating Circles and Ovals 
toolbar (Figure 8).

Figure 8: Circles and 
Ovals toolbar

Drawing elliptical and circular arcs
To draw an arc, choose the appropriate Arc 
symbol. Drag with the mouse to create the 
circle or ellipse.
Release the mouse button and move the 
cursor to the position where you want the arc 
to start. In the status bar, you can measure 
the actual angle in degrees. Single-click this 
point; the circle (or ellipse) disappears and 
moving the mouse creates the arc. Again, the 
status bar shows the current angle.
When you have drawn the arc to the length 
you want, click once more. The drawing of the 
arc is complete.
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Curves
The tools for drawing curves or polygons are on the toolbar that 
appears when you click the Curve icon  on the Drawing toolbar. 
This toolbar contains eight tools (Figure 9).

Note
Hovering the mouse pointer over this icon gives a tooltip of 
Curve. If you convert the icon to a floating toolbar, however, the 
title is Lines, as shown in Figure 9. 

Figure 9: Floating Curves toolbar (incorrectly titled “Lines”)

If you move the mouse cursor over one of the icons, a tooltip pops up 
with a description of the function. For a more detailed description of 
the handling of Bézier curves (curves and filled curves), see Chapter 
10 (Advanced Draw Techniques).

• Polygons: Draw the first line from the start point with the left 
mouse button held down. As soon as you release the mouse 
button, a first corner point is drawn, and you can move the mouse 
to see how the second line will look. Every mouse click sets 
another corner point. A double-click ends the drawing. A filled 
polygon automatically joins the last point to the first point to close 
off the figure and fills it with the current standard fill color. A 
polygon without filling will not be closed at the end of the 
drawing.

• Polygon 450: Just as with ordinary polygons, these will be formed 
from lines but with angles of 45 or 90 degrees between them.

• Freeform Line: With this tool you can draw just like with a pencil. 
Press and hold the left mouse button and move the mouse. It is not 
necessary to end the drawing with a double-click. Just  release the 
mouse button and the drawing is completed. If you have selected 
Freeform Line, Filled, the end point is joined automatically to the 
start point and the object is filled with the appropriate color.
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Gluepoints and connectors (basics)

Gluepoints
All Draw objects have associated invisible gluepoints, which become 
visible when you choose any of the connectors under the Connectors 
icon  on the Drawing toolbar and then move the mouse pointer over 
the object.

Most objects have four gluepoints, as shown in Figure 10. You can add 
more gluepoints, and customize gluepoints, using the toolbar of the 
same name (Figure 11).

Figure 10: Four gluepoints

Figure 11: Gluepoints toolbar

Gluepoints are not the same as the little blue or green “handles” of an 
object. The handles are for moving or changing the shape of an object, 
as described in Chapter 3 (Working with Objects and Object Points), 
but the gluepoints are used to “glue” a connector to an object.

For a more detailed description of the use of gluepoints, see Chapter 9 
(Organization Charts, Flow Diagrams, and More).

Connectors
Connectors are lines or arrows whose ends automatically dock to a 
gluepoint of an object. Connectors are especially useful in drawing 
organization charts, flow diagrams, and mindmaps. Even when objects 
are moved or reordered, the connectors remain attached.

Figure 12 shows two Draw objects and a connector.
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Figure 12: A connector between two objects

Draw offers a range of different connectors and connector functions. 
Open the floating Connectors toolbar by clicking on the arrow next to 
the Connector icon  (Figure 13).

Figure 13: The Connectors toolbar

For a more detailed description of the use of connectors, see Chapter 9 
(Organization Charts, Flow Diagrams, and More).

Drawing geometric shapes
Geometric shapes include:

• Basic shapes

• Symbol shapes

• Block arrows

• Flowcharts

• Callouts

• Stars
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Note

Depending on the number of  geometric shapes you select for 
editing, the information field in the toolbar shows the type of 
shape selected (if only one selected) or the number of draw 
objects selected (if more than one selected).

Figure 14 shows part of the Drawing toolbar with the icons referred to 
in the following sections. Clicking on the arrow next to the icon opens 
a floating toolbar with the relevant work tools.

Figure 14: Part of the main Drawing toolbar

Tip The use of all these tools is similar to that of the Rectangle tool, 
even though they produce different geometric shapes.

Basic shapes

The Basic Shapes icon  makes 
available the range of tools for 
drawing basic shapes.

If you choose the rectangle tool from 
this toolbar, it looks the same as a 
rectangle drawn using the Rectangle 
tool on the Drawing toolbar. The only 
differences you will see are in the 
information field in the status bar (in 
this case “Shape selected” rather than “Rectangle selected”).

Symbol shapes

The Symbol Shapes icon  
brings you to an array of tools for 
drawing the various symbol 
shapes.
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Block arrows

The Block Arrows icon  opens 
the Block Arrows toolbar.

Flowcharts
The tools for drawing flowcharts are 
accessed by clicking on the Flowcharts 
icon .

The creation of flowcharts, organization 
charts, and similar planning tools are 
described in Chapter 9 (Organization 
Charts, Flow Diagrams, and More).

Callouts

Use the Callouts icon , to open the 
Callouts toolbar.

Stars and banners
These tools are associated with the 

Stars icon .

You can add text to all these shapes. 
See “Using text elements in Draw
objects” on page 18.
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Figure 17: Block Arrows toolbar

Figure 18: Flowchart toolbar

Figure 20: Stars and Banners

Figure 19: Callouts toolbar



Adding text to objects
Draw offers two ways to add text to a drawing: in a dynamic text frame 
as an independent Draw object or as text in a previously drawn object. 
In the latter case, the text is integrated with the object.

Using dynamic text frames

The text tool is activated by clicking on the Text icon  for horizontal 
text or the Vertical Text icon  for vertical script (to be able see the 
icon and use this latter option, you must check Enabled for Asian 
languages under Tools > Options > Language Settings > 
Languages). If you still do not see the Vertical Text icon, enable it on 
the Drawing toolbar by clicking the arrow on the right hand side of the 
toolbar, select Visible Buttons, and click on Vertical Text to make this 
icon show on the toolbar.

Text frames can be moved and rotated like all draw objects. For more 
details on text input, see Chapter 10 (Advanced Draw Techniques).

After activating Text command mode, click at the location where you 
want to position the text. A small text frame appears. It contains only 
the cursor. You can move the frame, if desired. The Text Formatting 
toolbar appears (Figure 21), and you can choose the font type, font 
size, and other text properties and begin to type in your text.

Figure 21: Text Formatting toolbar

The text frame grows with the text. You can insert a line break with the 
Shift+Enter key combination. The Enter key begins a new paragraph. 
Neither line breaks nor new paragraphs terminate the text frame.
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Figure 22: Text input in a dynamic text frame

Observe the information field in the status bar: it shows that you are 
editing text and also provides details about the current cursor location
—paragraph, line, and column numbers.

Text properties can also be changed during text input. Any changes 
will be reflected from the cursor position onwards (Figure 23).

Figure 23: Changing text properties

After choosing the Text icon, you can also draw a frame with the 
mouse to contain future text. You can move the frame only after typing 
some text in it. Line breaks are inserted automatically at the right edge 
of the frame when the text fills the frame width (Figure 24). You can, 
however,—just like when editing other text—insert your own line 
breaks, begin new paragraphs, or change any of the text properties.

Figure 24: Text frame
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Using text elements in Draw objects
A text element is associated with most Draw objects. By means of 
these elements, text can be added to an object (see Figure 25).

The exceptions to this are control elements like buttons or list boxes, 
as well as 3D scenes and their associated elements and groups.

If the Double-click to edit Text icon  on the Options toolbar is 
active, you can start editing an object by double-clicking on it (or by 
pressing F2). In the middle of the Draw object, a black bar indicates 
the text cursor; start typing to input text. The status bar shows at the 
lower left “Text Edit” and the position of the cursor within the text.

Text can contain paragraphs, and these can be in the form of bulleted 
or numbered lists. For a new line without beginning a new paragraph, 
use (as in text documents) the key combination Shift+Enter. To end the 
text input, click next to the object or press the Esc key.

Figure 25: Adding text to objects
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