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Chapter 8
Getting Started with Math

What is Math?

Math is Apache OpenOffice’s component for writing mathematical equations. It is
most commonly used as an equation editor for text documents, but it can also be used
with other types of documents or stand-alone. When used inside Writer, the equation
is treated as an object inside the text document.

The equation editor is for writing equations in symbolic form, as in the
Note equation below. If you want to evaluate a numeric value, see the Calc
Guide.

df (x) _

= —In(x)+tan ' (x°)
dx

Getting Started

To insert an equation, choose Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Elements
window may appear. You will also see a small box with a gray border in your
document, where the formula will be displayed. (See Figure 1.)
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Entering a Formula

The equation editor uses a markup language to represent formulas. For example,
%beta creates the Greek character beta ( 8 ). This markup is designed to read similar

to English whenever possible. For example, a over b produces a fraction: % .

You can enter a formula in three ways:
* Select a symbol from the Elements window.

* Right-click on the equation editor and select the symbol from the context
menu.

* Type markup in the equation editor.

rE Untitled 1 - OpenOffice Writer |E|w

e Edit Wiew Format Tools Window Help
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Figure 1. Equation Editor, Elements window, and location of resulting
equation.

The context menu and the Elements window insert the markup corresponding to a
symbol. This provides a convenient way to learn the Math markup.

Click on the document body to exit the formula editor.

Note ) , .
Double-click on a formula to enter the formula editor again.

The Elements Window
The simplest method for entering a formula is to use the Elements window.
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(5 Elements (X7

% asb aeA fx) 2a
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a-b % azb a/b avb

aeb

Figure 2. Symbols are divided into
categories

The Elements window is divided into two main parts.

* The top shows the symbol categories. Click on these to change the list of
symbols.

* The bottom shows the symbols available in the current category.

Tip You can hide or show the Elements window with View > Elements.

Example 1: §5x4

For this example we will enter a simple formula: 5Xx4 . On the Elements window:
1) Select the top-left button of the categories (top) section.
2) Click on the multiplication symbol.

(5 Elements 3

Unary/binary >
Operators asb acA f(x) 2a

i & O

Multiplicationm., +a -a *a Fa -a

a*xb aab

a-b % azb a/b avb
asb

Figure 3. Selecting the multiplication
symbol
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When you select the multiplication symbol on the Elements window, two things
happen:

* The equation editor shows the markup: <?”> fimes <?>
* The body of the document shows a gray box like this: XU

0 3 D [

<?> times <?> |

+ E

Figure 4. Result of selecting the multiplication symbol

The <?> symbols shown in Figure 4 are placeholders that you can replace by other
text, for example 5 and 4. The equation will update automatically, and the result
should resemble Figure 5.

. To keep the equation from updating automatically, choose View >
Tip AutoUpdate Display from the menu bar. To update a formula
manually, press F9 or pick View > Update.

12x4]

0 03

5 times 4

4 *

Figure 5. Result of entering 5 and 4 next to the times operator

Right-click (Context) Menu

Another way to access mathematical symbols is to right-click on the equation editor.
This pops up the menu shown in Figure 6. The items in this menu correspond exactly
to those in the Elements window.
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o times 4 Unary/Binary Operators + +a 0
' Belations N -a 3
B i Set Operations v +-a 3
Eunctions v -+a ]
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Attributes v - b
Brackets v 2 cdot b
Formats v : :
Others v UL h-
O a*b
aoverb
adivb
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acirch
awideslash b
awidebslash b
neq a
aandb
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Figure 6. Right-click (Context) Menu

Markup

You can type the markup directly in the equation editor. For example, you can type 5
times 4 to obtain 5Xx4 . If you know the markup, this can be the fastest way to enter
a formula.

Tip The formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command
a=bh a=Db JVa sqrt {a}
a’ a™2 a, an
J‘ f( x)dx int f(x) dx Z a sum a n
a<b a<=b 00 infinity
axXb a times b Xy x cdoty
8 | Chapter 8
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Greek Characters

Greek characters (o, 3,7y, 0, and so on) are common in mathematical formulas.
These characters are not available in the Elements window or on the right-click
menu. Fortunately, the markup for Greek characters is simple: Type a % sign followed
by the name of the character, in English. (In localized versions of OpenOffice, these
names are localized.)

* To write a lowercase character, type the name of the character in lowercase.
* To write an uppercase character, type the name of the character in uppercase.

A complete table of Greek characters is provided in the Math Guide. See the table
below for some examples.

Lowercase Uppercase

$alpha — X $SALPHA — 4
tbeta — B $BETA — B
$gamma — 7y $GAMMA — T
$psi - Y $PSI - VY
sphi - ¢ SPHI - &
$theta — @ $STHETA — @

Another way to enter Greek characters is by using the Symbols catalog window.
Choose Tools > Catalog. Under Symbol set, select Greek and double-click on a
Greek letter from the list. The markup name of the character is shown below the list
window.

& Symbols B3
Symbol set [ Insert l
Greek i

: [ Close l
MNIOZE pgv m EXH®

| Edit... ]
& ¥ P T X ndd yp 1
BT ZpF ¢+ T A AT K
5 6 d y Kk w oo o a
w A A p ECOY € o
voc & ok -
alpha

Figure 7. Symbols catalog—used for entering Greek characters and some special
symbols.
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Example 2: © =~ 3.14159

For this example we will suppose that:

* We want to enter the above formula (the value of pi rounded to 5 decimal
places).

* We know the name of the Greek character (pi).
* But we do not know the markup associated with the ~ symbol.

Step 1: Type % followed by the text pi. This displays the Greek character 1t .

Step 2: Open the Elements window (View > Elements).

Step 3: The ~ symbol is a relation, so we click on the Relations button. If you hover
the mouse over this button you see the tooltip Relations (Figure 8).

Figure 9 shows the Elements window after clicking the Relations button. The symbol
we want is circled.

(5 Elements (53 Elements Ed|

&g ect 10 K o 2
m[h] el a (8) ﬁl;lj

+0 -0 a4 Fa -a a=b a=b a=b alb atb

a+b a-b axb axb asb a<b a>b||b alb

a-b % azb a/b avb asb azb a~b azb

a=b a<b a=b aeb a-b
Figure 8. Tool-tip indicates the a=b a=b a=b

Relations button.

Figure 9. After selecting Relations.
Step 4: Click on the a = b symbol. The equation editor now shows the markup
spi<?> simeqg <?>.

Step 5: Delete the <?> text and add 3.14159 at the end of the equation. We end up
with the markup %pi simeq 3.14159. The result is shown in Figure 10.
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LS 3._14159:

2 B8

pi simeqg 3.14159 I

£

Figure 10. Final result

Customization

Formula Editor as a Floating Window
The formula editor can cover a large part of the Writer window. To turn the formula
editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 11.

2) Hold down the Ctrl key and double-click.

=mc"2

_[g
l.

Figure 11. Hold down the Ctrl key and double-
click on the border of the formula editor to turn
it into a floating window.

Figure 12 shows the result. You can dock the floating window again by using the
same steps. Hold down the Ctrl key and double-click the window frame.

N "
= | Commands
E=mc 2| A

.V‘
3 ¥

Figure 12. Formula editor as a floating
window
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How Can | Make a Formula Bigger?

This is one of the most common questions people ask about Math. The answer is
simple, but not intuitive:

1) Start the formula editor and choose Format > Font size.

i Untitled 1 - OpenOffice Writer

File Edit View Format Tools Window Help

Fonts... o H =
Font Sjze...
Spacing...

| Alignment..

IE-- }I

JOSIE 1 Text Mode

Figure 13. Changing the font size for a
formula

2) Select a larger font size under Base size (top-most entry).

rﬁ' Font Sizes
Base size 16pt] s ’ OK ]
Relative sizes ’ Cancel ]
Text 100%

Indexes 50%

Eunctions 100%

1

Operators 100%

Limits 5 0%

% ¥

Figure 14. Edit Base size (top) to make a formula
bigger

The result of this change is illustrated in Figure 15.

Before: =3 14159
Adfter: m=3.14159

Figure 15. Result of changing the base font
size
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Formula Layout

The most difficult part of using Math comes when writing complicated formulas. This
section provides some advice.

Brackets Are Your Friends

Math knows nothing about order of operation. You must use brackets to state the
order of operations explicitly. Consider the following example.

Markup Result
2 over x + 1 24_1
by

2 over {x + 1}
x+1

Equations Over More Than One Line

Suppose you want to type an equation covering more than one line. For example:
x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the

Enter key, though the markup goes to a new line, the resulting equation does not. You
must type the newline command explicitly. This is illustrated in the table below.

Markup Result
x = 3
S x=3y=1

= 3 newline

x=3
=1 y:l

X

<

How do | Add Limits to My Sum/Integral?

The sum and int commands can (optionally) take the parameters from and to. These
are used for lower and upper limits respectively. These parameters can be used singly
or together. Limits for integrals are usually treated as subscripts and superscripts.
Remember that subscripts are indicated with and superscripts are indicated with ~.

Markup Result

n
sum from k =1 to n a k Zak
k=1
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Markup Result

int from 0 to x f(t) dt
or
int 07x f£(t) dt

O C—
\
=~
=
o
=
—
(=)
\
~
=

f

int from Re £

By

00
sum to infinity 2"{-n} 22_"

Note For more details on integrals and sums, see the Math Guide.

Brackets with Matrices Look Ugly!

For background, we start with an overview of the matrix command.

Markup Result

a b
c d

matrix { a # b ## c # d }

Note Rows are separated by two #’s and entries within each row are
separated by one #.

The first problem people have with matrices is that brackets do not scale with the
matrix.

Markup Result

(@ by

( matrix { a # b ## c # 4} )
c d

Math provides scalable brackets. That is, the brackets grow in size to match the size
of their contents. Use the commands left (and right) to make scalable brackets.

Markup Result
. . a b
left( matrix { a # b ## ¢ # d } right)
(C d )
Tip Use left[and right] to obtain square brackets.

How do | Make a Derivative?

Making derivatives essentially comes down to one trick: Tell Math it’s a fraction.
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In other words, you have to use the over command. Combine this with either the
letter d (for a total derivative) or the partial command (for a partial derivative) to
achieve the effect of a derivative.

Note Notice that we have to use braces (squiggly brackets) to make the

derivative.
Markup Result
{df} over {dx} i
dx
{partial f} over {partial vy} ﬂ
oy
2
{partial”2 f} over {partial t"2} aa]:
t

How do | Align My Equations at the Equals Sign?

Math does not have a command for aligning equations on a particular character, but
you can use a matrix to do this, as shown below.

Markup Result
matrix{
alignr x+y # {}={} # alignl 2 ## x+y = 2
alignrx # {}={} # alignl 2-y x = 2—y
}

The empty braces around = are necessary because = is a binary operator and thus
needs an expression on each side.

You can reduce the spacing around = if you change the inter-column spacing of the
matrix:
1) With the equation editor open, choose Format > Spacing from the menu bar.

2) In the Spacing dialog (Figure 16), click the Category button and select
Matrices in the drop-down menu.

3) Enter 0% for Column spacing and click OK.

Chapter 8
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& Spacing
Matrix =
Line spacing ‘3% m —
Column spacing % 2 [QHC
b d Category -
| Default

Figure 16: Changing spacing in a matrix formula

Numbering Equations

Equation numbering is one of Math’s best hidden features. The steps are simple, but
obscure:
1) Start a new line in the Writer document.

2) Type fn and then press F3.

The fn is replaced by a numbered formula:
E=mc’ (1)

Now you can double-click on the formula to edit it. For example, here is the Riemann
Zeta function:

Z(Z#iiz 2)

n=1 N

You can reference an equation (“as shown in Equation (1)”) with these steps:
1) Choose Insert > Cross-reference from the menu bar.
2) On the Cross-references tab (Figure 17), under Type, select Text.
3) Under Selection, select the equation number.
4) Under Format, select Reference.
5) Click Insert.

Done! If you later add more equations to the paper before the referenced equation,
all the equations will automatically renumber and the cross-references will update.

To insert the equation number without parenthesis around it, choose
Numbering instead of Reference under Format.

Tip
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Document |Cross-references |Fun|:ti|:|ns || DocInformation || Yariables || Database |
Type Selection
Set Reference g
Insert Reference [FA
Headings (3
Mumbered Paragraphs
Figure
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Insert reference ko MName
Page iz |
Chapter
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I Insert I [ Close ] [ Help
Figure 17. Inserting a cross-reference to an equation number
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