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Introduction

Introduction

This chapter looks at the tools and functions that let you modify existing drawings. All of the 
functions apply to the selected object or group of objects. The selected object or group can be 
distinguished from others by small colored squares or circles located around the object (this is also 
true when several objects are selected simultaneously). These points are called handles.

The handles form a rectangular frame that is just big enough to contain the object. Where several 
objects are selected, the frame around them corresponds to the smallest rectangle that can contain all 
of the objects. This frame is called the selection rectangle.

If the Options bar is displayed (select View > Toolbars > Options to turn it on, if it is not displayed), 
you can change the size of the handles using two buttons: Simple Handles shows the handles as flat 
squares, and Large Handles shows the handles in a larger size. You can combine the effects obtained 
by pressing on both buttons and thus have large handles having a 3D shape or small handles having 
no 3D shape, whichever suits your needs or preferences. The figure below shows the location of the 
handles and other buttons.

Figure 1: Location of handles on the Options toolbar

Selection modes
There are three selection modes:

1) Moving and changing size

2) Editing

3) Rotating points

To set the default mode (1 or 2) for selecting objects, click on the Points button  on the Drawing 
toolbar.

In standard mode (when you begin a new drawing), the Points button is not active, and the default 
mode is for selections to be moved or changed in size; these selections are indicated by small green 
squares.

When the Points button is active, the default mode is for selections to be edited; these selections are 
indicated by blue squares. Some objects will have one or more extra handles, which are larger or 
colored differently. This is explained in more detail in “Editing object points” on page 10.
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Introduction

Selections for rotating objects are indicated by small red circles and a symbol representing the center 

of rotation. To choose these selections, click on the Effects drop-down button  from the 
Drawing toolbar and after that on the object.

Changing the selection mode
To go from one mode to another, you can do one of the following:

Choose the Points button  from the Drawing toolbar to switch from simple selection mode 
to Points mode. You can also use the keyboard shortcut F8 (Points).1

Choose the Effects drop-down button from the Drawing Toolbar  to activate the Rotation 
mode for a selected object. To exit Rotation mode, click on the Selection icon .

If you often work in Rotation mode, you can choose the Rotation Mode after Clicking Object 

button  from the Options bar and cycle through normal and rotation modes just by clicking on 
the object. This can be more convenient than repeatedly clicking the selected object, then 
clicking the Rotate button from the Drawing toolbar.

Selecting objects

Direct selection
To select an object, the easiest way is to click directly on it. For objects that are not filled, you have 
to click directly on the object’s outline to select it.

Selection by framing
You can select several objects at once by using the mouse to drag a large 
rectangle around the objects with the Select button, as shown. For this to 
work, the  icon on the Drawing toolbar must be active.

Only objects that lie entirely within the rectangle will be selected.

1 This mode is described in more detail later in this chapter.
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Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. To select an 
object that is covered by another object, hold down the Alt key and click the object. To select an 
object that is covered by several objects, hold down the Alt key and click through the objects until 
you reach the required underlying object. To cycle through the objects in reverse order, hold down 
the Alt+Shift keys when you click. To help in making accurate selections, you can check the number 
and type of the selected objects, shown at the left of the status bar.

Note There may be some variation in the use of the Alt key on different operating 
systems. In general the Alt key on a Windows computer functions as described 
above, but on a Linux system it usually does not. If the Alt key on your system does 
not operate as described above, use the Tab key method described below.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle 
through the objects, stopping at the object you wish to select. To cycle through the objects in reverse 
order, press Shift+Tab. This is a very quick way to reach the object you want, but it may not be 
practical if you have a large number of objects in your drawing.

When you click on the selected object, its outline will appear briefly through the objects on top of the 
selected object.

In the illustration below, the square located beneath the circle was selected in this way (the circle was 
made semi-transparent in order to see the square).

Figure 2: Selecting a covered object

Arranging objects
In a complex drawing, you may have objects stacked up, one on top of the other, with the result that 
a particular object is hidden by one or more other objects above it. You can rearrange the stacking 
order of objects (move an object to the front or to the back of the stack) by selecting the object, 
clicking Modify > Arrange and selecting the appropriate Bring Forward or Send Backward 
option, or by right-clicking the object and selecting Arrange from the context menu, then selecting 
from the list of Bring Forward or Send Backward options.

On the Drawing toolbar, the Arrange tear-off menu on the  button contains the above options. A 
keyboard shortcut is Shift+Ctrl++ to bring an object to the top, and Shift+Ctrl+− to send an object 
to the bottom.

An exception to the above is an object which is located on the Controls layer. Such objects always lie 
above all other objects and are located within a separate stack on the Controls layer.

Selecting several objects
To select or deselect several objects one by one, hold down the Shift key and click on the various 
objects to be selected or deselected. One click on an object selects it; a second click deselects it.

Working with Objects and Object Points 3



Moving and dynamically adjusting an object’s size

Moving and dynamically adjusting an object’s 
size

There are several ways of moving or changing the size of an object. The method described here is 
called dynamic—in the sense that it is carried out using the mouse.

When you dynamically change an object, remember to check the right-hand area of the Status Bar at 
the bottom of your screen. This shows detailed information about the ongoing manipulation. For 
example, during a resizing manipulation, the following information is displayed.

The Information field (not shown in Figure 3) shows which object is selected; the (current) position
—X/Y coordinates, and object dimensions —width x height, of the object being moved are shown. 
The information displayed changes as the mouse is moved. The units of measurement displayed are 
those selected under Tools > Options > OpenOffice.org Draw > General.

Figure 3: Status Bar during dynamic adjustment

Dynamic movement of objects
To move an object, select it and then click within the object’s 
border and hold down the left mouse button while moving the 
mouse. During movement, the shape of the object appears as 
dotted lines to help with repositioning.

Figure 4: Moving an object

To drop the object at its new location, release the mouse button. The new position appears 
immediately in the Status Bar.

Dynamic size modification of objects
To change the size of a selected object (or a group of selected objects) with the mouse, you need to 
move one of the handles located around the selection. As shown in the following illustration, the 
outline of the resulting new object appears as a dotted line while the mouse button is pressed.

Figure 5: Changing the size of a selected object

Working with Objects and Object Points 4
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Moving and dynamically adjusting an object’s size

The results will differ depending on which handle you use. If you choose a corner handle (as shown 
in the figure above), you will resize the object along two axes at the same time. If you use a side 
handle, the objects will only be resized along one axis. The new size will appear immediately in the 
Status Bar.

Note If you press the Shift key at the same time as you carry out the resizing operation, 
the increase or decrease in size will be carried out symmetrically with respect to the 
two axes, which enables you to keep the same height/length aspect ratio of the 
object.

Dynamic size modification of objects with the help 
of the Status Bar
If you select an object and modify it using the mouse, the changes are immediately reflected in the 
Information field of the Status Bar. With geometric shapes (such as Basic Shapes, Symbol Shapes, 
Block Arrows), the only information shown in the Status Bar is that the shape is being resized, as 
shown in the top-left image in Figure 6. With geometric elements (rectangles, circles, and so on), the 
changes to the attributes of the element (either relative or absolute) are also shown, as in the top-right 
image in Figure 6.

In the case of a rectangle, the relative percentage of the x and y dimensions of the original shape are 
shown. For a line, much more information is given: the absolute change in x,y coordinates of the end 
point being moved, together with the current length and bearing of the modified line. These are all 
given in the Status Bar and updated dynamically as the end point is moved (see Figure 6).

This information can be very useful. It is the only place in which one can see the exact start and end 
angle locations of an arc, or where the length and bearing of a sloping line are shown. With this 
information you can size the object with considerable accuracy.

Figure 6: The Information field during dynamic size modification of objects
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Moving and dynamically adjusting an object’s size

Modifying an arc
The beginning and end points of an arc can be modified. Select the arc and click on the Points icon 

 on the Drawing toolbar to enter the Edit points mode2. In this mode, the handles on the selection 
frame change—two larger blue handles appear at the beginning and end points of the arc. When the 
mouse hovers over one of these points the cursor will change to a hand.

Figure 7: Editing an arc

If you click and hold the mouse button when the hand cursor appears, moving the mouse will change 
the location of the start or end point of the arc. The actual coordinates are shown in the Status Bar.

Rotating and shearing an object

Changing with the mouse
Rotating an object lets you slant the object along an axis. To do this dynamically, use the red handles, 
as you do when changing the size of the object.

Note Rotation works in a slightly different way for 3D objects because the rotation 
occurs in 3D space and not in one plane. See Chapter 7 (Working with 3D Objects) 
regarding rotation when the Edit Points mode is active.

To rotate an object (or a group of objects), drag a red corner handle point of the selection with the 
mouse. The mouse cursor takes the shape of an arc of a circle with an arrow at each end. A dotted 
outline of the object being rotated appears and the current angle of rotation is dynamically shown in 
the Status Bar.

Rotations are made about an axis which is displayed as a small symbol. This is normally located at 
the midpoint of the object, but you can move the axis of rotation with the mouse to any location you 
like.

2 This mode is described in more detail later in this chapter,

Working with Objects and Object Points 6



Rotating and shearing an object

Figure 8: Rotating an object

If you hold down the Shift key during the rotation, the operation will be carried out in increments of 
15°.

Changing inclination or perspective
To slant or shear objects, use the red handles located at the midpoint of an edge of the selected 
objects. The mouse pointer changes to a  when the pointer hovers over one of these midpoint 
handles. Not every object can be slanted—basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be used for shearing the object. 
This point stays fixed in location; the other sides and edges move in relation to it as the mouse is 
dragged (make sure that the  handle icon is showing before dragging).

Figure 9 shows how the vertices move in relation to each other during the shearing process. The 
circles represent the path of the vertices. The inclination axis is the bottom vertex of the triangle (the 
slanting handle used is the midpoint of the upper enclosing frame). All points on the figure will move 
through the same angle irrespective of the final shape. The actual angle is shown in the Status Bar.

Note Should you wonder where the triangle in the next figure comes from—it was 
produced with the (unfilled) polygon tool and then Close Object selected from the 
context menu.

Figure 9: Shearing an object

Working with Objects and Object Points 7



Rotating and shearing an object

This tool can be used to produce perspective drawings. The series of pictures in Figure 10 shows the 
method of constructing a cuboid or rectangular prism. To shorten the edges leading from front to 
back, reduce the length before you distort the height or width of the surface.

Figure 10: Perspective production of a cuboid

As with rotation, you can set the slanting to occur as steps of 15° by pressing the Shift key while 
moving the handle.

Setting size and position exactly

You can position and resize objects with the mouse, but this method is not very exact. If you need 
accurate positioning of objects, use Format > Position and Size from the menu bar, or right-click 
the object and select Position and Size from the context menu, or press F4. 

Position and Size
Open the Position and Size dialog (see Figure 11) and click on the first tab to set the appropriate 
values.

Figure 11: Position and size of an object

Working with Objects and Object Points 8



Setting size and position exactly

Position is defined as an X,Y coordinate relative to a fixed point (the base point), typically located at 
the upper left of the drawing area. If desired, you can temporarily change this base point to make 
positioning or dimensioning simpler (click on the radio button corresponding to the location of the 
base point in either of the two selection windows on the right side of the dialog—upper for 
positioning or lower for dimensioning). The possible base point positions correspond to the handles 
on the selection frame plus a central point. The change in position lasts only as long as you have the 
dialog open; when you close this dialog, Draw resets the base point to the standard position.

Tip The Keep ratio checkbox is very useful. Click it to keep the ratio of width to height 
fixed while you change the size of an object.

Either or both the size and position can be protected so that they cannot be inadvertently changed. 
Check the appropriate boxes to achieve this.

Tip You cannot move an object? Check to see if the position is protected!

Rotating objects
Click on the Rotation tab of the Position and Size dialog (see Figure 12). Here you can define the 
rotation angle, as well as the location of the pivot point.

Figure 12: Rotating an object

Slant and corner radius
With some Draw objects the slant angle (inclination or shearing) and corner radius can be set in this 
dialog (Figure 13).

Working with Objects and Object Points 9



Setting size and position exactly

Figure 13: Setting rounded corners and slant angle

Corner radius

Figure 14: Example of setting rounded corners

You can use this dialog to round the corners of the usual Draw objects—text boxes, legends, 
rectangles, and squares, as shown in Figure 14. The same effect can be achieved when you are in the 
points mode (by clicking the Points icon on the Drawing toolbar), by dragging the large handle with 
the mouse. The larger the value for the corner radius, the more round will be the object.

Slant

You can shear the older, classic Draw objects, but not the newer Shape objects. Enter the slant angle 
in the box marked Slant Angle.

Figure 15: Example of setting the slant angle in a classic Draw object

Editing object points

For polygons and Bézier curves, Draw offers a complete set of tools that let you accurately edit the 
contour of an object. To edit other objects in the same way, you must first convert them into curves. 
To do this, select the object, then right-click and choose Convert > To Curve or choose Modify > 
Convert > To Curve from the menu bar.

You can also convert the shapes to a polygon (Convert > To Polygon). With polygons, the edge 
points are always connected with straight lines and not with curves. Some of the techniques 
described work equally with polygons as with curves.

Working with Objects and Object Points 10



An alternative way to change the form of basic shapes

An alternative way to change the form of 
basic shapes

In current versions of Draw, many of the new shapes can be directly edited without having to first 
convert them to curves. You can recognize these objects by the presence of one (or more) yellow 
handles. Figure 16 shows a selection of shapes with such handles.

If you hover the mouse pointer over one of these handles and then drag it, you can change the form 
of the shape; the exact type of change is dependent on the shape itself. The mouse pointer changes to 
a hand with index finger outstretched when hovered over one of these handles.

Examples of what you can do with this tool are rounding the corners of a rectangle or square, 
changing the angles of an arc or ellipse, or altering the control points of a circular or elliptical 
segment.

Figure 16: Some basic shapes with yellow “handles”

How curves work

Editing curves works on the basis of a method called Bézier curves3. The complete study of such 
curves goes beyond this scope of this guide, and only the basics of this powerful method of editing 
the contour of an object are covered here. Chapter 10 (Advanced Draw Techniques) provides more 
information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through 
these points. Each tangent has two control points—one at each end—and a junction point where it 
meets the curve. The relative angle and distance between the control points determine the shape of 
the curve. Figure 17 shows several variations starting from a basic circle and changing only one 
point on the circle.

You can create many different shapes by moving either the junction point itself, or one or both of the 
round handle points at either end of the tangent.

3 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who 
developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles 
easier.

Working with Objects and Object Points 11



Figure 19: Symmetric 
Transition

How curves work

Figure 17: Creating different shapes by changing the tangent

Experimenting with moving the control points of a tangent will yield countless variations of the 
basic starting shape. Draw offers even more possibilities when you use the functions on the Bézier 
curve toolbar.

The Edit Points toolbar
When you work in Edit Points mode, use the Edit Points toolbar, shown in Figure 18. This toolbar 
can be activated by View > Toolbars > Edit Points. Once activated, it will appear whenever you 
select a curve and the Edit Points icon on the Drawing toolbar is active.

Figure 18: Edit Points toolbar

On this toolbar, some buttons are active or inactive depending on the selected object and object 
point. With the Convert to Curve icon, you can determine for individual points whether their 
connection will be made with straight lines or with curves.

Only with curves are the icons for tangents activated. An object which contains no curves is treated 
as a polygon.

The role of the three buttons enabling you to choose the type of tangent is described in the following 
chapter. The other buttons are described here in relation to working examples.

The three kinds of tangent
Three buttons in the Edit Points Toolbar let you select the type of tangent and convert from one type 
to another. Only one of these buttons can be active at any given time.

The Symmetric Transition button  lets you work with a 
symmetrical tangent (Figure 19). Any movement of one or the 
other of the handles will be carried over symmetrically to the other 
handle.

Working with Objects and Object Points 12



Figure 20: 
Asymmetric tangent

Figure 21: Inflexion 
point

Figure 22: Moving a junction 
point

How curves work

The Smooth Transition button  lets you separately adjust the 
lengths of the two parts of a tangent and so make the curve flatter 
or steeper. In Figure 20, you can clearly see that the curve is flatter 
on the longest side of the tangent. The tangent remains as a single 
straight line. This kind of tangent is known as a smooth junction. 
This button should not to be confused with the preceding one 
because their representations are fairly similar.

It is also possible to completely detach both sides of the tangent. In 
this case, the central point is known as the inflexion point. Using 
this technique, you can draw spikes and troughs in objects. Use the 

Corner Point button  to create an inflexion point around the 
selected point.

Examples
The following examples start from a filled circle. As mentioned earlier, in order to use Edit Points 
mode, you first need to convert the object to a curve.

You will notice that after the conversion, the handles located in the corners of the rectangle have 
disappeared. This behavior is normal in that the handles which are used in the Edit Points mode are 
located along the outline or trace of the drawn object.

The Move Points button  is the default mode when editing 
points. If it has not been activated, click on its button. When this 
mode is active, the mouse cursor has the following shape when it is 
hovered over an edit point:

Movement of a point is one of the easiest manipulations to do. 
Figure 22 illustrates how an egg can be drawn very easily by 
starting from a circle and dragging the the top point upwards.

Working with Objects and Object Points 13



Figure 23: Rotating a tangent

Figure 24: Adding an edit point  
to a curve

 

Figure 25: Deleting points from 
a curve

How curves work

To change the direction or location of the tangents, move the 
circular handles at each end. The mouse cursor then looks like this:

Use the Add Points button  to add an extra edit point to an 
existing curve. Click on the curve at the spot where you want to 
insert a point and then move the mouse slightly, in any direction, 
while holding down the button. Watch out! If you just click, the 
new point will not be added.

The tangent attributes associated with the new point depend on the 
buttons that are selected on the toolbar.

The Delete Points button  has the opposite effect: it subtracts 
one or more points from the curve. The resulting curve stretches 
itself automatically around the remaining points after subtraction.

Select one or more points to delete. You can select several points 
by holding down the Shift key (➊).

When you have selected the points you want to delete, click the 

Delete Points  button. The selected points disappear from the 
curve, which then reforms around the remaining points (➋).

You can also delete the selected points by pressing the Del key on 
the keyboard.

Working with Objects and Object Points 14
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Figure 27: Moving a 
segment

Figure 28: Closing an 
open curve

How curves work

 

Figure 26: Cutting a curve

Use the Split Curve button  to split or cut a curve at the 
location of the selected handle. If the object is filled, it will be 
emptied because the curve that represented the edge is no longer 
closed.

Check that you have selected the correct handle (➊), click the 

Split Curve button  (➋) and notice that the object is no longer 
filled. You can then check, by moving the point, that the curve has 
indeed been separated (➌).

If you have an open curve, the start point of the curve is larger than 
the others.

You can also separate a curve at several points simultaneously. Just 
keep the Shift key pressed down and select all of the points at 
which the cut should occur.

Drag and drop segments with the mouse to move them from the 
original curve.

To close an existing curve, select an open curve and click on the 

Close Bézier button .

The opening point is identified by a slightly larger handle (Figure 
28).

Working with Objects and Object Points 15

➊

➋

3



How curves work

Figure 29: Using the “select  
points” switch

The Select button  on the Drawing toolbar functions as a 
switch. It works as follows.

If you have two points linked together by a straight line (you do 
not need to have a curve between the points) and you insert a new 
point between them that is set at an angle to the initial straight line 
(and hence the two endpoints), then:

• If the Select button is active, you will have a drawing 
similar to that illustrated in ➊.

• If the Select button is not active, and you move the point 
you have just inserted to bring it back close to its initial 
position in the straight line, you will have a drawing similar 
to that illustrated in ➋.

The Eliminate Points button  button only functions with lines 
with multiple points. 

If the button is active, clicking on a point, holding the mouse key 
down and moving the mouse will draw virtual straight lines 
between the neighboring left and right points. 

When the two lines are more or less straight and you release the 
mouse button, the point is deleted and a line between the above 
mentioned two neighboring points replaces the previous two lines, 
thus eliminating one point. 

Note that this only works when the angle between the two lines 
shown dashed in the figure at left is less than a certain amount.

In the Tools > Options > OpenOffice.org Draw > Grid window 
there are options for snap settings relating to editing points when 
rotating and in point reduction mode.

Working with Objects and Object Points 16
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Figure 30: Select object and 
set Edit points mode

Figure 31: Draw virtual lines

Figure 32: Release mouse 
button

Figure 33: Line is reduced by 
one point

➋



Figure 34: Moving a point on 
a curve

How curves work

The Rotate function from the Effects drop-down button  on 
the Drawing toolbar and the Rotation Mode after Clicking 

Object button  on the Options toolbar can be used in Edit Point 
mode. In this case, it can be used to move single points around the 
contour of an object.

Switch into rotation mode by clicking on either of the rotation 
buttons. Notice that in rotation mode, all of the tangent points 
become red dots.

Select the point to be moved and then drag it around the contour 
while keeping the left mouse button pressed down (➊). When you 
let go of the mouse button, the point will be moved to the new 
position (➋).

If you move one of the handles located at the end of the tangents 
during rotation, you will make the object rotate in exactly the same 
way as with the usual rotation operations.

Important: To exit the effects mode, do not just click on the 

Effects button; click the Select button  on the Drawing toolbar.

Working with Objects and Object Points 17
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