
Impress Guide

Chapter 10
  Printing, e-mailing, 

exporting, and saving 
slide shows



Copyright

This document is Copyright © 2005–2011 by its contributors as listed below. You may 
distribute it and/or modify it under the terms of either the GNU General Public 
License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative 
Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), version 
3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Nicole Cairns
Peter Hillier-Brook
Jean Hollis Weber
Michele Zarri
Hazel Russman

Feedback
Please direct any comments or suggestions about this document to: 
authors@documentation.openoffice.org

Publication date and software version
Published 28 May 2011. Based on OpenOffice.org 3.3.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows 
and Linux. The table below gives some common substitutions for the instructions in 
this chapter. For a more detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options 
menu selection

OpenOffice.org > 
Preferences

Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles & Formatting window

You can download
 an editable version of this document from

 http://wiki.services.openoffice.org/wiki/Documentation/

http://wiki.services.openoffice.org/wiki/Documentation/
mailto:authors@documentation.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html


Contents

Copyright....................................................................................................................... 2

Note for Mac users........................................................................................................2

Introduction...................................................................................................................4

Quick printing................................................................................................................ 4

Controlling printing.......................................................................................................4
Selecting general printing options.............................................................................5
Printing multiple pages on a single sheet of paper...................................................5
Selecting slides to print.............................................................................................6
Selecting other information to print..........................................................................7
Printing in black and white (on a color printer)........................................................7
Printing handouts, notes, or outlines in Impress.......................................................7
Selecting default print options...................................................................................8

Printing a brochure........................................................................................................8

Exporting to PDF...........................................................................................................9
Quick export to PDF...................................................................................................9
Controlling PDF content and quality.........................................................................9

General page of PDF Options dialog box.............................................................10
Initial View page of PDF Options dialog box.......................................................11
User Interface page of PDF Options dialog box..................................................12
Links page of PDF Options dialog box.................................................................13
Security page of PDF Options dialog box............................................................14

Exporting as a Flash file..............................................................................................15

Exporting as web pages (HTML files)..........................................................................15

E-mailing a presentation..............................................................................................19
Digital signing of documents...................................................................................20

Opening and saving a PowerPoint file.........................................................................21
Saving an Impress file as a PowerPoint file.............................................................21
Opening a PowerPoint file in Impress......................................................................21

Printing, e-mailing, exporting, and saving slide shows 3



Introduction

This chapter provides information about printing, exporting, and e-mailing 
documents from OpenOffice.org Impress.

Quick printing

Click the Print File Directly icon  to send the entire document to the default 
printer defined for your computer.

Note

You can change the action of the Print File Directly icon to send the 
document to the printer defined for the document instead of the default 
printer for the computer. Go to Tools > Options > Load/Save > 
General and select the Load printer settings with the document 
option.

Controlling printing

Impress provides many options for printing a presentation: with multiple slides on 
one page, with a single slide per page, with notes, as an outline, with date and time, 
with page name, and more.

For more control over printing a presentation, choose File > Print to display the 
Print dialog box.

Figure 1. The Print dialog box
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The Print dialog box has four tabs, from which you can choose a range of options, as 
described in the following sections.

Note

The options selected on the Print dialog box apply to this printing of this 
document only.

To specify default printing settings, go to Tools > Options > 
OpenOffice.org – Print and Tools > Options > OpenOffice.org 
Impress – Print. See “Selecting default print options” on page 8 for 
more information.

Selecting general printing options
On the General tab of the Print dialog box (Figure 1), you can choose:

• The printer (from the printers available)

• Which slides to print, the number of copies to print, and whether to collate 
multiple copies (Range and copies section)

• Whether to print slides, notes, handouts, or an outline of the presentation.

• For handouts, how many slides per printed page and in what order (see page 7 
for details).

Click the Properties button to display a dialog box where you can choose portrait or 
landscape orientation, which paper tray to use, and the paper size to print on.

The Options tab of the Print dialog box provides other choices, as shown in Figure 2.

Figure 2: General print options

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog box, select the Page Layout tab (Figure 3).
2) In the Layout section, select from the drop-down list the number of pages to 

print per sheet. The preview panel on the left of the Print dialog box shows 
how the printed document will look.

3) When printing more than 2 pages per sheet, you can choose the order in which 
they are printing across and down the paper. The two pictures in Figure 3 
show the difference.

4) In the Page sides section, select whether to print all pages or only some pages.

5) Click the Print button.
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Figure 3: Printing multiple pages per sheet of paper

Selecting slides to print
In addition to printing a full presentation, you can choose to print individual slides, 
ranges of slides, or a selection of slides, using the Ranges and copies section of the 
General page of the Print dialog box.

Be sure Slides is selected in the Document box in the Print section.

Figure 4: Ranges and copies section of Print dialog box

To print an individual slide or several slides, do either of the following:

• Open the Print dialog box, choose the Slides option in the Ranges and copies 
section, type the slide numbers, and click Print. Multiple slides may be 
represented by a list (for example 1,3,7,11) or a range (for example 1-4).

• Select the slides in the Slides pane or the Slide Sorter view, then open the 
Print dialog box and choose Selection in the Ranges and copies section, and 
click Print.
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Selecting other information to print
On the OpenOffice.org Impress tab of the Print dialog box, you can choose:

• What to print in addition to the slides: Slide name, date and time, and hidden 
slides (pages).

• Whether to print in color, grayscale, or black and white (on a color printer).

• What size to print slides.

Figure 5: Selecting other information to print

Printing in black and white (on a color printer)
You may wish to print slides in black and white or grayscale on a color printer. To do 
this, choose either Grayscale or Black & white in the Color section on the 
OpenOffice.org Impress tab of the Print dialog box (Figure 5).

Printing handouts, notes, or outlines in Impress
The Document box also gives you the option of printing Handouts, Notes, or an 
Outline.

Handouts means the slides are printed in reduced size on the page, from one to nine 
slides per page. The slides can be printed horizontally (landscape orientation) or 
vertically (portrait orientation) on the page.

Notes prints a single slide per page with any notes entered for that slide in Notes 
View.

Outline prints the title and headings of each slide in outline format.
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To print handouts, notes, or outlines:

1) Choose File > Print from the menu bar.
2) In the Print section of the Print dialog box, select the required option from the 

Document box.
3) For Handouts, you can then choose how many slides to print per page, and the 

order in which they are printed.
4) Click the Print button.

Figure 6: Printing handouts

Selecting default print options
Selections on the Print dialog box over-ride any default settings. To specify default 
settings for printing, use Tools > Options > OpenOffice.org Impress > Print.

Other printer settings are found in Tools > Options > OpenOffice.org > Print. Use 
this page to specify quality settings for printing, and whether to have Impress warn 
you if the paper size or orientation of your document does not match the printer 
settings.

See Chapter 11 (Setting Up and Customizing Impress) for details.

Printing a brochure

You can print a presentation with two slides on each side of a sheet of paper, 
arranged so that when the printed pages are folded in half, the slides are in the 
correct order to form a booklet or brochure.

To print a brochure on a single-sided printer:

1) Choose File > Print.
2) In the Print dialog box, click Properties.
3) Check that the printer is set to the same orientation (portrait or landscape) as 

specified in the page setup for your document. Usually the orientation does not 
matter, but it does for brochures. Click OK to return to the Print dialog box.

4) Select the Page layout tab in the Print dialog box.

5) Select the Brochure option.
6) In the Page sides section, select Back sides / left pages option from the Include 

drop-down list.
7) Click the Print button.
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Figure 7: Printing a brochure from Impress

8) Take the printed pages out of the printer, turn the pages over, and put them 
back into the printer in the correct orientation to print on the blank side. You 
may need to experiment a bit to find out what the correct arrangement is for 
your printer.

9) On the Print dialog box, in the Page sides section, select Front sides / right 
pages option from the Include drop down box.

10)  Click the Print button.

Tip If your printer can print double-sided automatically, choose All pages.

Exporting to PDF

Impress can export presentations to PDF (Portable Document Format). This industry-
standard file format for file viewing is ideal for sending the file to someone else to 
view using Adobe Reader or other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire presentation using 
the default PDF settings. You are asked to enter the file name and location for the 
PDF file, but you do not get a chance to choose a page range or the print quality.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export 
as PDF. The PDF Options dialog box opens. This dialog box has five pages, described 
in this section. Make your selections, and then click Export. Then you are asked to 
enter the location and file name of the PDF to be created, and click Save to export 
the file.
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General page of PDF Options dialog box
On the General page, you can choose which pages (slides) to include in the PDF, the 
type of compression to use for images (which affects the quality of images in the 
PDF), and other options.

Figure 8: General page of PDF Options dialog box

Range section
• All: Exports the entire document.

• Pages: To export a range of slides, use the format 3-6 (pages 3 to 6). To export 
single slides, use the format 7;9;11 (slides 7, 9, and 11). You can also export a 
combination of slide ranges and single slides, by using a format like 
3-6;8;10;12.

• Selection: Exports whatever material is selected.
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Images section
• Lossless compression:  Images are stored without any loss of quality. Tends 

to make large files when used with photographs. Recommended for other kinds 
of images or graphics.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% 
tends to work well with photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower 
quality. For viewing on a computer screen generally a resolution of 72dpi (for 
Windows) or 96dpi (GNU/Linux) is sufficient, while for printing it is generally 
preferable to use at least 300 or 600 dpi, depending on the capability of the 
printer. Higher dpi settings greatly increase the size of the exported file.

Note
EPS (Encapsulated PostScript) images with embedded previews are 
exported only as previews. EPS images without embedded previews are 
exported as empty placeholders.

General section
• PDF/A-1: PDF/A is an ISO standard for long-term preservation of documents, 

by embedding all the information necessary for faithful reproduction (such as 
fonts) while forbidding other elements (including forms, security, and 
encryption). PDF tags are written. If you select PDF/A-1, the forbidden 
elements are grayed-out (not available).

• Tagged PDF: Tagged PDF contains information about the structure of the 
document’s contents. This can help to display the document on devices with 
different screens, and when using screen reader software. Some tags that are 
exported are table of contents, hyperlinks, and controls. This option can 
increase file sizes significantly.

• Create PDF form - Submit format: Choose the format of submitting forms 
from within the PDF file. This setting overrides the control’s URL property that 
you set in the document. There is only one common setting valid for the whole 
PDF document: PDF (sends the whole document), FDF (sends the control 
contents), HTML, and XML. Most often you will choose the PDF format.

• Export bookmarks: Exports slide names as “bookmarks” (a table of contents 
list displayed by some PDF readers, including Adobe Reader).

• Export comments: Exports comments as PDF notes. You may not want this!

• Export notes pages: Exports a set of Notes pages after the set of slides.

• Export automatically inserted blank pages: Not used in Impress.

• Embed standard fonts: In previous versions of OOo, the standard fonts 
(Times, Helvetica, Courier, Symbol, and ZapfDingbats) were only embedded 
into the PDF when the resulting file was of the PDF/A type, since the PDF/A 
standards requires this. In version 3.3, you can choose to embed these fonts in 
all PDF documents created by OOo to enhance display accuracy in PDF 
viewers.

Initial View page of PDF Options dialog box
On the Initial View page (Figure 9), you can choose how the PDF opens by default in 
a PDF viewer. The selections should be self-explanatory.
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Figure 9: Initial View page

User Interface page of PDF Options dialog box
On the User Interface page, you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are 
creating a PDF to be used as a presentation or a kiosk-type display.

Figure 10: User Interface page
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Window options section
• Resize window to initial page. Causes the PDF viewer window to resize to fit 

the first page of the PDF.

• Center window on screen. Causes the PDF viewer window to be centered on 
the computer screen.

• Open in full screen mode. Causes the PDF viewer to open full-screen instead 
of in a smaller window.

• Display document title. Causes the PDF viewer to display the document’s 
title in the title bar.

User interface options section
• Hide menubar. Causes the PDF viewer to hide the menu bar.

• Hide toolbar. Causes the PDF viewer to hide the toolbar.

• Hide window controls. Causes the PDF viewer to hide other window 
controls.

Transitions section
Includes Impress slide transition effects as the respective PDF effects.

Bookmarks section
Select how many heading levels are displayed as bookmarks, if Export bookmarks is 
selected on the General page.

Links page of PDF Options dialog box
On the Links page, you can choose how links are exported to PDF.

Figure 11: Links page of PDF Options dialog box

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet 
names, this option exports them as “named destinations” to which Web pages and 
PDF documents can link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions 
(such as .ODT, .ODS, and .ODP), this option converts the files names to .PDF in the 
exported PDF document.
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Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to 
the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog box
PDF export includes options to encrypt the PDF (so it cannot be opened without a 
password) and apply some digital rights management (DRM) features.

Figure 12: Security page

Note
Permission settings are effective only if the user’s PDF viewer respects the 
settings.

• With an open password set, the PDF can only be opened with the password. 
Once opened, there are no restrictions on what the user can do with the 
document (for example, print, copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its 
permissions can be restricted. See the options on Figure 12.

• With both the open password and permission password set, the PDF can only 
be opened with the correct password, and its permissions can be restricted.
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Figure 13 shows the pop-up dialog box displayed when you click the Set open 
password button on the Security page of the PDF Options dialog box.

Figure 13: Setting a password to encrypt a PDF

After you set a password for permissions, the other choices on the Security page 
(shown in Figure 12) become available. These selections should be self-explanatory.

Exporting as a Flash file

Macromedia Flash file format (.SWF) was created to store animation for web pages. 
Because almost all browsers play Flash movies (the Adobe Flash Player is available as 
a free download for those without Flash-capable browsers), these files can be viewed 
by just about anyone. With OpenOffice.org, you can export your Impress slide show 
as a .SWF file. To download the latest Adobe Flash Player for your operating system, 
go to: http://www.adobe.com/products/flashplayer/

Note Saving in Flash format does not retain animation and slide transitions.

To export the presentation as a Flash (.SWF) file:

1) Choose File > Export.
2) Select the location where you want the file saved and type a name for the file.
3) Under File Format, choose Macromedia Flash (SWF) (.swf) and click Save.

Exporting as web pages (HTML files)

You can export presentations as a series of web pages that can be viewed in any 
browser.

Note
Saving as web pages (HTML format) does not retain animation and slide 
transitions.
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1) Select File > Export and choose HTML Document as the file type.
2) Create a folder for the files, supply a name for the resulting HTML file, and 

click Save. The HTML Export Wizard opens.

Note

Depending on the size of your presentation and the number of graphics it 
contains, the HTML export function creates many HTML, JPG, and GIF 
files. If you simply save to your desktop (not in a specific folder), these 
separate HTML and graphics files will be all over your desktop. So be 
sure to create a folder to hold all the files.

3) Choose the design for all of the pages, either from an existing design or by 
creating a new one.
If you have not previously saved a design, the Existing Design choice is not 
available.

Figure 14: HTML Export – Choose a design

4) Click Next to select the type of web pages to create.

• Standard HTML: one page for each slide, with navigation links to move from 
slide to slide.

• Standard HTML with frames: one page with a navigation bar on the left-
hand side; uses slide title as navigation links. Click on links to display 
pages in right-hand side.

• Automatic: one page for each slide, with each page set with the Refresh 
meta tag so a browser automatically cycles from one page to the next.

• WebCast: generates an ASP or Perl application to display the slides. 
Unfortunately OOo has no direct support for PHP yet.
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Figure 15: HTML Export – Choose publication type

5) Decide how the images will be saved (PNG, GIF or JPG) and what resolution to 
use. When choosing a resolution, consider what the majority of your viewers 
might have. If you use a high resolution, then a viewer with a medium-
resolution monitor will have to scroll sideways to see the entire slide—probably 
not desirable.

Figure 16: HTML Export – Choose graphics type

6) If Create title page was chosen in step 4, supply the information for it on the 
next page. The title contains an author name, e-mail address and home page, 
along with any additional information you want to include.
This page of the Wizard does not display if Create title page was not chosen.

Exporting as web pages (HTML files) 17



Figure 17: HTML Export – Title page information

7) Choose the navigation button style to use to move from one page to another. If 
you do not choose any, OOo will create a text navigator.

Figure 18: HTML Export – Choose navigation style

8) Select the color scheme for the web pages. Available schemes include the 
document’s existing scheme, one based upon browser colors, and a completely 
user-defined scheme. You can save a new scheme so that it will appear on the 
first page of the HTML export wizard.
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Figure 19: HTML Export – Choose color scheme

9) Click Create to generate the HTML files. If this is a new design, a small dialog 
box pops up. If you might want to reuse this design, you can give it a name and 
save it. Otherwise, click Do Not Save.

Figure 20: Naming the design

E-mailing a presentation

OOo provides several ways to send a Writer document quickly and easily as an e-mail 
attachment in one of three formats: .ODP (OpenDocument Presentation, OOo’s 
default format), .PPT (Microsoft PowerPoint format), or PDF.

To send the current document in .ODP format:

1) Choose File > Send > Document as E-mail. OpenOffice.org opens a new e-
mail in your default e-mail program. The document is attached.

2) In your e-mail program, enter the recipient, subject and any text you want to 
add, then send the e-mail.

File > Send > E-mail as OpenDocument Presentation has the same effect.

If you choose E-mail as Microsoft PowerPoint, OOo first creates a .PPT file and 
then opens your e-mail program with the .PPT file attached. The .PPT file is not saved 
on your computer.
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Similarly, if you choose E-mail as PDF, OOo first creates a PDF using your default 
PDF settings (as when using the Export Directly as PDF toolbar button) and then 
opens your e-mail program with the .PDF file attached. The PDF file is not saved on 
your computer.

Tip
If you want to keep a copy of the .PPT or .PDF file as well as e-mailing it to 
someone, first save or export the presentation into the required format, 
then attach it to an e-mail in the usual way.

Digital signing of documents
To sign a document digitally, you need a personal key, the certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept 
secret, and a public key, which you add to your documents when you sign them. You 
can get a certificate from a certification authority, which may be a private company 
or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed 
from the document’s content plus your personal key. The checksum and your public 
key are stored together with the document. 

When someone later opens the document on any computer with a recent version of 
OpenOffice.org, the program will compute the checksum again and compare it with 
the stored checksum. If both are the same, the program will signal that you see the 
original, unchanged document. In addition, the program can show you the public key 
information from the certificate. You can compare the public key with the public key 
that is published on the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the 
digital signature.

On Windows operating systems, the Windows features for validating a signature are 
used. On Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or 
Firefox are used. For a more detailed description of how to get and manage a 
certificate, and signature validation, see “Using Digital Signatures” in the OOo Help.

To sign a document:

1) Choose File > Digital Signatures.
2) If you have not saved the document since the last change, a message appears. 

Click Yes to save the file.
3) After saving, you see the Digital Signatures dialog box. Click Add to add a 

public key to the document.

4) In the Select Certificate dialog box, select your certificate and click OK. 
5) You see again the Digital Signatures dialog box, where you can add more 

certificates if you want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon 
to view the certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or 
recorded changes are removed from files before you send them to other people or 
create PDFs from them.

20 Printing, e-mailing, exporting, and saving slide shows



In Tools > Options > OpenOffice.org > Security > Options, you can set OOo to 
remind (warn) you when files contain certain information and remove personal 
information automatically when saving documents or creating PDFs.

To remove personal and some other data from a file, go to File > Properties. On the 
General tab, uncheck Apply user data and then click the Reset button. This 
removes any names in the created and modified fields, deletes the modification and 
printing dates, and resets the editing time to zero, the creation date to the current 
date and time, and the version number to 1.

To remove version information, either go to File > Versions, select the versions from 
the list and click Delete, or use Save As and save the file with a different name.

Opening and saving a PowerPoint file

OpenOffice.org’s Impress file format is highly compatible with Microsoft’s PowerPoint 
format. You can open a PowerPoint presentation in Impress, edit it, then save it in its 
original PowerPoint format or in Impress format. You can also create a new 
presentation in Impress and save it as a PowerPoint file.

Saving an Impress file as a PowerPoint file
1) Choose  File > Save As from the menu bar.
2) Select the location where you want the PowerPoint file saved and type a name 

for the file.

3) Under File type, choose Microsoft PowerPoint 97/2000/XP (.ppt).
4) Click Save. If you have the “Warn when not saving in ODF or default format” 

option set in Options > Load/Save > General, the message shown in Figure
21 appears. Click Keep Current Format to confirm that you want to save the 
file in Microsoft PowerPoint format. You can deselect the Ask when not saving 
in ODF format checkbox and the message will not be shown again unless you 
re-enable it in the Options.

Figure 21: Warning message when saving in Microsoft PowerPoint format

Tip

Always save your work in Impress OpenDocument format (.odp) before 
saving in Microsoft format. Keep the Impress file as your working copy; 
if you need to change the presentation, change it in the Impress version 
and then save it again as PowerPoint. You are much less likely to have 
problems than if you open a file previously saved in PowerPoint format, 
edit it, and save it again.
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Opening a PowerPoint file in Impress
If you receive a file from someone in PowerPoint format and need to edit it in 
Impress, here is how:

1) In OpenOffice.org, choose File > Open from the menu bar.
2) Under File type, choose All files (*.*) or Presentations or Microsoft PowerPoint 

97/2000/XP from the drop-down list.

3) Navigate to the PowerPoint file, select it, and click Open.

The PowerPoint file can now be edited and saved as an Impress file or a PowerPoint 
file. To save the file as an Impress file, choose OpenDocument Presentation (.odp) 
as the File Type.

22 Printing, e-mailing, exporting, and saving slide shows


	Copyright
	Note for Mac users
	Introduction
	Quick printing
	Controlling printing
	Selecting general printing options
	Printing multiple pages on a single sheet of paper
	Selecting slides to print
	Selecting other information to print
	Printing in black and white (on a color printer)
	Printing handouts, notes, or outlines in Impress
	Selecting default print options

	Printing a brochure
	Exporting to PDF
	Quick export to PDF
	Controlling PDF content and quality
	General page of PDF Options dialog box
	Initial View page of PDF Options dialog box
	User Interface page of PDF Options dialog box
	Links page of PDF Options dialog box
	Security page of PDF Options dialog box


	Exporting as a Flash file
	Exporting as web pages (HTML files)
	E-mailing a presentation
	Digital signing of documents

	Removing personal data
	Opening and saving a PowerPoint file
	Saving an Impress file as a PowerPoint file
	Opening a PowerPoint file in Impress


