
Draw Guide

Chapter 11
  Introduction to Draw
OpenOffice.org’s Vector Drawing Component

OpenOffice.org



Copyright

This document is Copyright © 2005–2008 by its contributors as listed in the section titled Authors. 
You can distribute it and/or modify it under the terms of either the GNU General Public License, 
version 3 or later (http://www.gnu.org/licenses/gpl.html) or the Creative Commons Attribution 
License, version 3.0 (http://creativecommons.org/licenses/by/3.0/) or later.

All trademarks within this guide belong to their legitimate owners.

Authors
Agnes Belzunce
Daniel Carrera
Martin Fox
Peter Hillier-Brook
Gary Schnabl
Jean Hollis Weber
Linda Worthington

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments
This chapter is based on an original French document written for OpenOffice.org 1.x by Michel 
Pinquier (translated to English by Alex Thurgood) and previous content revised by Jim Taylor. The 
chapter was revised for OpenOffice 2.0 by the authors listed above, and later translated into German 
by Wolfgang Uhlig; the German revisions were then translated into English by Martin Fox.

Publication date and software version
Published 6 April 2008. Based on OpenOffice.org 2.4.

You can download an editable version of this document from 
http://oooauthors.org/en/authors/userguide2/published/

mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html
http://oooauthors.org/en/authors/userguide2/published/


Contents

Contents

Copyright................................................................................................................................................i

Authors....................................................................................................................................................i

Feedback.................................................................................................................................................i

Acknowledgments...................................................................................................................................i

Publication date and software version.....................................................................................................i

Introducton..................................................................................................................................................1

The Draw workplace...................................................................................................................................1

Rulers..........................................................................................................................................................2

Status bar.....................................................................................................................................................3

Toolbars.......................................................................................................................................................5

Floating toolbars.....................................................................................................................................5

Standard toolbar.....................................................................................................................................7

Line and Filling toolbar..........................................................................................................................7

Drawing toolbar......................................................................................................................................7

Color bar.................................................................................................................................................7

Options toolbar.......................................................................................................................................9

Drawing grid and guides......................................................................................................................10

Customizing toolbars............................................................................................................................11

Introduction to Draw i





Introducton

Introducton

Draw is a vector graphics drawing tool, although it can also perform some operations on raster 
graphics (pixels). It offers a series of powerful tools that enable you to quickly create a wide variety 
of graphical images.

Vector graphics store and display a picture as simple geometric elements (lines, circles, polygons, 
among others) rather than as a collection of pixels (points on the screen). This permits simpler 
storage and supports precise scaling of the picture elements.

Draw is fully integrated into the OpenOffice.org (OOo) suite, and this simplifies exchanging 
graphics with all components of the suite. For example, if you create an image in Draw, reusing it in 
a Writer document is as simple as doing a copy-and-paste. You can also work with drawings directly 
from within Writer or Impress, using a subset of the functions and tools from Draw.

Draw’s functionality is extensive, and even though it was not designed to rival high-end graphics 
applications, it possesses significantly more functionality than the drawing tools that are generally 
integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions that 
enable small three-dimensional drawings to be created (with texture and lighting effects), drawing 
and page-style integration, and Bézier curves.

The Draw Guide is not a course book that must be worked through from beginning to end. Rather, it 
is a reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some notions, such as file 
management or the way the OOo environment works, are mentioned only briefly, as they are covered 
in the Getting Started guide.

The Draw workplace

The main components of the Draw interface are shown in Figure 1.

The large area in the center of the window is where you make the drawings. You can surround the 
drawing area with toolbars and information areas. The number and position of the visible tools vary 
as a function of the task at hand or user preferences. Therefore, your setup may appear a little 
different. For example, many users put the main Drawing toolbar on the left-hand side of the 
workspace—not at the bottom, as shown here. The setup procedure is described in detail in Chapter 4 
(Menus and Toolbars) in the Getting Started guide.

You can split drawings in Draw over several pages. Multipage drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw window in Figure 1 gives an overview of 
the pages that you create. If the Pages pane is not visible on your setup,you can enable it from the 
View menu (View > Page Pane). To easily make changes to the page order, drag and drop one or 
more pages.
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The Draw workplace

Figure 1: Initial Draw window

Rulers

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they 
are not visible, you can enable them by selecting them from the View menu (View > Ruler).

The rulers show the size of a selected object on the page (see the gray double lines, highlighted in 
Figure 2). When no object is selected, they show the location of the mouse pointer, which helps to 
accurately position drawing objects.

You can also use the rulers to manage object handles and guide lines, making it easier to position 
objects.

The page margins in the drawing area are also represented on the rulers. You can change the margins 
directly on the rulers by dragging them with the mouse.
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Rulers

Figure 2: Rulers show the size of the selected object

To modify the units of measurement of the rulers (which you can define independently), right-click 
on the desired ruler, as illustrated for the horizontal ruler in Figure 3.

Figure 3: Rulers in a drawing

Status bar

The Status bar is located at the bottom of the screen (in all OOo components) and includes several 
Draw-specific fields, as identified in Figure 4.

The Information field shows which action is being carried out, or which object type is selected.

The Position field shows different information, depending on whether objects are currently selected 
or not:

• When no object is selected, the left number pair shows the current position (in X,Y Cartesian 
coordinates) of the mouse cursor.

• While an object is being resized with the mouse, the right number pair shows the size of the 
object (width and height).
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Status bar

Figure 4: Items on the Draw status bar

Note The sizes are given in the current measurement unit (not to be confused with the 
ruler units). This unit is defined in Tools > Options > OpenOffice.org Draw > 
General, where you can also change the scale of the page. Another way to change 
the scale is to double-click on the number shown in the status bar.

• If an object is selected, the left number pair shows the X,Y coordinates of the upper-left 
corner, and the right number pair displays the size of the object, as seen in Figure 4. These 
numbers do not relate to the solid object, but to the rectangle forming the selection outline. 
This outline is the smallest possible rectangle that can contain the visible part or parts of the 
object; see also Chapter 3 (Working with Objects and Object Points).

• When an object is selected, a double-click on this field opens the Position and Size dialog, 
which is described in detail in Chapter 4 (Changing Object Attributes).

The percentage shown in the Zoom field gives information about the current zoom factor. A double-
click or right-click on this field opens the Zoom dialog, where you can quickly change the zoom 
factor.

In the Indicator field, an asterisk (*) is shown whenever any change is made to the document but not 
yet saved to disk.

If you wish to digitally sign the document, a double-click or right-click in the Signature field brings 
up the signature box. Note that a document must be saved at least once before it can be signed. After 
it is signed, an indicator is present in this field.

The Slide field shows the page-sequence number for the current drawing page, in addition to the total 
number of pages that you created so far. This is useful when your drawing has a number of pages. If 
you select an object, the field enclosed by parentheses shows the layer in which the object resides 
within the drawing. In the example of Figure 4, the object is on the Layout layer of Slide 1, and there 
is a total number of one slide, so far.

The Template field shows which page template is being used for the current page. If you saved 
several slide designs, you can select one for the current page by double-clicking in this field (see 
Figure 5) and selecting Load after choosing a slide design.
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Status bar

Figure 5: Selecting a slide (page) design

Toolbars

You  can display or hide the various Draw toolbars, according to your needs. To display or hide a 
toolbar, click View > Toolbars. On the menu that appears, choose which toolbars you want to 
display.

You can also select the icons that you wish to appear on the toolbars. Some toolbars have icons that 
are not displayed by default, but you can choose to display them. You can also hide any icons that do 
appear on the toolbars, by default. To change the visible icons on any toolbar, click the arrow at the 
right-hand end of the toolbar and select Visible Buttons. On the list of the available icons that 
appears, select or deselect the icons you want to be visible. A checkmark next to an icon indicates 
that it is visible.

Floating toolbars
Many toolbar icons are marked with a small arrow. The arrow indicates that this icon has additional 
functions. Click the arrow, and a submenu or floating toolbar appears, showing its additional 
functions (see Figure 6).

You may wish to keep this submenu displayed on your screen, but in a different position. You can 
make a submenu into a floating toolbar. To do so, click the area at the top of the submenu, drag it 
across the screen to a location you want, and then release the mouse button. Floating toolbars can be 
redocked on an edge of the screen or within one of the existing toolbar areas at the top of the screen, 
as described in Chapter 4 (Changing Object Attributes).

An icon marked with a small arrow can often become a floating toolbar. The floating-toolbar 
capability is common to all components of OOo.
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Toolbars

Figure 6: An arrow next to an icon indicates additional functions.

Tip If you double-click on an icon on a floating toolbar, the command corresponding to 
that icon will run. You can then repeat this action as often as you like. To exit from 
this mode, press the Esc key or click on another icon (for example ).

Note The icon of a floating toolbar always shows the last command you used. This means 
that the icon you see on your screen may differ from any icon shown in this Guide.

Similarly, click on the arrow on the title bar of a floating toolbar to display additional functions (see 
Figure 7).

Figure 7: An arrow on a floating toolbar indicates that there are additional  
functions available.

In Draw, as in all OOo components, a toolbar can move to a new position by using the mouse. Hover 
the mouse over the end of the toolbar (look for two vertical columns of dots) until the cursor 
becomes two crossed arrows and then drag-and-drop, as desired.

The tools available in the various toolbars are explained in the following sections.
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Toolbars

Standard toolbar
The Standard toolbar is the same for all OOo components and is not described in detail here.

Figure 8: Standard toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 9) lets you modify the main properties of a drawing object: the 
icons and pulldown lists vary, according to the type of object selected. For example, to change the 
thickness of a line with the spinner, hover the mouse over the spinner and click the up or down arrow 
to achieve the desired thickness.

Figure 9: Line and Filling toolbar

In the example above, the available functions enable you to change the color, style, and width of the 
line drawn or the fill color, style, and other properties of an object. The object must first be selected 
with a mouse click. If the selected object is a text frame, the buttons for line style and fill color are 
changed to Invisible.

When text is selected, the Line and Filling toolbar changes to the Text Formatting toolbar (Figure
10), which is very similar to the Formatting toolbar in Writer. A more detailed explanation of the 
buttons on this toolbar can be found in Chapter 4 (Changing Object Attributes).

Figure 10: Text Formatting toolbar

Drawing toolbar
The Drawing toolbar (Figure 11) is the most important toolbar in Draw. It contains all the necessary 
functions for drawing various geometric and freehand shapes and for organizing them on the page. It 
is described in detail in Chapter 2 (Drawing Basic Shapes).

Figure 11: Drawing toolbar

Color bar
To display the Color bar (Figure 12), use View > Toolbars > Color Bar. The toolbar then appears at 
the bottom of the workspace and displays the current color palette.

Figure 12: Color bar

This toolbar lets you rapidly choose the color of the various objects (lines, areas, and 3D effects) in 
your drawing. The first box in the panel corresponds to transparency (no color).
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Toolbars

You can access several specialized color palettes in Draw, as well as change individual colors to your 
own taste. This is done using the Area dialog, reached by choosing Format > Area, as shown in 
Figure 13, or the pouring can icon on the Line and Filling toolbar (Figure 9).

Figure 13: Two ways to display the Area dialog

On the Area dialog, choose the tab marked Colors (Figure 14).

To load another palette, click on the Load Color List button (circled). The file selector dialog asks 
you to choose one of the standard OOo palettes (files bearing the file extension *.soc). For example, 
web.soc is a color palette that is particularly adapted to creating drawings that are going to appear 
in Web pages. The colors will correctly display on workstations with screens displaying at least 256 
colors.

A more detailed description of color palettes and their options can be found in Chapter 8 (Tips and 
Tricks).
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Toolbars

.Figure 14. Changing the color palette

Options toolbar
The Options toolbar lets you activate or deactivate various drawing aids. The Options Bar is not one 
of the toolbars displayed by default. To display it, select View > Toolbars > Options.

Figure 15: Options toolbar

The most important options to learn when starting to work in Draw are enclosed in red above. Their 
functions are described in the table below. The other buttons are described in greater detail in other 
chapters of the Draw Guide.
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Toolbars

Table 1: Functions on the Options toolbar

Icon Function

Rotation Mode after Clicking Object

Display (or hide the) Grid

Display (or hide the) Guides

Display (or hide Guides) When Moving

Snap to Grid

Snap to Guides

Snap to Page Margins

Snap to Object Borders

Snap to Object Points

Allow Quick Editing

Select Text Area Only

Double-click to edit Text

Simple Handles

Large Handles

Create Object with Attributes

Picture Placeholders

Contour Mode

Text Placeholders

Line Contour Only

Exit All Groups

Drawing grid and guides
Draw offers a grid as a drawing aid. The grid can be turned on or off by clicking on the Grid icon on 
the Options toolbar. The points of the grid displayed on the screen are not shown on the printed 
drawing. The color, spacing, and resolution of the grid points can be individually chosen for each 
axis. This is described in more detail in Chapter 8 (in the section titled “Configuring the grid”).
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Toolbars

Guides are special “helper lines” that can be turned on or off by clicking on the Guides icon on the 
Options toolbar. Draw offers a “Snap” function1, with which you can place drawings exactly on these 
guides. All snap functions are described in detail in Chapter 8 (Tips and Tricks).

Showing the position of the object while moving it makes positioning the object much easier. If this 
function is activated, pairs of vertical and horizontal lines enclosing the object are shown while 
moving the object. These lines extend to the edges of the drawing area. This function is also 
described in detail in Chapter 8.

Customizing toolbars
For greater control, you can add other functions to a toolbar and move tools between toolbars. To do 
this, in the View > Toolbars menu select Customize, select the Toolbars tab (see Figure 16), select 
the toolbar you want to change, and then select the desired buttons for that toolbar. Each toolbar has 
a different list of buttons.

Figure 16: Customizing a toolbar

1 Drawing objects can be snapped—that is, they can be attached to a grid point, a guide, a page margin, or a 
border or point of another object.
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