
Writer Guide

Chapter 44
  Formatting Pages

Using Page Styles, Tables, Frames, Columns, and Sections

OpenOffice.org



Copyright
This document is Copyright © 2005–2008 by its contributors as listed in the section titled Authors. 
You may distribute it and/or modify it under the terms of either the GNU General Public License, 
version 3 or later (http://www.gnu.org/licenses/gpl.html), or the Creative Commons Attribution 
License, version 3.0 (http://creativecommons.org/licenses/by/3.0/) or later.

All trademarks within this guide belong to their legitimate owners.

Authors
Agnes Belzunce
Ken Byars
Daniel Carrera
Peter Hillier-Brook
Lou Iorio
Sigrid Kronenberger
Peter Kupfer
Ian Laurenson
Iain Roberts
Gary Schnabl
Janet Swisher
Jean Hollis Weber
Michele Zarri

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments
Portions of the section on frames are taken from an article written by Bruce Byfield and originally 
published in Linux Journal.

Publication date and software version
Published 20 May 2008. Based on OpenOffice.org 2.3.1.

You can download an editable version of this document from 
http://oooauthors.org/en/authors/userguide2/published/

mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html
http://oooauthors.org/en/authors/userguide2/published/


Contents

Contents

Copyright................................................................................................................................................i

Authors....................................................................................................................................................i

Feedback.................................................................................................................................................i

Acknowledgments...................................................................................................................................i

Publication date and software version.....................................................................................................i

Introduction.................................................................................................................................................1

Choosing a layout method...........................................................................................................................1

Setting up basic page layout using styles....................................................................................................3

Inserting a page break without switching the style.................................................................................3

Defining a different first page for a document.......................................................................................4

Changing page orientation within a document.......................................................................................6

Setting up a landscape page style......................................................................................................6

Inserting a landscape page into a portrait document..........................................................................7

Changing page margins...............................................................................................................................8

Using columns to define the page layout.....................................................................................................9

Defining the number of columns on a page............................................................................................9

Using a predefined column layout...................................................................................................10

Specifying the number of columns..................................................................................................10

Distributing text across columns.....................................................................................................10

Formatting column width and spacing............................................................................................10

Formatting separator lines...............................................................................................................11

Reverting to a single-column layout................................................................................................11

Changing the number of columns for existing text...............................................................................11

Using frames for page layout.....................................................................................................................12

Creating frames....................................................................................................................................13

Moving, resizing, and changing frame attributes.................................................................................13

Anchoring a frame................................................................................................................................15

To Page............................................................................................................................................15

To Paragraph...................................................................................................................................15

To Character....................................................................................................................................15

As Character....................................................................................................................................15

Formatting Pages i



Contents

Linking frames.....................................................................................................................................16

Using tables for page layout......................................................................................................................18

Example: Creating sideheads using tables............................................................................................18

Using sections for page layout...................................................................................................................20

Creating sections..................................................................................................................................20

Using the Section page.........................................................................................................................21

Naming sections..............................................................................................................................21

Linking sections..............................................................................................................................22

Write-protecting sections.................................................................................................................22

Password-protecting sections..........................................................................................................22

Hiding sections................................................................................................................................23

Using the Columns page.......................................................................................................................23

Using the Indents page.........................................................................................................................24

Using the Footnotes/Endnotes page......................................................................................................24

Customizing footnotes.....................................................................................................................24

Customizing endnotes.....................................................................................................................26

Using the Background page..................................................................................................................26

Saving a new section............................................................................................................................26

Editing and deleting sections................................................................................................................26

Selecting a section...........................................................................................................................26

Editing section attributes.................................................................................................................27

Deleting sections.............................................................................................................................27

Editing the format of a section........................................................................................................27

Updating links......................................................................................................................................28

Updating links automatically...........................................................................................................28

Updating links manually.................................................................................................................29

Creating headers and footers.....................................................................................................................30

Portrait headers on landscape pages.....................................................................................................30

Numbering pages.......................................................................................................................................33

Preliminaries: fields..............................................................................................................................33

Preliminaries: Inserting a header..........................................................................................................34

Formatting the header......................................................................................................................34

Simple page numbering........................................................................................................................35

Formatting Pages ii



Contents

Combining header text and page number.............................................................................................35

Changing the number format................................................................................................................36

Numbering the first page something other than 1.................................................................................36

Numbering pages by chapter................................................................................................................37

Restarting page numbering...................................................................................................................38

Example: Restart page numbering: a preface..................................................................................39

Problems with restarting page numbering............................................................................................41

Solving the page count problem......................................................................................................41

Numbering portrait and landscape pages..............................................................................................43

Formatting Pages iii





Introduction

Introduction

Writer provides several ways for you to control page layouts:

• Page styles

• Columns

• Frames

• Tables

• Sections

This chapter describes these methods and some associated things:

• Headers and footers

• Numbering pages

• Changing page margins

Tip Page layout is usually easier if you select the options to show text, object, table, and 
section boundaries in Tools > Options > OpenOffice.org > Appearance and if you 
select the options for paragraph ends, tabs, breaks, and other items in Tools > 
Options > OpenOffice.org Writer > Formatting Aids.

Choosing a layout method

The best layout method depends on what the final document should look like and what sort of 
information will be in the document. Here are some examples. Do not worry if all this does not mean 
much to you now. The techniques mentioned are all described in this chapter.

For a book similar to this user guide with one 
column of text, some figures without text beside 
them, and some other figures with descriptive 
text, use page styles for basic layout, and use 
tables to place figures beside descriptive text, 
when necessary.
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Choosing a layout method

Use page styles (with two columns) for an index 
or other document with two columns of text 
where the text continues from the left-hand 
column to the right-hand column and then to the 
next page, all in sequence (also known as 
snaking columns of text). If the title of the 
document (on the first page) is full-page width, 
put it in a single-column section.

For a newsletter with a complex layout, two or 
three columns on the page, and some articles 
that continue from one page to some place 
several pages later, use page styles for basic 
layout. Place articles in linked frames and 
anchor graphics to fixed positions on the page, 
if necessary.

For a document with terms and translations to 
appear side-by-side in what appear to be 
columns, use a table to keep items lined up  so 
you can type in both “columns”.
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Setting up basic page layout using styles

Setting up basic page layout using styles

In Writer, page styles define the basic layout of all pages, including page size, margins, the 
placement of headers and footers, borders and backgrounds, number of columns, and so on.

Writer comes with several page styles, which you can build on or modify, and you can define new 
(custom) page styles. You can have one or many page styles in a single document.

Note All pages in a Writer document are based on styles. If you do not specify a page style, 
Writer uses the Default page style.

To change the layout of individual pages, either define a new page style or use one of the techniques 
(sections, frames, or tables) described later in this chapter.

This chapter describes some uses of page styles. Some other uses are discussed in Chapter 6 
(Introduction to Styles). The Page Style dialog box is covered in detail in Chapter 7 (Working with 
Styles).

Tip Any modifications of page styles, including the Default page style, apply only to the 
document you are working on. If you want the changes to be the default for all 
documents, you need to put the changes into a template and make that template the 
default template. See Chapter 10 (Working with Templates) for details.

Inserting a page break without switching the style
In many documents (for example, a multi-page report), you may want the text to flow from one page 
to the next as you add or delete information. Writer does this automatically, unless you override the 
text flow using one of the techniques described earlier.

If you do want a page break in a particular place, for example, to put a heading at the top of a new 
page, here is how to do it:

1) Position the cursor in the paragraph you want to be at the start of the next page. Right-click 
and choose Paragraph in the pop-up menu.

2) On the Text Flow page of the Paragraph dialog box (Figure 1), in the Breaks section, check 
Insert. Do not check With Page Style.

Figure 1: Inserting a manual page break

3) Click OK to position the paragraph at the start of the next page.
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Setting up basic page layout using styles

Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other pages 
in the document. For example, the first page of a letterhead typically has a different header, as shown 
in Figure 2, or the first page of a report might have no header or footer, while the other pages do. 
With OOo, you can define the style for the first page and specify the style for the following page to 
be applied automatically.

Figure 2: Letterhead with different page styles for first and following pages

As an example, we can use the First Page and Default page styles that come with OOo. Figure 3 
shows what we want to happen: the first page is to be followed by the default page, and all the 
following pages are to be in the Default page style.

Figure 3: Flow of page styles

To set up this sequence:

1) Open the Styles and Formatting window. (You can choose one of the following: click the 

Styles and Formatting icon  located at the left-hand end of the object bar, choose 
Format > Styles and Formatting, or press F11.)

2) On the Styles and Formatting window (Figure 4), click on the Page Styles icon   (fourth 
from the left) to display a list of page styles.
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Setting up basic page layout using styles

3) Right-click on First Page and select Modify from the pop-up menu.

Figure 4: Modifying the First Page style

4) On the Organizer page of the Page Style dialog box (Figure 5), look at the Next Style 
property. This property defines what the page style for the next page will be. It should be set 
to Default, but if it is not, you can change the next style by clicking on the drop-down button 
and choosing Default from the list of page styles.

Figure 5: Setting the Next Style property for a page style

5) On the other pages of this dialog box, you can turn on or off the header and footer for the first 
page and define other characteristics, such as columns, a page border, or a page background. 
For more information, see Chapter 7 (Working with Styles).

6) Click OK to save the changes.

Note You can override the Next Style property by manually inserting a page break and 
specifying a page style or by starting a page with a paragraph or table that has its 
own page style property defined. These techniques are described in “Inserting a
landscape page into a portrait document” on page 7.
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Setting up basic page layout using styles

Changing page orientation within a document
A document can contain pages in more than one orientation. A common scenario is to have a 
landscape page in the middle of a document, whereas the other pages are in a portrait orientation. 
Here are the steps to achieve it.

Setting up a landscape page style
1) Note the page style that is current and the margin settings. (You can find the margin settings 

on the Page page of the Page Style dialog box, as shown in Figure 8.)

2) Create a new style. (Right-click on the current page style in the Styles and Formatting 
window and choose New, as shown in Figure 6.)

Figure 6: Starting a new page style

3) On the Organizer page of the Page Style dialog box (Figure 7), name (by typing in the Name 
field) this new style Landscape and set the Next Style property to Landscape (to allow for 
having more than one sequential landscape page).

Figure 7: Naming the new style and setting the next page style to Landscape

4) On the Page page of the Page Style dialog box (Figure 8), set the Orientation to Landscape. 
The width and height attributes of the page will automatically change.

5) Change the margins so that they correspond with the margins of the portrait page. That is, the 
portrait top margin becomes the landscape left margin, and so on.

6) Click OK to save the changes.
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Setting up basic page layout using styles

Figure 8: Setting orientation and margins for a landscape page

Inserting a landscape page into a portrait document
Now that you have defined the Landscape page style, here is how to apply it.

1) Position the cursor in the paragraph or table at the start of the page that is to be set to 
landscape. Right-click and choose Paragraph or Table, respectively, in the pop-up menu.

2) On the Text Flow page of the Paragraph dialog box (Figure 9) or the Table Format dialog box 
(Figure 10), select Insert (or Break for a table) and With Page Style. Set the Page Style 
property to Landscape. Click OK to close the dialog box and to apply the new page style.

3) Position the cursor in the paragraph or table where the page is to return to portrait orientation 
and change the properties of that paragraph or table properties so that With Page Style is the 
portrait page style that was used before the Landscape page style.

4) Click OK to return to the previous portrait page style.

Figure 9: Specifying a page break before a paragraph
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Setting up basic page layout using styles

Figure 10: Specifying a page break before a table

Tip If you need the headers or footers on the landscape pages to be in portrait orientation, 
see “Portrait headers on landscape pages” on page 30.

Changing page margins

You can change page margins in two ways:

• Using the page rulers—quick and easy, but does not have fine control.

• Using the Page Style dialog box—can specify margins to two (fractional) decimal places.

Note If you change the margins using the rulers, the new margins affect the page style 
and will be shown in the Page Style dialog box the next time you open it.

To change margins using the rulers:

1) The shaded sections of the rulers are the margins (see Figure 11). Put the mouse cursor over 
the line between the gray and white sections. The pointer turns into a double-headed arrow.

2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 11: Moving the margins
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Changing page margins

Tip The small arrows on the ruler are used for indenting paragraphs. They are often in the 
same place as the page margins, so you need to be careful to move the margin marker, 
not the arrows. Place the mouse pointer between the arrows and, when the pointer 
turns into a double-headed arrow, you can move the margin (the indent arrows will 
move with it).

To change margins using the Page Style dialog box (Figure 8):

1) Right-click anywhere on the page and select Page from the pop-up menu.

2) On the Page page of the dialog box, type the required distances in the Margins boxes.

Using columns to define the page layout

You can use columns for page layout in several ways:

• Define the number of columns on a page, using page styles.

• Switch between one-column and multiple-column layouts on the same page.

• Select existing text and change the number of columns.

Defining the number of columns on a page
It is a good idea to define your basic page style (such as Default) with the most common layout to be 
used in your document, either single-column or multiple-column. You can then either define extra 
page styles for pages with different numbers of columns or use sections (described in “Using
sections for page layout” starting on page 20) for pages or parts of pages with different numbers of 
columns.

To define the number of columns on a page:

1) Choose Format > Columns or go to the Columns page of the Page Style dialog box.

2) On the Columns dialog box (Figure 12), choose the number of columns and specify any 
spacing between the columns and whether you want a vertical separator line to appear 
between the columns. You can use one of Writer’s predefined column layouts, or you can 
create a customized column layout. The preview box, located to the right of the Settings area, 
shows how the column layout will look.

3) Notice the Apply to box on the right-hand side of the dialog box. In this case, the changes are 
being applied to the Default page style.

4) Click OK to save the changes.
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Using columns to define the page layout

Figure 12: Defining the number of columns on a page

Using a predefined column layout
The Settings area displays five predefined column layouts. To use one of them, click the desired 
layout.

Specifying the number of columns
If you prefer to create a customized column layout, you must specify the number of columns that you 
want. Enter the desired number in the Columns box in the Settings area.

Distributing text across columns
You can distribute text across the columns in one of two ways:

• Evenly—If you choose to distribute text evenly, Writer will fill the first line of each column, 
followed by the second line of each column, and so on.

• Newspaper-style—If you choose to distribute text newspaper-style, Writer will fill the 
columns one at a time, beginning with the first column.

To distribute text evenly, check the Evenly distribute contents to all columns check box in the 
Settings area. Clear this check box if you want to distribute text newspaper-style.

Note This check box is not always displayed in the Settings area. See “Changing the
number of columns for existing text” on page 11.

Formatting column width and spacing
To create evenly-spaced columns that are all the same width, check the AutoWidth check box in the 
Width and spacing area.

To customize the width and spacing of the columns, follow these steps:

1) In the Width and spacing area, clear the AutoWidth check box.
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Using columns to define the page layout

2) On the Width line, enter a width for each column.

3) On the Spacing line, enter the amount of space that you want between each pair of columns.

If you specify more than three columns, use the arrow keys on the Column line to scroll among the 
columns.

Formatting separator lines
To display separator lines between the columns:

1) Eighteen separator line options exist: None or various lines of thicknesses which range from 
0.05 to 9 pt). From the Line drop-down list in the Separator line area, select the type of line 
that you want. (1 pt = 1 point = 1/12 pica = 1⁄72 inch = 127⁄360 mm = 0.3527 mm.)

2) The default format is for the separator lines to have the same height as the columns. If you 
want the separator lines to be shorter than the columns, use the Height box to enter the height 
of the separator lines as a percentage of the height of the columns. For example, if you enter 
50%, the separator lines will be half as high as the columns.

3) If you entered a height of less than 100%, use the Position drop-down list to select a vertical 
alignment for the separator lines. The vertical-positioning options are: Top, Centered, or 
Bottom.

Reverting to a single-column layout
To revert to a single-column layout, go to the Settings area and either reset the number in the 
Columns box to 1 or click the single-column layout icon.

Changing the number of columns for existing text
You might want some parts of a page to have one column and other parts of the page to have two or 
more columns. For example, you might have a page-width headline over a three-column news story.

You can create columns and then type or paste text into them, or you can select some existing text 
and change the number of columns for displaying it.

When you select text and change the number of columns for that text, Writer turns the selected text 
into a section, as described in “Using sections for page layout” on page 20.

Figure 13 shows the Columns dialog box for a selection. Notice that the Apply to box on the right-
hand side has Selection highlighted and an extra check box (Evenly distribute contents to all 
columns) appears in the upper left-hand part of the dialog box.

As you add text to the section, you will see that the text flows from one column to the next so that all 
the columns adjust to the same height. If this is not what you want, click anywhere in the section, 
then choose Format > Columns to reopen the Columns dialog box, deselect the Evenly distribute 
contents to all columns check box, and click OK to effect the change.

Tip Choose View > Nonprinting Characters (or press Ctrl+F10) to display end of 
paragraph markers (¶). Often, unexpected behavior of columns is due to extra 
paragraphs that are normally invisible to the user but are taking up space.
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Using columns to define the page layout

Figure 13: Specifying columns for a selection

Using frames for page layout

Frames can be very useful when producing a newsletter or other layout-intensive documents. Frames 
can contain text, tables, multiple columns, pictures, and other objects.

Use frames when you need to:

• Position something in a particular place on a page, for example, a logo or a “stop press” news 
box in one corner of a page.

• Allow text on one page to continue on another page, somewhere more distant than the next 
one, by linking the content of one frame to another so the contents flow between them as you 
edit the text.

• Wrap text around an object, such as a photograph.

Because OpenOffice.org does not allow you to define page styles with recurring frames, consider 
doing some quick sketches of the basic page layouts you need, indicating the approximate positions 
of different frames and their purposes. Try to keep the number of different page layouts as low as 
possible in order to avoid chaos in your design.

Pay special attention to the positioning of frames. Many of the predefined styles default to a center 
alignment. This is the lowest common denominator of design; centering all frames looks reasonably 
good in most cases but is rarely the best choice.

One of the most visually effective ways to position a frame is to align its left margin with that of the 
paragraph above it. To achieve this effect, insert the frame in a blank paragraph of the same style as 
the paragraph above. Then, select Insert > Frame > Type > Position > Horizontal > From Left to 
position the frame exactly where you want it.
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Using frames for page layout

You also should think about the type of wrap and the spacing between the frame and text. Instead of 
cramming a frame close to the text, use the Wrap tab to place some white space between them.

You can format frames individually or define and apply frame styles—see Chapter 7  (Working with 
Styles).

Tip The Help uses the phrase “text frame” for two quite different things with very 
different characteristics: frames (as discussed here) and text objects, which are 
drawing objects similar to lines and boxes.

Creating frames
You can create a frame in several ways, depending on your needs.

• Choose Insert > Frame) to create an empty frame. The Frame dialog box (Figure 15) 
appears. You can click OK and come back to customize it later, or you can set the frame’s 
characteristics at this stage.

• Select text or a graphic, choose Insert > Frame, and click OK to create a frame containing 
the selection. The selected text is automatically deleted from the normal text flow and 
inserted into the frame, and the Frame dialog box appears.

• Insert a picture or other object by selecting Insert > Picture > From file or Insert > Object 
to start the process to insert a picture or object. The item inserted automatically appears in a 
frame, but the Frame dialog box does not appear.

• Use the Insert Frame Manually icon on the Insert toolbar (go to View > Toolbars > Insert 
to display it), select the number of frames in the drop-down menu, and drag the mouse to 
draw the frame.

Figure 14: Using an icon on the Insert toolbar to create a frame

When you release the mouse button, a box appears where the cursor is 
located in the document. This box represents the frame: an area isolated 
from the main document.

To add content to a frame, first deselect the frame by clicking somewhere 
else on the page. Then, click inside the frame so that the cursor shifts its focus there. Now add 
content just like you would on the main page. When you are done, deselect the frame.

Moving, resizing, and changing frame attributes
When an object is added to Writer, it is automatically enclosed in a frame of a predetermined type. 
The frame sets how the object is placed on the page, as well as how it interacts with other elements 

Formatting Pages 13



Using frames for page layout

in the document. You can edit the frame by modifying the frame style it uses or by using a manual 
override when a frame is added to the document. Frame styles are discussed in Chapter 7 (Working 
with Styles).

To change the size or location of a frame, first select the frame, then use either the mouse or the 
Frame dialog box (Figure 15). Using the mouse is faster but less accurate. You might use the mouse 
for gross layout and the dialog box for fine-tuning.

You can resize the frame manually (by clicking on the green squares and dragging to the appropriate 
size) or start adding content to it (the frame will resize automatically if you, for example, add a large 
picture to it) or go back to the Frame dialog box and set the size and other characteristics.

To change the location of the frame using the mouse, drag and drop one of the edges or having the 
cursor anywhere within the frame. (The I-bar cursor changes to a four-headed arrow when properly 
positioned for a drag-and-drop move.) To change the size of the frame, drag one of the handles. Drag 
a handle on one of the sides to enlarge or reduce the text frame in one dimension only; drag a corner 
handle to enlarge or reduce it in both dimensions.

These resizing actions distort the proportions of the frame. Holding down the Shift key while 
dragging one of the handles makes the frame keep the same proportions.

You can open the Frame dialog box (Figure 15) at any time by selecting the frame, right-clicking, 
and choosing Frame from the pop-up menu.

Figure 15: Frame dialog box

To remove the default border on a newly created frame, open the Frame dialog box, go to the 
Borders page, and under Line Style, select None. Alternatively, you can assign a borderless frame 
style to the frame; see the Chapter 7 (Working with Styles) for information on frame styles.
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Using frames for page layout

Tip Do not confuse a frame’s border with the text boundaries that are made visible 
using the View menu (by checking View > Text Boundaries).

Figure 16: Removing the border from a frame

Anchoring a frame
Using the Frame dialog box (or by right-clicking and pointing to Anchor), you can anchor a frame to 
a page, paragraph, or character, or you can anchor it as a character.

To Page
The frame keeps the same position in relation to the page margins. It does not move as you add or 
delete text. This method is useful when the frame does not need to be visually associated with a 
particular piece of text. It is often used when producing newsletters or other documents that are very 
layout-intensive.

To Paragraph
The frame is associated with a paragraph and moves with the paragraph. It may be placed in the 
margin or another location. This method is useful as an alternative to a table for placing icons beside 
paragraphs.

To Character
The frame is associated with a character but is not in the text sequence. It moves with the paragraph 
but may be placed in the margin or another location. This method is similar to anchoring to a 
paragraph.

As Character
The frame is placed in the document like any other character and, therefore, affects the height of the 
text line and the line break. The frame moves with the paragraph as you add or delete text before the 
paragraph. This method is useful for adding a small icon in sequence in a sentence. It is also the best 
method for anchoring a graphic to an empty paragraph so it does not move around the page in 
unexpected ways.
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Linking frames
You can link several frames to each other even when they are on different pages of a document. The 
contents will automatically flow from one to the next. This technique is very useful when designing 
newsletters, where articles may need to be continued on a different page.

To link one frame to another:

1) Select the frame to be linked from.

2) Click the Link Frames icon  on the object bar.

3) Click the next frame in the series (which must be empty).

When a linked frame is selected, any existing links are indicated by a faint connecting line, as shown 
in Figure 17. Note that any frame-linking line will not be as clear as illustrated in the figure.

Figure 17: Linked frames

Note You cannot link from a frame to more than one other frame.

The height of a frame that is being linked from is fixed; you can change this height manually or by 
using the Frame dialog box, but it does not automatically adjust to the size of the contents (that is, 
the AutoHeight attribute is disabled). Only the last frame of a chain can adapt its height to the 
content.

The Options page of the Frame dialog box (Figure 18) shows the names of the selected frame and 
any frames it is linked to or from. You can change this information here. On this page, you can also 
select check boxes to protect the contents, position, and size of the frame.
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Figure 18: Options page of the Frame dialog box

On the Hyperlink page (Figure 19), you can specify the file for the hyperlink to open. This file can be 
on your machine, a network, or the Internet.

Figure 19: Hyperlink page of the Frame dialog box

The Wrap, Borders, Background, Columns, and Macro pages of the Frame dialog box are the same as 
those for frame styles. Refer to the Chapter 7 (Working with Styles) for details.
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Using tables for page layout

Using tables for page layout

Writer’s tables can serve several purposes, such as holding data as you might see it in a spreadsheet, 
lining up material, and creating more complex page layouts. For information about using tables of 
data, see Chapter 9 (Working with Tables).

This topic describes how to achieve some common layouts by using tables.

Example: Creating sideheads using tables
Sideheads and marginal notes are commonly used in documents from resumes to computer user 
guides. The main body of the text is offset to leave white space (usually on the left-hand side) in 
which the sideheads or notes are placed. The first paragraph is aligned beside the sidehead, as in 
Figure 20.

Example of a 
sidehead

In some cases you may want to put only one or two paragraphs in the table 
itself and the rest of the text and graphics in ordinary paragraphs (formatted to 
line up with the paragraphs in the table) so that text and graphics will flow 
more easily from one page to another when you add or delete material.

In other cases, you might put each paragraph in a separate row of the table and 
allow the table to break between pages.

Figure 20: Example of a sidehead

Note Sideheads can also be created by placing text in a frame using the Marginalia frame 
style, as described in the Chapter 7 (Working with Styles).

To create a table for use with a sidehead:

1) Place the cursor where you want the table to appear and choose Insert > Table (Ctrl+F12).

2) In the Insert Table dialog box (Figure 21), define a one-row, two-column table with no border 
and no heading. Click OK to create the table.

Figure 21: Defining a two-column borderless table with no header
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Using tables for page layout

3) Position the cursor over the central dividing line in the table. The cursor turns into a double-
headed arrow. Left-click and drag to resize the columns. Alternatively, right-click and choose 
Table from the pop-up menu; on the Columns page (Figure 22), make the columns the 
required width.

Figure 22: Defining a two-column table to line up with text offset at 1.2 inches

4) On the Table page of the Table Format dialog box (Figure 23), in the Spacing section, make 
the Above and Below values the same as the Top and Bottom spacing you have defined for 
ordinary paragraphs of text. Click OK to save your settings.

Figure 23: Defining the space above and below a table

Tip To check the top and bottom spacing for ordinary paragraphs:

1. Position the cursor in a paragraph and press F11 (unless the Styles and 
Formatting window is already open). Check that the Styles and Formatting 
window shows paragraph styles (top left button).

2. The current style should be highlighted. If no paragraph style is highlighted, 
select All Styles in the bottom drop-down list. Right-click on it and select 
Modify from the pop-up list.

3. Go to the Indents & Spacing page and look in the Spacing area for the values 
in   Above paragraph and Below paragraph.
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You may also want to turn off number recognition so that Writer will not try to format numbers if 
you want them to be plain text. To turn number recognition off:

1) Right-click in the table and then click Number Format on the pop-up menu.

2) On the Number Format dialog box (Figure 24), make sure the Category is set to Text. Click 
OK.

Figure 24: Setting number format to Text

Tip If you use this table format often, you may want to save it as AutoText, as described 
in Chapter 3 (Working with Text). Select the table (not just the contents) to assign 
the shortcut.

Using sections for page layout

A section is a block of text that has special attributes and formatting. You can use sections to:

• Write-protect text

• Hide text

• Dynamically insert the contents of another document

• Add columns, margin indents, a background color, or a background graphic to a portion of 
your document

• Customize the footnotes and endnotes for a portion of your document

Creating sections
To create a section:

1) Place the cursor at the point in your document where you want to insert the new section. Or, 
select the text that you want to place in the new section.

2) From the main menu, choose Insert > Section. The Insert Section dialog box opens.

3) Click the Section tab, if it is not already displayed. (See Figure 25.)
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The Insert Section dialog box has five tabbed pages:

• Use the Section page to set the section’s attributes.

• Use the Columns page to format the section into columns.

• Use the Indents page to set indents in the right and left margins of the section.

• Use the Background page to add color or a graphic to the section’s background.

• Use the Footnotes/Endnotes page to customize the section’s footnotes and endnotes.

At any time, you can reset a tabbed page to its default settings by clicking the Reset button. (Note, 
however, that you cannot reset the Section page. If you wish to undo changes to the Section page, 
you must do so manually.)

Using the Section page
Use the Section page (Figure 25) to set the attributes of the current section.

Naming sections
Writer automatically enters a name for the current section in the top box of the New section area. To 
change the name, select it and type over it. The name is displayed in the Sections category of the 
Navigator window. If you give your sections meaningful names, you can navigate to them more 
easily.

Figure 25: Inserting a section using the Insert Section dialog box
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Linking sections

You can insert the contents of another document into the current section and then have Writer 
update the section whenever the other document is updated. This is called linking the section 
to the other document.

To link the current section to another document, follow these steps:

1) In the Link area (see Figure 26), check the Link check box.

Figure 26: Linking sections

2) Click the (...) button to the right of the File name field. The Insert dialog box opens.

3) Find and select the document you want to insert and then click the Insert button. The Insert 
dialog box closes and the name of the selected document appears in the File name field.

4) If you want to insert only a section of the selected document, select the desired section from 
the Section drop-down list.

Note The section must already exist in the selected document. You cannot create a 
section in the selected document at this point.

You can update links automatically or manually. See “Updating links” on page 28.

Write-protecting sections
To write-protect the current section so that its contents cannot be edited, check the Protect check box 
in the Write protection area ( Figure 28).

Figure 27: Write-protecting sections

Note Write-protection protects only the section’s contents, not its attributes or format.

Password-protecting sections

To prevent others from editing the section’s attributes or format, protect the section with a password, 
as follows:

1) Check the With password check box. The Enter Password dialog box (Figure 28) opens.

2) Type a password in the Password field and then confirm the password by typing it again in 
the Confirm field.
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3) Click OK. The Enter Password dialog box closes. Anyone who tries to edit the section’s 
attributes or format will be prompted to enter the password.

Figure 28: Password-protecting a section

Note Passwords must contain at least five characters. The OK button remains inactive 
until you have typed five characters.

Hiding sections

You can hide the current section so that it will not be displayed on the screen or printed. You can also 
specify conditions for hiding the section. For example, you can hide the section only from certain 
users.

Note You cannot hide a section if it is the only content on the page or if the section is in a 
header, footer, footnote, endnote, frame, or table cell.

To hide a section, check the Hide check box in the Hide area (Figure 29).

Figure 29: Hiding sections

To hide the section only under certain conditions, enter the desired conditions in the With Condition 
field. The syntax and operators that you use to enter conditions are the same ones that you use to 
enter formulas. For syntax and a list of operators, see Writer’s online help under “conditions”.

If the section is write-protected with a password, the password must be entered to hide or reveal the 
text.

Note Hiding text is not a secure way to stop someone else reading it. It will stop the 
casual reader but will not prevent someone who actively wants to find out what you 
have hidden―even if it is password protected.

Using the Columns page
Use the Columns page of the Insert Section dialog box to format the current section into columns. 
This page is very similar to the Columns dialog box shown in Figure 13 on page 12. Please refer to 
that topic for details.
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Using the Indents page
Use the Indents page, pictured in Figure 30, to set indents in the right and left margins of the current 
section. Enter the desired left-margin indent in the Before section box. Enter the desired right-margin 
indent in the After section box. The preview box on the right-hand side of the page shows you how 
the section will look with the indents applied.

Figure 30: Indenting sections

Using the Footnotes/Endnotes page
Use the Footnotes/Endnotes page, pictured in Figure 31, to customize the current section’s footnotes 
and endnotes.

Customizing footnotes

If you want the current section’s footnotes to appear separately from the other footnotes in the 
document, check the Collect at end of text check box in the Footnotes area.

To number the current section’s footnotes separately from the other footnotes in the document, 
follow these steps:

1) In the Footnotes area, make sure that the Collect at end of text check box is checked.

2) Check the Restart numbering check box.

3) If you want the section’s footnotes to start at a number other than 1, enter the desired starting 
number in the Start at spin box.
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Figure 31: Setting footnotes and endnotes for sections

To edit the format of the section’s footnotes, follow these steps:

1) In the Footnotes area, make sure that the Collect at end of text and Restart numbering 
check boxes are checked.

2) Check the Custom format check box.

3) From the drop-down list under and to the right of the Custom format check box, select a 
numbering format for the footnotes.

4) To add text to the selected numbering format, use the Before and After fields. For example, if 
you want the footnote numbers to be preceded by the word “Note” and followed by a colon, 
fill the Before and After fields like this:

Figure 32: Numbering footnotes for sections
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Customizing endnotes

If you want the current section’s endnotes to appear at the end of the section rather than at the end of 
the document, check the Collect at end of section check box in the Endnotes area.

To number the current section’s endnotes separately from the other endnotes in the document, follow 
these steps:

1) In the Endnotes area, make sure that the Collect at end of section check box is checked.

2) Check the Restart numbering check box.

3) If you want the section’s endnotes to start at a number other than 1, enter the desired starting 
number in the Start at spin box.

To edit the format of the section’s endnotes, follow these steps:

1) In the Endnotes area, make sure that the Collect at end of section and Restart numbering 
check boxes are checked.

2) Check the Custom format check box.

3) From the drop-down list under and to the right of the Custom format check box, select a 
numbering format for the endnotes.

4) To add text to the selected numbering format, use the Before and After fields, as shown above 
for footnotes (Figure 32).

Using the Background page
Use the Background page to add color or a graphic to the background of the current section. This 
page is similar to the Background pages for paragraphs, frames, tables, and other objects in OOo. For 
more information, refer to Chapter 7 (Working with Styles).

Saving a new section
To save a new section so that it appears in your document, click the Insert button. The Insert Section 
dialog box closes and the new section appears in your document.

Editing and deleting sections
You can edit a section’s attributes and formatting, and you can also delete sections.

Selecting a section
To select the section that you want to edit or delete, follow these steps:

1) From the main menu, choose Format > Sections. The Edit Sections dialog box (Figure 33) 
opens.

2) The name of the current section appears in the Section area, in the field above the list box. If 
you want to edit or delete a different section, click the name of the desired section in the list. 
The selected section becomes the current section, and its name appears in the field above the 
list box.
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Figure 33: Edit Sections dialog box

Editing section attributes
To rename the current section, simply type over its name in the Section area.

From the Edit Sections dialog box, you can also edit the current section’s link, write-protect, and 
hide attributes. To learn how to edit these attributes, see:

“Linking sections” on page 22.

“Write-protecting sections” on page 22.

“Hiding sections” on page 23.

Deleting sections
To delete the current section, click the Remove button.

Note Writer will not prompt you to confirm the delete! To undo a delete, click the Cancel 
button.

Editing the format of a section

To edit the format of the current section, click the Options button. The Options dialog box (Figure
34) opens.

The Options dialog box has four tabbed pages: Columns, Indents, Background, and 
Footnotes/Endnotes. To learn how to use these pages, see:

“Using the Columns page” on page 23.

“Using the Indents page” on page 24.

“Using the Background page” on page 26.

“Using the Footnotes/Endnotes page” on page 24.
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To reset a page to its most recently saved settings, click the Reset button.

To save your Options settings and return to the Edit Sections dialog box, click OK.

Figure 34. Options dialog box for sections

Updating links
You can have Writer update linked sections automatically, and you can also update links manually.

Updating links automatically
The default behavior, whenever you open a document that contains links, is for Writer to prompt you 
to update the links. To have Writer update links without prompting you or to turn off automatic 
updating, follow these steps:

1) Choose Tools > Options > OpenOffice.org Writer > General. The dialog box displays 
general text document settings.

2) In the Update area (Figure 35), under Update links when loading, select one of the following 
three options:
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Figure 35: Writer > General options settings

• Select Always if you want Writer to update links automatically, without prompting you, 
whenever you open a document that contains links.

• Select On request if you want Writer to prompt you before updating links.

• Select Never if you do not want Writer to update links.

3) Click OK to save your settings. The Options dialog box closes.

Updating links manually
To update a link manually:

1) Open the document that contains the link.

2) Choose Edit > Links. The Edit Links dialog box opens. (See Figure 36.)

3) The list in the Edit Links dialog box displays the names of all the files that are linked to the 
current document. Click the file that corresponds to the link that you want to update.

4) Click the Update button. The most recently saved contents of the linked file appear in the 
current document.

5) To close the Edit Links dialog box, click Close.

Figure 36: Edit Links dialog box
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Creating headers and footers

Headers are portions of a document that always appear at the top of a page; footers appear at the 
bottom of a page. Typically, headers display the title or chapter name of a document. To insert a 
header, choose Insert > Header. Similarly, to insert a footer, choose Footer.

Figure 37: Inserting headers and footers

Depending on which option you choose, an area will appear at the top or bottom of the page where 
you can enter text. This text will appear at the top or bottom of every page.

Items such as document titles, chapter titles, and page numbers, which often go into headers and 
footers, are best added as fields. That way, if something changes, the headers and footers are all 
updated automatically.

Fields are covered in Chapter 14 (Working with Fields), but one example here may be useful. To 
insert the document title into the header:

1) Select File > Properties > Description, enter a title for your document in the Title area, and 
click OK to close the dialog box.

2) Add a header (Insert > Header > Default).

3) Place the cursor in the header part of the page.

4) Select Insert > Fields > Title. The title should appear on a gray background (which does not 
show when printed and can be turned off).

5) To change the title for the whole document, choose File > Properties > Description.

Portrait headers on landscape pages
When you define a header and footer on a landscape page, they will be aligned with the long side of 
the page. If your landscape pages are going to be inserted between portrait pages, you might want the 
headers and footers to be on the short sides of the landscape pages, so the final printed product looks 
like the contents of the landscape pages have been rotated 90 degrees on portrait pages.

You can set up portrait headers and footers on landscape pages by using a trick involving frames. 
These are a bit tedious to set up, but once you have done so, you can copy and paste them to other 
landscape pages. There does not appear to be a way to make this part of the landscape page style.
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To set up portrait headers and footers on landscape pages:

1) Calculate the required margins so the text area of the landscape page is the same size as the 
text area on the portrait pages, taking into account the space for headers and footers on the 
portrait pages. For example, this book uses the margins shown in the following table. The 
landscape right and left margins are 1 cm larger than the portrait top and bottom margins, 
respectively. This difference accounts for the extra space used by the portrait header and 
footer (0.5 cm for the height of the header or footer and a 0.5 cm gap between the header or 
footer and the main text).

Portrait page (right page) Landscape page (right page)

Top margin 1.5 cm Right margin 2.5 cm

Bottom margin 1.5 cm Left margin 2.5 cm

Left (inner) margin 2.8 cm Top margin 2.8 cm

Right (outer) margin 1.8 cm Bottom margin 1.8 cm

2) Create the landscape page style.

3) Measure the distance from the upper and left edges of the page to the upper left-hand corner 
of the space where you want the footer to appear. Measure the width and length of the space 
the footer will occupy (to match footers on portrait pages). See Figure 38.

Figure 38: Measuring the location and size of the footer frame

4) In a blank paragraph in the text, type the footer text or insert fields such as the page number 
or the chapter number and name—to match the footer text and fields on the portrait pages. 
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Assign the Footer style to this paragraph so the typeface, font size, and tab settings match 
those of the footers on the portrait pages.

5) Select the text (including the fields) you just entered. Choose Format > Character. On the 
Character dialog box, choose the Position tab (Figure 39) and set Rotation /  Scaling to 270 
degrees (counterclockwise). Click OK.

Figure 39: Rotating the footer text 270 degrees counterclockwise

6) With the text still selected, choose Insert > Frame. In the Frame dialog box, choose the Type 
tab (Figure 40) and enter the width, height, and horizontal and vertical position for the footer.

Figure 40: Defining the size and position of the footer frame
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7) If your footer has a line above the text, as in this book, on the Borders page (Figure 41), select 
a right border and specify the line width and spacing to the frame’s contents.

Figure 41: Specifying the border position, line width, and spacing to contents

8) Click OK to save these settings. The footer should now appear in the required position and 
orientation.

Repeat these steps (using appropriate measurements) to set up a portrait header on the landscape 
page.

Numbering pages

This section will describe techniques to insert page numbers and related information in a document. 
Some basic knowledge of the page styles, which are fully described in chapters 6 and 7 may be 
needed to follow some of the examples given. 

Preliminaries: fields
OpenOffice.org uses a feature called fields to manage page numbers. To insert a page number field, 
position the cursor where you want to insert the number and choose Insert > Fields > Page 
Number. The page number appears with a gray background. The gray background denotes a field.

Note The gray background is simply there to denote a field. This background is not 
printed. Choose View > Field Shadings (or press Ctrl+F8) to turn this feature off.

If you have seen lists in OOo, you might have noticed this gray background. OOo lists use fields. 
The page number field always displays the page number for the page where it is placed. If you see 
the words “Page number” instead of a number, press Ctrl+F9. This shortcut key toggles OOo 
between displaying the field’s contents (what the field is for) and the field’s results (what the field 
creates).

Note For a full introduction to fields, see Chapter 14, “Working with Fields”.
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Preliminaries: Inserting a header
As page numbers are usually contained in headers or footers, this section explains how to insert a 
header on a page. Inserting a footer requires an identical procedure. 

In OOo, headers are specified by page styles therefore when inserted all the pages with the same 
page style will display the same header. Chapter 7 describes how to format a header as part of the 
page style formatting. For the purpose of this example we will insert a header in the Default page 
style pages using manual formatting:

1) Select from the main menu Insert > Header > [Page Style]. 

2) The submenu contains as many entries as page styles used in your document. In addition the 
submenu will include the value All. If selected headers will be activated on all the pages of 
the document.

3) For our example, select the Default menu item to activate the headers only on the pages that 
use the Default page style. 

At this point you should see the (empty) header on the current page, as in Figure 42.

Figure 42. A page with a page header

What’s so special about headers? The same text in the header appears on all pages with that page 
style. (You can experience this yourself by entering some text into the header.) This property of 
headers (or footers), along with fields, forms the basis of OOo page numbering.

Caution The Insert Menu can also be used for deleting a preexisting header or footer for a 
page style. If that page style has a check mark in front of it, pointing to it will open 
an OOo dialog box warning about this and asking whether you want to delete the 
header or footer for that particular page style.

Formatting the header
In OpenOffice.org a header is considered a paragraph and therefore besides adding any text , fields, 
cross references you like, you can format the header text using the same techniques you use for 
formatting text in the main body of the document. 

Tip You can define a style for headers so that you can quickly obtain a consistent 
formatting in case you use several page styles. OpenOffice.org includes three 
predefined header styles, a generic one, one for left pages and one for right pages.
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Simple page numbering
The simplest case is to have the page number at the top of every page and nothing more. To do this, 
put the cursor on the header and select Insert > Fields > Page Number (Figure 43). Now, the correct 
page number appears on every page.

Figure 43. Page number inserted in the header

Combining header text and page number
There are a lot of interesting variations that you can apply without further knowledge of page styles. 
Here are some suggestions:

• Right-align the header to make the page number appear on the top-right:

• Add (type) the word page so the header reads page 1, page 2, and so on. This also requires 
using the Page Number field, discussed earlier (page 33).

• Add the document title so the header reads, for example: Peter's favourite poems, left 
justified, and page x with right justification, where x is the value of the Page Number field. 
Consider using a (right aligned) tab to separate the title from the page number.

• OOo also has a Page Count field (Insert > Fields > Page Count). Using it, you could, for 
example, have a header that reads page 2 of 12.

These variations are all illustrated in Figure 44.

Figure 44. Variations on the simple page numbering method
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Changing the number format
Many more variations are possible. For example, you can set the page number to display in Roman 
numerals. To do that you could double click on the page number and select the desired format, 
however it is a better choice to specify the format of numbers in the page style as explained here. In 
the Styles and Formatting dialog (press F11 if not already displayed) select the Page Styles icon and 
right-click on the highlighted entry for the current style: select Modify... which brings up the Page 
Style dialog.

On the Page page of the Page Style dialog box, in the Layout settings section (Figure 45), select 
i, ii, iii, ... from the Format drop-down list.

Figure 45: Changing format of page numbers

Numbering the first page something other than 1
Sometimes you may want to start a document with a page number greater than 1. For example, you 
may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but 
Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Follow these instructions to start the page numbering in a document at a number greater than 1. 
(These instructions are for a page number in a footer, but you could use a header instead.)

Tip Do not set a starting page number that is an even number because you will end up 
with a blank page before the first page when you print the file or export it as a PDF.

1) Choose Insert > Footer > [page style] to activate the footer. (If the page style is already 
checked in the Footer menu, point to it and click OK in the OpenOffice.org 2.0 dialog box 
that appears. Then point to that page style again to select it.)

2) The cursor is now in the footer. To insert the page number, choose Insert > Fields > Page 
Number. The page number will be 1.

3) Click in the first paragraph in the text area or type a paragraph of text.

4) Choose Format > Paragraph (or right-click and choose Paragraph from the pop-up menu) 
to display the Paragraph dialog box.

5) On the Text Flow page, in the Breaks section, select Insert and select Page in the Type drop-
down list. Select With Page Style and the page style you are using for the first page of the 
document.

6) The Page number field is now active. Type the page number you want to start with. Click OK 
to close the Paragraph dialog box.
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Numbering pages by chapter
Technical documents often include the chapter number with the page number in the header or footer. 
For example, 1-1, 1-2, 1-3, ...; 2-1, 2-2, 2-3, ...

To set up this type of page numbering in OOo, you need to do three things:

1) Ensure that your chapter titles are all identified by the same paragraph style, for example, the 
Heading1 style. 

2) Use Tools > Outline Numbering to tell OOo what paragraph style you are using for Level 1 
in your outline, and specify “1,2,3” in the Number box. (See Figure 46.)

Figure 46: Specifying paragraph style and numbering for chapter titles

3) Insert the chapter number in your document. To do this:

a) Place the cursor in the header or footer just before the page number you inserted earlier, 
and choose Insert > Fields > Other from the menu bar. 

b) On the Fields dialog (Figure 47), go to the Document page. Select Chapter in the Type 
list, Chapter number in the Format list, and 1 in the Layer box. Click Insert. 

c) Type a hyphen or other punctuation between the chapter number and the page number.

For more information, see “Choosing paragraph styles for outline levels” and “Including chapter or 
section information in page headers” in Chapter 7 (Working with Styles).
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Figure 47: Inserting a chapter number field

Restarting page numbering
Often you will want to restart the page numbering at 1, for example, on the page following a title 
page or a table of contents. In addition, many documents have the front matter (such as the table of 
contents) numbered with Roman numerals and the main body of the document numbered in Arabic 
numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:

1) Place the cursor in the first paragraph of the new page.

2) Choose Format > Paragraph.

3) On the Text Flow page of the Paragraph dialog box ( on page ), check Insert in the Breaks 
area.

4) In the Type drop-down list, select Page.

5) In the Position drop-down list, select Before or After to position where you want to insert the 
page break.

6) Check With Page Style and specify the page style to use.

7) Specify the page number to start from and then click OK.
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Method 2:

1) Place the cursor in the first paragraph of the new page.

2) Choose Insert > Manual break.

3) Page break is the default selected on the Insert Break dialog box (Figure 48).

Figure 48: Restarting page numbering after a manual page break

4) Choose the required page in the Style drop-down list.

5) Check Change page number.

6) Specify the page number to start from and then click OK.

Example: Restart page numbering: a preface
A standard preface has the following properties:

• Page numbers are displayed in Roman numerals (i, ii, iii, iv, …).

• After the preface, the document starts on a Default page.

• The page number resets to 1, and the number format becomes Arabic (1, 2, 3, 4, …).

Resetting the page number requires page breaks.

First, let’s get the preliminary work done for the Preface style:

1) Create a new page style and name it Preface.

2) Set its Next Style to Preface because a preface could span multiple pages.

3) Add a header to Preface and insert the Page Number field. Make the page numbers display as 
Roman numerals (i, ii, iii, iv, …):

a) Open the page style window for Preface (if not already open) and click the Header tab. 
Check Header on under Header.

b) Click the Page tab. Under Layout settings, in the Format drop-down list, set the format to 
i, ii, iii, …. (See Figure 49.) Click OK to close the dialog box.
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Figure 49. Set page number format to Roman numerals.

After the preface is written, we are ready to restart the page numbering in the main body of the 
document to Arabic numerals. Follow these steps:

1) Make an empty paragraph at the very end of the preface.

2) Put the cursor on the blank line.

3) Choose Insert > Manual Break.

4) Select Page break and choose the Default style.

5) Select the Change page number check box and set the new value to 1. Click OK to close the 
dialog box.

These settings are shown in Figure 50.

Figure 50. Set the new page number to 1 and the page style to Default.

Note You cannot assign an odd page number to a left page or an even page number to a 
right page. OOo strongly adheres to the convention that odd page numbers go on 
right-hand pages and even page numbers on left-hand pages.
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This change is also reflected on the status bar. The Page section of the status bar now includes both 
the total page count and the entry of the page number field (Figure 51).

Figure 51. Page number in the status bar

Problems with restarting page numbering
Restarting page numbering may lead to two problems.

• The Statistics page in the document’s Properties (File > Properties) always displays the total 
number of pages in the document, which may not be what you want to appear in the Page 
Count field.

• When page numbering is restarted, OOo always make sure that an odd-numbered page is a 
right page and an even-numbered page is a left page. It does this by inserting a blank page, if 
necessary. Sometimes this blank page is not desired, particularly when creating PDFs or when 
printing single sided.

Solving the page count problem
Suppose you know exactly how many pages are not to be included in the page count. (You want one 
page to be excluded in the page count for the following example.)

Instead of inserting a Page Count field, you can do the following:

1) Position the cursor where you want the page count to appear.

2) Press F2 to open the formula bar, just above the horizontal ruler in the main Writer window 
(see Figure 52).

3) After the equal sign, type page –1. If you want to exclude multiple pages, substitute the 
number of excluded pages for 1 in the formula.

4) Press Enter to close the formula bar and insert the resulting field into the document.

Figure 52: Formula bar

If you do not know the total number of pages in advance, then one approach is to create a set 
reference on the last page and then insert a cross reference to it. Refer to Chapter 14 (Working with 
Fields) for more information on setting references and inserting cross references.)

To create a set reference on the last page:

1) Go to the last page (Ctrl+End).
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2) Choose Insert > Cross-reference.

3) On the References page of the Fields dialog box (Figure 53), select Set Reference in the Type 
column.

Figure 53: Setting a reference on the last page of the document

4) In the Name box, enter LastPage.

5) Click Insert. LastPage is now listed in the Selection column.

To insert a cross-reference to the last page in the header or footer where you want to refer to the total 
number of pages:

1) Position the cursor at the desired location—for example after the space added after of in the 
header or footer, as in page xx of yy.

2) Choose Insert > Cross-reference.

3) On the References page of the Fields dialog box (Figure 54), select Insert Reference in the 
Type column and LastPage in the Selection column. LastPage now appears in the Name box.

4) In the Format column, select As page style. Click Insert.

Notes Do not delete the reference set at the end of the document. If you do, the cross-
reference will not work.

If a field, such as a cross-reference, does not automatically update, select the text 
containing the field and press F9.
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Figure 54: Inserting a cross-reference to the last page of a document

Numbering portrait and landscape pages
To create page numbers on portrait and landscape pages in the same place and orientation:

1) Refer to “Portrait headers on landscape pages” on page 30 to create a landscape page style 
and landscape header or footer styles. When creating the page style, check the Use dynamic 
spacing check box in the Spacing area in the Header or Footer pages of the Page Style dialog 
box.

2) Insert the page break and choose the landscape page style; do not change the page 
numbering.

3) In the relevant header or footer, insert the page number field (Insert > Fields > Page 
Number).
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