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What is Writer?

What is Writer?

Writer is the word processor component of OpenOffice.org (OOo). In addition to the usual features 
of a word processor (spell checking, thesaurus, hyphenation, autocorrect, find and replace, automatic 
generation of tables of contents and indexes, mail merge and others), Writer provides these important 
features:

• Templates and styles

• Powerful page layout methods, including frames, columns, and tables

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents

• Change tracking during revisions

• Database integration, including a bibliography database

• Export to PDF, including bookmarks

• And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 1. The menus and toolbars are described in 
Chapter 4 (Menus and Toolbars).

Other features of the Writer interface are covered in this chapter.

Figure 1: The main Writer workspace in Print Layout view
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Changing document views

Changing document views

Writer has several ways to view a document: Print Layout, Web Layout, Full Screen, and Zoom. To 
access these choices, go to the View menu. The only document view option with a submenu is Zoom.

Creating a new document

You can create a new, blank document in Writer in several ways:

• Press the Control+N keys. A new empty document opens. If you already have a document 
open, the new document appears in a new window.

• Use File > New > Text Document. The result is the same as pressing the Control+N keys.

• Click the New button on the main toolbar .

Creating a document from a template
You can use templates to create new documents in Writer. Templates serve as the foundation of a 
series of documents, making sure they all have a similar layout. For example, all the documents of 
this User Guide are based on the same template. By doing this, all the documents look alike; they 
have the same headers and footers, use the same fonts, and so on.

A new OpenOffice.org installation does not contain many templates, but you can add new templates 
to your installation and use them for new documents. This is explained in Chapter 12 (Working with 
Templates).  Many more templates can be downloaded from 
http://extensions.services.openoffice.org/ and other websites.

Once you have templates on your system, you can create new documents based on them by using 
File > New > Templates and Documents. This opens a window where you can choose the template 
you want to use for your document.

The example shown in Figure 2 uses a template called “Book” in the My Templates folder. Select it, 
then click Open. A new document is created based on the formats defined in the template.

Getting Started with Writer 2
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Creating a new document

Figure 2. Creating a document from a template

Saving a document

Save Writer documents the same way you save other documents. For more information, see Chapter 
3 (File Management in OpenOffice.org).

Saving as a Microsoft Word document
You may need to share your documents with other people who do not use OOo, but use Microsoft 
Word instead. Fortunately, OOo can read and write Word files (but not Word 2007; that capability is 
coming in OOo 3.0). To save a document as a Microsoft Word file:

1) First save your document in OOo’s format (.odt). If you do not, any changes you made since 
the last time you saved will only appear in the Microsoft Word version of the document.

2) Then click File > Save As. The Save As window (Figure 3) appears.

3) In the Save as type drop-down menu, select the type of Word format you need.

4) Click Save.

From this point on, all changes you make to the document will occur only in the Microsoft Word 
document. You have actually changed the name of your document. If you want to go back to working 
with the OOo version of your document, you must open it again.
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Saving a document

Tip To have OOo save documents by default in the Microsoft Word file format, go to 
Tools > Options > Load/Save. In the section named Default file format, under 
Document Type, select Text Document, then under Always save as, select the 
preferred file format.  See also “Choosing options for loading and saving 
documents” in Chapter 5 (Setting up OpenOffice.org).

Figure 3. Saving a file in Microsoft Word format

Working with text
Working with text (selecting, copying, pasting, moving) in Writer is similar to working with 
text in any other program. OOo also has some convenient ways to select items that are not 
next to each other, select a vertical block of text, move paragraphs quickly, and paste 
unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 4) using the mouse:

1) Select the first piece of text.

2) Hold down the Control key and use the mouse to select the next piece of text.

3) Repeat as often as needed.

4) Now you can work with the selected text (copy it, delete it, change the style, or whatever).
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Working with text

Note Macintosh users: substitute the Command key when instructions in this chapter say 
to use the Control key.

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the 
topic “Navigating and selecting with the keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD appears on the status bar.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the 
Shift key and select the next piece of text.

4) Repeat as often as needed.

5) Now you can work with the selected text.

6) Press Esc to exit from this mode.

Figure 4: Selecting items that are not next to each other

Selecting a vertical block of text
(New in OOo 2.4) You can now select a vertical block or “column” of text that is separated by spaces 
or tabs (as you might see in text pasted from e-mails, program listings, or other sources), using 
OOo’s block selection mode. To chang to block selection mode, use Edit > Selection Mode > Block 
Area, or click several times in the status bar on STD until it changes to BLK.

Now highlight the selection, using mouse or keyboard, as shown in Figure 5. 

Figure 5: Selecting a vertical block of text
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Working with text

Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You 
can use the mouse or the keyboard for these operations.

Cut: Use Edit > Cut or the keyboard shortcut Control+X or the Cut icon on the toolbar.

Copy: Use Edit > Copy or the keyboard shortcut Control+C or the Copy icon.

Paste: Use Edit > Paste or the keyboard shortcut Control+V or the Paste icon.

If you simply click on the Paste icon, any formatting the text has (such as bold or italics) is retained. 
To make the pasted text take on the formatting of the surrounding text where it is being pasted, click 
the triangle to the right of the Paste icon and select Unformatted text from the menu (Figure 6).

Figure 6: Paste menu

Moving paragraphs quickly
1) Put the cursor anywhere in the paragraph.

2) Press and hold the Control key and then press the up-arrow or down-arrow key.

The paragraph will move to before the previous paragraph or after the next paragraph in your 
document. To move more than one paragraph at a time, select at least part of both paragraphs before 
pressing the Control+arrow keys.

If you are using the Solaris operating system, the key combination is Control+AltGr+arrow keys.

Tip If your paragraphs suddenly jump from one place to another, the most likely reason 
is that you have accidentally pressed one of these key combinations.

Finding and replacing text and formatting
Writer has a Find and Replace feature that automates the process of searching for text inside a 
document. In addition to finding and replacing words and phrases, you can:

• Use regular expressions (wildcards) to fine-tune a search (see the Help for details).

• Find and replace specific formatting (see the Writer Guide for more information).

• Find and replace paragraph styles (see the Writer Guide for more information).

To display the Find & Replace dialog (Figure 7), use the keyboard shortcut Control+F or select Edit 
> Find & Replace.
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Working with text

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options such as matching the case, matching whole words only, or 
doing a search for similar words. (See below for some other choices.)

4) When you have set up your search, click Find. To replace text, click Replace instead. 

Figure 7: Expanded Find & Replace dialog

Tip If you click Find All, OOo selects all instances of the search text in the document. 
Similarly, if you click Replace All button, OOo will replace all matches.

Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and 
highly embarrassing) mistakes. A mistake with Replace All might require a manual, 
word-by-word, search to fix.

Inserting special characters
A special character is one not found on a standard English keyboard. For example, © ¾ æ ç 
ñ ö ø ¢ are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.
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Working with text

2) Click Insert > Special Character to open the Special Characters window (Figure 8).

3) Select the characters you wish to insert, in order, then click OK. The selected characters are 
shown in the lower left of the dialog. As you select a character, it is shown on the lower right, 
along with its numerical code.

Note Different fonts include different special characters. If you do not find a particular 
special character, try changing the Font selection.

Figure 8: The Special Characters window, where you can insert special characters.

Tip Notice that the characters selected appear in the bottom-left corner of the window.

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any that you have defined. To set the 
measurement unit and the spacing of default tab stops, go to Tools > Options > OpenOffice.org 
Writer > General.

You can also set or change the measurement unit by right-clicking on the ruler to open a list of units, 
as shown in Figure 9. Click on one of them to change the ruler to that unit.

Figure 9: Ruler showing default tab stops
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Working with text

Double-click on a blank part of the ruler to open the Indents & Spacing page of the Paragraph dialog. 
Double-click on the ruler itself to open the Tabs page of the Paragraph dialog (Figure 10) and fine-
tune tab stop settings.

Figure 10: The Tabs page of the Paragraph dialog, where you can adjust tab settings

Checking spelling
Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a wavy red line under any 
misspelled words. When the word is corrected, the line disappears.

To perform a separate spelling check on the document (or a text selection) click the 
Spellcheck button. This checks the document or selection and opens the Spellcheck dialog if 

any misspelled words are found.

Here are some more features of the spelling checker:

• You can change the dictionary language (for example, to Spanish, French or German) on the 
Spellcheck dialog.

• You can add a word to the dictionary. Click Add in the Spellcheck dialog and pick the 
dictionary to add it to.

• The Options dialog of the Spellcheck tool has a number of different options such as whether 
to check uppercase words and words with numbers. It also allows you to manage custom 
dictionaries, that is, add or delete dictionaries, and add or delete words in a dictionary.
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Working with text

• On the Font tab of the Paragraph Styles dialog, you can set paragraphs to be checked in a 
specific language (different from the rest of the document). See Chapter 7 (Working with 
Styles) in the Writer Guide for more information.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it 
corrects automatically. For example, “hte” will be changed to “the”. Select Tools > AutoCorrect to 
open the AutoCorrect dialog. There you can define which strings of text are corrected and how. In 
most cases, the defaults are fine.

Tip AutoCorrect is turned on by default. To turn it off, uncheck Format > AutoFormat 
> While Typing.

• To stop Writer from replacing a specific spelling, use Tools > AutoCorrect > 
Replace, highlight the word pair and click Delete.

• To add a new spelling to correct, type it into the Replace and With boxes and click New.

• See the different tabs of the dialog for the wide variety of other options available to fine-tune 
AutoCorrect.

Tip AutoCorrect can be used as a quick way to insert special characters. For example, 
(c)  will be autocorrected to ©. You can add your own special characters.

Using word completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to 
complete the word for you. To accept the suggestion, press Enter. Otherwise continue typing.

Tip Many people prefer not to use Word Completion. If you do not want to use it, select 
Tools > AutoCorrect > Word Completion and uncheck Enable Word Completion.

You can customize word completion from the Tools > AutoCorrect > Word Completion page:

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than completing the text as 
you type.

• Change the maximum number of words remembered for word completion and the length of 
the smallest words to be remembered.

• Delete specific entries from the word completion list.

• Change the key that accepts a suggested entry—the options are Right arrow, End key, Return 
(Enter), and Space bar.

Note Automatic word completion only occurs after you type a word for the second time 
in a document.
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Working with text

Using AutoText
AutoText allows you to assign text, tables, graphics and other items to a key combination. For 
example, rather than typing “Senior Management” every time you use that phrase, you might just 
type “sm” and press F3. Or you can save a formatted Note (like the one on this page) as AutoText 
and then insert a copy by typing “note” and pressing F3. 

To assign some text to an AutoText shortcut:

1) Type the text into your document.

2) Select the text so it is highlighted.

3) Select Edit > AutoText (or press Control+F3).

4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you can 
change.

5) Click the AutoText button on the right and select New (text only) from the menu.

6) Click Close to return to your document.

Tip If the only option under the AutoText button is Import, either you have not entered a 
name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 14 (Working with Fields) in 
the Writer Guide for more information.

Inserting dashes and non-breaking spaces
You can insert a dash by using the Special Characters window or by using AutoCorrect. For more 
about AutoCorrect, see “Controlling OOO’s AutoCorrect functions” in Chapter 5 (Setting up 
OpenOffice.org) and “Using AutoCorrect” on page 10 in this chapter.

– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. It is U+2013 
(scroll down to the General Punctuation section in the Special Characters window). To enter an 
en-dash using AutoCorrect, type at least one character, a space, two hyphens, another space, and 
at least one more letter, then a space. The two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. It is U+2014. 
To enter it using AutoCorrect, type at least one character, two hyphens, and at least one more 
character, then a space. The two hyphens will be replaced by an em-dash.

To insert a non-breaking space (to keep characters together, for example in a telephone number), 
press Control+Space on the keyboard.
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Formatting text

Formatting text

Using styles
Styles are central to using Writer. Styles enable you to easily format your document consistently, and 
to change the format with minimal effort. Often, when you format your document in Writer, you are 
using styles whether you realize it or not. A style is a named set of formatting options. Writer defines 
several types of styles, for different types of elements: characters, paragraphs, pages, frames, and 
lists. The use of styles is described in detail in Chapter 6 (Introduction to Styles) and Chapter 7 
(Working with Styles) in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 11 
shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for 
paragraph formatting.

Tip It is highly recommended that you use paragraph styles rather than manually 
formatting paragraphs, especially for long or standardized documents. For 
information on the advantages of styles, and how to use them, see Chapter 13 
(Working with Styles) in this book and Chapters 6 and 7 in the Writer Guide.

1 Open Styles and 
Formatting Window

5 Align Right 10 Numbering On/Off
6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1 12 Decrease Indent
3 Align Left 8 Line Spacing: 1.5 13 Increase Indent
4 Centred 9 Line Spacing: 2 14 Paragraph format dialog

Figure 11: The Formatting toolbar, showing buttons for paragraph formatting

Figure 12 shows examples of the different alignment options.

Figure 12: Different text alignment options
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Formatting text

Formatting characters
You can apply many formats to characters using the buttons on the Formatting toolbar. 
Figure 13 shows the Formatting toolbar as a floating toolbar, customized to show only the 
buttons for character formatting.

Tip It is highly recommended that you use character styles rather than manually 
formatting characters. For information on the advantages of styles, and how to use 
them, see Chapter 6 (Introduction to Styles) in the Writer Guide.

1 Open Styles and 
Formatting Window

6 Italic 12 Font Colour

7 Underline 13 Highlighting

2 Apply Style 8 Superscript 14 Background Colour

3 Font Name 9 Subscript 15 Open Character Format 
Dialog4 Font Size 10 Increase Font

5 Bold 11 Reduce Font

Figure 13: The Formatting toolbar, showing buttons for character formatting

Tip To remove manual formatting, select the text and click Format > Default 
Formatting, or right-click and select Default Formatting.

Autoformatting
You can set Writer to automatically format parts of a document according to the choices made on the 
Options page of the AutoCorrect dialog (Tools > AutoCorrect > Options).

Tip If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause.

Some common unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs 
(===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide as 
the page. The line is actually the lower border of the preceding paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*), or 
plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list is 
created when you type a number followed by a period (.), followed by a space or tab at the 
beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with 
the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, go to Format > AutoFormat and select or delete the items on the 
sub menu.
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Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.

• Use list (numbering) styles, as described in Chapter 7 (Working with Styles) in the 
Writer Guide.

• Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure
11). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list, and then click the 
appropriate icon on the toolbar.

Note It is a matter of personal preference whether you type your information first, then 
apply Numbering/Bullets, or apply them as you type. 

Using the Bullets and Numbering toolbar

You can create nested lists (where one or more list items has a sublist under it, as in an outline) 
by using the buttons on the Bullets and Numbering toolbar (Figure 14). You can move items up or 
down the list, or create subpoints, and even change the style of bullets. Use View > Toolbars > 
Bullets and Numbering to see the toolbar.

1 Bullets On/Off 6 Move Up (One Level) with 
Sub-points

10 Move Down
2 Numbering On/Off 11 Move Up in Sub-points
3 Numbering Off 7 Move Down (One Level) with 

Sub-points
12 Move Down in Sub-points

4 Up One Level 8 Insert Unnumbered Entry 13 Restart Numbering
5 Up One Level 9 Move Up 14 Bullets and Numbering

Figure 14: Bullets and Numbering toolbar

Hyphenating words
To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window (Figure 15). 

2) On the Paragraph Styles page of the Styles and Formatting window, right-click on Default in 
the list and select Modify.
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Formatting text

Figure 15: Modifying a style

3) On the Paragraph Style dialog, go to the Text Flow page (see Figure 16).

4) Under Hyphenation, select or deselect the Automatically checkbox. Click OK to save.

Note Turning on hyphenation for the Default paragraph style affects all other paragraph 
styles that are based on Default. You can individually change other styles so that 
hyphenation is not active; for example, you might not want headings to be 
hyphenated. Any styles that are not based on Default are not affected. For more on 
paragraph styles, see Chapter 6 (Introduction to Styles) and Chapter 7 (Working 
with Styles) in the Writer Guide.

Figure 16: Turning on automatic hyphenation

You can also set hyphenation choices through Tools > Options > Language Settings > 
Writing Aids. In Options, near the bottom of the dialog, scroll down to the find the 
hyphenation settings (see Figure 17).

Figure 17: Setting hyphenation options
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Notes Hyphenation options set on the Writing Aids dialog are effective only if 
hyphenation is turned on through paragraph styles.

Choices on the Writing Aids dialog for “characters before line break” and 
“characters after line break” override settings in paragraphs styles for “characters at 
line end” and “characters at line begin”. This is a bug.

To enter a conditional hyphen inside a word, press Control+minus sign. The word is hyphenated at 
this position when it is at the end of the line, even if automatic hyphenation for this paragraph is 
switched off.

To insert non-breaking hyphen, press Control+Shift+minus sign.

Undoing and redoing changes

To undo the most recent change, press Control+Z, or click the Undo icon  on the 
Standard toolbar, or select Edit > Undo from the menu bar. 

The Edit menu shows the latest change that can be undone, as shown in Figure 18.

Figure 18: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes that can 
be undone (Figure 19). You can select multiple changes and undo them at the same time.

Figure 19: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > 

Redo, or press Control+Y or click on the Redo icon . As with Undo, click on the triangle 
to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select Tools > Options > 
OpenOffice.org > Memory and change Undo number of steps. Be aware that asking OOo 
to remember more changes consumes more computer memory.

Getting Started with Writer 16



Tracking changes to a document

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, or under a 
different name, or both), then use Writer to combine the two files and show the differences. 
Click Edit > Compare Document. This technique is particularly useful if you are the only 
person working on the document, as it avoids the increase in file size and complexity caused 
by the other methods.

2) Save versions that are stored as part of the original file. However, this method can cause 
problems with documents of non-trivial size or complexity, especially if you save a lot of 
versions. Avoid this method if you can.

3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you 
have added or deleted material, or changed formatting. Later, you or another person can 
review and accept or reject each change.

Tip Not all changes are recorded. For example, changing a tab stop from align left to 
align right, and changes in formulas (equations) or linked graphics are not recorded.

Recording changes
See Chapter 2 (Setting up Writer) in the Writer Guide for instructions on setting up how 
changes will be displayed.

1) To begin tracking (recording) changes, click Edit > Changes > Record.

To show or hide the display of changes, click Edit > Changes > Show. 

Tip Hover the mouse pointer over a marked change; you will see a Help Tip showing 
the type of change, the author, date, and time of day for the change. If Extended 
Tips are enabled, you will also see any comments recorded for this change.

2) To entera comment on a marked change , place the cursor in the area of the change and then 
click Edit > Changes > Comment. (See Figure 20.) In addition to being displayed as an 
extended tip, the comment is also displayed in the list in the Accept or Reject Changes dialog.

You can move from one marked change to the next by using the arrow buttons. 
If no comment has been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Changes > Record again.
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Figure 20: Inserting a comment during change recording

Inserting notes
To insert a note that is not associated with a recorded change:

1) Place the cursor at the text you want to comment on, then click Insert > Note.

2) On the Insert Note dialog (Figure 21), type your note. Click Author to insert your initials and 
the date and time.

Figure 21: Inserting a note

To view a note, move the mouse pointer over the note marker (displayed as a small yellow 
rectangle). Writer displays the note in a Tip above the text. You can also double-click on the note to 
see it inside the Edit Note dialog. If you have trouble viewing or selecting notes this way, you can 
use the Navigator instead: expand the list of notes, select the one you want, right-click on it, and 
select Edit to display the Edit Note dialog.

The Edit Note dialog looks much like the Insert Note dialog, with the addition of forward and back 
arrow buttons if the document contains more than one note.
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Tip You can change the color of the note marker using the Tools > Options > 
OpenOffice.org > Appearance dialog.

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog (Figure 22) 

opens.

2) When you select a change in the dialog, the actual text is highlighted in the document, 
so you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click 
Accept All or Reject All if you do not want to review the changes individually.

Figure 22: The List tab of the Accept or Reject Changes dialog

Changes that have not yet been accepted or rejected are displayed in the list. Accepted changes are 
removed from the list and appear in the text without any marking.

To show only the changes of certain people, or only the changes made on specific days, or various 
other restrictions, use the Filter tab on the Accept or Reject Changes dialog. After specifying the 
filter criteria, return to the List tab to see those changes that meet your criteria.
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Formatting pages

Writer provides several ways for you to control page layouts:

• Page styles

• Columns

• Frames

• Tables

• Sections

For more information, see Chapter 4 (Formatting Pages) in the Writer Guide.

Tip Page layout is usually easier if you show text, object, table, and section boundaries 
in Tools > Options > OpenOffice.org > Appearance, and paragraph ends, tabs, 
breaks, and other items in Tools > Options > OpenOffice.org Writer > 
Formatting Aids.

Which layout method to choose?
The best layout method varies depending on what the final document should look like and what sort 
of information will be in the document. Here are some examples.

For a book similar to this user guide, with one 
column of text, some figures without text beside 
them, and some other figures with descriptive 
text, use page styles for basic layout, and tables 
to place figures beside descriptive text when 
necessary.
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For an index or other document with two 
columns of text, where the text continues from 
the left-hand column to the right-hand column 
and then to the next page, all in sequence (also 
known as “snaking columns” of text), use page 
styles (with two columns). If the title of the 
document (on the first page) is full-page width, 
put it in a single-column section.

For a newsletter with complex layout, two or 
three columns on the page, and some articles 
that continue from one page to some place 
several pages later, use page styles for basic 
layout. Place articles in linked frames and 
anchor graphics to fixed positions on the page 
if necessary.

For a document with terms and translations to 
appear side-by-side in what appear to be 
columns, use a table to keep items lined up, and 
so you can type in both “columns”.
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Creating headers and footers

A header is an area that appears at the top of a page. A footer appears at the bottom of the 
page. Information, such as page numbers inserted into a header or footer, displays on every 
page of the document with that page style.

To insert a header, click  Insert > Header > Default (or the page style, if not Default) as shown in 
Figure 23.

Figure 23: Inserting headers and footers

Other information such as document titles and chapter titles is often put into the header or footer. 
These items are best added as fields. That way, if something changes, the headers and footers are 
updated automatically. Here is one common example.

To insert the document title into the header:

1) Click File > Properties > Description and enter a title for your document.

2) Add a header (Insert > Header > Default).

3) Place the cursor in the header part of the page.

4) Select Insert > Fields > Title.  The title should appear on a gray background (which does not 
show when printed and can be turned off).

5) To change the title for the whole document, go back to File > Properties > Description.

Fields are covered in detail in Chapter 14 (Working with Fields) in the Writer Guide. 

For more about headers and footers, see Chapter 4 (Formatting Pages) and Chapter 6 (Introduction to 
Styles) in the Writer Guide.

Numbering pages

To automatically number pages:

1) Insert a header or footer, as described in “Creating headers and footers” on page 22.

2) Place the cursor in the header or footer where you want the page number to appear and click 
Insert > Fields > Page Number. 
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Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):

1) Type the word “page” and a space, then insert the page number as above

2) Press the spacebar once, type the word “of” and a space, then click Insert > Fields > Page 
Count.

Note The Page Count field inserts the total number of pages in the document, as shown 
on the Statistics tab of the document’s Properties window (File > Properties). If 
you restart page numbering anywhere in the document, then the total page count 
may not be what you want. See Chapter 4 (Formatting Pages) in the Writer Guide 
for more information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title 
page or a table of contents. In addition, many documents have the “front matter” (such as the table of 
contents) numbered with Roman numerals and the main body of the document numbered in Arabic 
numerals, starting with 1. 

You can restart page numbering in two ways.

Method 1:

1) Place the cursor in the first paragraph of the new page.

2) Click Format > Paragraph.

3) On the Text Flow tab of the Paragraph dialog (Figure 16 on page 15), select Breaks.

4) Select Insert and then With Page Style and specify the page style to use.

5) Specify the page number to start from, and then click OK.

Tip Method 1 is also useful for numbering the first page of a document with a page 
number greater than 1. For example, you may be writing a book, with each chapter 
in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with 
page 25 and Chapter 3 with page 51.

Method 2:

1) Insert > Manual break.

2) By default, Page break is selected on the Insert Break dialog (Figure 24).

3) Choose the required page Style.

4) Select Change page number.

5) Specify the page number to start from, and then click OK.
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Figure 24: Restarting page numbering after a manual page break

Changing page page margins

You can change page margins in two ways:

• Using the page rulers—quick and easy, but does not have fine control.

• Using the Page Style dialog—can specify margins to two decimal places.

Note If you change the margins using the rulers, the new margins affect the page style 
and will be shown in the Page Style dialog the next time you open it.

To change margins using the rulers:

1) The gray sections of the rulers are the margins (see Figure 25). Put the mouse cursor 
over the line between the gray and white sections. The pointer turns into a double-
headed arrow.

2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 25: Moving the margins

Tip The small arrows on the ruler are used for indenting paragraphs. They are often in the 
same place as the page margins, so you need to be careful to move the margin marker, 
not the arrows. Place the mouse pointer between the arrows and, when the pointer 
turns into a double-headed arrow, you can move the margin (the indent arrows will 
move with it).
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Changing page page margins

To change margins using the Page Style dialog:

1) Right-click anywhere on the page and select Page from the pop-up menu.

2) On the Page tab of the dialog, type the required distances in the Margins boxes.

Creating a table of contents

Writer’s table of contents feature lets you build an automated table of contents from the headings in 
your document. Before you start, make sure that the headings are styled consistently. For example, 
you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter 
subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are all 
you need. Creating a quick table of contents is simple:

1) When you create your document, use the following paragraph styles for different heading 
levels (such as chapter and section headings): Heading 1, Heading 2, and Heading 3. These 
are what will appear in your table of contents. You can use more levels of headings, but the 
default setting is to use only the first three levels in the table of contents.

2) Place the cursor where you want the table of contents to be inserted.

3) Select Insert > Indexes and Tables > Indexes and Tables.

4) Change nothing in the Insert Index/Table dialog. Click OK.

If you add or delete text (so that headings move to different pages) or you add, delete, or change 
headings, you need to update the table of contents. To do this:

1) Place the cursor within the table of contents.

2) Right-click and select Update Index/Table from the pop-up menu.

Note If you cannot place your cursor in the table of contents, choose Tools > Options > 
OpenOffice.org Writer > Formatting Aids, and then select Enable in the Cursor 
in protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and select 
Edit Index/Table from the pop-up menu. Chapter 12 (Creating Tables of Contents, Indexes and 
Bibliographies) of the Writer Guide describes in detail all the customizations you can choose.

Creating indexes and bibliographies

Indexes and bibliographies work in a similar way to tables of contents. Chapter 12 (Creating Tables 
of Contents, Indexes and Bibliographies) of the Writer Guide describes the process in detail. In 
addition to alphabetical indexes, other types of indexes supplied with Writer include those for 
illustrations, tables, and objects, and you can even create a user-defined index. For example, you 
might want an index containing only the scientific names of species mentioned in the text, and a 
separate index containing only the common names of species. Before creating some types of indexes, 
you first need to create index entries embedded in your Writer document.
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Printing from Writer

This section describe some general features of printing from Writer. For details on printing 
brochures, envelopes, and mailing labels, see Chapter 5 (Printing, Faxing, Exporting, and E-mailing) 
in the Writer Guide.

For quick printing, click the Print File Directly icon  to send the entire document to the default 
printer defined for your computer.

Note (New in OOo 2.3) You can change the action of the Print File Directly icon to send 
the document to the printer defined for the document instead of the default printer 
for the computer. Go to Tools > Options > Load/Save > General and select the 
Load printer settings with the document checkbox.

For more control over printing, use File > Print to display the Print dialog (Figure 26). On the Print 
dialog, you can choose:

• Which printer to use (if more than one are installed on your system) and the properties of the 
printer—for example, orientation (portrait or landscape), which paper tray to use, and what 
paper size to print on. The properties available depend on the selected printer; consult the 
printer’s documentation for details.

• What pages to print, how many copies to print, and in what order to print them.

• Use dashes to specify page ranges and commas or semicolons to separate ranges; for 
example: 1, 5, 11–14, 34–40.

• Selection is the highlighted part of a page or pages.

• What items to print. Click the Options button to display the Printer Options dialog (Figure
27).

Figure 26. The Print dialog
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Selecting print options for a document
Selections on the Printer Options dialog apply to this printing of this document only. To specify 
default printing options for Writer, see Chapter 5 (Setting up OpenOffice.org).

Some items of interest on the Printer Options dialog (Figure 27) include:

• In the Contents section, you might choose not to print graphics or page background in drafts, 
for example (to save toner or ink).

• In the Pages section, you can choose:

• Print only left (even-numbered) pages or only right (odd-numbered) pages. These settings 
are useful when you want to print on both sides of the page, but do not have a printer that 
handles this automatically.

• Print in reversed page order.

• Brochure—see Chapter 5 (Printing, Faxing, Exporting, and E-mailing) of the Writer 
Guide for details.

• In the Notes section, you can choose whether to print any notes that have been added to your 
document (using Insert > Note), and where to print the notes.

Selecting default print options
Selections on the Printer Options dialog over-ride any default settings. To specify default 
settings for printing, use Tools > Options > OpenOffice.org Writer > Print. The page 
displayed contains the same choices as the Printer Options dialog. See Chapter 5 in the 
Writer Guide for more about this dialog.

Figure 27. Printer Options dialog
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Other printer settings are found in Tools > Options > OpenOffice.org > Print. See Chapter 5 
(Setting up OpenOffice.org) for more about this dialog. Use this page to specify quality settings for 
printing, and whether to have OOo warn you if the paper size ororientation of your document does 
not match the printer settings.

Previewing pages before printing
The normal page view in Writer shows what each page will look like when printed. If you are 
designing a document to be printed double-sided, you may want to see what facing pages look like. 
OOo provides a way to do this in Page Preview.

1) Click File > Page Preview, or click the Page Preview button .

The Writer window changes to display the current page and the following page, and shows 
the Page Preview toolbar (Figure 28) in place of the Formatting toolbar.

Figure 28. Page Preview toolbar

2) Click the Book Preview icon  to display left and right pages in their correct orientation.

3) To print the document in this page view, click the Print page view icon  to open 
the Print dialog (Figure 26). Choose your options and click OK to print as usual.

4) To choose margins and other options for the printout, click the Print options page view icon 

 to display the Print Options dialog (Figure 29).

Figure 29. Print Options dialog
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