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Introduction

Introduction

OpenOffice.org (OO0) has a component for mathematical equations. It is most commonly
used as an equation editor for text documents, but it can also be used with other types of
documents or stand-alone. When used inside Writer, the equation is treated as an object inside
the text document.

Note The equation editor is for writing equations in symbolic form (as in equation 1). If
you want to evaluate a numeric value, see the Calc Guide.

(M

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Selection window
appears. You will also see a small box (with a gray border) in your document, where the
formula will be displayed.

[v][o][+] Usitizlsell - O gagOF e s ricar (- J[o][x]
File Edit View Format Tools Window Help
£ -=cH=2 a8 & @ =
Selection

H:hh asb aea fu) 2a

i (&) &2

A0 4

+d -4 a4 Fa4a -d

a+b a-b axb axb asb

azb a/b avb

7
o
ole

Figure 1. Equation Editor, Selection window, and location of resulting equation.

The equation editor uses a markup language to represent formulas. For example, %obeta
creates the Greek character beta ( 8 ). This markup is designed to read similar to English

. . a
whenever possible. For example, a over b produces a fraction: 5
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Entering a formula

Entering a formula

There are three ways to enter a formula:
+ Select a symbol from the Selection window.
+ Right-click on the equation editor and select the symbol from the context menu.
+ Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a symbol.
Incidentally, this provides a convenient way to learn the OOoMath markup.

Note Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

The Selection window

The simplest method for entering a formula is the Selection window, shown in Figure 2.

[w |+ [NSETECEOTIN x |
% agb aed F(:) >a

a & (2) %

+4 -4 *a F4a -4

a-b axb axb asb
Symbols

a-b % azb a/b avb

asb

Figure 2. Symbols are divided into categories

The Selection window is divided into two main portions.
+ The top shows the symbol categories. Click on these to change the list of symbols.

+ The bottom shows the symbols available in the current category.

Tip You can hide (or unhide) the Selection window with View > Selection.
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Entering a formula

Example 1: 5x4

For this example we will enter a simple formula: 5X4 On the Selection window:
1) Select the top-left button of the categories (top) section (Figure 3).
2) Click on the multiplication symbol (shown in Figure 3).

‘Unary/binary operatori
/

BB A-o=-h00 B
{Sb ash -F(:) 2a

icatioﬂ

axb asb

a-b % azb a/b avb

Figure 3. Unary/binary operators

When you select the multiplication symbol on the Selection window, two things happen:
« The equation editor shows the markup: <?> times <?>

« The body of the document shows a gray box with the figure: XU

ST

A kA

<7 times <7 | -

4 3

Figure 4. The multiplication symbol

The “ <?> " symbols (Figure 4) are placeholders that you can replace by other text. The
equation will update automatically, and the result should resemble Figure 5.

15%4

A kA

4 3

5 times 4| -

-

4 3

Figure 5. Result of entering “5” and “4” next to the “times” operator
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Entering a formula

Tip
display.

To keep the equation from updating automatically, select View > AutoUpdate

To update a formula manually, press 9 or select View > Update.

Right-click menu

Another way to access mathematical symbols is to right-click on the equation editor. This

produces a menu as shown in Figure 6.

5 times 4|

i Unary/Binary Operators

Relations

Set Operations
Functions
Operators
Attributes
Brackets
Formats
Others

Figure 6. Right-click menu

-+a
a+b
a-b
acdot b

* ¥ v v v v v v |w

atimes b

dt b
aoverb
adivb
alb
acirch

a wideslash b
a widebslash b

Note

The entries in this menu correspond exactly to those in the Selection window.

Markup

You can type the markup directly in the equation editor. For example, you can type “5 times
4 to obtain 5X4 . If you know the markup, this can be the fastest way to enter a formula.

Tip

As a mnemonic, the formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command

a=b a=b Ja sqrt {a}
a’ a2 a, an

f f(x)dx int f(x) dx > a, suma n
a<b a<=b 00 infinity
axb atimes b Xy x cdot 'y
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Entering a formula

Greek characters

Greek characters ( «, B,y ,0 , etc) are common in mathematical formulas. These characters
are not available in the selection box or the right-click menu. Fortunately, the markup for
Greek characters is simple: Type a % sign followed the name of the character, in English.

- To type a lowercase character, write the name of the character in lowercase.
- To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples:

Lowercase Uppercase

%l pha —» 9%ALPHA — 4
%beta — B YBETA — B
Ygamma — y YGAMA — T
%psi - Y %Sl 4
Yphi - ¢ %PHI - @
% heta — @ WHETA —» O

Note A complete table of Greek characters is included in page 23.

Another way to enter Greek characters is by using the catalog window. Go to Tools >
Catalog. The catalog window is shown in Figure 7. Under “Symbol Set” select “Greek” and
double-click on a Greek letter from the list.

n n Snials m

Symbol set Insert

Greek

Ak

Close

A
M N
0y
%
W T8 v o
¢ £

AEHT I
o @ I¥Y P

s x s

Ay ov ow oo

Edit...

T o~ =~
= I 2D =

q
g% m v

e X

o

alpha

Figure 7. Catalog - used for entering Greek characters
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Entering a formula

Example 2: 7™ =~ 3.14159

For this example we will suppose that:
«  We want to enter the above formula (the value of pi rounded to 5 decimal places).
«  We know the name of the Greek character (“pi”).
- But we do not know the markup associated with the ~ symbol.

Step 1: Type “%” followed by the text “pi”. This displays the Greek character 77 .

Step 2: Open the Selection window (View > Selection).

Step 3: The = symbol is a relation, so we click on the relations button asb 1f you hover the
mouse over this button you see the tooltip “Relations” (Figure 8).

[v] ERIBCLIOTII X |
- (5] o i
a a = 4

+4 -4 *4a F4 -a

a+b a-b axb a#b asb
a-b % azb a/b avb

aeb

Figure 8. Tooltip indicates the “Relations” button.

Step 4: Delete the <?> text and add “3.14159” at the end of the equation. Hence we end up
with the markup “ %pi  si meq 3. 14159 . The result is shown in Figure 9.

im~3.14150 -

A0 A

4 L3

i simeq 3.14159] -

4 F

Figure 9. Final result
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Customizations

Customizations

Formula editor as a floating window

As seen in Figure 1, the formula editor can cover a large part of the Writer window. To turn
the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 10.

2) Hold down the Control key and double-click.
\Em ™2

Figure 10. Hold down the Control key and double-click on the border of
the math editor to turn it into a floating window.

Figure 11 shows the result. You can make the floating window back into an embedded frame,
using the same steps. Hold down the Control key and double-click the window frame.

u n O ITarA S E m

=mc"? -

Figure 11. Equation editor as a floating window

How can | make a formula bigger?

This is one of the most common questions people ask about OOoMath. The answer is simple,
but not intuitive:

1) Start the formula editor and go to Format > Font size.

Math Objects 7



Customizations

(«|[o] L PR SO PENUTTICEROTG W RITET (- [o](x]
File Edit View | Format | Tools Window Help
B -= = Fonts... 5 - @ . ).)
—| Font Size... H —
LZ"'ILIIEILI 780910 11 12
————— Spacing...
. . . Alignment...
ar=3.14150 =
. . . Text Mode
@
4 »
Papi simeq 3.14159 -
A »

Figure 12. Changing the font size for a formula

2) Select a larger font size under “Base Size” (top-most entry), as shown in Figure 13.

[v][+] FORIGIone x]

Base size hept = oK

Relative sizes e
It 100% s
Indexes 60% = Default
Functions 100% =
Operators 100% s
Limits 60% =

Figure 13. Edit “Base size” (top) to make a formula bigger.

The result of this change is illustrated in Figure 14.

Before: T=23.14159

After: m=314159

Figure 14. Result of changing the base font size.

Formula layout

The most difficult part of using OOoMath comes when writing complicated equations. This
section provides some advice about writing complex formulas.

Math Objects 8



Formula layout

Brackets are your friends

OOoMath knows nothing about order of operation. You must use brackets to state order of
operations explicitly. Consider the following example:

Result
2 over Xx + 1 2
—+1
X
2 over {x + 1} 2
x+1

Equations over more than one line

. . . x=3
Suppose you want to type an equation covering more than one line. For example: p=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter
key, though the markup goes to a new line, the resulting equation does not. You must type the
newline command explicitly. This is illustrated in the table below.

Result
X =3 x=3y=1
y =1
X = 3 newine x=3
y =1 y=1

Math Objects 9



Common problem areas

Common problem areas

How do | add limits to my sum/integral?

The “sum” and “int” commands can (optionally) take in the parameters “from” and “to”.
These are used for lower and upper limits respectively. These parameters can be used singly
or together. Limits for integrals are usually treated as subscripts and superscripts.

Markup Result

sumfromk =1 to n a_k n
Zak

=
—_

int fromO to x f(t) dt

or
int_O0~x f(t) dt
int fromRe f

ft)de or [ f(t)dr

B ey © S =
\

sumto infinity 2*{-n} n

F[\?s

Note For more details on integrals and sums, see the table on page 17.

Brackets with matrices look ugly!

For background, we start with an overview of the matrix command:

matrix { a# b ## c # d } a b
c d
Note Rows are separated by two #’s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not “scale” with the matrix:

Result

( matrix { a# b #t c #d} ) (@ b)
c d

OOoMath provides “scalable” brackets. That is, the brackets grow in size to match the size of
their contents. Use the commands lef?( and right) to make scalable brackets.

Math Objects 10



Common problem areas

left( matrix { a# b ## c # d } right)

c d

¥

Tip Use left[ and right] to obtain square brackets.

How do | make a derivative?

Making derivatives essentially comes down to one trick: 7el/ OOo its a fraction.

In other words, you have to use the “over” command. Combine this with either the letter
“d” (for a total derivative) or the “partial” command (for a partial derivative) to achieve the
effect of a derivative.

Markup Result

{df} over {dx} df
dx
{partial f} over {partial y} of
dy
{partial”~2 f} over {partial t~"2} ézf
or’

Note Notice that we had to use squiggly brackets to make the derivative.

Numbering equations

Equation numbering is one of OOoMath’s best hidden features. The steps are simple, but
obscure:

1) Start a new line.
2) Type “fn” and then press F3.
The “fn” is replaced by a numbered formula:
E=mc’ )

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta
function:

cla)=3 )

n=1 N

Math Objects 11



Common problem areas

You can reference an equation (“as shown in Equation (2)’) with these steps:
1) Insert > Cross-reference.
2) Click on the References tab (Figure 15).
3) Under Tjpe, select Text.
4) Under Selection, pick the equation number.
5) Under Format, choose Reference.

6) Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the
equations will automatically renumber and the cross-references will update.

[v]+] Pravae 8
Document References Functions | Doclnformation | Variables | Database
Type Selection Format
Set Reference (1 Page
Insert Reference (2 Chapter
Text Reference
Bookmarks Above/Below
As Page Style

Category and Number
Caption Text
Numbering

Insert Close Help

Figure 15. Inserting a cross-reference to an equation number.

Tip To insert the equation number without parenthesis around it, choose Numbering
under Format instead of Reference.
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Math commands - Reference

Math commands - Reference

Unary / binary operators

Operation
+sign

—sign

+/— sign

—/+ sign

Boolean not
Addition +
Multiplication dot
Multiplication (X)
Multiplication (*)
Boolean and
Subtraction (-)

Division (fraction)

Division (operand)
Division (slash)
Boolean or

Concatenate

Command

+1

neg a
atb
acdotb
a times b
a*b
aand b
a—b

aoverb

adivb
a/b
aorb

acircb

Display

axb

axb

Math Objects
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Relational operators

Operation

Is equal

Is not equal
Approximately

Divides

Does not divide

Less than

Greater than

Similar to or equal
Parallel

Orthogonal to

Less than or equal to
Greater than or equal to
Similar to

Congruent

Less than or equal to
Greater than or equal to
Proportional

Toward

Arrow left

Double arrow left and
right

Arrow right

Command
a=b

a<>b

a approx 2
a divides b
a ndivides b
a<?2

a>?2

a simeq b

a parallel b
a ortho b

a leslant b

a geslant b
asimb
aequivb
a<=b
a>=b
apropb

a toward b
a dlarrow b

a dlrarrow b

a drarrow b

Math commands - Reference

Display

a#x?2

Math Objects

14



Set operations

Operation

Is in

Is not in

Owns

Empty set
Intersection

Union

Difference

Quotient

Aleph

Subset

Subset or equal to
Superset

Superset or equal to
Not subset

Not subset or equal
Not superset

Not superset or equal
Set of natural numbers
Set of integers

Set of rational numbers
Set of real numbers

Set of complex numbers

Command
ain B

a notin B

A owns b
emptyset

A intersection B
A union B

A setminus B
A slash B
aleph

A subset B

A subseteq B
A supset B

A supseteq B
A nsubset B
A nsubseteq B
A nsupset B
A nsupseteq B
setN

setZ
setQ
setR

setC

Math commands - Reference

Display
a€B
a¥&B
A3b

ANB
AUB
A\B
AlB

Math Objects
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Functions

Operation
Exponential
Natural logarithm
Exponential function
Logarithm

Power

Sine

Cosine

Tangent
Cotangent

Square root
Arcsine

Arc cosine
Arctangent

Arc cotangent

n'" root

Hyperbolic sine
Hyperbolic cosine
Hyperbolic tangent
Hyperbolic cotangent
Absolute value

Arc hyperbolic sine

Arc hyperbolic cosine
Arc hyperbolic tangent
Arc hyperbolic cotangent

Factorial

Command
func e*{a}
In(a)
exp(a)
log(a)
a”{b}
sin(a)
cos(a)
tan(a)
cot(a)
sqrt{a}
arcsin(a)
arccos(a)
arctan(a)
arccot(a)
nroot{a}{b}
sinh(a)
cosh(a)
tanh(a)
coth(a)
abs{a}
arsinh(a)
arccosh(a)
arctanh(a)
arccoth(a)

fact{a}

Math commands - Reference

Display

a

In(a)
exp(a)
log(a)
sin(a)
cos(a)
tan(a)
cot (a)
Va

arcsin (a)
arccos(a)
arctan (a)
arccot (a)
3

sinh (a)
cosh(a)
tanh (a)
coth (a)
4

arsinh (a

artanh (a

)

arcosh (a)
(a)

(a)

arcoth (a

al

Math Objects

16



Operators

Math commands - Reference

All operators can be used with the limit functions (“from” and “to”).

Operation
Limit

Sum

Product

Coproduct

Upper and lower bounds
shown with integral

Integral
Double integral
Triple integral

Lower bound shown with
summation symbol

Contour integral
Double curved integral
Triple curved integral

Upper bound shown with
product symbol

Command
lim{a}
sum{a}
prod{a}
coprod{a}

int from {r 0} to {r t} a

int{a}

iint{a}

iiint{a}

sum from{3}b
linta

llint a

lllint a

prod to{3} r

Display

lim a

Math Objects
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Math commands - Reference

Attributes
Operation Command Display
Acute accent acute a a
Grave accent grave a a
Reverse circumflex check a a
Breve breve a a
Circle circle a a
Vector arrow vec a a
Tilde tilde a a
Circumflex hat a a
Line above bar a a
Dot dota a
Wide vector arrow widevec abc abc
Wide tilde widetilde abe abc
Wide circumflex widehat abc abc
Double dot ddot a a
Line over overline abc abc
Line under underline abc abc
Line through overstrike abc acb
Triple dot dddot a a
Transparent (useful to get a phantom a
placeholder of a given size)
Bold font bold a a
Italic font' ital “a” a
Resize font size 16 qv qv
Following item in sans serif font sans qv qv
font?
Following item in serif font font serif qv qv
Following item in fixed font font fixed qv qv
Make color of following text color cyan qv qv
cyan’

Unquoted text that is not a command is considered to be a variable. Variables are, by default, italicized.

There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed (non-proportional). To
change the actual fonts used for custom fonts and the fonts used for variables (unquoted text), numbers and

functions, use Format > Fonts.

Math Objects
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Operation

Make color of following text
yellow

Make color of following text
white

Make color of following text
green

Make color of following text
blue

Make color of following text
red

Make color green returns to
default color black

Brace items to change color
of more than one item

Command

color yellow qv

color white qv

color green qv

color blue qv

color red qv

color green X qv

color green {X qv}

Math commands - Reference

Display

qv
qv

qv

Xqv

3 For all coloring, the color will apply only to the text immediately following the command until the next space is

encountered. In order to have the color apply to more characters, place the text you want in color in curly

brackets.

Math Objects
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Miscellaneous

Operation
Infinity

Partial

Nabla

There exists
For all

H bar

Lambda bar
Real part
Imaginary part
Weierstrass p
Left arrow
Right arrow
Up arrow
Down arrow
Dots at bottom
Dots at middle
Dots vertical
Dots diagonal upward

Dots diagonal downward

Command
infinity
partial
nabla
exists
forall

hbar
lambdabar
re

im

wp
leftarrow
rightarrow
uparrow
downarrow
dotslow
dotsaxis
dotsvert
dotsup

dotsdown

Math commands - Reference

Display

Y]

c~7 11T

Math Objects
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Brackets

Operation

Round Brackets

Square Brackets
Double Square Brackets
Single line

Double line

Braces

Angle Brackets
Operator Brackets

Group brackets (used for
program control)

Scalable round brackets

(add the word “left
before a left bracket and

“right” before a right
bracket)

Square brackets scalable

(as above)

Double square brackets
scalable

Line scalable

Double line scalable
Brace scalable

Angle bracket scalable

Operator brackets
scalable

Over brace scalable

Under brace scalable

Command

(a)

[b]

ldbracket c rdbracket
lline a rline

ldline a rdline

Ibrace w rbrace
langle d rangle

langle a mline b rangle

{a}

left ( tack{a#b#2} right )

left [ stack{ x # y} right ]

left Idbracket ¢ right
rdbracket

left lline a right rline

left Idline d right rdline
left Ibrace e right rbrace
left langle f right rangle

left langle g mline h right
rangle

{The brace is above}
overbrace a

{the brace is
below}underbrace {f}

Math commands - Reference

Display

(a)
]
[c]

al]
(w)
(d)
(alb)

—

The braceis above

the braceis below
f

Math Objects
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Formats

Operation
Left superscript

Center superscript

Right superscript
Left subscript

Center subscript

Right subscript

Align character to left (text
is aligned center by default)
Align character to center
Align character to right

Vertical stack of 2

Vertical stack, more than 2

Matrix stack

Common mathematical
arrangement

New line

Small gap (grave)

Large gap (tilde)

Command
a lsup{b}

a csup{b}

a™{b}
a Isub{b}
acsub{b}

a_{b}

stack { Hello world # alignl (a) }

stack {Hello world # alignc(a)}

stack { Hello world # alignr(a)}

binom{a}{b}

stack{a#b #z}

matrix{a # b ## c # d}

matrix {a # "="b ## {} # "="c}

asldkfjo newline sadkfj

stuff “stuff
stuff~stuff

Math commands - Reference

Helloworld
(a)
Helloworld
(a)
Hello world
(a)

[ RN

asldkfio
sadkfj

stuff stuff’
stuff  stuff

Math Objects
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Characters - Greek

Math commands - Reference

%ALPHA
%ETA

%MU

%P1

%UPSILO
N

%alpha
%eta
%mu
%pi

%upsilon

Y%varsigma

~ 3 5 =

S 3 = 3 2

n

%BETA B | %cH1
%GAMMA I’ | %IOTA

%NU N | %OMEGA
%PSI ¥ | %RHO
%XI E | %ZETA
%beta B %.chi
%gamma y | %lota
Y%nu v | %omega
%rho p | Yesigma

%varepsilo ¢ | %varphi
n

%vartheta g | %xi

X | %DELTA

I | %KAPPA

Q | %OMICRO
N

P | %SIGMA

VA

X | %delta

t Y%kappa

w | %omicron

o | %tau

@ | Yovarpi

& | Yozeta

0

%EPSILON

%LAMBDA
%PHI

%THETA

%epsilon
%lambda
%phi
%theta

%varrho

PN

m

o ° 9 >

Characters - Special

%and A
%infinite o0

Y%perthousand

%00

%angle <
%noelement &

Ystrictlygreaterthan >

%element €
%notequal #

Ystrictlylessthan <<

%identical =
%or V

%tendto —
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