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Choosing Options that Affect all of AOO

This section covers some of the settings that apply to all the components of AOO and
are particularly important when using Writer. Other general options are discussed in
Chapter 2 (Setting Up OpenOffice) in the Getting Started guide.

Click Tools > Options (on macOS use OpenOffice > Preferences). The list on the
left-hand side of the Options—OpenOffice dialog box varies depending on which
component of AOO is open. The illustrations in this chapter show the list as it appears
when a Writer document is open.

Click the expansion symbol (+ sign or triangle) by OpenOffice on the left-hand side. A
list of pages drops. Selecting an item in the list causes the right-hand side of the
dialog box to display the relevant page.

5 OpenOffice
General
Memory
View
Print
Paths
Colors
Fonts
Security
Appearance
Accessibility
Java
Online Update

Figure 1: OpenOffice options

The Back button has the same effect on all pages of the Options
Note dialog box. It resets options to the values that were in place when you
opened AOO.

User Data Options

Because Writer uses the name or initials stored in the OpenOffice—User Data page
for several things, including document properties (created by and last edited by
information) and the name of the author of notes and changes, you will want to
ensure that the correct information appears here.

Fill in the form (shown in Figure 2) or amend or delete any existing incorrect
information.
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Address
Company
First/Last name/Initials lared Kobos JE
Street
City/ State/Zip
Country/Region
Title/Position
Tel. (HomeWork)

Fax / E-mail

Figure 2: Filling in user data

General Options
The options on the OpenOffice—General page are described below.
Help
M Tips
O Extended tips

OHelp Agent

Reset Help Agent

Help formatting Default v

Open/Save dialogs
[ Use OpenOffice dialogs

Document status

O Printing sets "document modified" status

Year (two digits)

Interpret as years between 1930 2 and 2029
Figure 3: Setting general options for OpenOffice

Help—Tips
When Tips is active, one or two words will appear when you hold the mouse
pointer over an icon or field, without clicking.

Help—Extended tips
When Extended tips are active, a brief description of the function of a particular
icon or menu command or a field on a dialog box appears when you hold the
mouse pointer over that item.

Help—Help Agent
To turn off the Help Agent, deselect this option. To restore the default behavior,
click Reset Help Agent.
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Help—Help formatting
High contrast is an operating system setting that changes the system color
scheme to improve readability. To display Help in high contrast (if your computer’s
operating system supports this), choose one of the high-contrast style sheets from
the pull-down list.

High-contrast style Visual effect

Default Black text on white background
High Contrast #1 Yellow text on black background
High Contrast #2 Green text on black background
High Contrast Black White text on black background
High Contrast White Black text on white background

Open/Save dialogs
To use the standard Open and Save dialog boxes for your operating system,
deselect the Use OpenOffice dialogs option. When this option is selected, the
Open and Save dialog boxes supplied with OpenOffice will be used. This book uses
the AOO Open and Save dialog boxes in illustrations.

Document status
If this option is selected, then the next time you close the document after printing,
the print date is recorded in the document properties as a change, and you will be
prompted to save the document again, even if you did not make any other
changes.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is
set to 1930, and you enter a date of 1/1/30 or later into your document, the date is
interpreted as 1/1/1930 or later. An “earlier” date is interpreted as being in the
following century; that is, 1/1/20 is interpreted as 1/1/2020.

Memory Options

In the Options dialog, click OpenOffice > Memory. Some considerations:

* More memory can make OpenOffice faster and more convenient (for example,
more undo steps require more memory); but the trade-off is less memory
available for other applications, and you could run out of memory altogether.

e If your documents contain a lot of objects such as images, or the objects are
large, AOO’s performance may improve if you increase the memory for AOO or
the memory per object. If you find that objects seem to disappear from a
document that contains a lot of them, increase the number of objects in the
cache. (The objects are still in the file even if you cannot see them on screen.)

* To load the Quickstarter (an icon on the desktop or in the system tray) when
you start your computer, select the option near the bottom of the dialog. This
makes OpenOffice start faster; the trade-off is that AOO uses some memory
even when not being used. This option (sometimes called Enable systray
quickstarter) is not available on all operating systems.
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Undo
Number of steps 100 =

Graphics cache

Use for OpenOffice 20 -~ | MB
Memory per object 5.2 - MB
Remove from memory after 00:10 : hh:mm

Cache for inserted objects
Number of objects 20 =

OpenOffice Quickstarter
[ Load OpenOffice during system start-up

Figure 4: Choosing Memory options for the OpenOffice applications

View Options

The options on the OpenOffice— View page affect the way the document window
looks and behaves. Some of these options are described below. Set them to suit your
personal preferences.

User Interface Graphics output
Scaling 100% |2 [V] Use hardware acceleration
lcon size and style Use Anti-Aliasing
|Sma|l IZ” |Ga|ax}r (default) Iz" Mouse
Use systern font for user interface Mouse positioning
|Nn:| automatic positioning |E||
Menu

Middle mouse button

Icons in menus

|Autu:umatic scrolling IZ”
|Aut|:|matic IZ”
: Selecti
Font Lists slectien
["] Show preview of fonts Transparency 5% [

Show font history

Figure 5: Choosing View options for OpenOffice applications

User Interface—Scaling
If the text in the help files or on the menus of the AOO user interface is too small
or too large, you can change it by specifying a scaling factor. Sometimes a change
here can have unexpected results, depending on the screen fonts available on
your system. However, it does not affect the font size of the text in your
documents.

User Interface—Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or
Large); the Automatic icon size option uses the setting for your operating
system. The second box specifies the icon style (theme); here the Automatic

Chapter 2 Setting up Writer | 7



option uses an icon set compatible with your operating system and choice of
desktop: for example, KDE or Gnome on Linux.

User Interface—Use system font for user interface
If you prefer to use the system font (the default font for your computer and
operating system) instead of the font provided by AOO for the user interface,
select this option.

User interface—Screen font Anti-Aliasing
(Not available in Windows; not shown in Figure 5.) Smooths the screen
appearance of text. Enter the smallest font size to apply anti-aliasing.

Menu—Icons in menus
Causes icons as well as words to be visible in menus.

Font Lists—Show preview of fonts
Causes the font list to look like Figure 6, Left, with the font names shown as an
example of the font; with the option deselected, the font list shows only the font
names, not their formatting (Figure 6, Right). The fonts you will see listed are
those that are installed on your system.

Bitstream Vera Sans| 11 v| | B | i Bitstream Vera Sans] 11

AlAnal A |Aial ~

- Arial Black
AIA_I’IE' Black Arial Marrow
Al Arnal Narrow Arial Unicode M5
AlAvaniGarde Bk BT Autumn
AAvaniGarde Md BT Y-

. Bitstream Yera Sans Mono

AlBakerSienet BT ¥|  |pitstream Vera Serif v

Figure 6: Font list (Left) showing preview; (Right) without preview

Font Lists—Show font history
Causes the last five fonts you have assigned to the current document to be
displayed at the top of the font list.

Graphics output—Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve
the screen display. Not supported on all operating systems and AOO distributions.

Graphics output—Use Anti-Aliasing
Enables and disables anti-aliasing, which makes the display of most graphical
objects look smoother and with fewer artifacts. Not supported on all operating
systems and AOO distributions.

Tip Press Shift+Control+R to restore or refresh the view of the current
document.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialog
boxes.

Middle mouse button
Defines the function of the middle mouse button.
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* Automatic scrolling - dragging while pressing the middle mouse button

shifts the view.

* Paste clipboard - pressing the middle mouse button inserts the contents of
the “Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by
Edit > Copy/Cut/Paste or their respective keyboard shortcuts. The clipboard and
can contain different contents at the same time.

“Selection clipboard”

Function

Clipboard

Selection clipboard

Copy content

Paste content

Pasting into another
document

Edit > Copy Control+C

Edit > Paste Control+V
pastes at the cursor
position.

No effect on the
clipboard contents.

Select text, table, or object.

Clicking the middle mouse
button pastes at the mouse
pointer position.

The last marked selection is
the content of the selection

clipboard.

Print Options

On the OpenOffice—Print page, set the print options to suit your default printer and
your most common printing method.

Reduce print data

Settings for @ Printer Print to file
Printer
Reduce transparency Reduce gradients
Reduce bitmaps Convert colors to grayscale

Printer warnings

| Paper size | Transparency

| Paper orientation

Figure 7: Choosing general printing options to apply to all AOO
components

In the Printer warnings section near the bottom of the page, you can choose whether
to be warned if the paper size or orientation specified in your document does not
match the paper size or orientation available for your printer. Having these warnings
turned on can be quite helpful, particularly if you work with documents produced by
people in other countries where the standard paper size is different from yours.
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. If your printouts are incorrectly placed on the page or chopped off at
Tip the top, bottom, or sides or the printer is refusing to print, the most
likely cause is page-size incompatibility.

Path Options

On the OpenOffice—Paths page, you can change the location of files associated with,
or used by, AOO to suit your working situation. In a Windows system, for example,
you might want to store documents by default somewhere other than Documents.

To make changes, select an item in the list shown in Figure 8 and click Edit. On the
Select Paths dialog (not shown), add or delete folders as required, and then click OK
to return to the Options dialog. Note that many items can have at least two paths
listed: one to a shared folder (which might be on a network) and one to a user-
specific folder (normally on the user’s personal computer).

. You can use the entries in the OpenOffice—Paths dialog to compile a
Tip list of files, such as those containing AutoText, that you need to back
up or copy to another computer.

Paths used by OpenOffice

Tvpe [Path
AutoCorrect C\Users\fxcampos\AppData\Roaming\OpenOffice\d\user\autocor
AutoText C\Users\fxcampos\AppData\Roaming\OpenOffice\d\user\autotex
Backups C\Users\fxcampos\AppData\Roaming\OpenOffice\d\user\backup
Gallery C\Users\fxrcampos\AppData\Roaming\OpenOffice\d\user\gallery
Graphics C\Users\fxrcampos\AppData\Roaming\OpenOffice\d\user\gallery
My Documents C\Users\fxcampos\Documents
Templates C\Users\fxcampos\AppData\Roaming\OpenOffice\d\user\templat
Temporary files C\Users\fxcampos\AppData\Local\Temp

< >

Default Edit...

Figure 8: Viewing the paths of files used by AOO

Color Options

On the OpenOffice—Colors page, you can specify colors to use in AOO documents.
You can select a color from a color table, edit an existing color, or define new colors.
These colors will then be available in color selection palettes in AOO.

10 | Chapter 2 Setting up Writer



Properties

Name Blue classic Add
Color “:| Blue classic > ‘ Modify
Color table .
IS | [ [ [ ] |
- J-.---IEJJ [ RGB v Delete...
EEEOEEN 1000 —
W[ [ ] [ (O [ r—
 /AEEEEEN " AE | . =
T T T LT O ——
ANEEEEEEEEE = =
T T LT T R —
- HEERTEEER = O = =
/AN EEE Wm0
EOmCmEl 100
OO CREIE O]
am | e [ [ .

AN H N Em v

Figure 9: Defining colors to use in color palettes in AOO

To modify a color:
1) Select the color to modify from the list or the color table.

2) Enter the new values that define the color. If necessary, change the settings
from RGB (Red, Green, Blue) to CMYK (Cyan, Magenta, Yellow, Black) or vice
versa. The changed color appears in the lower of the two color preview boxes
at the top.

3) Modify the Name as required.

4) Click the Modify button. The newly defined color is now listed in the Color
table.

Alternatively, click the Edit button to open the Color dialog, shown in Figure 10. Here
you can select a color from the color window in the upper area, or you can enter
values on the right using your choice of RGB, CMYK, or HSB (Hue, Saturation, and
Brightness) values.

The upper color window is linked directly with the color input fields; as you choose a
color in the upper window, the numbers change accordingly. The two color fields at
the bottom show the appearance of the adjusted color on the left and the original
color on the right.

Modify the color components as required and click OK to exit the dialog. The newly
defined color now appears in the lower of the color preview boxes shown in Figure 9.
Type a name for this color in the Name box, then click the Add button. A small box
showing the new color is added to the Color table.
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Color Picker X
RGB
© Red 207 =
' Green 231 :
< Blue 245 >
Hex # cfe7f5
ofO HsB -
®  Hue 202° =
' Saturation 16 % =
Brightness 96 % =
CMYK-
Cyan 16 % =
. Magenta 6% =
= Yellow 0% :
Key 4% -

Figure 10: Editing colors

Another way to define or alter colors is through the Colors page of the Area dialog,
where you can also save and load palettes, a feature that is not possible here. In
Writer, draw a temporary draw object and use the context menu of this object to open
the Area dialog.

Font Options

You can define replacements for any fonts that might appear in your documents. If
you receive from someone else a document containing fonts that you do not have on
your system, AOO will substitute fonts for those it does not find. You might prefer to
specify a different font from the one the program chooses.

On the OpenOffice—Fonts page:
1) Select Apply Replacement Table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do
not have this font on your system, it will not appear in the drop-down list in
this box, so you need to type it in.)

3) In the Replace With box, select a suitable font from the drop-down list of
fonts installed on your computer.

4) The check mark to the right of the Replace with box turns green. Click on this
check mark. A row of information now appears in the larger box below the
input boxes. Select the boxes under Always and Screen.

5) In the bottom section of the page, you can change the typeface and size of the
font used to display source code such as HTML and Basic (in macros).
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Apply replacement table

Fent Replace with
Helvetica |E| Arial |E| ]
Always Screen only | Font Replace with
Helvetica Arial -

m

1

Font settings for HTML, Basic and 5L sources

Fonts |Autnmatic IZH
Mon-proportional fonts only
Size 10 [+

Figure 11: Defining a font to be substituted for another font

Security Options

Use the OpenOffice—Security page to choose security options for saving documents

and for opening documents that contain macros.

Security options and warnings

Adjust security related options and define warnings for hidden
information in documents.

Dptions...

Passwords for web connections
["] Persistently save passwords for web connections

Protected by a master password (recommended)

Passwords are protected by a master password. You will be asked to
enter it once per session, if 00o-dev retrieves a password from the
protected password list.

Connections...

Master Password...

Macro security

Adjust the security level for executing macros and specify trusted
macro developers.

Macro Security...

Figure 12: Choosing security options for opening and saving documents

Security Options and warnings

If you record changes, save multiple versions, or include hidden information or
notes in your documents, and you do not want some recipients to see that
information, you can set warnings to remind you to remove it, or you can have
AOO remove some of it automatically. Note that (unless removed) much of this
information is retained in a file whether the file is in OpenOffice’s default
OpenDocument format, or has been saved to other formats, including PDF.
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Click the Options button to open a separate dialog with specific choices (Figure
13).

Remove personal information on saving. Select this option to always remove
user data from the file properties when saving the file. To manually remove
personal information from specific documents, deselect this option and then use
the Delete button under File > Properties > General.

Security options and warmings |£|

Security warnings

Warn if docurnent contains recorded changes, versions, hidden information or notes:

When saving or sending | When signing
When printing When creating POF files

Security options

Remove perscnal information on saving
Recommend password protection on saving

| Ctrl-click required to follow hyperlinks

Ok | | Cancel | | Help

ILTigure 13: Security options and warnings dialog box

Ctri-click required to follow hyperlinks. Many people find creating and editing
documents easier when accidental clicks on links do not activate the links.

The other options on this dialog should be self-explanatory.

Macro security
Click the Macro Security button to open the Macro Security dialog, where you
can adjust the security level for executing macros and specify trusted sources.

Appearance Options

Writing, editing, and (especially) page layout are often easier when you can see the
page margins (text boundaries), the boundaries of tables and sections, grid lines, and
other features. In addition, you might prefer to use colors that are different from
AOQ'’s defaults for such items as note indicators or field shadings.

On the OpenOffice—Appearance page, you can specify which items are visible, and
the colors used to display various items.

e To show or hide items such as text boundaries, select or deselect them.

* To change the default colors for items, click the down-arrow in the Color
setting column by the name of the item and select a color from the pop-up box.

* To save your color changes as a color scheme, type a name in the Scheme box
and click Save.
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Color scheme

Scheme OpenOffice i ‘ Save... Delete

Custom colors

On |User interface elements ‘Color setting ‘Preview ‘

General P

Document background “:| Automatic ¥ ‘

I Text boundaries “:l Automatic, v ‘
Application background “:| Automatic ‘

Object boundaries “:| Automatic ¥ ‘
OTable boundaries “:| Automatic v ‘

Font color “:I Automatic ‘ -
OUnvisited links “:| Automatic v ‘ -

O Visited links /. . .71 s

Figure 14: Showing or hiding text, object, and table boundaries

Choosing Options for Loading and Saving Documents

You can set the Load/Save options to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion
symbol (+ sign or triangle) to the left of Load/Save.

Options - Load/Save

# OpenOffice

=
General iZ Load/Save

VBA Properties
Microsoft Office

HTML Compatibility This is where you define general settings
Figure 15: Load/Save options

General Load/Save Options

Most of the choices on the Load/Save—General page (Figure 16) are familiar to users
of other office suites. Some items of interest are described below.

Load user-specific settings with the document
When you save a document, certain settings are saved with it. Some settings
(printer name, data source linked to the document) are always loaded with a
document, whether this option is selected. If you select this option, these
document settings are overruled by the user-specific settings of the person who
opens it. If you deselect this option, the user’s personal settings do not overrule
the settings in the document. For example, your choice (in the options for AOO
Writer) of how to update links is affected by the Load user-specific settings
option.
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Load
| Load user-specific settings with the document

| Load printer settings with the document

Save
Edit document properties before saving

| Always create backup copy

| Save AutoRecovery information every 15 = Minutes
| S5ave URLs relative to file system

| Save URLs relative to internet

Default file format and ODF settings
ODF format version 1.2 Extended (recommended) IZ”

| Size optimization for ODF format
| Warn when not saving in ODF or default format

Document type Always save as

Text document Iz” |GDFTE:¢I: Document Iz”

Figure 16: Choosing Load and Save options

Load printer settings with the document
If this option is not selected, the printer settings that are stored with the
document are ignored when you print it using the Print File Directly icon. The
default printer in your system is used instead.

Edit document properties before saving
If this option is selected, the Document Properties dialog pops up to prompt you to
enter relevant information the first time you save a new document (or whenever
you use Save As).

Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information
used by the AutoRecovery process. AutoRecovery in OpenOffice does not
overwrite the original file; it saves a temporary version.

Note Using this option is not a substitute for regularly saving your
work.

Save URLs relative to file system / internet
Relative addressing to a file system is only possible if the source document and
the referenced document are both on the same drive. A relative address always
starts from the directory in which the current document is located. It is
recommended to save relatively if you want to create a directory structure on an
Internet server.

Default file format and ODF settings
ODF format version. OpenOffice by default saves documents in Open Document
Format (ODF) version 1.2. This format has been the default for many years and
only very old versions of OpenOffice or other software would not be able to handle
such documents.
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Size optimization for ODF format. OpenOffice's documents are XML files.
When you select this option, AOO writes the XML data without indents and line
breaks. If you want to be able to read the XML files in a text editor in a structured
form, deselect this option.

Document type. If you routinely share documents with users of Microsoft Word,
you might want to change the Always save as attribute for text documents to one
of the Word formats.

Note Although Writer can open files in the .docx format produced by
Microsoft Word, it cannot save in .docx format.

VBA Properties Load/Save Options

On the Load/Save—VBA Properties page, you can choose whether to keep any macros
in Microsoft Office documents that are opened in OpenOffice. These macros are
disabled in AOO.

If you choose Load Basic code, you can edit the macros in AOO. The changed code
is saved in an AOO document but is not retained if you save into a Microsoft Office
format.

If you choose Save original Basic code, the macros are retained unchanged if you
save the file into Microsoft Office format.

Save original Basic code takes precedence over Load Basic code. If both options
are selected, and you edit the disabled code in AOO, the original Microsoft Basic code
will be saved when saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect
Save original Basic code. The document will be saved without the Microsoft Basic
code.

Microsoft Waord 97/2000/XP
Load Basic code

Save original Basic code

Microsoft Excel 97/2000/XP
Load Basic code

[] Executable code
Sawve original Basic code

Microsoft PowerPoint 97/2000/XP
Load Basic code

Save original Basic code
Figure 17: Choosing Load/Save VBA
Properties
Microsoft Office Load/Save Options

On the Load/Save—Microsoft Office page, you can choose what to do when importing
and exporting Microsoft Office OLE objects (linked or embedded objects or
documents such as spreadsheets or equations).
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Select the [L] check boxes to convert Microsoft OLE objects into the corresponding
OpenOffice OLE objects when a Microsoft document is loaded into AOO (mnemonic:
“I for “load”).

Select the [S] check boxes to convert OpenOffice OLE objects into the corresponding
Microsoft OLE objects when a document is saved in a Microsoft format (mnemonic:
“S” for “save”).

[L] [5]

] B MathType to OpenOffice Math or reverse A~
a O  WinWord to OpenOffice Writer or reverse

a O  Excel to OpenOffice Calc or reverse

a O  PowerPoint to OpenOffice Impress or reverse

[L]: Load and convert the object
[S]: Convert and save the object

Figure 18: Choosing Load/Save Microsoft Office options

HTML Compatibility Load/Save Options

Choices made on the Load/Save—HTML Compatibility page affect HTML pages
imported into OpenOffice and those exported from AOO. See HTML documents;
importing/exporting in the Help for more information.

Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to
<font size=7> tags, if they are used in the HTML pages. (Many pages no longer
use these tags.)

Import—Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands
separator characters differ according to the locale of the HTML page. The
clipboard, however, contains no information about the locale. If this option is not
selected, numbers will be interpreted according to the Language—Locale setting
in Tools > Options > Language Settings > Languages (see page 31). If this
option is selected, numbers will be interpreted as for the English (USA) locale.
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Font sizes Import

FY D ' i '
Size 1 7 : Use "English (USA)' locale for numbers
= O Import unknown HTML tags as fields
Size 2 10 =
Olgnore font settings
Size 3 12 =
= Export
Size 4 14 =
OpenOffice Writer M
Size 5 18 =
[ OpenOffice Basic
Size 6 24 = . .
= Display warning
Size 7 36 =

O Print layout

[ Copy local graphics to Internet

Character set ‘Western Europe (Windows-1252/

Figure 19: Choosing HTML compatibility options

Import—Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by AOO to be imported
as fields. For an opening tag, an HTML ON field will be created with the value of
the tag name. For a closing tag, an HTML OFF will be created. These fields will
be converted to tags in the HTML export.

Import—Ignore font settings
Select this option to have AOO ignore all font settings when importing. The fonts
that were defined in the HTML Page Style will be used.

Export
To optimize the HTML export, select a browser or HTML standard from the
Export box. If OpenOffice Writer is selected, specific OpenOffice Writer
instructions are exported.

Export—OpenOffice Basic
Select this option to include AOO Basic macros (scripts) when exporting to HTML
format. You must activate this option before you create the OpenOffice Basic
macro; otherwise the script will not be inserted. OpenOffice Basic macros must be
located in the header of the HTML document. Once you have created the macro in
the OpenOffice Basic IDE, it appears in the source text of the HTML document in
the header.

If you want the macro to run automatically when the HTML document is opened,
choose Tools > Customize > Events.

Export—Display warning
When the OpenOffice Basic option (see above) is not selected, the Display
warning option becomes available. If the Display warning option is selected,
then when exporting to HTML a warning is shown that OpenOffice Basic macros
will be lost.

Export—Print layout
Select this option to export the print layout of the current document as well.
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The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing
documents. These capabilities are only effective if print layout export is activated.

Export—Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet
server when uploading using FTP.

Export—Character set
Select the appropriate character set for the export.

Choosing Options for Writer

Settings chosen on the pages in the OpenOffice Writer section of the Options dialog
box determine how your Writer documents look and behave while you are working on
them.

If the Options dialog box is not already open, click Tools > Options.

Click the expansion symbol (+ sign or triangle) by OpenOffice Writer on the left-hand
side of the Options—OpenOffice dialog box. A list of pages appears.

OpenOffice
Load/Save ' . .
= OpenOffice Writer

Language Settings

OpenOffice Writer

General

0D 8B B H

View This is where you specify various settings for text docui
Formatting Aids your text documents are handled in OpenOffice and an
Grid documents. You can also define a few settings for the ¢
Basic Fonts (Western) afterwards.

Print

Table

Changes
Compatibility
AutoCaption

Mail Merge E-mail
Figure 20: OpenOffice Writer options

General Options

The choices on the OpenOffice Writer—General page affect the updating of links and
fields, the units used for rulers and other measurements, and the default tab stop
positions.

Update links when loading
Depending on your work patterns, you may not want links to be updated when you
load a document. For example, if your file links to other files on a network, you
won’t want those links to update when you are not connected to the network.
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Update

Update links when loading Automatically
Always | Fields
@ On request | Charts
Mewver
Settings
Measurement unit |Ir1ch IE”
Tab stops 0.25" =

Figure 21: Choosing general options for Writer

Update fields and charts automatically
You may not want fields or charts to update automatically when you are working,
because that slows down performance.

Settings—Tab stops
The Tab stops setting specifies the distance the cursor travels for each press of
the Tab key. This setting is also used for the indent distance applied by the
Increase Indent and Decrease Indent buttons on the Formatting Bar, which
affect the indentation of entire paragraphs.

Using the default tab stops to space out or indent material on a page is not
recommended. If you use the default tab interval and then send the document to
someone who uses a different default tab interval, then your tabbed material will
be displayed using the other person’s default tab settings. In addition, any
changes to the default tab stops will change the existing default tab stops in any
document you open afterward, as well as tab stops you insert after making the
change.

To avoid these unwanted changes, define your own tabs in paragraph styles or
individual paragraphs (see “Defining your own tab stops and indents” in Chapter
3, Working with Text).

View Options

Two pages of options set the defaults for viewing Writer documents: View (described
here) and Formatting Aids (described below).

If the items on the OpenOffice Writer—View page are not self-explanatory, you can
easily test their effects in a blank document.

This is a good page to check if, for example, you cannot see graphics on the screen,
or you see field codes instead of the text or numbers you are expecting.
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Guides View

[] Guides while maving Horizontal scrollbar

Simple handles [¥] Vertical scrollbar
[] Large handles Ruler

Display Herizontal ruler m
ﬁraphics and ohjects [¥] Vertical ruler m
Tables [ Smooth scroll
Drrawings and controls
[ Field codes

Comments
Figure 22: Choosing View options for Writer

Formatting Aids Options

The display of symbols such as paragraph ends and tabs helps you when writing,
editing, and doing page layout. For example, you might want to know if any blank
paragraphs or tabs are included or if any tables or graphics are too wide and intrude
into the margins of the page.

On the OpenOffice Writer—Formatting Aids page, select the required options.

Display of Direct cursor
Paragraph end U Direct cursor

Custom hyphens

Spaces

Non-breaking spaces

Tabs
Breaks
Hidden text

L] Fields: Hidden text

Insert

® Paragraph alignment
' Left paragraph margin
> Tabs

' Tabs and spaces

Cursor in protected areas
Enable

O Fields: Hidden paragraphs

Layout assistance
U Math baseline alignment

Figure 23: Choosing Formatting Aids options

22 | Chapter 2 Setting up Writer



Direct cursor lets you enter text, images, tables, frames, and other
objects in any blank area in your document. Writer inserts blank
paragraphs and tabs to position the text or objects.

This feature is incompatible with rigorous use of styles and can lead
to many formatting oddities, so it should be avoided by professional
writers.

Note

Grid Options

Specifying “snap to grid” can be very helpful when you are trying to align several
objects such as graphics or tables.

On the OpenOffice Writer—Grid page, you can choose whether to enable this feature
and what grid intervals to use. If the grid intervals (subdivisions) are too large, you
may find that you do not have enough control in placing the objects.

Grid
[ Snap to grid
[] Visible grid
Resolution Subdivision
Horizontal 039" = Horizontal 5 +1 point(s)
Vertical 039" = Vertical 5 =1 point(s)

Synchronize axes

Figure 24: Choosing Grid options

Chapter 2 Setting up Writer | 23



Default Fonts

The default fonts specified on the OpenOffice Writer—Basic Fonts (Western) page
apply to both Writer documents and HTML (Web) documents.

Basic fonts (Western)

Font Size
Default Times Mew Roman |Z| 12
Heading Arial 14

Caption Times Mew Roman 12

ENpENRENRENREN

Index 12

Tirmes Mew Roman

=]

List Times Mew Roman |Z| 12
=]
=]

Current document only

Default

Figure 25: Choosing default fonts

* If you want to change the defaults, do so on this page. You can, of course,
choose other fonts for use in specific documents, either by applying direct
formatting or by defining and applying styles in those documents.

* When choosing fonts on this page you are not limited to single fonts or to the
ones shown in the drop-down list. You can specify a “font family” as a
comma-separated set of fonts that includes those suitable for Windows,
Macintosh, Linux, and other operating systems. These choices are particularly
important in HTML documents.

e If the document is viewed on a system that does not have the first font
specified, it will use one of the other fonts if that one is available. Otherwise, it
will substitute a font that is available on the system.

* Type the list of fonts, separated by commas, in the boxes. If you want these
defaults to apply to the current document only, select that option. The Default
button resets the values on this page to the defaults installed with OpenOffice.
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Print Options

On the OpenOffice Writer—Print page (Figure 26), you can choose which items are
printed with the document by default. These options are in addition to those on the
OpenOffice—Print page (Figure 7).

Contents Pages Comments
| Pictures and objects | Left pages @ Mone
| Form controls | Right pages Comments only
| Page background Brochure End of document
Print text in black End of page
Hidden text

Text placeholder

Other
| Print automatically inserted blank pages

Paper tray from printer settings

Fax =Monex> IE”

Figure 26: Choosing Print options for Writer

Some considerations:

When you are working on drafts, and you want to save printer ink or toner, you
might want to deselect some items in the Contents section.

The Print text in black selection causes colored text (but not graphics) to
print as black on a color printer; on a black-and-white printer, this option
causes color text to print as solid black instead of shades of gray (dithered).

The Print text in black option has a different effect than the Convert colors
to gray scale on the Options—OpenOffice—Print page (Figure 7), which prints
all graphics as gray scale on color printers. (On black-and-white printers, color
in graphics normally prints as gray scale.)

If you are printing double-sided on a non-duplexing printer, you might choose
to print only left or right pages, then turn the stack over and print the other
pages.

Depending on how your printer ejects pages (face up or face down), you might
need to print the pages in reverse order, so they stack in the correct order as
they are printed.

You can override any of these defaults when printing a document.

Tip Click File > Print, then click the Options button on the Print dialog

box. The Printer Options dialog box that appears is similar to the one
shown in Figure 26.
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Default Table Options
On the OpenOffice Writer—Table page, you can specify the default behavior of tables.

Default Input in tables
Y| Heading ¥ | Mumber recognition
/| Repeat on each page | Mumber format recognition
Do not split V| Alignment
| Border

Keyboard handling

Mowve cells Insert cell
Bow 0.20" = Row 0.20" =
Celumn 0.20" = Column 1.00" =
Behavicr of rows/columns
Eixed Changes affect the adjacent area only
Fixed, proportional Changes affect the entire table
@ Yariable Changes affect the table size

Figure 27: Choosing default Table options

Some considerations:

e If most of your tables will require borders or headings, select those options. If
most of your tables are used for page layout, deselect borders and headings.

* Number recognition can be very useful if most of your tables contain
numerical data; Writer will recognize dates or currency, for example, and
format the numbers appropriately. However, if you want the numbers to
remain as ordinary text, this feature can be quite irritating, so you will want to
deselect it.

* The Keyboard handling section specifies the distances that cells move when
you use keyboard shortcuts to move them and the size of rows and columns
inserted using keyboard shortcuts.

* The choices in the Behavior of rows/columns section determine the effects that
changes to rows or columns have on adjacent rows or columns and the entire
table. You might need to test these selections to fully understand the effects.

Change Tracking Options

If you plan to use the change-tracking feature of Writer, use the OpenOffice Writer—
Changes page to choose the way inserted and deleted material is marked, whether
and how attribute changes are marked, and whether and how change bars are
marked in the margins.
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Text display

Insertions

Attributes [Underfined Bl

Color By author [=] —IM—
Deletions

Attributes Strikethrough [-]

Color By author [=] —Be}e%—
Changed attributes

Attributes Bold [=] .

o By oot = Attributes]
Lines changed

Mark Left margin =] F

Color ' Light red ] = =

Figure 28: Choosing options for tracking changes

Compatibility Options

Do you need to import Microsoft Word documents into AOO Writer? If so, you might
want to select some or all of the settings on the OpenOffice Writer—Compatibility
page. If you are not sure about the effects of these settings, leave them as the
defaults provided by AOO. For information about the settings not described below,
see the Help.

Use printer metrics for document formatting
If this option is selected, the printer specified for the document determines how
the document is formatted for viewing on screen. The line breaks and paragraph
breaks you see on screen match those that apply when the document is printed on
that printer.

This setting can be useful when several people are reviewing a document that will
eventually be printed on a specific printer or when the document is exported to
PDF (a process that uses “Adobe PDF” as the printer).

If this option is not selected, a printer-independent layout will be used for screen
display and printing.
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Compatibility options for writerexpt
Options

| Add spacing between paragraphs and tables (in current document]
Add paragraph and table spacing at tops of pages (in current decurment)
Use OpenOffice.org 1.1 tabstop formatting
Do not add leading (extra space) between lines of text
Use OpenOffice.org 1.1 line spacing
| Add paragraph and table spacing at bottom of table cells
Use OpenOffice.org 1.1 object positioning
Use OpenOffice.org 1.1 text wrapping arcund objects
Consider wrapping style when positioning chjects
Expand word space on lines with manual line breaks in justified paragraphs

Use as Default

Figure 29: Choosing compatibility options

Add spacing between paragraphs and tables (in current document)
In OpenOffice Writer, paragraph spacing is defined differently than it is in MS
Word documents. If you have defined spacing between two paragraphs or tables,
spacing is also added in the corresponding MS Word documents.

If this option is selected, MS Word-compatible spacing is added between
paragraphs and tables in OpenOffice Writer documents.

Add paragraph and table spacing at tops of pages (in current document)
You can define paragraphs to have space appear before (above) them. If this
option is selected, any space above a paragraph will also appear if the paragraph
is at the beginning of a page or column, if the paragraph is positioned on the first
page of the document, or after a manual page break.

If you import an MS Word document, the spaces are automatically added during
the conversion.

Add paragraph and table spacing at bottom of table cells
Specifies that the bottom spacing is added to a paragraph, even when it is the last
paragraph in a table cell.

Use as Default

Click this button to use the current settings on this page as the default in
OpenOffice.
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AutoCaption Options

Do you want AOO to automatically insert captions for tables, pictures, frames, and
OLE objects that have been inserted in a Writer document?

You may not always want captions for every table, for example, if

Note you use tables for layout as well as for tables of data. You can always
add captions to individual tables, graphics, or other objects (right-
click > Caption).

If you do want automatic captions on one or more object types:
1) Choose OpenOffice Writer > AutoCaption on the Options dialog box.

2) On the OpenOffice Writer—AutoCaption page (Figure 30), select the checkbox
next to an object you want to be automatically captioned (Picture in the
example shown).

3) With the item highlighted, specify the characteristics of the caption. The
supplied categories for captions are Drawing, lllustration, Table, and Text.
However, you are not limited to the supplied categories. If you want to use
another name (for example, Figure) for the caption label, type the required
term in the box. In the example shown, I have added the category “Figure” to
the list.

Additional information about numbering captions by chapter, character styles, frame
styles, and other items on the AutoCaption page, is given in later chapters in the
Writer Guide.

Add captions automatically CEIE

when inserting: Category Figure ~
L OpenOffice Writer Table Numbering Arabic (12 3) 4
O OpenOffice Writer Frame

ElOpenOffice Writer Picture Numbering separator

O OpenOffice Spreadsheet

O OpenOffice Chart Separator

O OpenOffice Drawing i

L OpenOffice Presentation e Below ‘

O OpenOffice Formula

Numbering captions by chapter
OOther OLE Objects gcap yehap

Level v

Separator
Caption order Category and frame format
Category first he Character style None v

] O Apply border and shadow
Figure 1:

Figure 30: Setting up a new category for automatic captions on graphics
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Mail Merge E-mail Options

You can produce form letters using Writer and then use the mail merge function to
personalize those letters and send them to a number of addresses taken from a data
source, such as an address book. Mail merged documents can be printed and mailed,

or sent by e-mail.

Use the OpenOffice Writer—Mail Merge E-mail page to set up the user and server
information for sending form letters by e-mail. If you are not sure what information to
put in any of the fields, consult your e-mail program or your Internet service provider.

Uzer information

¥our name
E-Mail address
[ send replies to different e-mail address
BEeply address
Outgoing server (SMTP) Settings
Server name Port | 587

[7] Use secure connection (S5L)

’ Server Suthentication l

’ Test Settings... l

Figure 31: Specifying settings for use when e-mailing mail-merged
form letters

Choosing Options for HTML Documents

You can configure OpenOffice to treat HTML documents in Writer differently than
regular documents.
1) If the Options dialog box is not already open, click Tools > Options.

2) Click the expansion symbol (+ sign or triangle) by OpenOffice Writer/Web on
the left-hand side of the Options—OpenOffice dialog box. A list of pages drops.

Here you can customize settings related to printing, formatting aids, view options,
table defaults, the grid, and a default background for HTML documents you're
working with in Writer.

Many of the options available under Options—OpenOffice Writer/Web

Note are identical to the settings under Options—OpenOffice Writer but
will only affect HTML documents opened in Writer. The previous
sections contain detailed discussion on these options.

30 | Chapter 2 Setting up Writer



Choosing Language Settings

You may need to do several things to set the language settings to what you want:
* Install the required Language Pack
* Install the required dictionaries
* Change some locale and language settings
* Choose spelling options

Install the Required Language Pack

If you need to change the language of the user interface so that menus, dialogs, the
Help files and so on are in a different language than your current installation, you
must download a Language Pack. These are available at the same web page as the
full installation of OpenOffice, https://www.openoffice.org/download/index.html. Choose your
operating system, language, and software version and click the Download language
pack button. A page at SourceForge will automatically open, and the download will
start automatically after a few seconds. Navigate to the folder you saved the
download in and install the Language Pack in the same way that you installed
OpenOffice. The Language Pack does not include a dictionary.

Install the Required Dictionaries

OpenOffice automatically installs several dictionaries with the program. To add other
dictionaries, be sure you are connected to the Internet, and then use Tools >
Language > More Dictionaries Online. AOO will open your default web browser to
a page containing links to additional dictionaries that you can install. Follow the
prompts to select and install the ones you want.

Change Some Locale and Language Settings

You can change some details of the locale and language settings that AOO uses for all
documents or for specific documents.

In the Options dialog box, choose Language Settings > Languages.

Options - Language Settings

# OpenOffice
# Load/Save _
s @  Language Settings
Languages
Writing Aids
® OpenOffice Writer This is where you make settings concerning language and-

Figure 32: OpenOffice language options

On the right-hand side of the Language Settings—Languages page (Figure 33),
change the User interface, Locale setting, Default currency, and Default languages
for documents as required. In the example, English (USA) has been chosen for all the
appropriate settings.

If you want the language (dictionary) setting to apply to the current document only,
instead of being the default for all new documents, select For the current
document only.
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If necessary, select the options to enable support for Asian languages (Chinese,
Japanese, Korean) and support for CTL (complex text layout) languages such as
Hindi, Thai, Hebrew, and Arabic. If you choose either of these options, the next time
you open this page, you will see some extra pages under Language Settings, as
shown in Figure 34. These pages (Searching in Japanese, Asian Layout, and Complex
Text Layout) are not discussed here.

Language of

User interface
Locale setting

Decimal separator key

|Default - English (USA)

B

|Default - English (USA)

B

Same as locale setting ()

Default currency |Defau|t- usD IE”
Default languages for documents

Western "% English (USA) B

Asian | [Mone] |

CTL | [Mone] |

[] For the current document only

Enhanced language support
[] Enabled for Asian languages

[] Enabled for complex text layout (CTL)

Figure 33: Choosing language options

Options - Language Settings

OpenOffice.org

Load/Save

=
Languages
Writing Aids
Searching in Japanese
Asian Layout
Complex Text Layout

@ Language Settings

This is where you make settings concerning |
with OpenOffice.org.

Figure 34: Extra pages available when enhanced language support
options are selected

Choose Spelling Options

To choose the options for checking spelling, choose Language Settings > Writing
Aids. In the Options section of the page, select the settings that are useful for you.
Some considerations:

* If you do not want spelling checked while you type, deselect Check spelling
as you type.

e If you use a custom dictionary that includes words in all uppercase and words
with numbers (for example, AS/400), select Check uppercase words and
Check words with numbers.
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* Check special regions includes headers, footers, frames, and tables when
checking spelling.

Here you can also check which of the user-defined (custom) dictionaries are active, or
you can add or remove dictionaries by clicking the New or Delete buttons.

Writing aids

Available language modules

Hunspell SpellChecker [ Edit... ]
Libhyphen Hyphenatar
OpenOffice.org Mew Thesaurus

Uzer-defined dictionaries

oracle [All] [ Mew... ]

[¥] soffice [Al]

[¥] IgnoreAllList [All] [ Edit... ]
Delete

Options

Check spelling as you type - Edit...

Check gramrnar as you type [=]

[ Check uppercase words B

= Check words with numbers

Check capitalization 18

1] Pl I SR ) [ pu

Figure 35: Choosing languages, dictionaries, and options for checking spelling

OpenOffice does not have a grammar checker, but you can install a

Note grammar checker extension such as LanguageTool and access that
tool from Tools > Spelling and Grammar. See Chapter 14 for more
about installing extensions.

Controlling Writer’s AutoCorrect Functions

Some people find some or all of the items in Writer’s AutoCorrect feature annoying
because Writer changes what you type when you do not want it changed. Many
people find some AutoCorrect functions quite helpful; if you do, then select the
relevant options. But if you find unexplained changes appearing in your document,
this is a good place to look to find the cause.

To open the AutoCorrect dialog box, choose Tools > AutoCorrect Options. (You
need to have a document open for this menu item to appear.) In Writer, this dialog
box has five tabs. Many of the options are described in Chapter 3 (Working with Text)
in this book.
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AutoCorrect X

Replacements and exceptions for language: ‘Eng\ish (USA) N

Replace Exceptions Options Localized Options Word Completion

E

[T]
Use replacement table A
Correct TWo INitial CApitals
Capitalize first letter of every sentence
Automatic *bold* and _underline_
URL Recognition
Replace dashes
Delete spaces and tabs at beginning and end of paragraph
Delete spaces and tabs at end and start of line
O  Ignore double spaces
Apply numbering - symbol: *
Apply border
Create table
O Apply Styles
Remove blank paragraphs
Replace Custom Styles
Replace bullets with: -
Combine single line paragraphs if length greater than 50 % v

B AR A A E R

BEOO

) [M]: Replace while modifying existing text
Edit...
- [T]: AutoFormat/AutoCorrect while typing
Figure 36: The AutoCorrect dialog box in Writer, showing the five tabs and

some of the choices on the Options tab
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