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Choosing options that affect all of OOo

Choosing options that affect all of OOo

This section covers some of the settings that apply to all the components of OpenOffice.org. 
Other general options are discussed in Chapter 5 (Setting Up OpenOffice.org) in the Getting 
Started guide.

1) Click Tools > Options. The list on the left-hand side varies depending on which 
component of OOo is open. The illustrations in this chapter show the list as it appears 
when when OpenOffice.org Impress is open.

2) Click the + sign to the left of OpenOffice.org on the left-hand side. A list of subsections 
drops down.

Note The Back button has the same effect on all pages of the Options dialog. It resets the 
options to the values that were in place when you opened OpenOffice.org.

User Data options
Impress uses the first and last name stored in the User Data page to fill in the Created and 
Modified fields in the document properties, and the optional Author field often used in the 
footer of a presentation, so you will want to ensure that your name appears there. To do this:

1) In the Options dialog, click OpenOffice.org > User Data.

2) Fill in the form on the OpenOffice.org – User Data page or delete any existing incorrect 
information.

Print options
Set the print options to suit your default printer and your most common printing method. You 
can change these settings at any time, either through this dialog or during the printing process 
(by clicking the Options button on the Print dialog).

In the Options dialog, click OpenOffice.org > Print.

See Chapter 10 (Printing, e-mailing, exporting, and saving slide shows) for more about the 
options on this page.

Color options
On the OpenOffice.org – Colors page (Figure 1), you can specify colors to use in OOo 
documents. You can select a color from a color table, edit an existing color, or define new 
colors. These colors will then be available in color selection palettes in all components of 
OOo. You can also define colors within Impress, but those colors will not be available to other 
components of OOo.
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Figure 1. Defining colors to use in color palettes in OOo

Appearance options
On the OpenOffice.org – Appearance page (Figure 2), you can specify which items are visible 
and the colors used to display various items.

1) In the Options dialog, click OpenOffice.org > Appearance.

2) The only choice specific to Impress (and Draw) is the color of the grid points. Scroll 
down in the page until you find Drawing / Presentation (see Figure 2).

To change the default color for grid points, click the down-arrow by the color and select 
a new color from the pop-up box.

3) If you wish to save your color changes as a color scheme, click Save, type a name in 
the Scheme box; then click OK.

Figure 2. Changing the color of grid points in Impress and Draw
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Choosing options for Impress

In the Options dialog, click the + sign to the left of OpenOffice.org Impress on the left-hand 
side. A list of subsections drops down. (See Figure 3.)

General options
In the Options dialog, click OpenOffice.org > Impress > General.

Figure 3: Specifying general options for Impress

Text objects section

Allow quick editing sets Impress to immediately switch to the text editing mode when you 
click a text object. You can also activate text editing mode through the Allow Quick Editing 

icon  on the Options toolbar.

Only text area selectable sets Impress to select a text frame when you click on text. In the area 
of the text frame that is not filled with text, an object behind the text frame can be selected. 

You can also activate this mode through the Select Text Area Only icon  on the Options 
toolbar.

New document section

Start with Wizard sets Impress to start with the Presentation Wizard when opening a 
presentation with File > New > Presentation.

Settings section

Use background cache sets Impress to use the cache for displaying objects on the master page. 
This setting speeds up the display. Unmark this box if you want to display changing contents 
on the master page.
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Copy when moving automatically creates a copy when you move, rotate or resize an object 
while holding down the Ctrl key. The original object will remain in its current position and 
size.

Objects always movable lets you move an object with the Rotate tool enabled. If this box is 
not marked, the Rotate tool can only be used to rotate an object.

Unit of measurement determines the unit of measurement for presentations.

Tab stops defines the spacing between tab stops.

Start presentation section

Always with current page specifies that a presentation starts with the current slide. Unmark this 
box to always start a presentation with the first page.

Compatibility section

The settings in this area are valid for the current document only.

Use printer metrics for document formatting applies printer metrics for printing and for 
formatting the display on the screen. If this box is not checked, a printer-independent layout is 
used for screen display and printing.

Add spacing between paragraphs in the current document calculates the paragraph spacing in 
Impress exactly as Microsoft PowerPoint does. Microsoft PowerPoint adds the bottom spacing 
of a paragraph to the top spacing of the next paragraph to calculate the total spacing between 
both paragraphs. Impress normally uses only the larger of the two spacings.

View options
In the Options dialog, click OpenOffice.org > Impress > View.

Figure 4: Specifying view options for Impress
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Alternative display section

If graphics elements are very complex, the screen display may build up a little slower than 
usual. Choosing alternative display options prevents some items from displaying on the screen 
during editing and thus speeds up screen redisplay.

Image placeholders displays only the contour of inserted graphics. You can also use the 

Picture Placeholders icon  on the Options toolbar.

Contour mode displays only the contour of filled drawings, without the fill. You can also use 

the Contour Mode icon  on the Options toolbar.

Text placeholders displays a text window without its text contents. You can also use the Text 

placeholders icon  on the Options toolbar.

Line contour only displays lines and contours as fine lines, ignoring the currently used line 

width. You can also use the Line contour only icon  on the Options toolbar.

Display section

Rulers visible displays the rulers at the top and the left of the work area.

Guides when moving displays dotted guides that extend beyond the box containing the selected 
object and which cover the entire work area, helping you position the object when moving it. 

You can also use the Guides when moving icon  on the Options toolbar.

All control points in Bézier editor displays the control points of all Bézier points if you have 
previously selected a Bézier curve. If this box is not marked, only the control points of the 
selected Bézier points will be visible.

Contour of each individual object displays the contour line of each individual object when 
moving the object. This enables you to see if single objects conflict with other objects in the 
target position. If you do not mark this box, Impress displays only a square contour that 
includes all selected objects.

Grid options
The Grid page defines the grid settings for Impress. Using a grid helps you determine the exact 
position of your objects. You can also set this grid in line with the snap grid.

If you have activated the snap grid but wish to move or create individual objects without snap 
positions, you can press the Ctrl to deactivate the snap grid for as long as needed.

In the Options dialog, click OpenOffice.org > Impress > Grid.

Grid section

Snap to grid activates the “snap” function.

Visible grid displays grid points on the screen. These points will not display or print as part of 
a presentation.
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Figure 5: Specifying grid options for Impress

Resolution section

Here you can set the unit of distance for the spacing between horizontal and vertical grid 
points and subdivisions (intermediate points) of the grid.

Synchronize axes changes the current grid settings symmetrically.

Snap section

To snap lines snaps the edge of a dragged object to the nearest snap line when you release the 

mouse button. You can also use the Snap to Guides icon  on the Options toolbar.

To the page margins aligns the contour of the graphic object to the nearest page margin. The 
cursor or a contour line of the graphics object must be in the snap range. You can also use the 

Snap to Page Margins icon  on the Options toolbar.

To object frame aligns the contour of the graphic object to the border of the nearest graphic 
object. The cursor or a contour line of the graphics object must be in the snap range. You can 

also use the Snap to Object Border icon  on the Options toolbar.

To object points aligns the contour of the graphic object to the points of the nearest graphic 
object. The cursor or a contour line of the graphics object must be in the snap range. You can 

also use the Snap to Object Points icon  on the Options toolbar.

Snap range defines the snap distance between the mouse pointer and the object contour. 
Impress snaps to a snap point if the mouse pointer is nearer than the distance selected in the 
Snap range box.
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Snap position section

When creating or moving objects restricts graphic objects vertically, horizontally or diagonally 
(45°) when creating or moving them. You can temporarily deactivate this setting by pressing 
the Shift key.

Extend edges creates a square based on the longer side of a rectangle when the Shift key is 
pressed before you release the mouse button. This also applies to an ellipse (a circle will be 
created based on the longest diameter of the ellipse). When the Extend edges box is not 
marked, a square or a circle will be created based on the shorter side or diameter.

When rotating restricts the rotation of graphic objects within the rotation angle that you 
selected in the When rotating box. If you want to rotate an object outside the defined angle, 
press the Ctrl key when rotating. Release the key when the desired rotation angle is reached.

Point reduction defines the angle for point reduction. When working with polygons, you might 
find it useful to reduce their editing points.

Print options
In the Options dialog, click OpenOffice.org > Impress > Print.

See Chapter 10 (Printing, e-mailing, exporting, and saving slide shows) for more about the 
options on this page.

Figure 6: Specifying print options for Impress
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Customizing the user interface

Customizing the menu font
If you want to change the menu font from that supplied by OOo to the system font for your 
operating system, do this:

1) Choose Tools > Options > OpenOffice.org > View.

2) Check Use system font for user interface and click OK.

Customizing menu content
You can customize menus in OpenOffice.org. 

1) Choose Tools > Customize.

2) On the Customize dialog, pick the Menus page (Figure 7).

Figure 7. The Menus page of the Customize dialog
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3) In the Save In drop-down list, choose whether to save this changed menu for Impress or 
for a selected document.

4) In OpenOffice.org Impress Menus, select the menu you want to customize in the 
Menu drop-down list.

5) You can customize each menu by clicking on the Menu or Modify buttons.

6) You can add commands in a menu by clicking on the Add button.

7) You can create a new menu by clicking on the New button.

8) When you are done customizing menus, click OK to save your changes.

Customizing toolbars

Figure 8. The Toolbars page of the Customize window
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1) Open the Toolbars page of the Customize dialog (Figure 8) in one of these ways:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize 
Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize > Toolbars tab from the menu bar.

2) In the Save In drop-down list, choose whether to save this changed toolbar for Impress 
or for a selected document.

3) In the OpenOffice.org Impress Toolbars section, choose the toolbar you want to 
modify, or click on the New button to create a new toolbar.

4) Click the Toolbar button on the right to display a drop-down list of choices.

5) To display or hide commands, select or deselect the checkboxes in the Toolbar Content 
– Commands section.

6) To change the position of commands on a toolbar, select a command and click the big 
up and down arrows to the right of the lists.

7) To add commands to a toolbar, click the Add button on the right. The Add Commands 
dialog opens. Follow the instructions on this dialog and then click Add to return to the 
Customize dialog.

8) When you are done customizing menus, click OK to save your changes.

Customizing keyboard shortcuts 
The Appendix to this book lists the default keyboard shortcuts supplied with Impress. You can 
change these defaults or add new shortcuts. You can assign shortcuts to standard Impress 
functions or your own macros and save them for use with Impress only, or with the entire 
OpenOffice.org suite.

Caution Be careful when reassigning your operating system’s or OOo’s predefined shortcut 
keys. Many key assignments are universally understood shortcuts, such as F1 for 
Help, and are always expected to provide certain results. Although you can easily 
reset the shortcut key assignments to the OOo defaults, changing some common 
shortcut keys can cause confusion, frustration and possible data loss or corruption, 
especially if other users share your computer.

As an example, suppose you wish to assign a shortcut key to easily insert a duplicate slide in 
your presentation. You could assign the Insert key as a logical shortcut for this purpose, as 
described below:

1) Choose Tools > Customize.

2) On the Customize dialog, pick the Keyboard page (Figure 9).

3) As the shortcut key assignment is only relevant with Impress, and not OpenOffice.org in 
general, select the Impress button (at the upper right corner of the Keyboard tab).
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4) Next select Insert in the Category list and Duplicate Slide in the Function list.

5) Now select the shortcut key Insert in the Shortcut keys list and click the Modify button 
at the upper right.

6) Click OK to accept the change. Now the Insert shortcut key will insert a duplicate slide 
immediately after the currently selected slide.

Notes 1. All existing shortcut keys for the currently selected Function are listed in the 
Keys selection box. Since there was no currently assigned shortcut for the 
Insert > Duplicate Slide function the Keys list was empty. If it had not been, and 
you wished to reassign a shortcut key combination that was already in use, you 
would first have had to Delete the existing Key.

2. Shortcut keys that are greyed-out in the listing on the Customize dialog, such as 
F1 and F10, are not available for reassignment.

Figure 9: Customizing keyboard shortcuts
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Saving changes to a file

Changes to the shortcut key assignments (and other configurations) can be saved in a keyboard 
configuration file for use at a later time, thus permitting you to create and apply different 
configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button near the 
bottom right of the Customize dialog.

2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an 
existing file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog will appear if you are about to overwrite an existing 
file, otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the 
Load button near the bottom right of the Customize dialog, and then select the configuration 
file from the Load Keyboard Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button near the 
bottom right of the Customize dialog. Use this feature with care as no confirmation dialog will 
be displayed; the defaults will be set without any further notice or user input.

Running macros from key combinations

You can also define shortcut key combinations that will run macros. These shortcut keys are 
strictly user-defined; none are built in. For information on macros, see Chapter 17 (Getting 
started with macros) in the Getting Started guide.
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