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Positioning objects with zoom

Positioning objects with zoom

With zoom you can place objects with higher precision (Figure 1).

Figure 1: Using zoom to place objects with greater precision

Zoom adjustments using the status bar
The current zoom value is displayed in the status bar.

Figure 2: Zoom level on the status bar

A double-click on the zoom value opens the Zoom dialog (see Figure 3), from which you can change 
the zoom factor (right-clicking opens a more limited selection list).

Figure 3: Selecting a zoom factor

You can enter a zoom factor in the Variable field, select from one of the preset zoom values, or use 
one of the three other choices:

• Entire Page: The entire page is displayed on the monitor, reduced in size if necessary 
to fit.

• Page Width: The right and left page edges are set to the vertical edges of the monitor.

• Optimal: The drawing (or selected object)—not the page—is enlarged to just fit in the 
Draw window.
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Positioning objects with zoom

Figure 4: Zoom values - Entire Page, Page Width, Optimal

The Zoom toolbar
The Zoom toolbar provides additional zoom options. On the Standard toolbar (View > Toolbars > 
Standard), click on the downwards arrow of the Zoom button . You can also permanently 
display the toolbar by clicking on View > Toolbars > Zoom.

Figure 5: Zoom Toolbar

Enlarges the monitor picture. First click on the button, then on the object. 
Alternatively drag to create a zoom “window”.

Makes the monitor picture smaller. Just click on the button.

Zooms objects to their original size.

Changes between the last zoom factors.

Shows the entire page.

Zooms to page width.

Zooms all objects of the drawing to Optimal.

Zooms the selected object to Optimal.

Enables moving the drawing inside the Draw window, using the mouse.

Positioning objects with snap functions

In Draw, objects can be positioned to grid points, to special snap points and lines, to object frames, to 
single object points, or to page edges. This function is known as Snap. In this manner objects can be 
very accurately positioned in a drawing.

If you want to use the snap function, it is much easier to work with the highest practical zoom value. 
It is possible to use two different snap functions at the same time, for example snap to a guide line 
and to the page edge. It is best, however, to activate only those functions that you really need.

Examples for setting up the snap functions are found in Chapter 10 (Advanced Draw Techniques).
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Positioning objects with snap functions

Snap to grid
Use this function to move an object exactly to a grid point (see Figure 6). This function can be 
switched on and off with View > Grid > Snap to Grid and on the Options toolbar with the icon .

Figure 6: Exact positioning with the snap to grid function

Showing the grid
Make the grid visible under View > Grid > Display Grid. Alternatively turn the grid on and off with 
the icon  on the Options toolbar.

Changing the color of the grid points
By default the grid points are bright gray and not too easy to see. Go to Tools > Options > 
OpenOffice.org > Appearance. In the Drawing / Presentation section, you can change the color of 
the grid points (see Figure 7). On the Color Settings pulldown menu select a more suitable/visible 
color, for example black.

Figure 7: Changing the color of the grid points

Configuring the grid
Under Tools > Options > OpenOffice.org Draw > Grid you can change the settings of the grid 
(Figure 8).

No adjustment is necessary in the Grid field, for these settings can be changed directly from the 
icons on the Options toolbar.
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Positioning objects with snap functions

Figure 8: Configuring the grid

Resolution: sets the horizontal and vertical distance between two grid points (see Figure 9).

Figure 9: Grids with different resolutions

Subdivisions: determines how many steps there are between adjacent grid points. Intermediate steps 
make it possible to have a larger separation between two grid points, so the drawing remains clearer 
(see Figure 10). Objects can snap to intermediate points in exactly the same way as grid points.

Figure 10: Grid with intermediate steps (subdivisions)

The other settings are largely self-explanatory. One important setting is the field Snap range. Grid 
points and guiding lines are both optical help elements that are managed separately by Draw. If you 
have activated a snap function and then move an object, Draw looks in the vicinity of the position of 
the object for those special help elements. This determines the final position of the object, and with 
the snap range setting you can determine the extent of this search area. Exactly how large the snap 
area is depends on the current environment: which particular snap functions are in use, how the grid 
is configured, and whether or not there may be collisions with other objects. It is usually necessary to 
do a little experimenting to find what best suits your needs.
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Positioning objects with snap functions

Snap to Snap objects (snap lines and snap points)
Snap lines run horizontal or vertical and appear are dashed lines. Snap points appear as small 
crosses, again with dashed lines.

Note In Version 2 of OOo the name of the buttons in the Options toolbar are “Display 
Guides” and “Snap to Guides” when what is actually meant is “Display Snap line” 
and “Snap to Snap line”. These will be corrected in subsequent versions.

If you have activated this function, you can position objects exactly. Horizontal and vertical snap 
lines can be used together. Snap lines are not active immediately after inserting them but are turned 
on (or off) using the  icon or with the View menu. If the snap line is no longer needed you can 
hide it (or subsequently display it again) with the Display Guides icon  or using the View menu.

Figure 11: Objects ‘connected’ to snap lines (left) or to a snap point (right). Note 
that the snap point functions as if it were the intersection of two snap lines.

Inserting a snap line with the mouse
To insert a snap line in a drawing:

1) Hover the mouse cursor over either ruler.

2) Click and hold the right mouse button.

3) Drag the mouse into the drawing area to produce a snap line.

The snap line can at any time be moved with the mouse. Moving a snap line will not, however, move 
any objects that have been snapped to that line.

Inserting snap points and snap lines using coordinates
The command Insert > Snap point / line opens a dialog (Figure 12) where you can specify X and Y 
coordinates and choose the type of snap object: point, vertical line, or horizontal line.
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Positioning objects with snap functions

Figure 12: Setting a) snap object type and 
b) snap object position using X,Y coordinates

Editing snap points and snap lines
All snap objects can be edited after setting them. If you right-click on a snap object, an appropriate 
menu opens. This menu contains a number of possible commands, including Delete.

Snap to page edge
With this function you can snap objects to the page edge (Figure 13). A combination with snap lines 
and snap to grid is also possible.

Figure 13: Objects positioned on the page margins

Snap to object frame
With this function you can position one drawing object on the frame of another. The connection point 
can lie anywhere on the object frame. If you want to use this function, you should deactivate Snap to 
grid. Figure 14 shows some examples of this function. Note that a typical object frame ‘touches’ the 
frame of a round object at only one of four points.
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Positioning objects with snap functions

Figure 14: Objects positioned on the frame of another object

Snap to object points
This function operates in a similar manner to the one just described. The difference is that the 
connection point can lie only at one of the four corner points of both the object being moved and the 
target object. This leads to the situation where two round objects have a 'connection point' which 
does not lie on either object but at one of the red circled points in Figure 15.

Figure 15: Objects connected to the object point of another object

Positioning objects with helper lines
To simplify the positioning of objects it is possible to make visible guiding lines—extensions of the 
edges of the object—while it is being moved. These guiding lines have no snap function.

The guiding lines can be (de-)activated under Tools > Options > OpenOffice.org Draw > View > 

Guides when moving, or by clicking on the  icon on the Options toolbar.
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Positioning objects with snap functions

Figure 16: Working with guiding lines

Drawing to scale

In Draw a drawing is made on a predefined drawing area or canvas. This will usually be in the Letter 
or A4 format depending on your locale settings, and will be output to some “standard” printer that 
you have set up on your computer (usually referred to as the default printer). Depending on the 
actual size of the drawn objects it will often be necessary or convenient to reduce or enlarge the 
drawing by some scaling value. You can specify the scale that you wish to use under Tools > 
Options > OpenOffice.org Draw > General.

The scale and selected unit of measurement are automatically reflected in the rulers, the window 
position and the window size. If you work regularly with scaled drawings, it may be useful to store 
the details in a template that you can call up when you start a new drawing and not have to input the 
various settings every time.

Whether you draw in a 1:1 scale or in another has no effect on the basic drawing operations. Draw 
will automatically calculate the necessary values (for example, dimension lines). The grid spacing is 
independent of drawing scale as the grid is not a drawing element but only an optical drawing aid.

Note If you want to insert elements in a drawing from the Gallery or Clipboard, you 
should draw these to the same scale as you are using for the drawing to ensure the 
proper size ratio is maintained.

Splitting complex drawings on multiple layers

Layers are like transparencies that lie one on top of another on an overhead projector. You can insert 
and extract single layers as desired. For example in architecture the floor plan, heating, and electrical 
wiring can all be on separate layers. With complex drawings this layer technique offers many 
advantages. You can make layers visible or invisible as needed or you can protect a layer from 
further changes while you work.

In Draw three layers are always present by default: Layout, Controls, and Dimension Lines.
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Splitting complex drawings on multiple layers

To change to a layer, click on its tab. Everything which is drawn will be placed on the currently 
selected layer (usually Layout—this is the default layer when you create a new drawing). The 
Controls layer is for control elements (for example icons, pulldowns etc) and is not usually used for 
ordinary drawing elements. The Dimension Lines layer is used whenever you insert a dimension line 
on a drawing (unless the layer is made invisible). Use Insert > Layer to insert a new layer in a 
drawing (Figure 17 left).

Figure 17: Insert and modify layers

Right-click on a layer tab to bring up a menu where you can insert or delete a layer, rename an 
existing layer, or modify a layer. You can change the names of the user-defined layers; the default 
layer names cannot be changed.

If you choose Modify you will see the dialog in Figure 17 right. On the Modify Layer dialog you 
can specify the following properties:

• Visible: If this property is not activated, the layer will not be shown (the layer is 
removed from the stack).

• Printable: If this property is not activated, the layer will not be printed. This is useful 
if you use a ‘draft’ layer for guides or annotations that you use in making the drawing 
but should not appear in the final output.

• Protected: All objects on this layer are protected from deletion, editing, or moving. No 
additional objects can be added to a protected layer. This property is useful when a 
base plan is to be protected while adding a new layer with other details.

Tip Somewhat confusing is the fact that you can move objects on one layer although 
you are working on another layer. To prevent accidentally deleting or moving 
objects on another layer, you should protect that layer.

An example drawing – house plan and furniture
A popular application for programs like Draw is the “moving the furniture” scenario. The floor plan 
of a room or a house is easily drawn with Draw. The simplest way is to draw walls as thick lines. You 
can also draw single rectangles or polygons, place them together, select them and then from the 
right-click menu use Shapes > Merge to make a single figure, then add a hatching pattern. Before 
you do this, you should read the section “Drawing to scale” on page 8.
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Splitting complex drawings on multiple layers

For this example a suitable measurement unit is centimeter. The drawing scale and grid settings will 
depend on the size of the floorplan.

With the field Position and Size you can very easily position and dimension the individual wall 
sections. Watch out that the rectangles completely overlap (see Figure 18) otherwise the merging will 
give uneven edges.

Figure 18: Wall corner from two rectangles. From upper to 
lower: before merging, after merging and after hatching

Figure 19 shows the finished floor plan. In addition, a chest of drawers has been added.

Figure 19: Floorplan with chest of drawers

The body of the chest is drawn on the Layout layer, the pulled-out drawers and the open doors drawn 
as a group and put on a separate user-defined layer (Layer4 in our example). Figure 20 shows how 
this is done. Making the layer with the drawers and doors visible or hidden will show them open and 
closed (see Figure 21). Hidden layers are shown with a colored tab.
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Splitting complex drawings on multiple layers

   
Figure 20: Using layers for different parts of a drawing. (Left) Draw the body of the 
chest on the Layout layer. (Right) Create a new layer and draw the open drawers and 
doors, keeping the Layout layer visible to help you position the additional objects.

   
Figure 21: Making layers visible or hidden. (Left) Hide the Layout layer to see 
what is on Layer4. (Right) Show the Layout layer and hide Layer4 to show chest  
with drawers closed.

Caution If you copy a drawing object to the Clipboard or in the Gallery all layers other than 
the three standard layers (Layout, Controls and Dimension Lines) are ‘lost’ and all 
objects will, by pasting into a new Draw document, be placed on the Layout layer. 
The reconstruction of layers is much easier if you assemble objects on a layer into a 
group before copying.

Changing the layer of a drawing object
Draw has no direct command to change layers. To move an object to another layer, change to the 
new layer, select the desired object or group, and then cut and paste it in position. Watch the status 
bar (here the information field) to follow and check the change in layer. 

You can also click on the object, hold the mouse button pressed for about two seconds to copy the 
object to the Clipboard, and then paste it on the appropriate layer.
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Multi-page document

Multi-page document

Draw documents, like presentation (Impress) documents, can consist of multiple pages. As in 
Impress, tools to manage pages and backgrounds are available.

Pages are automatically named as Slide 1, Slide 2, on so on. This description is relative; if you move 
pages around, they are automatically renumbered. If you want to have fixed slide (page) names, you 
must name them yourself. Page names are useful for working with the Navigator and when you want 
to insert single slides using Insert > File into another document.

Pages area
By default the Pages area is docked on the left of the 
Draw window. It shows every page in the document as a 
small picture. Select a picture from the Pages area and 
the corresponding page is loaded in the main workspace. 
Click on the page to activate it for editing.

The Pages area behaves similar to the Styles and 
Formatting area. Drag on the gray separator line to 
change the width of the Pages pane. Click on the middle 
of this line to show or hide the pane. Double-click with 
the Control key pressed in the upper gray area to dock or 
undock the area, which can be turned into a floating 
window.

In the Pages area you can drag and drop a picture to 
change the order of pages in the document; a black 
horizontal line shows the position where the page will be 
inserted.
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Multi-page document

Using the context menu you can insert or delete pages or 
duplicate pages with copy and paste.

Using page backgrounds
With background pages you set common page settings for multiple pages of the Draw document. 
These include setting the color or graphics of the background, background objects, and fields such as 
page numbering and author.

Note The terms used in this area may not be completely consistent, so that the terms 
Slide – Page and Master – Background – Page template are used more or less 
interchangeably in places. If you look for information in Help, it may serve to use 
alternative search terms.

Creating a page background
Change with View > Master to the Master view and note that a related Master View toolbar opens. If 
this toolbar does not appear, activate it with View > Toolbars. In this toolbar are switches for a new 
background page and to rename the master page. The same functions are available by right-clicking 
on a page picture in the Pages area of the Master view. The button for deleting a master page is only 
available when you select a background page in the Pages area which has not yet been assigned to 
any page.

Figure 22: Master View toolbar

To return to normal mode, click the Close Master View button or View > Normal.

You can edit background pages just like normal pages. With Format > Page > Background you can 
set the color, pattern, or background picture. These settings are specific to each background page. 
You can set in the Master view the size and orientation of the page; such settings apply to all pages.

If you insert drawing objects on a background page, they are visible on all pages that use this 
background page. This a convenient way, for example, to place a logo on every page.
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Multi-page document

Master pages are organized in layers just like normal pages. The layers of normal pages are 
associated with the layer of the same name on the Master page. Accordingly the layers 
Layout/Control/Dimension Lines are considered to be a unit and the Master page layer Background 
objects is associated with them.

With Insert > Fields you can insert the date, time, page number, author and filename. No other fields 
are available. With page number you cannot insert a fixed page number but a variable – only on the 
page itself does the number appear and then determined by the position of the page. The number is 
automatically adjusted if the page is subsequently moved.

Assigning and managing page backgrounds
You can open the Slide Design dialog (Figure 24) in two ways:

• Right-click on the page and choose Page > Slide design (see Figure 23), or

• Look in the bottom right of the status bar to see which background page is considered as the 
current one. Double-click in this field.

Figure 23: Commands on the Page pop-up menu

The Slide Design dialog (Figure 24) shows the available background pages for that page.

Figure 24: Slide design dialog

If the Exchange background page checkbox is selected, the selected background page will be used 
on all pages of the document, not just on the currently active page.

The option Delete unused backgrounds (previous bug fixed in Version 2.3.1 and later) deletes any 
backgrounds (as shown in the Slide Design dialog) that have not been assigned to a page.
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Multi-page document

Click the Load button to open the Load Slide Design dialog (Figure 25). From here you can load 
previously prepared background pages. All Draw and Impress templates can be used for this purpose. 
Note, however, that using Impress templates will bring in only the background and not the other 
elements prepared in Impress.

Figure 25: Load Slide Design dialog

There is no special option to store background pages as templates. Instead you can load a document 
with the desired background page and store this document as a document template with File > 
Template > Store.

Color palette – adding or changing single 
colors

Draw (like all OOo components) uses color palettes for the representation of colors. In addition you 
can customize the color palette to suit your own needs and wishes. You can modify colors in a 
palette, add other colors, or create new color palettes.

Reach these options with Tools > Options > OpenOffice.org > Colors or with Format > Area > 
Colors (tab) (see Figure 26). The latter method allows color palettes to be loaded or to be stored for 
future use. Any modifications made to colors apply only to the currently active palette.

OpenOffice.org always uses internally the RGB color model. For the definition of a color value, 
other methods are also available. The conversion to RGB values is made automatically.

The color values can be input directly as numbers. Choose between the color model RGB (base 
colors Red, Green and Blue) and CMYK (base colors Cyan, Magenta, Yellow and Black, K= Key).

Tip Information about color models can be found under:

http://en.wikipedia.org/wiki/Color_model

The individual color tones are produced with different values of the base colors. The color value can 
be any integer value between 0 and 255. As an example, Red 3 has (in the RGB model) a red value of 
184, a green value of 71 and a blue value of 0. The CMYK color model uses percentages (in this case 
0%, 44%, 72%, and 28% respectively).

By changing these values, you manipulate the color tone. Either enter a number directly or use the 
spinners on the right side of each field. The change in color will be shown in the lower color field 
(see Figure 26). Click the Modify button to apply and store the new setting.

To add a new color to the current palette, enter a new name in the Name field and set the desired 
color values. Click Add. The new color will be added to the end of the palette and stored in the 
currently active palette.
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Color palette – adding or changing single colors

You can also delete colors from a palette. Select the color from the Color pulldown menu and click 
on the Delete button, then on OK to confirm the change.

Figure 26: The Colors tab in the Area dialog

Clicking on the Edit button opens a special dialog to allow setting individual colors (see Figure 27). 
Many more input possibilities are available in this dialog.

In the lower area you can enter values in the RGB and CMYK models as well as the HSB (Hue, 
Saturation and Brightness) model.

The two color fields at lower right show the value of the color as selected (left) and the currently set 
value from the color value fields (right).

Figure 27: Color dialog
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Color palette – adding or changing single colors

The color windows in the upper area permit a direct selection of color without any knowledge of 
color values. The right upper color window is linked directly with the various color model input 
fields; as you choose a color in this window the numbers change accordingly and a preview of the 
color appears in the right of the two color fields (lower right in Figure 27).

If you click OK, the color window is closed and the input field is again active. You can at this stage 
select your previously defined color, as described above, give it a new name and store it by clicking 
the Add button. The old color will then (without any further warning) be overwritten.

Using the Color dialog

Method 1
You can change the current color by modifying the individual color values. It is possible to jump 
from one color model to another during this process. The settings are always calculated and stored 
according to the RGB model, possibly with some slight adjustment to your input values in the other 
models.

With the HSB color model, the color tone of the three parameters Hue 
(possible values from 0 to 359), Saturation (possible values from 0 to 
100) and Brightness (possible values from 0 to 100) is defined. The 
number for the color represents the angle in a color wheel, the other 
two are both percentage values.

Method 2
You can select a new color by clicking on a color in the color window at the upper right of the dialog. 
The chosen color is shown in a black frame. The frame can be dragged with the mouse. If this color 
is not quite right, you can fine tune it as described above in Method 1 by changing the color values.

As you drag the small square you will see the value change in 
the number fields. The CMYK and RGB are more or less self 
explanatory. To make the HSB model a little clearer, some 
additional comments are necessary.

To better understand the working of the HSB model, move the 
frame from left to right and top to bottom. You will see that the 
Hue and Saturation values change from their maximum to their 
minimum (hue by horizontal movement and saturation by 
vertical movement), the brightness remains the same (see 
figure at left). This latter can only be adjusted by inputing a 
value into the number field.

Method 3
The left color window is divided like a chess board into 8 x 8 individual fields, each with a different 
color. Most important are the colors in each of the corner fields. The color red changes stepwise to 
green in the first row, and stepwise to yellow in the first column. The color green in the last column 
changes stepwise to blue.
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Color palette – adding or changing single colors

This window thus contains a stepwise change between each of the four main colors in the corner 
points. If you hover the mouse over a square the RGB value is shown as a tooltip. For example, the 
yellow corner field (lower left) has RGB values of 255, 255 and 0 (full red, full green and no blue).

Click on this yellow field. A frame appears. If you click the -> arrow under the color windows the 
selected color is assigned (see picture below).

You can also change the color fields by changing (one or more) of the corner fields. Click on the 
field you want to change, then set the color with the mouse in the right color window and/or with the 
number fields. When you click now on the <- arrow, the new color will be assigned to the corner 
square you selected (see Figure 26).

Figure 28: Changing the color of a corner square

Cool effects

Duplication
Duplication makes copies of an object while applying a set of changes (such as color or rotation) to 
the duplicates.

Figure 29: Duplication example.

To start duplication, click on an object or group and choose Edit > Duplicate. The Duplicate dialog 
(Figure 30) appears.
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Cool effects

Figure 30: Duplicate dialog.

Choose the number of copies, their separation (placement), rotation, and so on. The choices above 
applied to a blue rectangle produce the result shown in Figure 29.

Cross-fading
Cross-fading transforms one shape into another. The result is a new group of objects including the 
two end points and the intermediate steps.

Figure 31: Cross-fading example

To do a cross-fade, first select two objects.

Figure 32: The two objects selected for cross fading

Then choose Edit > Cross-fading.
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Cool effects

Figure 33: Cross-fading dialog

On the dialog choose the number of increments (transition steps). You probably want to have Cross-
fade attributes and Same orientation both checked. The end result is shown in Figure 31.

Which object goes in front?

How do I tell OpenOffice.org I want  and not ?

If you want  then select  (the object we want in front), right-click and choose Arrange > 

Bring to Front (or press Ctrl + Shift + +). Or select  (the object we want behind), right-click 
and choose Arrange > Send to Back or press Ctrl + Shift + -.
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