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Introduction

This Appendix describes some common customizations that you may
wish to do.

You can customize menus, toolbars, and keyboard shortcuts in
OpenOffice.org, add new menus and toolbars, and assign macros to
events. However, you cannot customize context (right-click) menus.

Other customizations are made easy by extensions that you can install
from the OpenOffice.org website or from other providers.

Customizations to menus and toolbars can be saved in a template.
Note To do so, first save them in a document and then save the document
as a template as described in Chapter 3 (Styles and Templates).

Customizing menu content

In addition to changing the menu font (described in Chapter 2), you
can add and rearrange items on the menu bar, add items to menus, and
make other changes.

To customize menus:

1) Choose Tools > Customize.
2) On the Customize dialog, pick the Menus page (Figure 1).

3) In the Save In drop-down list, choose whether to save this
changed menu for the application (for example, Writer) or for a
selected document.

4) In the section OpenOffice.org <name of the program
(example: Writer)> Menus, select from the Menu drop-down
list the menu that you want to customize. The list includes all the
main menus as well as sub-menus, that is menus that are
contained under another menu. For example, in addition to File,
Edit, View, and so on, there is File | Send and File |Templates. The
commands available for the selected menu are shown in the
central part of the dialog.

5) To customize the selected menu, click on the Menu or Modify
buttons. You can also add commands to a menu by clicking on the
Add button. These actions are described in the following sections.
Use the up and down arrows next to the Entries list to move the
selected menu item to a different position.

6) When you have finished making all your changes, click OK to save
them.
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Figure 1. The Menus page of the Customize dialog

Creating a new menu

In the Customize dialog, click New to display the dialog shown in
Figure 2.

1) Type a name for your new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into
the required position on the menu bar.

3) Click OK to save.
The new menu now appears on the list of menus in the Customize

dialog. (It will appear on the menu bar itself after you save your
customizations.)

After creating a new menu, you need to add some commands to it, as
described in “Adding a command to a menu” on page 7.
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Figure 2: Adding a new menu

Modifying existing menus

To modify an existing menu, select it in the Menu list and click the
Menu button to drop down a list of modifications: Move, Rename,
Delete. Not all of these modifications can be applied to all the entries
in the Menu list. For example, Rename and Delete are not available
for the supplied menus.

To move a menu (such as File), choose Menu > Move. A dialog similar
to the one shown in Figure 2 (but without the Menu name box) opens.
Use the up and down arrow buttons to move the menu into the
required position.

To move submenus (such as File | Send), select the main menu (File) in
the Menu list and then, in the Menu Content section of the dialog,
select the submenu (Send) in the Entries list and use the arrow keys to
move it up or down in the sequence. Submenus are easily identified in
the Entries list by a small black triangle on the right hand side of the
name.

In addition to renaming, you can specify a keyboard shortcut that
allows you to select a menu command when you press Alt+ an
underlined letter in a menu command.

1) Select a menu or menu entry.

2) Click the Menu button and select Rename.
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3) Add a tilde (~) in front of the letter that you want to use as an
accelerator. For example, to select the Save All command by
pressing Alt+V, enter Sa~ve All.

Adding a command to a menu

You can add commands to the supplied menus and to menus you have
created. On the Customize dialog, select the menu in the Menu list and
click the Add button in the Menu Content section of the dialog.

On the Add Commands dialog, select a category and then the
command, and click Add. The dialog remains open, so you can select
several commands. When you have finished adding commands, click
Close. Back on the Customize dialog, you can use the up and down
arrow buttons to arrange the commands in your preferred sequence.

Add Commands B

To add a command to a menu, select the category and then the
command. You can also drag the command to the Cormmands list of
the Menus tab page in the Customize dialog.

Category Commands
A About OOo-dev A Add
AutoPilot: Address Data Sourc
Templates AutoPilot: Presentation Close
Edit Bibliography Database
Options Create HTML Document Hel
BASIC Create Master Docurment D€p
Insert Edit Macros
Documents =] Exit
Format Extended Tips
Controls &% Help
Mavigate © Help Agent
Table Help on Help
Drawing @, Load URL S
Sraphic v < 3

Description

Displays general program information such as version number and copyrights.

Figure 3: Adding a command to a menu

Modifying menu entries

In addition to changing the sequence of entries on a menu or submenu,
you can add submenus, rename or delete the entries, and add group
separators.

To begin, select the menu or submenu in the Menu list near the top of
the Customize page, then select the entry in the Entries list under
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Menu Content. Click the Modify button and choose the required action
from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a
separator line after the highlighted entry.

Customizing toolbars

You can customize toolbars in several ways, including choosing which
icons are visible and locking the position of a docked toolbar, as
described in Chapter 1 (Introducing OpenOffice.org). This section
describes how to create new toolbars and add other icons (commands)
to the list of those available on a toolbar.

To get to the toolbar customization dialog, do any of the following:
« On the toolbar, click the arrow at the end of the toolbar and
choose Customize Toolbar.
« Choose View > Toolbars > Customize from the menu bar.

« Choose Tools > Customize from the menu bar and pick the
Toolbars page (Figure 4).

Menus | Keyboard |Toolbars |Events
OpenOffice, org Writer Toolbars
Toolbar Standard il [ Mew. .. ]
[ Toolbar = ]
Toolbar Content
Commands | 9, Load URL o [ add... ]
E ke 1
4 - [ Madify - |
B || Mew Docurnent From Templat
v | (=2 Open...
v | [H] save
[ Save As..,
v | £ Document as E-mail...,
~
W | [=# Fdit File I
£ >
Save In CpenOffice, arg Wriker w
Description
Creates a new OpenOffice,org document,

Figure 4. The Toolbars page of the Customize dialog
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To customize toolbars:

1)

2)

In the Save In drop-down list, choose whether to save this
changed toolbar for the application (for example, Writer) or for a
selected document.

In the section OpenOffice.org <name of the program

(example: Writer)> Toolbars, select from the Toolbar drop-
down list the toolbar that you want to customize.

3) You can create a new toolbar by clicking on the New button, or

customize existing toolbars by clicking on the Toolbar or Modify
buttons, and add commands to a toolbar by clicking on the Add
button. These actions are described below.

4) When you have finished making all your changes, click OK to save

them.

Creating a new toolbar
To create a new toolbar:

1)
2)

Choose Tools > Customize > Toolbars from the menu bar.

Click New. On the Name dialog, type the new toolbar's name and
choose from the Save In drop-down list where to save this
changed menu: for the application (for example, Writer) or for a
selected document.

f MName ﬁ

Toolbar Name oK

Mew Toolbar 1] l |
Cance l

Save ln
00o-dev Writer v [ Help l

The new toolbar now appears on the list of toolbars in the Customize
dialog. After creating a new toolbar, you need to add some commands
to it, as described below.

Adding a command to a toolbar

If the list of available buttons for a toolbar does not include all the
commands you want on that toolbar, you can add commands. When you
create a new toolbar, you need to add commands to it.

1)

On the Toolbars page of the Customize dialog, select the toolbar
in the Toolbar list and click the Add button in the Toolbar Content
section of the dialog.
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2) The Add Commands dialog is the same as for adding commands to
menus (Figure 3). Select a category and then the command, and
click Add. The dialog remains open, so you can select several
commands. When you have finished adding commands, click
Close. If you insert an item which does not have an associated
icon, the toolbar will display the full name of the item: the next
section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog, you can use the up and down
arrow buttons to arrange the commands in your preferred
sequence.

4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of
the commands have associated icons.

To choose an icon for a command, select the command and click
Modify > Change icon. On the Change Icon dialog, you can scroll
through the available icons, select one, and click OK to assign it to the
command.

rﬁ Change Icon W
lcons
— — l Import... l
SEeRpEUIY=>==HS 0 &
v 00 %2 ) % B8N D oabe o2 EYREEE N | |
Fogev="HHov=wQ [ ¥ ]

L wimd &,
VESEE

i ==
EROV OB

Mote:
The size of anicon should be 16x16 pixel to achieve best quality. Different
sized icons will be scaled automatically.

= =&

& ol

EIII

[ oK ] [ Cancel ] [ Help ]

Figure 5: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into
OOo by clicking the Import button on the Change Icon dialog. Custom
icons must be 16 x 16 or 26 x 26 pixels in size and cannot contain more
than 256 colors.
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Example: Adding a Fax icon to a toolbar
You can customize OpenOffice.org so that a single click on an icon
automatically sends the current document as a fax.
1) Be sure the fax driver is installed. Consult the documentation for
your fax modem for more information.

2) Choose Tools > Options > OpenOffice.org Writer > Print. The
dialog shown in Figure 6 opens.

3) Select the fax driver from the Fax list and click OK.

Contents Pages Comments
Graphics Left pages ¥ None
Tables Right pages ) Comments only
Crawings [] Reversed () End of document
Controls [] Brochure ) End of page
Background
[] Print black

[] Hidden text
[] Text placeholder
Other
Print autormatically inserted blank pages
[[] Create single print jobs

[] Paper tray from pratecsatbiag

=

Fax =None= ) g

Figure 6: Setting up OOo for sending faxes

4) Click the arrow icon at the end of the Standard toolbar. In the
drop-down menu, choose Customize Toolbar. The Toolbars page
of the Customize dialog appears (Figure 4). Click Add.

5) On the Add Commands dialog (Figure 7), select Documents in the
Category list, then select Send Default Fax in the Commands list.
Click Add. Now you can see the new icon in the Commands list.

6) In the Commands list, click the up or down arrow button to

position the new icon where you want it. Click OK and then click
Close.

Your toolbar now has a new icon to send the current document as a
fax.
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Figure 7: Adding a Send Fax command to a toolbar

Assigning shortcut keys

In addition to using the built-in keyboard shortcuts (listed in Appendix
A), you can define your own. You can assign shortcuts to standard OOo
functions or your own macros and save them for use with the entire
OpenOffice.org suite.

Caution

Be careful when reassigning your operating system’s or OO0’s
predefined shortcut keys. Many key assignments are universally
understood shortcuts, such as F1 for Help, and are always
expected to provide certain results. Although you can easily

A reset the shortcut key assignments to the OOo defaults,

changing some common shortcut keys can cause confusion,
frustration and possible data loss or corruption, especially if
other users share your computer.

To adapt shortcut keys to your needs, use the Customize dialog, as
described below.

1)
2)
3)
4)

5)

Select Tools > Customize > Keyboard. The Customize dialog
opens.

To have the shortcut key assignment available in all components
of OpenOffice.org select the OpenOffice.org button.

Next select the required function from the Category and Function
lists.

Now select the desired shortcut keys in the Shortcut keys list and
click the Modify button at the upper right.

Click OK to accept the change. Now the chosen shortcut keys will
execute the function chosen in step 3 above whenever they are
pressed.

12
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All existing shortcut keys for the currently selected Function are
listed in the Keys selection box. If the Keys list is empty, it
indicates that the chosen key combination is free for use. If it
were not, and you wanted to reassign a shortcut key

Note  (ombination that is already in use, you must first delete the
existing key.
Shortcut keys that are greyed-out in the listing on the Customize
dialog, such as F1 and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys

You can configure shortcut keys to quickly assign styles in your
document. Some shortcuts are predefined, such as Ctri+0 for the Text
body paragraph style, Ctri+1 for the Heading 1 style, and Ctri+2 for
Heading 2. You can modify these shortcuts and create your own.

1) Click Tools > Customize > Keyboard. The Keyboard page of the
Customize dialog (Figure 8) opens.

Menus |Keyboard |Toolbars | Events
Shortcut keys () OpenOffice.org
Ctrl+0 Text body Al = e
Ctrl+1 Heading 1 * Wiriter
Ctrl+2 Heading 2
Ctrl+3 Heading 3
Ctrl+4 Heading 4
Ctrl+5 Heading 5 l Delete l
Ctrl+6
Ctrl+7
Ctrl+8
Ctrl+9 List 1 [ Load... l
Ctrl+A -
Ctrl+B Bold l Save... l
Ctrl+C —
Ctri+D Double Underline
Ctrl+F Centerad hd l fecsl l
Functions
Category Function Keys
Mumbering # || | List » | | Cirl+9
Modify List 1
# OpenOffice.org Macrc List 1 Cont.
£l Styles List 1 End
CharacterStyles List 1 Start
ParagraphStyles List 2
FrameStyles List 2 Cont.
PageStyles List 2 End
HumberingStyles List 2 Start
¥ |List 3
< * List 3 Cont. e

Figure 8. Defining keyboard shortcuts for applying styles
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2) To have the shortcut key assignment available only with one
component (for example, Writer), select that component’s name in
the upper right corner of the page; otherwise select
OpenOffice.org button to make it available to every component.

3) Choose the shortcut keys you want to assign a style to. In this
example, we have chosen Ctri+9.

4) In the Functions section at the bottom of the dialog, scroll down
in the Category list to Styles. Click the + sign to expand the list of
styles.

5) Choose the category of style. (This example uses a paragraph
style, but you can also choose character styles and others.) The
Function list will display the names of the available styles for the
selected category. The example shows some of OO0’s predefined
styles.

6) To assign Ctri+9 to be the shortcut key combination for the List 1
style, select List 1 in the Function list, and then click Modify.
Ctrl+9 now appears in the Keys list on the right, and List 1
appears next to Ctri+9 in the Shortcut keys box at the top.

7) Make any other required changes, and then click OK to save
these settings and close the dialog.

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard
configuration file for use at a later time, thus permitting you to create
and apply different configurations as the need arises. To save keyboard
shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save
button near the bottom right of the Customize dialog (Figure 8).

2) In the Save Keyboard Configuration dialog, select All files from
the Save as Type list.
3) Next enter a name for the keyboard configuration file in the

File name box, or select an existing file from the list. If you need
to, browse to find a file from another location.

4) Click Save. A confirmation dialog appears if you are about to
overwrite an existing file, otherwise there will be no feedback and
the file will be saved.

Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing
configuration, click the Load button near the bottom right of the
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Customize dialog, and then select the configuration file from the Load
Keyboard Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the
Reset button near the bottom right of the Customize dialog. Use this
feature with care as no confirmation dialog will be displayed; the
defaults will be set without any further notice or user input.

Assigning macros to events

In OOo, when something happens, we say that an event occured. For
example, a document was opened, a key was pressed, or the mouse
moved. You can associate a macro with an event, so the macro is run
when the event occurs. For example, a common use is to assign the
“open document” event to run a macro that performs certain setup
tasks for the document.

To associate a macro with an event, use the Events page of the
Customize dialog. For more information, see Chapter 13 (Getting
Started with Macros).

Adding functionality with extensions

An extension is a package that can be installed into OpenOffice.org to
add new functionality.

Although individual extensions can be found in different places, the
official OpenOffice.org extension repository is at
http://extensions.services.openoffice.org/. Some extensions are free of
charge; others are available for a fee. Check the descriptions to see
what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In OOo, select Tools > Extension Manager from the menu bar.
In the Extension Manager dialog (Figure 9), click Add.

3) A file browser window opens. Find and select the extension you
want to install and click Open. The extension begins installing.
You may be asked to accept a license agreement.
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4) When the installation is complete, the extension is listed in the
Extension Manager dialog.

To get extensions that are listed in the repository, you can open
Ti the Extension Manager and click the Get more extensions
P here link. You do not need to download them separately as in
step 1 above.

Extension Manager [Z]@
EO English spelling and hyphenation dictionaries and thesaurus 2009,05.058 r_J,im -
E{) French “Classic and Reform 1990" spelling, thesaurus and hyphen... 3.4.1 Dicollecte r_‘r‘

o Professional Template Pack II - English 1.0 Sun Microsyskems
EO The second kemplate pack by Sun Microsyskems provides more than 120 professionally designed
document, spreadsheet, presentation and database templates for professional and stunning loaking
documents and presentations,
Disable ] [ Remowve
EO spanish spelling dictionary Z005.07.01 r_J,im
— Temnlate CThanner 1 7 5 s
Get more extensions onling. ..
[ add... ] [ Check For Updates. .. ] l Close:

Figure 9: Using the Extension Manager

To install a shared extension, you need write access to the

Note OpenOffice.org installation directory.

Using extensions

This section describes a few of the more important and popular
extensions to OpenOffice.org. In each case, you need to first install the
extension as described in the previous section.

PDF Import

Enables you to make minor modifications to the text of existing PDF
files when the original source files do not exist or you are unable to
open the source files. (Whenever possible, modify the source and
regenerate the PDF to obtain the best results.)
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When the extension is installed, PDF is listed as a choice in the File
Type drop-down list in the File > Open dialog.

Best results can be achieved with the PDF/ODF hybrid file format,
which this extension also enables. A hybrid PDF/ODF file is a PDF file
that contains an embedded ODF source file. Hybrid PDF/ODF files will
be opened in OpenOffice.org as an ODF file without any layout
changes.

Non-hybrid PDF documents open in Draw. Depending on the
complexity of the layout, changes may be easy or difficult to make, and
the saved result may or may not preserve the original layout. Font
substitution may occur.

Documents with more sophisticated layouts, such as those created with
professional desktop publishing applications that use special fonts and
complex vector graphics, are not suitable for the PDF Import
Extension. Similarly, longer documents (> 20 pages) may cause some
performance and stability problems.

From Sun Microsystems. Open source.

Presenter Console

Provides extra control over slide shows (presentations); for example,
the presenter has ability to see the upcoming slide, the slide notes, and
a presentation timer—while the audience sees only the current slide.
The Presenter Console displays the elements in three easily
changeable views:

- The first view displays the current slide, including the effects, and
the upcoming slide.

« The second view shows the speaker's notes in large, clear, and
scalable type, plus the current and upcoming slide.

e The third view is a slide sorter view with the slide thumbnails.
From Sun Microsystems. Open source.

The Presenter Console works only on an operating system that

Note supports multiple displays.

Report Builder

Creates stylish, complex database reports from Base. You can define
group and page headers, group and page footers, and calculation
fields. Export your reports into PDF or OpenDocument formats, or
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send them as email attachments. From Sun Microsystems. Open
source.

Professional Template Pack Il

Provides more than 120 templates for Writer, Calc, and Impress.
Available in several languages. After you have installed this extension,
you will find the templates under File > New > Templates and
Documents. From Sun Microsystems. Freeware.

Template Changer

Adds two new items to the File > Templates menu in Writer that
allow you to assign a new template to the current document or to a
folder of documents. All styles and formatting will be loaded from that
template and the document will behave as it was created using that
template. Open source.
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