
Writer Guide

Chapter 33
  Working with Text

Using OpenOffice.org Writer

OpenOffice.org



Copyright
This document is Copyright © 2005–2008 by its contributors as listed in the section titled Authors. 
You may distribute it and/or modify it under the terms of either the GNU General Public License, 
version 3 or later (http://www.gnu.org/licenses/gpl.html), or the Creative Commons Attribution 
License, version 3.0 (http://creativecommons.org/licenses/by/3.0/) or later.

All trademarks within this guide belong to their legitimate owners.

Authors
Agnes Belzunce
Daniel Carrera
Laurent Duperval
Katharina Greif
Peter Hillier-Brook
Michael Kotsarinis
Peter Kupfer
Iain Roberts
Gary Schnabl
Jean Hollis Weber
Michele Zarri

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments
Camillus Gerard Cai did some early work on this chapter, which has since been rewritten.

Publication date and software version
Published 20 May 2008. Based on OpenOffice.org 2.3.1.

You can download an editable version of this document from 
http://oooauthors.org/en/authors/userguide2/published/

mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html
http://oooauthors.org/en/authors/userguide2/published/


Contents

Contents

Copyright................................................................................................................................................i

Authors....................................................................................................................................................i

Feedback.................................................................................................................................................i

Acknowledgments...................................................................................................................................i

Publication date and software version.....................................................................................................i

Introduction.................................................................................................................................................1

Selecting text...............................................................................................................................................1

Selecting items that are not consecutive.................................................................................................1

Cutting, copying, and pasting text...............................................................................................................2

Moving paragraphs quickly.........................................................................................................................3

Finding and replacing text...........................................................................................................................4

Use wildcards (regular expressions).......................................................................................................5

Find and replace specific formatting......................................................................................................6

Find and replace paragraph styles..........................................................................................................7

Inserting special characters..........................................................................................................................7

Inserting dashes and non-breaking spaces..............................................................................................8

Non-breaking spaces.........................................................................................................................8

Non-breaking hyphen........................................................................................................................8

En and em dashes..............................................................................................................................8

Formatting paragraphs.................................................................................................................................8

Setting tab stops and indents................................................................................................................10

Changing the default tab stops interval...........................................................................................11

Formatting characters................................................................................................................................12

Autoformatting..........................................................................................................................................12

Creating numbered or bulleted lists...........................................................................................................14

Using the Bullets and Numbering toolbar............................................................................................14

Example: configuring a nested list..................................................................................................15

Using footnotes and endnotes...............................................................................................................17

Inserting footnotes/endnotes.................................................................................................................17

Defining the format of footnotes/endnotes...........................................................................................18

Checking spelling......................................................................................................................................19

Working with Text i



Contents

Using the thesaurus....................................................................................................................................20

Hyphenating words....................................................................................................................................21

Using AutoCorrect.....................................................................................................................................22

Using word completion.............................................................................................................................23

Using AutoText..........................................................................................................................................24

Line numbering.........................................................................................................................................24

Undoing and redoing changes...................................................................................................................25

Tracking changes to a document...............................................................................................................26

Preparing a document for review..........................................................................................................26

Recording changes...............................................................................................................................27

Inserting notes......................................................................................................................................28

Accepting or rejecting changes and comments.....................................................................................28

Merging modified documents...............................................................................................................30

Comparing documents..........................................................................................................................30

Linking to another part of a document......................................................................................................30

Using hyperlinks...................................................................................................................................31

Using cross-references.........................................................................................................................31

Using bookmarks..................................................................................................................................31

Working with hyperlinks...........................................................................................................................31

Editing hyperlinks................................................................................................................................33

Switching between insert and overwrite mode..........................................................................................33

Counting the words in a selection..............................................................................................................33

Working with Text ii



Introduction

Introduction

This chapter covers the basics of working with text in Writer, the word-processing component of 
OpenOffice.org (OOo). It assumes that you are familiar with the use of a mouse and keyboard and 
that you have read about Writer’s menus and toolbars and other topics covered in Chapter 1 
(Introducing Writer).

We recommend that you also follow the suggestions in Chapter 2 (Setting up Writer) about 
displaying formatting aids, such as end-of-paragraph marks, and selecting other setup options.

When you have read this chapter, you should know how to:

• Select, cut, copy, paste, and move text

• Find and replace text

• Insert special characters

• Format paragraphs and characters

• Create numbered or bulleted lists

• Check spelling, use the thesaurus, and choose hyphenation options

• Use the autocorrection, word completion, autotext, and line numbering features

• Track changes and undo and redo changes

Selecting text

Before you can do anything with text, you need to select it. Selecting text in Writer is similar to 
selecting anything in other applications.

In addition to selecting blocks of text, you can select items that are not consecutive.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 1) using the mouse:

1) Select the first piece of text.

2) Hold down the Control (Ctrl) key and use the mouse to select the next piece of text.

3) Repeat as often as needed.

4) Now you can work with the selected text (copy it, delete it, change the style, or whatever).

Note Macintosh users: substitute the Command key when instructions in this chapter say 
to use the Control key.

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the 
topic “Navigating and Selecting with the Keyboard” in the OpenOffice.org Help (F1) in the 
Help menu.)
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Selecting text

2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD appears on the Status Bar.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the 
Shift key and select the next piece of text.

4) Repeat as often as needed. Now you can work with the selected text.

5) Press Esc to exit from this mode.

Figure 1: Selecting items that are not next to each other

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You 
can copy or move text within a document, or between documents, by dragging or by using menu 
selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web 
pages and paste it into a Writer document.

To move (cut and paste) selected text using the mouse, drag it to the new location and release it. To 
copy selected text, hold down the Control key while dragging. The text retains the formatting it had 
before dragging.

After selecting text, you can use the mouse or the keyboard for these operations.

Cut: Use Edit > Cut or the keyboard shortcut Control+X or the Cut icon on the toolbar .

Copy: Use Edit > Copy or the keyboard shortcut Control+C or the Copy icon .

Paste: Use Edit > Paste or the keyboard shortcut Control+V or the Paste icon .

The result of a paste operation depends on the source of the text to be pasted. If you simply click on 
the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from Web 
sites and other sources may also be placed into frames or tables. If you do not like the results, click 
the Undo icon and try again.

To make the pasted text take on the formatting of the surrounding text where it is to be pasted, 
choose either:

• Edit > Paste Special

• or click the triangle to the right of the Paste icon

• or click the Paste icon without releasing the left mouse button
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Cutting, copying, and pasting text

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending upon the origin and formatting of 
the text (or other object) to be pasted. See Figure 2 for an example with text on the clipboard.

Figure 2: Paste menu

This example includes the formatting option DDE link. DDE is an acronym for Dynamic Data 
Exchange, a mechanism whereby selected data in document A can be pasted into document B as a 
linked, ‘live’ copy of the original. It would be used, for example, in a report written in Writer 
containing time-varying data, such as sales results sourced from a Calc spreadsheet. The DDE link 
ensures that, as the source spreadsheet is updated so is the report, thus reducing the scope for error 
and reducing the work involved in keeping the Writer document up to date.

Moving paragraphs quickly

1) Place the cursor anywhere in the paragraph.

2) Press Control+Alt.

3) Holding the Control+Alt keys down, press the up-arrow or down-arrow key.

The paragraph will move to a new location either before the previous paragraph or after the next 
paragraph in your document. To move more than one paragraph at a time, select at least part of all 
paragraphs (including the end of the first paragraph you want to move and the start of the last) before 
pressing the Control+Alt+arrow keys.

If you are using Solaris, the key combination is Control+AltGr+arrow keys.

Tip If your paragraphs suddenly jumped from one place to another, the most likely 
reason is that you have accidentally pressed one of these key combinations.

Note In some machines  the Control+Alt+arrow key combination is reserved for screen 
flipping. You have to deactivate or assign different key combination for screen 
flipping (usually through display / graphics adapter settings in your computer) 
before using this feature.
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Finding and replacing text

Finding and replacing text

When looking for certain words in a 3000-word essay, it would be inefficient (and close to 
impossible!) to go through every word manually. Writer has a Find and Replace feature that 
automates the process of searching for text inside a document.

In addition to finding and replacing words and phrases, you can:

• Use wildcards and regular expressions to fine-tune a search.

• Find and replace specific formatting.

• Find and replace paragraph styles.

To display the Find & Replace dialog box (Figure 3), use the keyboard shortcut Control+F or select 
Edit > Find & Replace.

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options, such as matching the case, matching whole words only, or 
doing a search for similar words. (See below for some other choices.)

4) When you have set up your search, click Find. To replace text, click Replace instead.

Tip If you click Find All, Writer selects all instances of the search text in the document. 
Similarly, if you click Replace All button, Writer will replace all matches.

Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and 
highly embarrassing) mistakes. A mistake with Replace All might require a manual, 
word-by-word search to fix.

Figure 3: The Find & Replace dialog box
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Finding and replacing text

Use wildcards (regular expressions)
Wildcards (also known as regular expressions) are combinations of characters that instruct OOo how 
to search for something. Regular expressions are very powerful but not very intuitive. They can 
save time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by OOo.

Tip The online help describes many more regular expressions and their uses.

Note To search for a character that is defined as a wildcard, type a backslash (\) before 
the character. For example, to find the text $5.00, you would conduct a search using 
\$5\.00.

To use wildcards and regular expressions when searching and replacing:

1) On the Find & Replace dialog box, click More Options to see more choices. On this 
expanded dialog box (Figure 4), select the Regular expressions checkbox.

2) Type the search text, including the wildcards, in the Search for box and the replacement text 
(if any) in the Replace with box. Not all regular expressions work as replacement characters; 
the line break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not recommended).

Table 1. Examples of search wildcards (regular expressions)

To find
Use this 
expression

Examples and comments

Any single character . b.d finds bad, bud, bid, and bed.

Any string of characters .* b.*d finds bad, brand, and board.

One of the specified 
characters

[xyz] b[iu]n finds bin and bun.

Any single character in 
this range

[x-y] [r-t]eed finds reed, seed, and teed; ranges must 
be in alphabetically ascending order.

Any single character 
except the characters 
inside the brackets

[^x] p[^a]st finds post and pest, but not past.

The beginning of a word \<start \<log finds logbook and logistics, but not 
catalog.

The end of a word end\> log\> finds catalog, but not logistics.

A paragraph marker $ Does not work as a replacement character. Use \n 
instead.

A line break \n Finds a line break that was inserted with Shift
+Enter. When used as a replacement character, it 
inserts a paragraph marker.
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Finding and replacing text

Find and replace specific formatting
A very powerful use of Find & Replace takes advantage of the format option. For example, you 
might want to replace underlined words with italics.

On the Find & Replace dialog box (with More Options displayed, as in Figure 4):

1) To search for text with specific formatting, enter the text in the Search for box. To search for 
specific formatting only, delete any text in the Search for box.

2) Click Format to display the Text Format (Search) dialog box. The tabs on this dialog box are 
similar to those on the Paragraph format and Paragraph Style dialog boxes. Choose the 
formats you want to search for and then click OK. The names of selected formats appear 
under the Search for box. For example, you might search for all text in 14-point bold 
Helvetica.

3) To replace text, enter the replacement text in the Replace with box.

To search for specific text with specific formatting (for example, the word hello in bold), 
specify the formatting, put the text in the Search for box and leave the Replace with box 
blank.

To remove specific character formatting, click Format, select the Font tab, then select the 
opposite format (for example, No Bold). The No Format button on the Find & Replace 
dialog box clears all previously selected formats.

4) Click Find, Find All, Replace, or Replace All.

Figure 4: Expanded Find & Replace dialog box
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Finding and replacing text

Tip Unless you plan to search for other text using those same attributes, click No 
Format to remove the attributes after completing your search. If you forget to do 
this, you may wonder why your next search fails to find words you know are in the 
document.

Find and replace paragraph styles
If you combine material from several sources, you may discover that lots of unwanted paragraph 
styles have suddenly shown up in your document. To quickly change all the paragraphs of one 
(unwanted) style to another (preferred) style:

1) On the expanded Find & Replace dialog box (Figure 4), select Search for Styles. (If you 
have attributes specified, this checkbox is labeled Including Styles.) The Search for and 
Replace with boxes now contain a list of styles.

2) Select the styles you want to search for and replace.

3) Click Find, Find All, Replace, or Replace All.

Inserting special characters

A “special” character is one not found on a standard English keyboard. For example, © ¾ æ ç ñ ö ø ¢ 
are all special characters. To insert a special character:

1) Place the cursor in your document where you want the character to appear.

2) Click Insert > Special Character to open the Special Characters dialog box ().

Figure 5: The Special Characters dialog box, where you can insert special characters.

3) Select the characters (from any font or mixture of fonts) you wish to insert, in order; then 
click OK. The selected characters are shown in the lower left of the dialog box. As you select 
each character, it is shown on the lower right, along with the numerical code for that 
character.
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Inserting special characters

Tip Notice that the characters selected appear in the bottom-left corner of the dialog box.

Note Different fonts include different special characters. If you do not find a particular 
special character you want, try changing the Font selection.

Inserting dashes and non-breaking spaces

Non-breaking spaces
To prevent two words from being separated at the end of a line, press Control+spacebar after the 
first word.

Non-breaking hyphen
You can use a non-breaking hyphen in cases where you do not want the hyphen to appear at the end 
of a line. Examples of non-breaking hyphens are: in a range such as A-Z or the hyphens in a 
telephone number, such as 123-4567. To insert a non-breaking hyphen, press Shift+Control+minus 
sign.

En and em dashes
To enter en and em dashes, use the Replace dashes option under Tools > AutoCorrect > Options 
(Figure 15). This option replaces two hyphens, under certain conditions, with the corresponding 
dash.

Another means of inserting en or em dashes is through the Insert > Special Characters menu. 
Select the U+2013 or U+2014 character, respectively.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 6 
shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for 
paragraph formatting.

Tip It is highly recommended that you use paragraph styles rather than manually 
formatting paragraphs, especially for long or standardized documents. For 
information on the advantages of styles and how to use them, see Chapter 6 
(Introduction to Styles).
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Formatting paragraphs

1 Open Styles and 
Formatting Window

5 Align Right 10 Numbering On/Off
6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1 12 Decrease Indent
3 Align Left 8 Line Spacing: 1.5 13 Increase Indent
4 Centered 9 Line Spacing: 2 14 Paragraph format dialog

Figure 6: Formatting toolbar, showing buttons for paragraph formatting

Figure 7 shows examples of the different alignment options.

Figure 7: Different text alignment options

When using justified text the last line is by default aligned to the left, however you can choose to 
align the last line to the center of the paragraph area or justify it so that spaces are inserted between 
the words in order to fill the whole line. In the case where the last line consists of a single word, you 
can also have this word stretched to cover the whole line. Figure 8 shows ran example of the effect 
obtain when setting each of these options

Figure 8: Four different types of justification for the last line of a paragraph

These options are controlled in the Alignment page of the Paragraph Style dialog box or the 
Format > Paragraph dialog box (see Figure 9).
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Formatting paragraphs

Figure 9: Options for the last line of a justified paragraph

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any that you have defined. To set the 
measurement unit and the spacing of default tab stops, go to Tools > Options > OpenOffice.org 
Writer > General.

You can also set or change the measurement unit by right-clicking on the ruler to open a list of units, 
as shown in Figure 10. Click on one of them to change the ruler to that unit.

Figure 10: Ruler showing default tab stops

Double-click on a part of the ruler that is not between the left and right indent icons to open the 
Indents & Spacing page of the Paragraph dialog box. Double-click anywhere between the left and 
right indent icons on the ruler itself to open the Tabs page of the Paragraph dialog box (Figure 11).
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Formatting paragraphs

Figure 11: Specifying tab stops and fill characters

Changing the default tab stops interval
Using tabs to space out material on a page is not recommended (depending on what you are trying to 
accomplish, a borderless table is usually a better choice), but if you do use tabs, do not use the 
default tabs set in Tools > Options > OpenOffice.org Writer > General (Figure 12); instead, define 
your own tab settings, as described in this section.

Figure 12: Selecting a default tab stop interval

If you use the default tab interval and then send the document to someone else who has chosen a 
different default tab interval, tabbed material will change to use the other person’s tab settings. This 
may cause a major formatting problem, as illustrated in Figure 13.

Figure 13: Default tab settings might be different
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Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar.  Figure 14 
shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for character 
formatting.

Tip It is highly recommended that you use character styles rather than manually 
formatting characters. For information on the advantages of styles and how to use 
them, see Chapter 6 (Introduction to Styles).

1 Open Styles and 
Formatting Window

6 Italic 12 Font Color

7 Underline 13 Highlighting

2 Apply Style 8 Superscript 14 Background Color

3 Font Name 9 Subscript 15 Open Character Format 
Dialog4 Font Size 10 Increase Font

5 Bold 11 Reduce Font

Figure 14: Formatting toolbar, showing buttons for character formatting

Tip To remove manual formatting, select the text and click Format > Default 
Formatting or right-click and select Default Formatting from the pop-up menu.

Autoformatting
Writer can be set to automatically format parts of a document according to the choices made on the 
Options page of the AutoCorrect dialog box (Tools > AutoCorrect > Options). See Figure 15.

The Help describes each of these choices and how to activate the autoformats. Some common 
unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs 
(===) on a line and then press Enter the paragraph is replaced by a horizontal line as wide as 
the page. The line is actually the lower border of the preceding paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), asterisk 
(*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered 
list is created when you type a number followed by a period (.), followed by a space or tab at 
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted 
with the Default, Text body or Text body indent paragraph styles.

Tip If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause.
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Autoformatting

Figure 15: Autoformat choices on the Options page of the AutoCorrect dialog box

To turn autoformatting on or off, go to Format > AutoFormat (Figure 16) and select or deselect the 
items on the submenu.

Figure 16: Turning autoformatting on or off
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Autoformatting

• While Typing automatically formats the document while you type.

• If While Typing is deselected, you can select Apply to automatically format the file.

• Apply and Edit Changes automatically formats the file and then opens a dialog box where 
you can accept or reject the changes.

Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.

• Use list styles, as described in Chapter 7 (Working with Styles).

• Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure 6). 
This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list and then click on the 
appropriate icon on the toolbar.

Note It is a matter of personal preference whether you type your information first, then 
apply Numbering/Bullets or apply these as you type.

Using the Bullets and Numbering toolbar
You can create a nested list (where one or more list items has a sublist under it, as in an outline) by 
using the buttons on the Bullets and Numbering toolbar (Figure 17). You can move items up or down 
the list, create subpoints, and even change the style of bullets.

1 Bullets On/Off 7 Demote One Level with 
Subpoints

12 Move Down with Subpoints
2 Numbering On/Off
3 Numbering Off 8 Insert Unnumbered Entry 13 Restart Numbering
4 Promote One Level 9 Move Up 14 Bullets and Numbering
5 Demote One Level 10 Move Down
6 Promote One Level with 

Subpoints
11 Move Up with Subpoints

Figure 17: Bullets and Numbering toolbar

Tip It is possible to move a list entry up, together with all of its sub-entries. Do this by 
clicking the Promote One Level With Subpoints button.
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Creating numbered or bulleted lists

If you create a nested list using the predefined styles, all the levels of the list (up to 10) apply the 
same numbering (or bullet) format, however in many circumstances you will want to use a 
combination of numbering formats and bullets when creating a nested list. Such lists with a mixture 
of numbering formats and bullets can be easily configured as described in the following example. 
Additional information on lists and in particular the technique to create your own list style are in 
Chapter 7 (Working with Styles).

Tip When creating nested lists, one option is to enter all the list paragraphs first and 
apply the levels afterwards.

You can use keyboard shortcuts to move paragraphs up or down the outline levels. 
Place the cursor at the beginning of the numbered paragraph and press:

Tab Down a level
Shift+Tab Up a level

To insert a tab stop at the beginning of a numbered paragraph (that is, after the 
number but before the text), press Control+Tab.

Example: configuring a nested list
We will use a numbering style to produce the following effect:

  I.  Level-1 list item

      A. Level-2 list item

           i. Level-3 list item

              a) Level-4 list item

This example uses one of the supplied styles, Numbering 1, however if you intend to reuse this type 
of nested list you can also create a new style as illustrated in Chapter 7 (Working with Styles).

1) Create the first item and apply the Numbering 1 style from the Styles and Formatting 
window. 

2) Select Format > Bullets and Numbering to open the dialog box that controls the appearance 
of the list.

3) Go to the Outline page (Figure 18), where you will find that one style matches our 
requirements. Click once on that style.
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Creating numbered or bulleted lists

Figure 18: Choosing a predefined outline-numbering style

4) To modify the layout of the list, use the Options tab (Figures 19 and 20). Notice that the 
preview on the right shows the outline selected. In the Level box on the left, select 1, then 2, 
3, and 4 and see how the information in the Numbering and After boxes changes.

Use the Options page to set different punctuation; for example, a period (full stop) after “a” 
on level 4 instead of a parenthesis.

Figure 19: Checking the outline numbering for level-1 list items
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Creating numbered or bulleted lists

Figure 20: Numbering style for level-2 list items

To make the indentation at each level greater or less than the default, change it on the 
Position page. Select the level, then make any changes in the indentation, spacing, or 
numbering alignment.

5) Repeat for each level as required, then click OK.

Tip With outline numbering you can define different bullet styles for the different levels 
of a bullet list. Use the Bullets tab of the Bullets and Numbering dialog box (not 
shown) to select the basic style. Return to the Options tab to customize the bullet for 
each indent level. Here you can set bullets to any character. See the Graphics tab for 
more bullets.

Using footnotes and endnotes
Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected at 
the end of a document.

To work effectively with footnotes and endnotes, you need to:

• Insert footnotes.

• Define the format of footnotes.

• Define the location of footnotes on the page; see Chapter 4 (Formatting Pages).

Inserting footnotes/endnotes
To insert a footnote or an endnote, put the cursor where you want the footnote/endnote marker to 
appear. Then select Insert > Footnote from the menu bar or click the Insert Footnote Directly or 
Insert Endnote Directly icon on the Insert toolbar (see Figure 21).

Figure 21: Using the Insert Footnote Directly icon on the toolbar
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Creating numbered or bulleted lists

A footnote (or endnote) marker is inserted in the text, and the cursor is relocated to the footnote area 
at the bottom of the page (or to the endnote area at the end of the document). Type the footnote or 
endnote content in this area.

If you use Insert > Footnote, the Insert Footnote dialog box (Figure 22) is displayed. Here you can 
choose whether to use the automatic numbering sequence specified in the footnote settings and 
whether to insert the item as a footnote or an endnote.

Figure 22: Inserting a footnote directly

If you use the Insert Footnote Directly or Insert Endnote Directly icon, the footnote or endnote 
automatically takes on the attributes previously defined in the Footnote Settings dialog box (Figure
23).

You can edit an existing footnote or endnote the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or endnote 
are deleted automatically, and the numbering of other footnotes or endnotes is adjusted 
automatically.

Defining the format of footnotes/endnotes
To format the footnotes themselves, click Tools > Footnotes. On the Footnote Settings dialog box 
(Figure 23), choose settings as required. The Endnotes page has similar choices.
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Creating numbered or bulleted lists

Figure 23: Defining footnote formatting

Checking spelling

Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a wavy red line under any 
misspelled words. Once the word is corrected, the red wavy line disappears.

 To perform a separate spellcheck on the document (or a text selection) click the Spellcheck 
button. This checks the document or selection and opens the Spellcheck dialog box (Figure

24) if any misspelled words are found.

Here are some more features of the spelling checker:

• You can right-click on a word with a wavy underline, to open a powerful context menu. If you 
select from the suggested words on the menu, the selection will replace the misspelled word 
in your text. Other menu options are discussed below.

• You can change the dictionary language (for example, Spanish, French, or German) on the 
Spellcheck dialog box.

• You can add a word to a dictionary. Click Add in the Spellcheck dialog box and pick the 
dictionary to add it to.

• The Options dialog box of the Spellcheck tool has a number of different options such as 
whether to check uppercase words and words with numbers. It also allows you to manage 
custom dictionaries, that is, add or delete dictionaries and add or delete words in a dictionary.

• On the Font page of the Paragraph Styles dialog box, you can set paragraphs to be spell-
checked in a specific language (different from the rest of the document). See Chapter 7 
(Working with Styles) for more information.
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Checking spelling

Figure 24: Selecting a word from dictionary using the Spellcheck dialog box

Using the thesaurus

The thesaurus offers alternative words and phrases. Select the word or phrase you want to find 
alternatives for and select Tools > Language > Thesaurus or press Control+F7. Click on a meaning 
to show alternative words and phrases for that meaning of the word. For example, when given the 
word “house”, the thesaurus offers several meanings, including “dwelling”, “legislature”, and “sign 
of the zodiac”. If you click on “dwelling”, you will see “dwelling”, “home”, “domicile”, “abode”, 
and other alternatives, as shown in Figure 25.

Note If the current language does not have a thesaurus installed, this feature is disabled.

Figure 25: The thesaurus offers alternatives to words
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Hyphenating words

To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window (Figure 26).

Figure 26: Modifying a style

2) On the Paragraph Styles page of the Styles and Formatting window, right-click on Default 
and select Modify.

3) On the Paragraph Style dialog box, select the Text Flow tab (Figure 27).

4) Under Hyphenation, select or deselect the Automatically checkbox. Click OK to save.

Figure 27: Turning on automatic hyphenation

Note Turning on hyphenation for the Default paragraph style affects all other paragraph 
styles that are based on Default. You can individually change other styles so that 
hyphenation is not active; for example, you might not want headings to be 
hyphenated. Any styles that are not based on Default are not affected. For more on 
paragraph styles, see Chapter 6 (Introduction to Styles) and Chapter 7 (Working 
with Styles).

You can also set hyphenation choices through Tools > Options > Language Settings > Writing 
Aids. In Options, near the bottom of the dialog box, scroll down to find the hyphenation settings (see 
Figure 28).
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Figure 28: Setting hyphenation options

To change the minimal number of characters for hyphenation, the minimum number of characters 
before a line break, or the minimum number of characters after a line break, select the item, and then 
click Edit.

Hyphenate without inquiry specifies that you will never be asked to manually hyphenate words 
that the hyphenation dictionary does not recognize. If this box is not selected, when a word is not 
recognized, a dialog box will open where you can manually enter hyphens.

Hyphenate special regions specifies that hyphenation will also be carried out in footnotes, headers, 
and footers.

Notes Hyphenation options set on the Writing Aids dialog box are effective only if 
hyphenation is turned on through paragraph styles.

Choices on the Writing Aids dialog box for “characters before line break” and 
“characters after line break” override settings in paragraph styles for “characters at 
line end” and “characters at line begin”. This is a bug.

To enter a conditional hyphen inside a word, press Control+minus sign. The word is hyphenated at 
this position when it is at the end of the line, even if automatic hyphenation for this paragraph is 
switched off.

Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it 
corrects automatically. For example, “hte” will be changed to “the”. Select Tools > AutoCorrect to 
open the AutoCorrect dialog box. There you can define what strings of text are corrected and how. In 
most cases, the defaults are fine.

Tip AutoCorrect is automatically turned on. To turn it off, uncheck Format > 
AutoFormat > While Typing.

• To stop Writer replacing a specific spelling, use Tools > AutoCorrect > Replace, highlight 
the word pair and click Delete.

• To add a new spelling to correct, type it into the Replace and With boxes and click New.

• See the different pages of the dialog box for the wide variety of other options available to 
fine-tune AutoCorrect.

Tip AutoCorrect can be used as a quick way to insert special characters. For example, 
(c) will be autocorrected to ©. You can add your own special characters.
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Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to 
complete this word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

Tip Many people prefer not to use Word Completion. If you do not want to use it, select 
Tools > AutoCorrect > Word Completion and uncheck Enable word completion.

You can customize word completion from the Tools > AutoCorrect > Word Completion page 
(Figure 29).

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than completing the text as 
you type.

• Change the maximum number of words remembered for word completion and the length of 
the smallest words to be remembered.

• Delete specific entries from the word completion list.

• Change the key that accepts a suggested entry—the options are right arrow, End key, Return 
(Enter), Space bar, and Tab.

Figure 29: Customizing word completion

Note Automatic word completion only occurs after you type a word for the second time 
in a document.
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Using AutoText

AutoText allows you to assign text, tables, graphics, and other items to a key combination. For 
example, rather than typing out “Senior Management”, you just have to type “sm” and press F3. Or 
you can save a formatted Tip (like the one on the next page) as AutoText and then inserting a copy by 
typing “tip” and pressing F3.

To insert AutoText, type the shortcut and press F3.

To assign some text to an AutoText shortcut:

1) Type the text into your document.

2) Select the text.

3) Go to Edit > AutoText (or press Control+F3).

4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you can 
change.

5) Click the AutoText button on the right of the AutoText dialog box and select New (text only) 
from the menu.

6) Click Close to return to your document.

Tip If the only option under the AutoText button is Import, either you have not entered 
a name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 14 (Working with Fields) for 
more information.

Line numbering

Line numbering puts line numbers in the margin. The line numbers are displayed on screen and are 
printed. Figure 30 shows an example with numbering on every line.

Click Tools > Line Numbering and select the Show numbering checkbox in the top left corner. 
Then click OK.

Figure 30: Line numbering example
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You can choose how many lines are numbered (for example, every line or every tenth line), the 
numbering type and whether numbers restart on each page. In addition, a text separator (any text you 
choose) can be set on a different numbering scheme (one every 12 lines, for example). See Figure 31.

Figure 31: The Line Numbering dialog box

Undoing and redoing changes

To undo the most recent change, press Control+Z, click the Undo icon  on the Standard toolbar, 
or select Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone, as shown in Figure 32.

Figure 32: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes that can be 
undone (Figure 33). You can select multiple changes and undo them at the same time.
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Figure 33: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, or 

press Control+Y or click on the Redo icon . As with Undo, click on the triangle to the right of 
the arrow to get a list of the changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select Tools > Options > 
OpenOffice.org > Memory and change Undo: Number of steps. Be aware that asking OOo to 
remember more changes makes it consume more memory.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

• Make your changes to a copy of the document (stored in a different folder, under a different 
name, or both), then use Writer to combine the two files and show the changes you made. 
Click Edit > Compare Document. This technique is particularly useful if you are the only 
person working on the document, as it avoids the increase in file size and complexity caused 
by the other methods.

• Save versions that are stored as part of the original file. However, this method can cause 
problems with documents of nontrivial size or complexity, especially if you save a lot of 
versions. Avoid this method if you can.

• Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you 
have added or deleted material or changed formatting. Later, you or another person can 
review and accept or reject each change.

Tip Not all changes are recorded. For example, changing a tab stop from align left to 
align right and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review
When you send a document to someone else to review or edit, you may want to prepare it first so that 
the editor or reviewer does not have to remember to turn on the revision marks. After you have 
protected the document, any user must enter the correct password in order to turn off the function or 
accept or reject changes.

1) Open the document. To check whether it contains multiple versions, click File > Versions. If 
multiple versions are listed, save the current version as a separate document with a different 
name and use this new document as the review copy.
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2) With the review copy open, make sure that change recording is turned on. The Edit > 
Changes > Record menu item has a check mark next to it when recording is turned on.

3) Click Edit > Changes > Protect Records. On the Enter Password dialog box, type a 
password (twice) and click OK.

Note Passwords must contain at least five characters. It is not necessary to password 
protect the document while preparing it for review.

Recording changes
See Chapter 2 (Setting up Writer) for instructions on setting up how your changes will be displayed.

1) To begin tracking (recording) changes, click Edit > Changes > Record.

To show or hide the display of changes, click Edit > Changes > Show.

Tip Hold the mouse pointer over a marked change; you will see a Help Tip showing the 
type of change, the author, date, and time of day for the change. If Extended Tips are 
enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and then 
click Edit > Changes > Comment. (See Figure 34.) In addition to being displayed as an 
extended tip, the comment is also displayed in the list in the Accept or Reject Changes dialog 
box.

Figure 34: Inserting a comment during change recording

To move from one marked change to the next, use the arrow buttons. If no comment has been 
recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Changes > Record again.
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Inserting notes
To insert a note that is not associated with a recorded change:

1) Place the cursor at the text you want to comment on, then click Insert > Note.

2) On the Insert Note dialog box (Figure 35), type your note. Click the Author button to insert 
your initials and the date and time.

To view a note, move the mouse pointer over the note marker (displayed as a small yellow 
rectangle). Writer displays the note in a Tip above the text. You can also double-click on the note to 
see it inside the Edit Note dialog box. If you have trouble viewing or selecting notes this way, you 
can use the Navigator instead: expand the list of notes, select the one you want, right-click on it, 
select Note, and then select Edit to display the Edit Note dialog box.

The Edit Note dialog box looks much like the Insert Note dialog box, with the addition of forward 
and back arrow buttons if the document contains more than one note.

Tip You can change the color of the note marker using the Tools > Options > 
OpenOffice.org > Appearance dialog box. (In the Text Document section ─ Note 
Indicator.)

Figure 35: Inserting a note

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog box (Figure

36) opens.

2) When you select a change in the dialog box, the actual change is highlighted in the document, 
so you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click Accept All 
or Reject All if you do not want to review the changes individually.

Changes that have not yet been accepted or rejected are displayed in the list. Accepted changes are 
removed from the list and appear in the text without any marking.
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Figure 36: The List tab of the Accept or Reject Changes dialog box

To show only the changes of certain people or only the changes on specific days or various other 
restrictions, use the Filter page (Figure 37) on the Accept or Reject Changes dialog box. After 
specifying the filter criteria, return to the List page to see those changes that meet your criteria.

Figure 37: The Filter page of the Accept or Reject Changes dialog box
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Merging modified documents
The processes discussed to this point are effective when you have one reviewer at a time. Sometimes, 
however, multiple reviewers all return edited versions of a document at the same time. In this case, it 
may be quicker to review all of these changes at once, rather than one review at a time. For this 
purpose, you can merge documents in Writer.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open one copy.

2) Click Edit > Changes > Merge Document and select and insert another copy of the 
document to be merged with the first.

3) After the documents merge, the Accept or Reject Changes dialog box opens, as in Figure
36, showing changes by more than one reviewer. If you want to merge more documents, 
close the dialog box and then repeat step 2.

4) Repeat until all copies are merged.

All recorded changes are now included in the open copy. Save this file under another name.

Comparing documents
Sometimes reviewers may forget to record the changes they make. This is not a problem with Writer 
because you can find the changes if you compare documents.

In order to compare documents, you need to have the original document and the one that is edited. To 
compare them:

1) Open the edited document. Select Edit > Compare Document.

2) The Insert dialog box appears. Select the original document and click Insert.

Writer finds and marks the changes and displays the Accept or Reject Changes dialog box. From this 
point, you can go through and accept or reject changes procedure as described earlier.

Linking to another part of a document

If you type in references to other parts of the document, those references can easily get out of date if 
you reorganize the order of topics, add or remove material, or reword a heading, OOo provides two 
ways to ensure that your references are up to date, by inserting links to other parts of the same 
document or to a different document: hyperlinks and cross-references.

The two methods have the same result if you Control+click the link when the document is open in 
OOo: you are taken directly to the cross-referenced item. However, they also have two major 
differences: 

• The text in a hyperlink does not automatically update if you change the text of the linked 
item (although you can change it manually), but changed text does automatically update in a 
cross-reference.

• When using a hyperlink, you do not have a choice of the content of the link (for example text 
or page number), but when using a cross-reference, you do have several choices, including 
bookmarks.
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Using hyperlinks
To insert a cross-reference as a hyperlink in your document, use the Navigator:

1) Open the documents containing the items you want to cross-reference.

2) Open the Navigator (by clicking its icon, choosing Edit > Navigator, or pressing F5.

3) Click the arrow next to the Drag Mode icon, and select Insert as Hyperlink.

4) In the list at the bottom of the Navigator, select the document containing the item that you 
want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The name of the 
item is inserted in the document as an active hyperlink.

Using cross-references
To ensure that references update if you reword a heading, caption, or other linked item, use 
automatic cross-references. See “Using automatic cross-references” in Chapter 14 (Working with 
Fields) for details.

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse 
click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink. 
For more about bookmarks, see “Using bookmarks” in Chapter 14 (Working with Fields).

Working with hyperlinks

When you type text (such as a website addresses or URL) that can be used as a hyperlink, OOo 
formats it automatically, creating the hyperlink and applying to the text a color and underlining. If 
this does not happen, you can enable this feature using Tools > AutoCorrect > Options and 
selecting the URL Recognition checkbox.

Tips If you do not want OOo to convert a specific URL to a hyperlink, select Edit > Undo 
Insert from the menu bar or press Control+Z immediately after the formatting has 
been applied.

To change the color of hyperlinks, go to Tools > Options > OpenOffice.org > 
Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes, 
pick the new colors and click OK. Caution: this will change the color for all 
hyperlinks in all components of OpenOffice.org—this may not be what you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link 
character style or define and apply new styles to selected links.

You can also insert and modify links using the Hyperlink dialog (Figure 38). To display the dialog, 

click the Hyperlink icon  on the Standard toolbar or select Insert > Hyperlink from the menu 
bar. To turn existing text into a link, highlight it before opening the Hyperlink dialog.
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Figure 38. Hyperlink dialog showing details for Internet links

On the left hand side, select one of the four types of hyperlink:

• Internet: a web address, normally starting with http://

• Mail & News: for example an email address.

• Document: the hyperlink points to another document or to another place in the presentation.

• New document: the hyperlink creates a new document.

The top right part of the dialog changes according to the choice made for the hyperlink type. A full 
description of all the choices, and their interactions, is beyond the scope of this chapter. Here is a 
summary of the most common choices used in presentations.

For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet), 
and enter the required web address (URL). 

For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver address 
and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open File button opens a file 
browser); leave this blank if you want to link to a target in the same presentation. Optionally specify 
the target in the document (for example a specific slide). Click on the Target icon to open the 
Navigator where you can select the target, or if you know the name of the target, you can type it into 
the box.

For a New Document type hyperlink, specify whether to edit the newly created document 
immediately or just create it (Edit later) and the type of document to create (text, spreadsheet, etc.). 
For a presentation, Edit now is the more likely choice. The Select path button opens a directory 
picker.

The Further settings section in the bottom right part of the dialog is common to all the hyperlink 
types, although some choices are more relevant to some types of links.
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• Set the value of Frame to determine how the hyperlink will open. This applies to documents 
that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button.

• Text specifies the text that will be visible to the user.

• Name is applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

• Event button: this button will be activated to allow OOo to react to events for which the user 
has written some code (macro). This function is not covered in this book.

Editing hyperlinks
From OOo 2.3, to edit a hyperlink, you can either click anywhere in the link text, or position the 
cursor in the link text using the arrow keys, and then open the Hyperlink dialog by clicking the 
Hyperlink icon on the Standard toolbar or selecting Edit > Hyperlink from the menu bar. (To 
activate a hyperlink, it is now necessary to hold down the Ctrl key while clicking on the link.)

With OOo 2.2.1 and earlier, clicking on a hyperlink activates the link. Therefore, to edit a link, either 
move the cursor into the link using the keyboard arrow keys, or change the status of the link by 
clicking on the acronym HYP (hyperlink) in the Status bar to change it to SEL (select), then open the 
Hyperlink dialog as described above.

Tip If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until 
you have edited all of them. Be sure to click Apply after each one. When you are 
finished, click Close.

Switching between insert and overwrite mode

With the keyboard, press Insert to toggle between overwrite mode and insert mode. In insert mode, 
any text after the cursor position moves forward to make room for the text you type; in overwrite 
mode, text after the cursor position is replaced by the text you type. The current mode is displayed on 
the Status Bar.

With the mouse, click in the area on the Status Bar that indicates the current mode in order to switch 
to the other mode.

Counting the words in a selection

Select a block of text and choose Tools > Word Count. OOo displays the number of words and 
characters in the selection as well as the number of words in the document. You can also see the 
number of words and characters (and other information) in the entire document in File > Properties 
> Statistics.
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